source: projects/specs/trunk/m/mono/mono-vl.spec @ 521

Revision 521, 24.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: .NET runtime environment
2Summary(ja): .NET ランタイム環境
3Name: mono
4Version: 2.6.1
5Release: 2%{?_dist_release}
6Group: Development/Languages
7License: GPL, LGPL, MIT X11
8URL: http://www.mono-project.com/
9Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
10Source1: monodir.c
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildRequires: bison
14BuildRequires: glib2-devel
15BuildRequires: pkgconfig
16BuildRequires: libicu-devel
17BuildRequires: libgdiplus-devel >= 2.0
18BuildRequires: zlib-devel
19# JIT only availible on these:
20ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
21
22%description
23The Mono runtime implements a JIT engine for the ECMA CLI
24virtual machine (as well as a byte code interpreter, the
25class loader, the garbage collector, threading system and
26metadata access libraries.
27
28%description -l ja
29Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
30コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
31およびメタデータアクセスライブラリの機能を持ちます。
32
33%package core
34Summary: The Mono CIL runtime, suitable for running .NET code
35Summary(ja): .NET の実行に適した Mono CIL ランタイム
36Group: Development/Languages
37Requires: libgdiplus
38
39%description core
40This package contains the core of the Mono runtime including its
41Virtual Machine, Just-in-time compiler, C# compiler, security
42tools and libraries (corlib, XML, System.Security, ZipLib,
43I18N, Cairo and Mono.*).
44
45%package devel
46Summary:        Development tools for Mono
47Summary(ja):    Mono 開発ツール
48Group:          Development/Languages
49Requires:       mono-core = %{version}-%{release}
50Requires:       glib2-devel
51
52%description devel
53This package completes the Mono developer toolchain with the mono profiler,
54assembler and other various tools.
55
56%package nunit
57Summary:        NUnit Testing Framework
58Summary(ja):    NUnit テストフレームワーク
59Group:          Development/Languages
60Requires:       mono-core = %{version}-%{release}
61Requires:       glib2-devel
62
63%description nunit
64NUnit is a unit-testing framework for all .NET languages. Initially
65ported from JUnit, the current release, version 2.2, is the fourth
66major release of this Unit based unit testing tool for Microsoft .NET.
67It is written entirely in C# and  has been completely redesigned to
68take advantage of many .NET language features, for example
69custom attributes and other reflection related capabilities. NUnit
70brings xUnit to all .NET languages.
71
72%package locale-extras
73Summary:        Extra locale information for Mono
74Summary(ja):    Mono 用追加ロケール情報
75Group:          Development/Languages
76Requires:       mono-core = %{version}-%{release}
77
78%description locale-extras
79This package contains assemblies to support I18N applications for
80non-latin alphabets.
81
82# The above seems safe
83
84%package jscript
85Summary:        JScript .NET support for Mono
86Summary(ja):    Mono 用 JScript .NET サポート
87Group:          Development/Languages
88Requires:       mono-core = %{version}-%{release}
89
90%description jscript
91This package contains the JScript .NET compiler and language runtime.
92This allows you to compile and run JScript.NET application and
93assemblies.
94
95%package extras
96Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
97Group:          Development/Languages
98Requires:       mono-core = %{version}-%{release}
99
100%description extras
101This package provides the libary and application to run services
102and daemons with Mono. It also includes stubs for the following
103.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
104System.Configuration.Install, System.Management, System.Messaging.
105
106%package winforms
107Summary:        Windows Forms implementation for Mono
108Group:          Development/Languages
109Requires:       mono-core = %{version}-%{release}
110
111%description winforms
112This package provides a fully managed implementation of
113System.Windows.Forms, the default graphical toolkit for .NET
114applications.
115
116%package web
117Summary:        ASP.NET, Remoting, and Web Services for Mono
118Group:          Development/Languages
119Requires:       mono-core = %{version}-%{release}
120
121%description web
122This package provides the ASP.NET libraries and runtime for
123development of web application, web services and remoting support.
124
125%package data
126Summary:        Database connectivity for Mono
127Group:          Development/Languages
128Requires:       mono-core = %{version}-%{release}
129
130%description data
131This package provides a Mono assembly to facilitate data access
132and manipulation with databases, LDAP compatible directory servers
133and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
134System.DirectoryServices assemblies, it also includes a command
135line sql application as well as the Microsoft SQL Server and ODBC
136data providers.
137
138%package data-sqlite
139Summary:        sqlite database connectivity for Mono
140Group:          Development/Languages
141Requires:       mono-core = %{version}-%{release}
142Requires:       sqlite
143
144%description data-sqlite
145This package contains the ADO.NET Data provider for the sqlite
146database.
147
148%package data-sybase
149Summary:        Sybase database connectivity for Mono
150Group:          Development/Languages
151Requires:       mono-core = %{version}-%{release}
152
153%description data-sybase
154This package contains the ADO.NET Data provider for the Sybase
155database.
156
157%package data-oracle
158Summary:        Oracle database connectivity for Mono
159Group:          Development/Languages
160Requires:       mono-core = %{version}-%{release}
161
162%description data-oracle
163This package contains the ADO.NET Data provider for the Oracle
164database.
165
166%package data-postgresql
167Summary:        Postgresql database connectivity for Mono
168Group:          Development/Languages
169Requires:       mono-core = %{version}-%{release}
170
171%description data-postgresql
172This package contains the ADO.NET Data provider for the PostgreSQL
173database.
174
175%package data-firebird
176Summary:        Firebird database connectivity for Mono
177Group:          Development/Languages
178Requires:       mono-core = %{version}-%{release}
179
180%description data-firebird
181This package contains the ADO.NET Data provider for the Firebird
182database.
183
184%package -n ibm-data-db2
185Summary:        IBM DB2 database connectivity for Mono
186Group:          Development/Languages
187Requires:       mono-core = %{version}-%{release}
188
189%description -n ibm-data-db2
190This package contains the ADO.NET Data provider for the IBM DB2
191Universal database.
192
193%package -n bytefx-data-mysql
194Summary:        MySQL database connectivity for Mono
195Group:          Development/Languages
196Requires:       mono-core = %{version}-%{release}
197
198%description -n bytefx-data-mysql
199This package contains the ADO.NET Data provider for MySQL. This is
200no longer maintained. MySQL AB now provides MySQL Connector/Net
201which is fully managed and actively maintained.
202
203%package -n monodoc
204Summary:        The Mono documentation system
205Group:          Development/Tools
206Requires:       mono-core = %{version}-%{release}
207Requires:       libgluezilla >= 2.4
208Obsoletes:      monodoc-core <= 2.0-1vl5
209
210%description -n monodoc
211monodoc is the documentation package for the mono .NET environment
212
213
214## macros
215%define mono_dir %{_prefix}/lib/mono
216%define mono_doc %{_prefix}/lib/monodoc
217%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
218        %{mono_dir}/%{2}/%{1}.dll \
219        %{nil}
220%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
221        %{mono_dir}/%{2}/%{1}.dll \
222        %{mono_dir}/%{3}/%{1}.dll \
223        %{nil}
224%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
225        %{mono_dir}/%{2}.exe \
226        %{mono_dir}/%{2}.exe.mdb \
227        %{nil}
228%define bin_exe_and_conf(bin, exe) %{_bindir}/%{1} \
229        %{mono_dir}/%{2}.exe \
230        %{mono_dir}/%{2}.exe.mdb \
231        %{mono_dir}/%{2}.exe.config \
232        %{nil}
233
234
235%prep
236%setup -q
237## These are only needed if there are patches to the runtime
238#rm -f libgc/libtool.m4
239#autoreconf --force --install
240#autoreconf --force --install libgc
241
242# Remove prebuilt binaries
243rm -rf mcs/class/lib/monolite/*
244
245
246%build
247gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
248
249export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
250%configure \
251        --with-jit=yes \
252        --with-ikvm=yes \
253        --with-sigaltstack=no \
254        --with-moonlight=yes \
255        --with-libgdiplus=installed
256
257# don't use parallel builds
258#make %{?_smp_mflags}
259make
260
261
262%install
263[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
264make install DESTDIR=%{buildroot}
265
266install monodir %{buildroot}%{_bindir}
267
268%{__rm} %{buildroot}%{_libdir}/*.la
269%{__rm} %{buildroot}%{_libdir}/*.a
270
271## Remove unused files
272%{__rm} %{buildroot}%{_bindir}/mono-find-provides
273%{__rm} %{buildroot}%{_bindir}/mono-find-requires
274
275# This was removed upstream:
276%{__rm} -fr %{buildroot}%{mono_dir}/gac/Mono.Security.Win32/[12]*
277%{__rm} -rf %{buildroot}%{mono_dir}/1.0/Mono.Security.Win32.dll
278%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
279%{__rm} %{buildroot}%{_datadir}/libgc-mono/README*
280%{__rm} %{buildroot}%{_datadir}/libgc-mono/barrett_diagram
281%{__rm} %{buildroot}%{_datadir}/libgc-mono/*.html
282%{__rm} %{buildroot}%{_datadir}/libgc-mono/gc.man
283%{__rm} %{buildroot}/%{_bindir}/jay
284%{__rm} -r %{buildroot}%{_datadir}/jay
285%{__rm} %{buildroot}%{_mandir}/man1/jay.1
286%{__rm} %{buildroot}%{_mandir}/man1/monostyle.1
287%{__rm} %{buildroot}%{_mandir}/man1/oldmono.1
288%{__rm} %{buildroot}%{_mandir}/man1/mint.1
289%{__rm} %{buildroot}%{mono_dir}/1.0/browsercaps-updater.exe*
290
291%find_lang mcs
292
293
294%clean
295[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
296
297%post core -p /sbin/ldconfig
298%postun core -p /sbin/ldconfig
299%post devel -p /sbin/ldconfig
300%postun devel -p /sbin/ldconfig
301
302%files core -f mcs.lang
303%defattr(-,root,root,-)
304%doc AUTHORS COPYING.LIB ChangeLog NEWS README
305%dir %{mono_dir}
306%dir %{mono_dir}/1.0
307%dir %{mono_dir}/2.0
308%dir %{mono_dir}/3.5
309%dir %{mono_dir}/gac
310%dir %{mono_dir}/compat-*
311%bin_and_exe csharp 2.0/csharp
312%bin_and_exe certmgr 1.0/certmgr
313%bin_and_exe chktrust 1.0/chktrust
314%bin_and_exe lc 2.0/lc
315%{_bindir}/gacutil
316%bin_and_exe gacutil1 1.0/gacutil
317%bin_and_exe gacutil2 2.0/gacutil
318%bin_exe_and_conf gmcs 2.0/gmcs
319%bin_and_exe installvst 1.0/installvst
320%bin_and_exe mconfig 2.0/mconfig
321%bin_and_exe mod 1.0/mod
322%{_bindir}/mono
323%{_bindir}/monodir
324%{_bindir}/mono-api-*
325%bin_and_exe mono-cil-strip 1.0/mono-cil-strip
326%{_bindir}/mono-test-install
327%bin_and_exe monolinker 2.0/monolinker
328%bin_and_exe mozroots 1.0/mozroots
329%{_bindir}/mcs
330%bin_exe_and_conf mcs1 1.0/mcs
331%bin_and_exe setreg 1.0/setreg
332%bin_and_exe sn 1.0/sn
333%bin_exe_and_conf sqlmetal 2.0/sqlmetal
334%bin_and_exe svcutil 2.0/svcutil
335%{_libdir}/libMonoPosixHelper.so
336%{_libdir}/libmono.so.*
337%{_libdir}/libmono-profiler-logging.so.*
338%{mono_dir}/1.0/ictool.exe
339%{mono_dir}/1.0/ictool.exe.mdb
340%{mono_dir}/?.0/installutil.*
341%{mono_dir}/?.0/mono-api-info*
342%{mono_dir}/?.0/mscorlib.dll
343%{mono_dir}/?.0/mscorlib.dll.mdb
344%{mono_dir}/3.5/System.Web.Extensions*
345%{mono_dir}/3.5/Microsoft.Build.*
346%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
347%{mono_dir}/gac/Mono.Cecil
348%{mono_dir}/gac/Mono.Cecil.Mdb
349%{mono_dir}/xbuild/*
350%gac_and_2dll cscompmgd 2.0 1.0
351%gac_and_2dll Commons.Xml.Relaxng 2.0 1.0
352%gac_and_2dll CustomMarshalers 2.0 1.0
353%gac_and_2dll I18N 2.0 1.0
354%gac_and_2dll I18N.West 2.0 1.0
355%gac_and_2dll ICSharpCode.SharpZipLib 2.0 1.0
356%gac_and_1dll Mono.C5 2.0
357%gac_and_2dll Mono.Cairo 2.0 1.0
358%gac_and_2dll Mono.CompilerServices.SymbolWriter 2.0 1.0
359%gac_and_2dll Mono.GetOptions 2.0 1.0
360%gac_and_2dll Mono.Posix 2.0 1.0
361%gac_and_2dll Mono.Security 2.0 1.0
362%gac_and_2dll System 2.0 1.0
363%gac_and_1dll System.Configuration 2.0
364%gac_and_2dll System.Drawing 2.0 1.0
365%gac_and_2dll System.Security 2.0 1.0
366%gac_and_2dll System.Xml 2.0 1.0
367%gac_and_1dll System.Xml.Linq 2.0
368%gac_and_1dll System.Core 2.0
369%gac_and_1dll Mono.CSharp 2.0
370%gac_and_1dll Mono.Debugger.Soft 2.0
371%gac_and_1dll Mono.Management 2.0
372%gac_and_1dll Mono.Simd 2.0
373%gac_and_1dll Mono.Tasklets 2.0
374%gac_and_1dll System.ComponentModel.DataAnnotations 2.0
375%gac_and_1dll System.IdentityModel.Selectors 2.0
376%gac_and_1dll System.IdentityModel 2.0
377%gac_and_1dll System.Runtime.Serialization 2.0
378%gac_and_2dll OpenSystem.C 2.0 1.0
379%gac_and_1dll WindowsBase 2.0
380%dir %{_sysconfdir}/mono
381%dir %{_sysconfdir}/mono/1.0
382%dir %{_sysconfdir}/mono/2.0
383%dir %{_sysconfdir}/mono/mconfig
384%config (noreplace) %{_sysconfdir}/mono/config
385%config (noreplace) %{_sysconfdir}/mono/1.0/machine.config
386%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
387%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
388%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
389%{_prefix}/lib/mono-source-libs/
390%{_mandir}/man1/certmgr.1.gz
391%{_mandir}/man1/chktrust.1.gz
392%{_mandir}/man1/csharp.1.gz
393%{_mandir}/man1/gacutil.1.gz
394%{_mandir}/man1/lc.1.gz
395%{_mandir}/man1/mconfig.1.gz
396%{_mandir}/man1/mcs.1.gz
397%{_mandir}/man1/mono.1.gz
398%{_mandir}/man1/monolinker.1.gz
399%{_mandir}/man1/mozroots.1.gz
400%{_mandir}/man1/setreg.1.gz
401%{_mandir}/man1/sn.1.gz
402%{_mandir}/man1/resgen.1.gz
403%{_mandir}/man1/mono-cil-strip.1.gz
404%{_mandir}/man1/xbuild.1.gz
405%{_mandir}/man5/mono-config.5.gz
406
407%files devel
408%defattr(-,root,root,-)
409%{_bindir}/al
410%{_bindir}/genxs
411%{_bindir}/ilasm1
412%{_bindir}/mkbundle
413%bin_and_exe mkbundle1 1.0/mkbundle
414%bin_and_exe mkbundle2 2.0/mkbundle
415%{_bindir}/monodis
416%{_bindir}/monograph
417%{_bindir}/monop1
418%{_bindir}/mono-gdb.py
419%{_bindir}/pedump
420%{_bindir}/resgen1
421%bin_and_exe al1 1.0/al
422%bin_and_exe al2 2.0/al
423%bin_and_exe caspol 1.0/caspol
424%bin_and_exe cert2spc 1.0/cert2spc
425%bin_and_exe cilc 1.0/cilc
426%bin_and_exe dtd2xsd 1.0/dtd2xsd
427%bin_and_exe dtd2rng 1.0/dtd2rng
428%bin_and_exe genxs1 1.0/genxs
429%bin_and_exe sgen 2.0/sgen
430%bin_and_exe ilasm 1.0/ilasm
431%bin_and_exe ilasm2 2.0/ilasm
432%bin_and_exe macpack 1.0/macpack
433%bin_and_exe makecert 1.0/makecert
434%bin_and_exe monop 1.0/monop
435%bin_and_exe monop2 2.0/monop
436%bin_exe_and_conf mono-shlib-cop 2.0/mono-shlib-cop
437%bin_and_exe mono-xmltool 2.0/mono-xmltool
438%bin_and_exe pdb2mdb 2.0/pdb2mdb
439%bin_and_exe permview 1.0/permview
440%bin_and_exe prj2make 1.0/prj2make
441%bin_and_exe resgen 1.0/resgen
442%bin_and_exe resgen2 2.0/resgen
443%bin_and_exe secutil 1.0/secutil
444%bin_and_exe signcode 1.0/signcode
445%bin_and_exe xbuild 2.0/xbuild
446%{mono_dir}/1.0/culevel*
447%{mono_dir}/2.0/MSBuild
448%{mono_dir}/2.0/Microsoft.Build.xsd
449%{mono_dir}/2.0/Microsoft.*.targets
450%{mono_dir}/2.0/Microsoft.Common.tasks
451%{mono_dir}/2.0/xbuild.rsp
452%gac_and_2dll PEAPI 2.0 1.0
453%gac_and_2dll Microsoft.Build.Engine 3.5 2.0
454%gac_and_2dll Microsoft.Build.Framework 3.5 2.0
455%gac_and_1dll Microsoft.Build.Tasks 2.0
456%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
457%gac_and_1dll Microsoft.Build.Utilities 2.0
458%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
459%gac_and_2dll Microsoft.VisualC 2.0 1.0
460%{_libdir}/libmono-profiler-aot.*
461%{_libdir}/libmono-profiler-cov.*
462%{_libdir}/libmono.so
463%{_libdir}/libMonoSupportW.so
464%{_libdir}/libmono-profiler-logging.so
465%{_libdir}/libikvm-native.so
466%{_libdir}/pkgconfig/dotnet.pc
467%{_libdir}/pkgconfig/mono-cairo.pc
468%{_libdir}/pkgconfig/mono.pc
469%{_libdir}/pkgconfig/cecil.pc
470%{_libdir}/pkgconfig/dotnet35.pc
471%{_libdir}/pkgconfig/mono-lineeditor.pc
472%{_libdir}/pkgconfig/mono-options.pc
473%{_libdir}/pkgconfig/wcf.pc
474%{_includedir}/mono-1.0
475%dir %{_datadir}/mono-1.0
476%dir %{_datadir}/mono-1.0/mono
477%dir %{_datadir}/mono-1.0/mono/cil
478%{_datadir}/mono-1.0/mono/cil/cil-opcodes.xml
479%{_mandir}/man1/al.1.gz
480%{_mandir}/man1/cert2spc.1.gz
481%{_mandir}/man1/cilc.1.gz
482%{_mandir}/man1/dtd2xsd.1.gz
483%{_mandir}/man1/genxs.1.gz
484%{_mandir}/man1/ilasm.1.gz
485%{_mandir}/man1/macpack.1.gz
486%{_mandir}/man1/makecert.1.gz
487%{_mandir}/man1/mkbundle.1.gz
488%{_mandir}/man1/mono-shlib-cop.1.gz
489%{_mandir}/man1/mono-xmltool.1.gz
490%{_mandir}/man1/monodis.1.gz
491%{_mandir}/man1/monop.1.gz
492%{_mandir}/man1/pdb2mdb.1.gz
493%{_mandir}/man1/permview.1.gz
494%{_mandir}/man1/prj2make.1.gz
495%{_mandir}/man1/secutil.1.gz
496%{_mandir}/man1/sgen.1.gz
497%{_mandir}/man1/signcode.1.gz
498
499%files nunit
500%defattr(-,root,root,-)
501%bin_exe_and_conf nunit-console 1.0/nunit-console
502%bin_exe_and_conf nunit-console2 2.0/nunit-console
503%gac_and_2dll nunit.core 2.0 1.0
504%gac_and_2dll nunit.framework 2.0 1.0
505%gac_and_2dll nunit.util 2.0 1.0
506%gac_and_2dll nunit.mocks 2.0 1.0
507%gac_and_2dll nunit-console-runner 2.0 1.0
508%gac_and_2dll nunit.core.extensions 2.0 1.0
509%gac_and_2dll nunit.core.interfaces 2.0 1.0
510%gac_and_2dll nunit.framework.extensions 2.0 1.0
511%{_libdir}/pkgconfig/mono-nunit.pc
512
513%files locale-extras
514%defattr(-,root,root,-)
515%gac_and_2dll I18N.MidEast 2.0 1.0
516%gac_and_2dll I18N.Rare 2.0 1.0
517%gac_and_2dll I18N.CJK 2.0 1.0
518%gac_and_2dll I18N.Other 2.0 1.0
519
520%files jscript
521%defattr(-,root,root,-)
522%bin_and_exe mjs 1.0/mjs
523%gac_and_2dll Microsoft.JScript 2.0 1.0
524
525%files extras
526%defattr(-,root,root,-)
527%{_mandir}/man1/mono-service.1.gz
528%bin_and_exe mono-service 1.0/mono-service
529%bin_and_exe mono-service2 2.0/mono-service
530%{mono_dir}/gac/mono-service
531%gac_and_2dll System.Management 2.0 1.0
532%gac_and_2dll System.Messaging 2.0 1.0
533%gac_and_2dll System.ServiceProcess 2.0 1.0
534%gac_and_1dll System.ServiceModel 2.0
535%gac_and_2dll System.Configuration.Install 2.0 1.0
536%gac_and_2dll Microsoft.Vsa 2.0 1.0
537%gac_and_2dll Mono.Messaging.RabbitMQ 2.0 1.0
538%gac_and_2dll Mono.Messaging 2.0 1.0
539%gac_and_2dll RabbitMQ.Client 2.0 1.0
540
541%files winforms
542%defattr(-,root,root,-)
543%gac_and_2dll System.Windows.Forms 2.0 1.0
544%gac_and_2dll Accessibility 2.0 1.0
545%gac_and_2dll System.Design 2.0 1.0
546%gac_and_2dll System.Drawing.Design 2.0 1.0
547
548%files web
549%defattr(-,root,root,-)
550%bin_and_exe httpcfg 2.0/httpcfg
551
552%bin_and_exe disco 1.0/disco
553%bin_and_exe soapsuds 1.0/soapsuds
554%bin_and_exe wsdl 1.0/wsdl
555%{_bindir}/wsdl1
556%bin_and_exe wsdl2 2.0/wsdl
557%bin_and_exe xsd2 2.0/xsd
558%bin_and_exe xsd 1.0/xsd
559
560%gac_and_2dll Mono.Http 2.0 1.0
561%gac_and_1dll Mono.Web 2.0
562%gac_and_2dll Mono.WebBrowser 2.0 1.0
563%gac_and_2dll System.Runtime.Remoting 2.0 1.0
564%gac_and_2dll System.Web 2.0 1.0
565%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 2.0 1.0
566%{mono_dir}/compat-2.0/System.Web.Extensions*dll
567%gac_and_1dll System.ServiceModel.Web 2.0
568%gac_and_1dll System.Web.Abstractions 2.0
569%gac_and_1dll System.Web.DynamicData 2.0
570%gac_and_1dll System.Web.Mvc 2.0
571%gac_and_1dll System.Web.Routing 2.0
572%gac_and_2dll System.Web.Services 2.0 1.0
573%gac_and_2dll System.Web.Extensions.Design 3.5 2.0
574%gac_and_1dll System.Web.Extensions 2.0
575%{_mandir}/man1/disco.1.gz
576%{_mandir}/man1/soapsuds.1.gz
577%{_mandir}/man1/wsdl.1.gz
578%{_mandir}/man1/xsd.1.gz
579%config (noreplace) %{_sysconfdir}/mono/browscap.ini
580%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
581%config (noreplace) %{_sysconfdir}/mono/1.0/DefaultWsdlHelpGenerator.aspx
582%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
583%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
584%{_mandir}/man1/httpcfg.1.gz
585%{_libdir}/pkgconfig/mono.web.pc
586%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
587%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
588%{_libdir}/pkgconfig/system.web.mvc.pc
589
590%files data
591%defattr(-,root,root,-)
592%bin_and_exe sqlsharp 2.0/sqlsharp
593%{mono_dir}/gac/System.Data.Services
594%gac_and_2dll System.Data 2.0 1.0
595%gac_and_1dll System.Data.DataSetExtensions 2.0
596%gac_and_1dll System.Data.Linq 2.0
597%gac_and_2dll Mono.Data 2.0 1.0
598%gac_and_2dll Mono.Data.Tds 2.0 1.0
599%gac_and_2dll Mono.Data.TdsClient 2.0 1.0
600%gac_and_2dll System.EnterpriseServices 2.0 1.0
601%gac_and_2dll Novell.Directory.Ldap 2.0 1.0
602%gac_and_2dll System.DirectoryServices 2.0 1.0
603%gac_and_1dll System.Transactions 2.0
604%{_mandir}/man1/sqlsharp.1.gz
605
606%files data-sqlite
607%defattr(-,root,root,-)
608%gac_and_2dll Mono.Data.SqliteClient 2.0 1.0
609%gac_and_2dll Mono.Data.Sqlite 2.0 1.0
610
611%files data-sybase
612%defattr(-,root,root,-)
613%gac_and_2dll Mono.Data.SybaseClient 2.0 1.0
614
615%files data-oracle
616%defattr(-,root,root,-)
617%gac_and_2dll System.Data.OracleClient 2.0 1.0
618
619%files data-postgresql
620%defattr(-,root,root,-)
621%gac_and_2dll Npgsql 2.0 1.0
622
623%files data-firebird
624%defattr(-,root,root,-)
625%gac_and_1dll FirebirdSql.Data.Firebird 1.0
626
627%files -n bytefx-data-mysql
628%defattr(-,root,root,-)
629%gac_and_2dll ByteFX.Data 2.0 1.0
630
631%files -n ibm-data-db2
632%defattr(-,root,root,-)
633%gac_and_2dll IBM.Data.DB2 2.0 1.0
634
635%files -n monodoc
636%defattr(-, root, root)
637%bin_and_exe mdoc 2.0/mdoc
638%{_bindir}/mdoc-*
639%{_bindir}/mdass*
640%{_bindir}/mdval*
641%{_bindir}/mod
642%{_bindir}/monodoc*
643%{mono_dir}/gac/monodoc
644%{mono_dir}/monodoc/monodoc.dll
645%{mono_doc}/*
646%{_mandir}/man1/md*
647%{_mandir}/man1/monodoc*
648%{_mandir}/man5/mdoc*
649%{_libdir}/pkgconfig/monodoc.pc
650
651%changelog
652* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
653- unuse _smp_mflags
654
655* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
656- updated mono to 2.6.1
657- simplified macros
658
659* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
660- updated mono to 2.4.3
661  added %%{mono_dir}/2.0/lc.exe*
662  added %%gac_dll System.Web.Mvc
663  added %%{mono_dir}/xbuild/*
664  added %%{_mandir}/man1/lc.1.gz
665  added %%{_mandir}/man1/xbuild.1.gz
666
667* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
668- updated mono to 2.4.2.3
669
670* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
671- updated mono to 2.4.2.2
672
673* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
674- new upstream release
675- build with latest rpm to update mono-dependencies
676
677* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
678- updated mono to 2.4.2
679
680* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
681- fix temporary workaround against build failure on ppc,
682  from RH bugzilla #494026
683  - statically link mono to libmono: remove "--disable-static" from configure
684  - ensure removing *.a files in the install section
685- remove prebuilt binaries under mcs/class/lib/monolite/ before building
686
687* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
688- fixed paths using %%mono_dir, %%mono_doc macros
689- added Requires:libgluezilla >= 2.4 in monodoc
690
691* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
692- new upstream release
693- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
694
695* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
696- new upstream release
697- dropt %%{_bindir}/mono-find-{provides,requires}
698- added --with-libgdiplus=installed
699
700* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
701- update to mono-2.0 released source
702- BR: libgdiplus-devel >= 2.0
703
704* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
705- removed *.la
706
707* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
708- updated mono to 2.0
709- updated url
710- changed macro %%monodir to %%mono_dir
711- dropt mono-1.1.13.4-selinux-ia64.patch
712- dropt mono-1.1.13.4-ppc-threading.patch
713- dropt mono-1.2.3-use-monodir.patch
714
715* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
716- applied new versioning policy, spec in utf-8
717- dropt mono-1.2.5-libdir.patch
718- reverted monodir macro to using %%{_prefix}/lib/mono
719
720* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
721- updated monodir to %%{_libdir}/mono
722
723* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
724- new upstream release
725- splited mono-basic package
726
727* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
728- new upstream release
729
730* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
731- new upstream release
732
733* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
734- disabled Patch2 on Vine/ppc environment
735
736* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
737- updated source and sub-packages based on Fedora packages
738  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
739  - new upstream version(mono-1.0.6)
740  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
741  - new upstream version(mono-1.0.5)
742  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
743  - new upstream version(mono-1.0.4)
744        -- changed to use configure
745  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
746  - rebuild for Vine Linux (based on mono.spec inside src archive)
747  - Fixed BuildRequires: gc-devel, libicu-devel
748  - add Japanese translation
749
750* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
751- rebuild for ppc TLS issue (#184446)
752
753* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
754- Update to 1.1.13.4
755- Add patch so mono doesn't segfault on PPC SMP machines
756- Minor spec cleanup
757
758* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
759- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
760  for bug 182965)
761
762* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
763- Updated patch from Paolo Molaro <lupus@ximian.com>
764
765* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
766- Patch from Jakub to make work with SELinux better
767
768* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
769- Rebuild
770
771* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
772- rebuilt for new gcc4.1 snapshot and glibc changes
773
774* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
775- Update to 1.1.13.2
776
777* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
778- Update to 1.13
779- Add libgdiplus dep to mono-core
780- Add s390x to build
781
782* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
783- Update to 1.1.12.1
784
785* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
786- rebuild
787
788* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
789- Disable s390 due to some build failure
790
791* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
792- Build on s390 and x86-64 now
793
794* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
795- Initial version
Note: See TracBrowser for help on using the repository browser.