source: projects/specs/trunk/m/mono/mono-vl.spec @ 3285

Revision 3285, 26.8 KB checked in by owa, 13 years ago (diff)

mono-2.10.1

Line 
1Summary: .NET runtime environment
2Summary(ja): .NET ランタイム環境
3Name: mono
4Version: 2.10.1
5Release: 1%{?_dist_release}
6Group: Development/Languages
7License: GPL, LGPL, MIT X11
8URL: http://www.mono-project.com/
9Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
10Source1: monodir.c
11
12# patch for Vine Linux
13Patch0: mono-2.8.1-ppc.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: bison
17BuildRequires: glib2-devel
18BuildRequires: pkgconfig
19BuildRequires: libicu-devel
20BuildRequires: libgdiplus-devel >= 2.0
21BuildRequires: zlib-devel
22# JIT only availible on these:
23ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
24Obsoletes: %{name}-jscript < 2.8
25Obsoletes: %{name}-data-sybase < 2.8
26Obsoletes: %{name}-data-firebird < 2.8
27Obsoletes: bytefx-data-mysql < 2.8
28
29%description
30The Mono runtime implements a JIT engine for the ECMA CLI
31virtual machine (as well as a byte code interpreter, the
32class loader, the garbage collector, threading system and
33metadata access libraries.
34
35%description -l ja
36Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
37コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
38およびメタデータアクセスライブラリの機能を持ちます。
39
40%package core
41Summary: The Mono CIL runtime, suitable for running .NET code
42Summary(ja): .NET の実行に適した Mono CIL ランタイム
43Group: Development/Languages
44Requires: libgdiplus
45
46%description core
47This package contains the core of the Mono runtime including its
48Virtual Machine, Just-in-time compiler, C# compiler, security
49tools and libraries (corlib, XML, System.Security, ZipLib,
50I18N, Cairo and Mono.*).
51
52%package devel
53Summary:        Development tools for Mono
54Summary(ja):    Mono 開発ツール
55Group:          Development/Languages
56Requires:       mono-core = %{version}-%{release}
57Requires:       glib2-devel
58
59%description devel
60This package completes the Mono developer toolchain with the mono profiler,
61assembler and other various tools.
62
63%package nunit
64Summary:        NUnit Testing Framework
65Summary(ja):    NUnit テストフレームワーク
66Group:          Development/Languages
67Requires:       mono-core = %{version}-%{release}
68Requires:       glib2-devel
69
70%description nunit
71NUnit is a unit-testing framework for all .NET languages. Initially
72ported from JUnit, the current release, version 2.2, is the fourth
73major release of this Unit based unit testing tool for Microsoft .NET.
74It is written entirely in C# and  has been completely redesigned to
75take advantage of many .NET language features, for example
76custom attributes and other reflection related capabilities. NUnit
77brings xUnit to all .NET languages.
78
79%package locale-extras
80Summary:        Extra locale information for Mono
81Summary(ja):    Mono 用追加ロケール情報
82Group:          Development/Languages
83Requires:       mono-core = %{version}-%{release}
84
85%description locale-extras
86This package contains assemblies to support I18N applications for
87non-latin alphabets.
88
89%package extras
90Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
91Group:          Development/Languages
92Requires:       mono-core = %{version}-%{release}
93
94%description extras
95This package provides the libary and application to run services
96and daemons with Mono. It also includes stubs for the following
97.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
98System.Configuration.Install, System.Management, System.Messaging.
99
100%package winforms
101Summary:        Windows Forms implementation for Mono
102Group:          Development/Languages
103Requires:       mono-core = %{version}-%{release}
104
105%description winforms
106This package provides a fully managed implementation of
107System.Windows.Forms, the default graphical toolkit for .NET
108applications.
109
110%package web
111Summary:        ASP.NET, Remoting, and Web Services for Mono
112Group:          Development/Languages
113Requires:       mono-core = %{version}-%{release}
114
115%description web
116This package provides the ASP.NET libraries and runtime for
117development of web application, web services and remoting support.
118
119%package data
120Summary:        Database connectivity for Mono
121Group:          Development/Languages
122Requires:       mono-core = %{version}-%{release}
123
124%description data
125This package provides a Mono assembly to facilitate data access
126and manipulation with databases, LDAP compatible directory servers
127and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
128System.DirectoryServices assemblies, it also includes a command
129line sql application as well as the Microsoft SQL Server and ODBC
130data providers.
131
132%package data-sqlite
133Summary:        sqlite database connectivity for Mono
134Group:          Development/Languages
135Requires:       mono-core = %{version}-%{release}
136Requires:       sqlite
137
138%description data-sqlite
139This package contains the ADO.NET Data provider for the sqlite
140database.
141
142%package data-oracle
143Summary:        Oracle database connectivity for Mono
144Group:          Development/Languages
145Requires:       mono-core = %{version}-%{release}
146
147%description data-oracle
148This package contains the ADO.NET Data provider for the Oracle
149database.
150
151%package data-postgresql
152Summary:        Postgresql database connectivity for Mono
153Group:          Development/Languages
154Requires:       mono-core = %{version}-%{release}
155
156%description data-postgresql
157This package contains the ADO.NET Data provider for the PostgreSQL
158database.
159
160%package -n ibm-data-db2
161Summary:        IBM DB2 database connectivity for Mono
162Group:          Development/Languages
163Requires:       mono-core = %{version}-%{release}
164
165%description -n ibm-data-db2
166This package contains the ADO.NET Data provider for the IBM DB2
167Universal database.
168
169%package -n monodoc
170Summary:        The Mono documentation system
171Group:          Development/Tools
172Requires:       mono-core = %{version}-%{release}
173Requires:       libgluezilla >= 2.4
174Obsoletes:      monodoc-core <= 2.0-1vl5
175
176%description -n monodoc
177monodoc is the documentation package for the mono .NET environment
178
179## macros
180%define mono_dir %{_prefix}/lib/mono
181%define mono_doc %{_prefix}/lib/monodoc
182%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
183        %{mono_dir}/%{2}.exe \
184        %{mono_dir}/%{2}.exe.* \
185        %{nil}
186%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
187        %{mono_dir}/%{2}/%{1}.dll \
188        %{nil}
189%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
190        %{mono_dir}/%{2}/%{1}.dll \
191        %{mono_dir}/%{3}/%{1}.dll \
192        %{nil}
193%define gac_and_3dll(dll)  %{mono_dir}/gac/%{1} \
194        %{mono_dir}/%{2}/%{1}.dll \
195        %{mono_dir}/%{3}/%{1}.dll \
196        %{mono_dir}/%{4}/%{1}.dll \
197        %{nil}
198
199
200%prep
201%setup -q
202%ifarch ppc
203%patch0 -p1 -b .ppc
204%endif
205
206## These are only needed if there are patches to the runtime
207#rm -f libgc/libtool.m4
208#autoreconf --force --install
209#autoreconf --force --install libgc
210
211## Remove prebuilt binaries
212#rm -rf mcs/class/lib/monolite/*
213
214%build
215gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
216
217export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
218%configure \
219        --with-jit=yes \
220        --with-ikvm=yes \
221        --with-sigaltstack=no \
222%ifarch ppc
223        --with-sgen=no \
224        --disable-system-aot \
225%endif
226        ;
227
228# don't use parallel builds
229# make %{?_smp_mflags}
230make
231
232
233%install
234[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
235make install DESTDIR=%{buildroot}
236
237install monodir %{buildroot}%{_bindir}
238
239## Remove unused files
240%{__rm} -f %{buildroot}%{_libdir}/*.la
241%{__rm} -f %{buildroot}%{_libdir}/*.a
242%{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
243%{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
244
245## This was removed upstream:
246%{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32/2*
247%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
248%{__rm} -rf %{buildroot}%{_datadir}/libgc-mono
249%{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
250%{__rm} -f %{buildroot}%{_bindir}/prj2make
251%{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
252%{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
253
254%find_lang mcs
255
256
257%clean
258[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
259
260%post core -p /sbin/ldconfig
261%postun core -p /sbin/ldconfig
262%post devel -p /sbin/ldconfig
263%postun devel -p /sbin/ldconfig
264
265
266%files core -f mcs.lang
267%defattr(-,root,root,-)
268%doc AUTHORS COPYING.LIB ChangeLog NEWS README
269##{_bindir}/mcs
270%{_bindir}/mono
271%{_bindir}/monodir
272%{_bindir}/mono-api-*
273%{_bindir}/mono-configuration-crypto
274%{_bindir}/mono-heapviz
275%ifnarch ppc
276%{_bindir}/mono-sgen
277%endif
278%{_bindir}/peverify
279%{_bindir}/mprof-report
280%{_bindir}/mono-test-install
281%{_libdir}/libMonoPosixHelper.so
282%{_libdir}/libmono-2.0.so.*
283%ifnarch ppc
284%{_libdir}/libmonosgen-2.0.so.*
285%endif
286%{_libdir}/libmono-profiler-aot.so.*
287%{_libdir}/libmono-profiler-cov.so.*
288%{_libdir}/libmono-profiler-iomap.so.*
289%{_libdir}/libmono-profiler-log.so*
290%dir %{mono_dir}
291%dir %{mono_dir}/4.0
292%dir %{mono_dir}/3.5
293%dir %{mono_dir}/2.0
294%dir %{mono_dir}/gac
295%dir %{mono_dir}/compat-2.0
296%bin_and_exe ccrewrite 4.0/ccrewrite
297%bin_and_exe csharp 4.0/csharp
298%bin_and_exe csharp2 2.0/csharp
299%bin_and_exe certmgr 4.0/certmgr
300%bin_and_exe chktrust 4.0/chktrust
301%bin_and_exe dmcs 4.0/dmcs
302%bin_and_exe lc 4.0/lc
303%bin_and_exe gacutil 4.0/gacutil
304%bin_and_exe gacutil2 2.0/gacutil
305%bin_and_exe gmcs 2.0/gmcs
306%bin_and_exe installvst 4.0/installvst
307%bin_and_exe mconfig 4.0/mconfig
308%bin_and_exe mcs 2.0/mcs
309%bin_and_exe mod 4.0/mod
310%bin_and_exe mono-cil-strip 4.0/mono-cil-strip
311%bin_and_exe monolinker 2.0/monolinker
312%bin_and_exe mozroots 4.0/mozroots
313%bin_and_exe setreg 4.0/setreg
314%bin_and_exe sn 4.0/sn
315%bin_and_exe sqlmetal 4.0/sqlmetal
316%bin_and_exe svcutil 4.0/svcutil
317%{mono_dir}/4.0/browsercaps-updater.exe*
318%{mono_dir}/4.0/monolinker.exe*
319%{mono_dir}/4.0/ictool.exe*
320%{mono_dir}/4.0/installutil.exe*
321%{mono_dir}/4.0/mono-api-info.exe
322%{mono_dir}/4.0/mscorlib.dll*
323%{mono_dir}/2.0/mscorlib.dll*
324%{mono_dir}/3.5/Microsoft.Build.*
325%{mono_dir}/4.0/Microsoft.CSharp.targets
326%{mono_dir}/3.5/Microsoft.CSharp.targets
327%{mono_dir}/2.0/Microsoft.CSharp.targets
328%{mono_dir}/4.0/Microsoft.Common.targets
329%{mono_dir}/3.5/Microsoft.Common.targets
330%{mono_dir}/2.0/Microsoft.Common.targets
331%{mono_dir}/4.0/Microsoft.VisualBasic.targets
332%{mono_dir}/3.5/Microsoft.VisualBasic.targets
333%{mono_dir}/2.0/Microsoft.VisualBasic.targets
334%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
335%{mono_dir}/gac/Mono.Cecil
336%{mono_dir}/gac/Mono.Cecil.Mdb
337%{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
338%{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
339%gac_and_2dll cscompmgd 4.0 2.0
340%gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
341%gac_and_2dll CustomMarshalers 4.0 2.0
342%gac_and_2dll I18N 4.0 2.0
343%gac_and_2dll I18N.West 4.0 2.0
344%gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
345%gac_and_1dll Microsoft.CSharp 4.0
346%gac_and_2dll Mono.C5 4.0 2.0
347%gac_and_2dll Mono.Cairo 4.0 2.0
348%gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
349%gac_and_2dll Mono.Posix 4.0 2.0
350%gac_and_2dll Mono.Security 4.0 2.0
351%gac_and_1dll Mono.Security.Win32 4.0
352%gac_and_2dll Mono.CSharp 4.0 2.0
353%gac_and_1dll Mono.CodeContracts 4.0
354%gac_and_2dll Mono.Debugger.Soft 4.0 2.0
355%gac_and_2dll Mono.Management 4.0 2.0
356%gac_and_2dll Mono.Simd 4.0 2.0
357%gac_and_2dll Mono.Tasklets 4.0 2.0
358%gac_and_2dll System 4.0 2.0
359%gac_and_2dll System.Configuration 4.0 2.0
360%gac_and_1dll System.Dynamic 4.0
361%gac_and_2dll System.Drawing 4.0 2.0
362%gac_and_2dll System.Core 4.0 2.0
363%gac_and_1dll System.ComponentModel.Composition 4.0
364%gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
365%gac_and_2dll System.IdentityModel 4.0 2.0
366%gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
367%gac_and_2dll System.Net 4.0 2.0
368%gac_and_1dll System.Numerics 4.0
369%gac_and_1dll System.Runtime.Caching 4.0
370%gac_and_1dll System.Runtime.DurableInstancing 4.0
371%gac_and_2dll System.Runtime.Serialization 4.0 2.0
372%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
373%gac_and_2dll System.Security 4.0 2.0
374%gac_and_1dll System.Xaml 4.0
375%gac_and_2dll System.Xml 4.0 2.0
376%gac_and_2dll System.Xml.Linq 4.0 2.0
377%gac_and_2dll OpenSystem.C 4.0 2.0
378%gac_and_2dll WindowsBase 4.0 2.0
379%dir %{_sysconfdir}/mono
380%dir %{_sysconfdir}/mono/4.0
381%dir %{_sysconfdir}/mono/2.0
382%dir %{_sysconfdir}/mono/mconfig
383%config (noreplace) %{_sysconfdir}/mono/config
384%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
385%config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
386%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
387%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
388%config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
389%{_prefix}/lib/mono-source-libs/
390%{_mandir}/man1/ccrewrite.1.gz
391%{_mandir}/man1/certmgr.1.gz
392%{_mandir}/man1/chktrust.1.gz
393%{_mandir}/man1/csharp.1.gz
394%{_mandir}/man1/gacutil.1.gz
395%{_mandir}/man1/lc.1.gz
396%{_mandir}/man1/mconfig.1.gz
397%{_mandir}/man1/mcs.1.gz
398%{_mandir}/man1/mono.1.gz
399%{_mandir}/man1/monolinker.1.gz
400%{_mandir}/man1/mozroots.1.gz
401%{_mandir}/man1/mprof-report.1.gz
402%{_mandir}/man1/setreg.1.gz
403%{_mandir}/man1/sn.1.gz
404%{_mandir}/man1/resgen.1.gz
405%{_mandir}/man1/mono-api-info.1.gz
406%{_mandir}/man1/mono-cil-strip.1.gz
407%{_mandir}/man1/mono-configuration-crypto.1.gz
408%{_mandir}/man5/mono-config.5.gz
409
410%files devel
411%defattr(-,root,root,-)
412%{_bindir}/genxs
413%{_bindir}/mkbundle
414%{_bindir}/mono-gdb.py
415%{_bindir}/monodis
416%{_bindir}/monograph
417%{_bindir}/pedump
418%{_bindir}/xbuild
419%{_libdir}/libmono-2.0.so
420%{_libdir}/libmono-profiler-aot.so
421%{_libdir}/libmono-profiler-cov.so
422%{_libdir}/libmono-profiler-iomap.so
423%ifnarch ppc
424%{_libdir}/libmonosgen-2.0.so
425%endif
426%{_libdir}/libMonoSupportW.so
427%{_libdir}/libikvm-native.so
428%{mono_dir}/4.0/mkbundle.exe*
429%{mono_dir}/2.0/mkbundle.exe*
430%{mono_dir}/4.0/genxs.exe*
431%{mono_dir}/2.0/genxs.exe*
432%{mono_dir}/2.0/ilasm.exe*
433%bin_and_exe al 4.0/al
434%bin_and_exe al2 2.0/al
435%bin_and_exe caspol 4.0/caspol
436%bin_and_exe cert2spc 4.0/cert2spc
437%bin_and_exe dtd2xsd 4.0/dtd2xsd
438%bin_and_exe dtd2rng 4.0/dtd2rng
439%bin_and_exe sgen 4.0/sgen
440%bin_and_exe ilasm 4.0/ilasm
441%bin_and_exe macpack 4.0/macpack
442%bin_and_exe makecert 4.0/makecert
443%bin_and_exe monop 4.0/monop
444%bin_and_exe monop2 2.0/monop
445%bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
446%bin_and_exe mono-xmltool 4.0/mono-xmltool
447%bin_and_exe pdb2mdb 4.0/pdb2mdb
448%bin_and_exe permview 4.0/permview
449%bin_and_exe resgen 4.0/resgen
450%bin_and_exe resgen2 2.0/resgen
451%bin_and_exe secutil 4.0/secutil
452%bin_and_exe signcode 4.0/signcode
453%{mono_dir}/xbuild
454%{mono_dir}/4.0/xbuild.*
455%{mono_dir}/3.5/xbuild.*
456%{mono_dir}/2.0/xbuild.*
457%{mono_dir}/4.0/culevel.exe*
458%{mono_dir}/2.0/culevel.exe*
459%{mono_dir}/4.0/MSBuild/*.xsd
460%{mono_dir}/3.5/MSBuild/*.xsd
461%{mono_dir}/2.0/MSBuild/*.xsd
462%{mono_dir}/4.0/Microsoft.Build.xsd
463%{mono_dir}/3.5/Microsoft.Build.xsd
464%{mono_dir}/2.0/Microsoft.Build.xsd
465%{mono_dir}/4.0/Microsoft.*.targets
466%{mono_dir}/3.5/Microsoft.*.targets
467%{mono_dir}/2.0/Microsoft.*.targets
468%{mono_dir}/4.0/Microsoft.Common.tasks
469%{mono_dir}/3.5/Microsoft.Common.tasks
470%{mono_dir}/2.0/Microsoft.Common.tasks
471%gac_and_2dll PEAPI 4.0 2.0
472%gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
473%gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
474%gac_and_1dll Microsoft.Build.Tasks 2.0
475%gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
476%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
477%gac_and_1dll Microsoft.Build.Utilities 2.0
478%gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
479%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
480%gac_and_2dll Microsoft.VisualC 4.0 2.0
481%{_libdir}/pkgconfig/cecil.pc
482%{_libdir}/pkgconfig/dotnet.pc
483%{_libdir}/pkgconfig/dotnet35.pc
484%{_libdir}/pkgconfig/mono-cairo.pc
485%{_libdir}/pkgconfig/mono.pc
486%{_libdir}/pkgconfig/mono-2.pc
487%{_libdir}/pkgconfig/mono-lineeditor.pc
488%{_libdir}/pkgconfig/mono-options.pc
489%{_libdir}/pkgconfig/monosgen-2.pc
490%{_libdir}/pkgconfig/wcf.pc
491%{_includedir}/mono-2.0
492%{_mandir}/man1/al.1.gz
493%{_mandir}/man1/cert2spc.1.gz
494%{_mandir}/man1/dtd2xsd.1.gz
495%{_mandir}/man1/genxs.1.gz
496%{_mandir}/man1/ilasm.1.gz
497%{_mandir}/man1/macpack.1.gz
498%{_mandir}/man1/makecert.1.gz
499%{_mandir}/man1/mkbundle.1.gz
500%{_mandir}/man1/mono-shlib-cop.1.gz
501%{_mandir}/man1/mono-xmltool.1.gz
502%{_mandir}/man1/monodis.1.gz
503%{_mandir}/man1/monop.1.gz
504%{_mandir}/man1/pdb2mdb.1.gz
505%{_mandir}/man1/permview.1.gz
506%{_mandir}/man1/secutil.1.gz
507%{_mandir}/man1/sgen.1.gz
508%{_mandir}/man1/signcode.1.gz
509%{_mandir}/man1/xbuild.1.gz
510
511%files nunit
512%defattr(-,root,root,-)
513%bin_and_exe nunit-console 4.0/nunit-console
514%bin_and_exe nunit-console2 2.0/nunit-console
515%gac_and_2dll nunit.core 4.0 2.0
516%gac_and_2dll nunit.framework 4.0 2.0
517%gac_and_2dll nunit.util 4.0 2.0
518%gac_and_2dll nunit.mocks 4.0 2.0
519%gac_and_2dll nunit-console-runner 4.0 2.0
520%gac_and_2dll nunit.core.extensions 4.0 2.0
521%gac_and_2dll nunit.core.interfaces 4.0 2.0
522%gac_and_2dll nunit.framework.extensions 4.0 2.0
523%{_libdir}/pkgconfig/mono-nunit.pc
524
525%files locale-extras
526%defattr(-,root,root,-)
527%gac_and_2dll I18N.MidEast 4.0 2.0
528%gac_and_2dll I18N.Rare 4.0 2.0
529%gac_and_2dll I18N.CJK 4.0 2.0
530%gac_and_2dll I18N.Other 4.0 2.0
531
532%files extras
533%defattr(-,root,root,-)
534%{_mandir}/man1/mono-service.1.gz
535%bin_and_exe mono-service 4.0/mono-service
536%bin_and_exe mono-service2 2.0/mono-service
537%{mono_dir}/gac/mono-service
538%gac_and_2dll System.Configuration.Install 4.0 2.0
539%gac_and_2dll System.Management 4.0 2.0
540%gac_and_2dll System.Messaging 4.0 2.0
541%gac_and_2dll System.ServiceProcess 4.0 2.0
542%gac_and_2dll System.ServiceModel 4.0 2.0
543%gac_and_1dll System.ServiceModel.Discovery 4.0
544%gac_and_1dll System.ServiceModel.Routing 4.0
545%gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
546%gac_and_2dll Mono.Messaging 4.0 2.0
547%gac_and_2dll RabbitMQ.Client 4.0 2.0
548%{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
549%{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
550
551%files winforms
552%defattr(-,root,root,-)
553%gac_and_2dll Accessibility 4.0 2.0
554%gac_and_2dll System.Design 4.0 2.0
555%gac_and_2dll System.Drawing.Design 4.0 2.0
556%gac_and_2dll System.Windows.Forms 4.0 2.0
557%gac_and_1dll System.Windows.Forms.DataVisualization 4.0
558
559%files web
560%defattr(-,root,root,-)
561%{mono_dir}/2.0/xsd.exe*
562%{mono_dir}/compat-2.0/System.Web.Extensions*dll
563%{mono_dir}/compat-2.0/System.Web.Mvc.dll
564%bin_and_exe disco 4.0/disco
565%bin_and_exe soapsuds 4.0/soapsuds
566%bin_and_exe xsd 4.0/xsd
567%bin_and_exe wsdl 4.0/wsdl
568%bin_and_exe wsdl2 2.0/wsdl
569%bin_and_exe httpcfg 4.0/httpcfg
570%gac_and_2dll Mono.Http 4.0 2.0
571%gac_and_2dll Mono.Web 4.0 2.0
572%gac_and_2dll Mono.WebBrowser 4.0 2.0
573%gac_and_2dll System.Runtime.Remoting 4.0 2.0
574%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
575%gac_and_2dll System.ServiceModel.Web 4.0 2.0
576%gac_and_2dll System.Web 4.0 2.0
577%gac_and_1dll System.Web.ApplicationServices 4.0
578%gac_and_2dll System.Web.Abstractions 4.0 2.0
579%gac_and_2dll System.Web.DynamicData 4.0 2.0
580%gac_and_1dll System.Web.Mvc 2.0
581%gac_and_2dll System.Web.Routing 4.0 2.0
582%gac_and_2dll System.Web.Services 4.0 2.0
583%gac_and_2dll System.Web.Extensions.Design 4.0 2.0
584%gac_and_2dll System.Web.Extensions 4.0 2.0
585%gac_and_1dll Microsoft.Web.Infrastructure 4.0
586%gac_and_1dll WebMatrix.Data 4.0
587%{_mandir}/man1/disco.1.gz
588%{_mandir}/man1/soapsuds.1.gz
589%{_mandir}/man1/wsdl.1.gz
590%{_mandir}/man1/xsd.1.gz
591%config (noreplace) %{_sysconfdir}/mono/browscap.ini
592%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
593%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
594%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
595%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
596%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
597%{_mandir}/man1/httpcfg.1.gz
598%{_libdir}/pkgconfig/mono.web.pc
599%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
600%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
601%{_libdir}/pkgconfig/system.web.mvc.pc
602%{_libdir}/pkgconfig/system.web.mvc2.pc
603
604%files data
605%defattr(-,root,root,-)
606%bin_and_exe sqlsharp 4.0/sqlsharp
607%gac_and_2dll Mono.Data.Tds 4.0 2.0
608%gac_and_2dll Novell.Directory.Ldap 4.0 2.0
609%gac_and_2dll System.Data 4.0 2.0
610%gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
611%gac_and_2dll System.Data.Linq 4.0 2.0
612%gac_and_2dll System.Data.Services 4.0 2.0
613%gac_and_2dll System.Data.Services.Client 4.0 2.0
614%gac_and_2dll System.DirectoryServices 4.0 2.0
615%gac_and_2dll System.EnterpriseServices 4.0 2.0
616%gac_and_2dll System.Transactions 4.0 2.0
617%{mono_dir}/gac/System.Data.Services.Client
618%{_mandir}/man1/sqlsharp.1.gz
619
620%files data-sqlite
621%defattr(-,root,root,-)
622%gac_and_2dll Mono.Data.Sqlite 4.0 2.0
623
624%files data-oracle
625%defattr(-,root,root,-)
626%gac_and_2dll System.Data.OracleClient 4.0 2.0
627
628%files data-postgresql
629%defattr(-,root,root,-)
630%gac_and_2dll Npgsql 4.0 2.0
631
632%files -n ibm-data-db2
633%defattr(-,root,root,-)
634%gac_and_2dll IBM.Data.DB2 4.0 2.0
635
636%files -n monodoc
637%defattr(-, root, root)
638%bin_and_exe mdoc 2.0/mdoc
639%{_bindir}/mdoc-*
640%{_bindir}/mdass*
641%{_bindir}/mdval*
642%{_bindir}/mod
643%{_bindir}/monodoc*
644%{mono_dir}/gac/monodoc
645%{mono_dir}/monodoc/monodoc.dll
646%{mono_doc}/*
647%{_mandir}/man1/md*
648%{_mandir}/man1/monodoc*
649%{_mandir}/man5/mdoc*
650%{_libdir}/pkgconfig/monodoc.pc
651
652
653%changelog
654* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10.1-1
655- updated mono to 2.10.1
656
657* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
658- updated mono to 2.8.2
659
660* Tue Dec 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-2
661- add Patch0 (mono-2.8.1-ppc.patch)
662- add configure option "--with-sgen=no" and "--disable-system-aot" (ppc only)
663- fix %%files (add %%ifnarch ppc)
664
665* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
666- updated mono to 2.8.1
667
668* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
669- comment out script that removes prebuilt binaries, because gmcs.exe require
670
671* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
672- updated mono to 2.8
673- modified macros used in %%files
674- removed below:
675  - packages:
676    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
677  - libraries:
678    ByteFX.Data, FirebirdSql.Data.Firebird
679    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
680    Microsoft.JScript, Microsoft.Vsa
681  - commands:
682    cilc, mjs, prj2make (replaced by xbuild)
683
684* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
685- build with rpm-4.8.1-1 for pkg-config file
686
687* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
688- updated mono to 2.6.7
689
690* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
691- updated mono to 2.6.4
692
693* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
694- updated mono to 2.6.3
695  added RabbitMQ.Client.Apigen.exe
696
697* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
698- unuse _smp_mflags
699
700* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
701- updated mono to 2.6.1
702- simplified macros
703
704* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
705- updated mono to 2.4.3
706  added %%{mono_dir}/2.0/lc.exe*
707  added %%gac_dll System.Web.Mvc
708  added %%{mono_dir}/xbuild/*
709  added %%{_mandir}/man1/lc.1.gz
710  added %%{_mandir}/man1/xbuild.1.gz
711
712* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
713- updated mono to 2.4.2.3
714
715* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
716- updated mono to 2.4.2.2
717
718* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
719- new upstream release
720- build with latest rpm to update mono-dependencies
721
722* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
723- updated mono to 2.4.2
724
725* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
726- fix temporary workaround against build failure on ppc,
727  from RH bugzilla #494026
728  - statically link mono to libmono: remove "--disable-static" from configure
729  - ensure removing *.a files in the install section
730- remove prebuilt binaries under mcs/class/lib/monolite/ before building
731
732* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
733- fixed paths using %%mono_dir, %%mono_doc macros
734- added Requires:libgluezilla >= 2.4 in monodoc
735
736* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
737- new upstream release
738- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
739
740* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
741- new upstream release
742- dropt %%{_bindir}/mono-find-{provides,requires}
743- added --with-libgdiplus=installed
744
745* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
746- update to mono-2.0 released source
747- BR: libgdiplus-devel >= 2.0
748
749* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
750- removed *.la
751
752* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
753- updated mono to 2.0
754- updated url
755- changed macro %%monodir to %%mono_dir
756- dropt mono-1.1.13.4-selinux-ia64.patch
757- dropt mono-1.1.13.4-ppc-threading.patch
758- dropt mono-1.2.3-use-monodir.patch
759
760* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
761- applied new versioning policy, spec in utf-8
762- dropt mono-1.2.5-libdir.patch
763- reverted monodir macro to using %%{_prefix}/lib/mono
764
765* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
766- updated monodir to %%{_libdir}/mono
767
768* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
769- new upstream release
770- splited mono-basic package
771
772* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
773- new upstream release
774
775* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
776- new upstream release
777
778* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
779- disabled Patch2 on Vine/ppc environment
780
781* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
782- updated source and sub-packages based on Fedora packages
783  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
784  - new upstream version(mono-1.0.6)
785  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
786  - new upstream version(mono-1.0.5)
787  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
788  - new upstream version(mono-1.0.4)
789        -- changed to use configure
790  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
791  - rebuild for Vine Linux (based on mono.spec inside src archive)
792  - Fixed BuildRequires: gc-devel, libicu-devel
793  - add Japanese translation
794
795* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
796- rebuild for ppc TLS issue (#184446)
797
798* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
799- Update to 1.1.13.4
800- Add patch so mono doesn't segfault on PPC SMP machines
801- Minor spec cleanup
802
803* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
804- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
805  for bug 182965)
806
807* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
808- Updated patch from Paolo Molaro <lupus@ximian.com>
809
810* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
811- Patch from Jakub to make work with SELinux better
812
813* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
814- Rebuild
815
816* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
817- rebuilt for new gcc4.1 snapshot and glibc changes
818
819* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
820- Update to 1.1.13.2
821
822* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
823- Update to 1.13
824- Add libgdiplus dep to mono-core
825- Add s390x to build
826
827* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
828- Update to 1.1.12.1
829
830* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
831- rebuild
832
833* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
834- Disable s390 due to some build failure
835
836* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
837- Build on s390 and x86-64 now
838
839* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
840- Initial version
Note: See TracBrowser for help on using the repository browser.