source: projects/specs/trunk/m/mono/mono-vl.spec @ 2222

Revision 2222, 26.1 KB checked in by owa, 14 years ago (diff)

new upstream

Line 
1Summary: .NET runtime environment
2Summary(ja): .NET ランタイム環境
3Name: mono
4Version: 2.8.1
5Release: 1%{?_dist_release}
6Group: Development/Languages
7License: GPL, LGPL, MIT X11
8URL: http://www.mono-project.com/
9Source0: http://ftp.novell.com/pub/mono/sources/mono/%{name}-%{version}.tar.bz2
10Source1: monodir.c
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildRequires: bison
13BuildRequires: glib2-devel
14BuildRequires: pkgconfig
15BuildRequires: libicu-devel
16BuildRequires: libgdiplus-devel >= 2.0
17BuildRequires: zlib-devel
18# JIT only availible on these:
19ExclusiveArch: %{ix86} x86_64 ppc ia64 s390 s390x armv4l sparc
20Obsoletes: %{name}-jscript < 2.8
21Obsoletes: %{name}-data-sybase < 2.8
22Obsoletes: %{name}-data-firebird < 2.8
23Obsoletes: bytefx-data-mysql < 2.8
24
25%description
26The Mono runtime implements a JIT engine for the ECMA CLI
27virtual machine (as well as a byte code interpreter, the
28class loader, the garbage collector, threading system and
29metadata access libraries.
30
31%description -l ja
32Mono ランタイムは ECMA CLI 仮想機械用 JIT エンジンの実装です。バイト
33コードインタプリタ、クラスローダ、ガベージコレクタ、スレッドシステム
34およびメタデータアクセスライブラリの機能を持ちます。
35
36%package core
37Summary: The Mono CIL runtime, suitable for running .NET code
38Summary(ja): .NET の実行に適した Mono CIL ランタイム
39Group: Development/Languages
40Requires: libgdiplus
41
42%description core
43This package contains the core of the Mono runtime including its
44Virtual Machine, Just-in-time compiler, C# compiler, security
45tools and libraries (corlib, XML, System.Security, ZipLib,
46I18N, Cairo and Mono.*).
47
48%package devel
49Summary:        Development tools for Mono
50Summary(ja):    Mono 開発ツール
51Group:          Development/Languages
52Requires:       mono-core = %{version}-%{release}
53Requires:       glib2-devel
54
55%description devel
56This package completes the Mono developer toolchain with the mono profiler,
57assembler and other various tools.
58
59%package nunit
60Summary:        NUnit Testing Framework
61Summary(ja):    NUnit テストフレームワーク
62Group:          Development/Languages
63Requires:       mono-core = %{version}-%{release}
64Requires:       glib2-devel
65
66%description nunit
67NUnit is a unit-testing framework for all .NET languages. Initially
68ported from JUnit, the current release, version 2.2, is the fourth
69major release of this Unit based unit testing tool for Microsoft .NET.
70It is written entirely in C# and  has been completely redesigned to
71take advantage of many .NET language features, for example
72custom attributes and other reflection related capabilities. NUnit
73brings xUnit to all .NET languages.
74
75%package locale-extras
76Summary:        Extra locale information for Mono
77Summary(ja):    Mono 用追加ロケール情報
78Group:          Development/Languages
79Requires:       mono-core = %{version}-%{release}
80
81%description locale-extras
82This package contains assemblies to support I18N applications for
83non-latin alphabets.
84
85%package extras
86Summary:        Provides the infrastructure for running and building daemons and services with Mono as well as various stub assemblies
87Group:          Development/Languages
88Requires:       mono-core = %{version}-%{release}
89
90%description extras
91This package provides the libary and application to run services
92and daemons with Mono. It also includes stubs for the following
93.NET 1.1 and 2.0 assemblies: Microsoft.Vsa,
94System.Configuration.Install, System.Management, System.Messaging.
95
96%package winforms
97Summary:        Windows Forms implementation for Mono
98Group:          Development/Languages
99Requires:       mono-core = %{version}-%{release}
100
101%description winforms
102This package provides a fully managed implementation of
103System.Windows.Forms, the default graphical toolkit for .NET
104applications.
105
106%package web
107Summary:        ASP.NET, Remoting, and Web Services for Mono
108Group:          Development/Languages
109Requires:       mono-core = %{version}-%{release}
110
111%description web
112This package provides the ASP.NET libraries and runtime for
113development of web application, web services and remoting support.
114
115%package data
116Summary:        Database connectivity for Mono
117Group:          Development/Languages
118Requires:       mono-core = %{version}-%{release}
119
120%description data
121This package provides a Mono assembly to facilitate data access
122and manipulation with databases, LDAP compatible directory servers
123and/or XML data exchange. Beyond the ADO.NET, Novell.LDAP and
124System.DirectoryServices assemblies, it also includes a command
125line sql application as well as the Microsoft SQL Server and ODBC
126data providers.
127
128%package data-sqlite
129Summary:        sqlite database connectivity for Mono
130Group:          Development/Languages
131Requires:       mono-core = %{version}-%{release}
132Requires:       sqlite
133
134%description data-sqlite
135This package contains the ADO.NET Data provider for the sqlite
136database.
137
138%package data-oracle
139Summary:        Oracle database connectivity for Mono
140Group:          Development/Languages
141Requires:       mono-core = %{version}-%{release}
142
143%description data-oracle
144This package contains the ADO.NET Data provider for the Oracle
145database.
146
147%package data-postgresql
148Summary:        Postgresql database connectivity for Mono
149Group:          Development/Languages
150Requires:       mono-core = %{version}-%{release}
151
152%description data-postgresql
153This package contains the ADO.NET Data provider for the PostgreSQL
154database.
155
156%package -n ibm-data-db2
157Summary:        IBM DB2 database connectivity for Mono
158Group:          Development/Languages
159Requires:       mono-core = %{version}-%{release}
160
161%description -n ibm-data-db2
162This package contains the ADO.NET Data provider for the IBM DB2
163Universal database.
164
165%package -n monodoc
166Summary:        The Mono documentation system
167Group:          Development/Tools
168Requires:       mono-core = %{version}-%{release}
169Requires:       libgluezilla >= 2.4
170Obsoletes:      monodoc-core <= 2.0-1vl5
171
172%description -n monodoc
173monodoc is the documentation package for the mono .NET environment
174
175## macros
176%define mono_dir %{_prefix}/lib/mono
177%define mono_doc %{_prefix}/lib/monodoc
178%define bin_and_exe(bin, exe) %{_bindir}/%{1} \
179        %{mono_dir}/%{2}.exe \
180        %{mono_dir}/%{2}.exe.* \
181        %{nil}
182%define gac_and_1dll(dll)  %{mono_dir}/gac/%{1} \
183        %{mono_dir}/%{2}/%{1}.dll \
184        %{nil}
185%define gac_and_2dll(dll)  %{mono_dir}/gac/%{1} \
186        %{mono_dir}/%{2}/%{1}.dll \
187        %{mono_dir}/%{3}/%{1}.dll \
188        %{nil}
189%define gac_and_3dll(dll)  %{mono_dir}/gac/%{1} \
190        %{mono_dir}/%{2}/%{1}.dll \
191        %{mono_dir}/%{3}/%{1}.dll \
192        %{mono_dir}/%{4}/%{1}.dll \
193        %{nil}
194
195
196%prep
197%setup -q
198## These are only needed if there are patches to the runtime
199#rm -f libgc/libtool.m4
200#autoreconf --force --install
201#autoreconf --force --install libgc
202
203## Remove prebuilt binaries
204#rm -rf mcs/class/lib/monolite/*
205
206
207%build
208gcc -o monodir %{SOURCE1} -DMONODIR=\"%{mono_dir}\"
209
210export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
211%configure \
212        --with-jit=yes \
213        --with-ikvm=yes \
214        --with-sigaltstack=no \
215        ;
216
217# don't use parallel builds
218# make %{?_smp_mflags}
219make
220
221
222%install
223[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
224make install DESTDIR=%{buildroot}
225
226install monodir %{buildroot}%{_bindir}
227
228## Remove unused files
229%{__rm} -f %{buildroot}%{_libdir}/*.la
230%{__rm} -f %{buildroot}%{_libdir}/*.a
231%{__rm} -f %{buildroot}%{_bindir}/mono-find-provides
232%{__rm} -f %{buildroot}%{_bindir}/mono-find-requires
233
234## This was removed upstream:
235%{__rm} -rf %{buildroot}%{mono_dir}/gac/Mono.Security.Win32/2*
236%{__rm} -rf %{buildroot}%{mono_dir}/2.0/Mono.Security.Win32.dll
237%{__rm} -rf %{buildroot}%{_datadir}/libgc-mono
238%{__rm} -rf %{buildroot}%{_datadir}/mono-2.0/mono/cil
239%{__rm} -f %{buildroot}%{_bindir}/prj2make
240%{__rm} -f %{buildroot}%{_mandir}/man1/prj2make.*
241%{__rm} -f %{buildroot}%{_mandir}/man1/cilc.*
242
243%find_lang mcs
244
245
246%clean
247[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %{__rm} -rf %{buildroot}
248
249%post core -p /sbin/ldconfig
250%postun core -p /sbin/ldconfig
251%post devel -p /sbin/ldconfig
252%postun devel -p /sbin/ldconfig
253
254
255%files core -f mcs.lang
256%defattr(-,root,root,-)
257%doc AUTHORS COPYING.LIB ChangeLog NEWS README
258%{_bindir}/mcs
259%{_bindir}/mono
260%{_bindir}/monodir
261%{_bindir}/mono-api-*
262%{_bindir}/mono-configuration-crypto
263%{_bindir}/mono-heapviz
264%{_bindir}/mono-sgen
265%{_bindir}/peverify
266%{_bindir}/mono-test-install
267%{_libdir}/libMonoPosixHelper.so
268%{_libdir}/libmono-2.0.so.*
269%{_libdir}/libmonosgen-2.0.so.*
270%{_libdir}/libmono-profiler-aot.so.*
271%{_libdir}/libmono-profiler-cov.so.*
272%{_libdir}/libmono-profiler-iomap.so.*
273%{_libdir}/libmono-profiler-logging.so.*
274%dir %{mono_dir}
275%dir %{mono_dir}/4.0
276%dir %{mono_dir}/3.5
277%dir %{mono_dir}/2.0
278%dir %{mono_dir}/gac
279%dir %{mono_dir}/compat-4.0
280%dir %{mono_dir}/compat-2.0
281%bin_and_exe ccrewrite 4.0/ccrewrite
282%bin_and_exe csharp 4.0/csharp
283%bin_and_exe csharp2 2.0/csharp
284%bin_and_exe certmgr 4.0/certmgr
285%bin_and_exe chktrust 4.0/chktrust
286%bin_and_exe dmcs 4.0/dmcs
287%bin_and_exe lc 4.0/lc
288%bin_and_exe gacutil 4.0/gacutil
289%bin_and_exe gacutil2 2.0/gacutil
290%bin_and_exe gmcs 2.0/gmcs
291%bin_and_exe installvst 4.0/installvst
292%bin_and_exe mconfig 4.0/mconfig
293%bin_and_exe mod 4.0/mod
294%bin_and_exe mono-cil-strip 4.0/mono-cil-strip
295%bin_and_exe monolinker 2.0/monolinker
296%bin_and_exe mozroots 4.0/mozroots
297%bin_and_exe setreg 4.0/setreg
298%bin_and_exe sn 4.0/sn
299%bin_and_exe sqlmetal 4.0/sqlmetal
300%bin_and_exe svcutil 4.0/svcutil
301%{mono_dir}/4.0/browsercaps-updater.exe*
302%{mono_dir}/4.0/monolinker.exe*
303%{mono_dir}/4.0/ictool.exe*
304%{mono_dir}/4.0/installutil.exe*
305%{mono_dir}/4.0/mono-api-info.exe
306%{mono_dir}/4.0/mscorlib.dll*
307%{mono_dir}/2.0/mscorlib.dll*
308%{mono_dir}/3.5/Microsoft.Build.*
309%{mono_dir}/4.0/Microsoft.CSharp.targets
310%{mono_dir}/3.5/Microsoft.CSharp.targets
311%{mono_dir}/2.0/Microsoft.CSharp.targets
312%{mono_dir}/4.0/Microsoft.Common.targets
313%{mono_dir}/3.5/Microsoft.Common.targets
314%{mono_dir}/2.0/Microsoft.Common.targets
315%{mono_dir}/4.0/Microsoft.VisualBasic.targets
316%{mono_dir}/3.5/Microsoft.VisualBasic.targets
317%{mono_dir}/2.0/Microsoft.VisualBasic.targets
318%{mono_dir}/compat-*/ICSharpCode.SharpZipLib.dll
319%{mono_dir}/gac/Mono.Cecil
320%{mono_dir}/gac/Mono.Cecil.Mdb
321%{mono_dir}/mono-configuration-crypto/4.0/Mono.Configuration.Crypto.dll*
322%{mono_dir}/mono-configuration-crypto/4.0/mono-configuration-crypto.exe*
323%gac_and_2dll cscompmgd 4.0 2.0
324%gac_and_2dll Commons.Xml.Relaxng 4.0 2.0
325%gac_and_2dll CustomMarshalers 4.0 2.0
326%gac_and_2dll I18N 4.0 2.0
327%gac_and_2dll I18N.West 4.0 2.0
328%gac_and_2dll ICSharpCode.SharpZipLib 4.0 2.0
329%gac_and_1dll Microsoft.CSharp 4.0
330%gac_and_2dll Mono.C5 4.0 2.0
331%gac_and_2dll Mono.Cairo 4.0 2.0
332%gac_and_2dll Mono.CompilerServices.SymbolWriter 4.0 2.0
333%gac_and_2dll Mono.Posix 4.0 2.0
334%gac_and_2dll Mono.Security 4.0 2.0
335%gac_and_1dll Mono.Security.Win32 4.0
336%gac_and_2dll Mono.CSharp 4.0 2.0
337%gac_and_1dll Mono.CodeContracts 4.0
338%gac_and_1dll Mono.Debugger.Soft 2.0
339%gac_and_2dll Mono.Management 4.0 2.0
340%gac_and_2dll Mono.Simd 4.0 2.0
341%gac_and_2dll Mono.Tasklets 4.0 2.0
342%gac_and_2dll System 4.0 2.0
343%gac_and_2dll System.Configuration 4.0 2.0
344%gac_and_1dll System.Dynamic 4.0
345%gac_and_2dll System.Drawing 4.0 2.0
346%gac_and_2dll System.Core 4.0 2.0
347%gac_and_1dll System.ComponentModel.Composition 4.0
348%gac_and_2dll System.ComponentModel.DataAnnotations 4.0 2.0
349%gac_and_2dll System.IdentityModel 4.0 2.0
350%gac_and_2dll System.IdentityModel.Selectors 4.0 2.0
351%gac_and_1dll System.Numerics 4.0
352%gac_and_1dll System.Runtime.Caching 4.0
353%gac_and_1dll System.Runtime.DurableInstancing 4.0
354%gac_and_2dll System.Runtime.Serialization 4.0 2.0
355%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
356%gac_and_2dll System.Security 4.0 2.0
357%gac_and_1dll System.Xaml 4.0
358%gac_and_2dll System.Xml 4.0 2.0
359%gac_and_2dll System.Xml.Linq 4.0 2.0
360%gac_and_2dll OpenSystem.C 4.0 2.0
361%gac_and_2dll WindowsBase 4.0 2.0
362%dir %{_sysconfdir}/mono
363%dir %{_sysconfdir}/mono/4.0
364%dir %{_sysconfdir}/mono/2.0
365%dir %{_sysconfdir}/mono/mconfig
366%config (noreplace) %{_sysconfdir}/mono/config
367%config (noreplace) %{_sysconfdir}/mono/2.0/machine.config
368%config (noreplace) %{_sysconfdir}/mono/4.0/machine.config
369%config (noreplace) %{_sysconfdir}/mono/mconfig/config.xml
370%config (noreplace) %{_sysconfdir}/mono/2.0/settings.map
371%config (noreplace) %{_sysconfdir}/mono/4.0/settings.map
372%{_prefix}/lib/mono-source-libs/
373%{_mandir}/man1/ccrewrite.1.gz
374%{_mandir}/man1/certmgr.1.gz
375%{_mandir}/man1/chktrust.1.gz
376%{_mandir}/man1/csharp.1.gz
377%{_mandir}/man1/gacutil.1.gz
378%{_mandir}/man1/lc.1.gz
379%{_mandir}/man1/mconfig.1.gz
380%{_mandir}/man1/mcs.1.gz
381%{_mandir}/man1/mono.1.gz
382%{_mandir}/man1/monolinker.1.gz
383%{_mandir}/man1/mozroots.1.gz
384%{_mandir}/man1/setreg.1.gz
385%{_mandir}/man1/sn.1.gz
386%{_mandir}/man1/resgen.1.gz
387%{_mandir}/man1/mono-api-info.1.gz
388%{_mandir}/man1/mono-cil-strip.1.gz
389%{_mandir}/man1/mono-configuration-crypto.1.gz
390%{_mandir}/man5/mono-config.5.gz
391
392%files devel
393%defattr(-,root,root,-)
394%{_bindir}/genxs
395%{_bindir}/mkbundle
396%{_bindir}/mono-gdb.py
397%{_bindir}/monodis
398%{_bindir}/monograph
399%{_bindir}/pedump
400##{_bindir}/prj2make
401%{_bindir}/xbuild
402%{_libdir}/libmono-2.0.so
403%{_libdir}/libmono-profiler-aot.so
404%{_libdir}/libmono-profiler-cov.so
405%{_libdir}/libmono-profiler-iomap.so
406%{_libdir}/libmono-profiler-logging.so
407%{_libdir}/libmonosgen-2.0.so
408%{_libdir}/libMonoSupportW.so
409%{_libdir}/libikvm-native.so
410%{mono_dir}/4.0/mkbundle.exe*
411%{mono_dir}/2.0/mkbundle.exe*
412%{mono_dir}/4.0/genxs.exe*
413%{mono_dir}/2.0/genxs.exe*
414%{mono_dir}/2.0/ilasm.exe*
415%bin_and_exe al 4.0/al
416%bin_and_exe al2 2.0/al
417%bin_and_exe caspol 4.0/caspol
418%bin_and_exe cert2spc 4.0/cert2spc
419%bin_and_exe dtd2xsd 4.0/dtd2xsd
420%bin_and_exe dtd2rng 4.0/dtd2rng
421%bin_and_exe sgen 4.0/sgen
422%bin_and_exe ilasm 4.0/ilasm
423%bin_and_exe macpack 4.0/macpack
424%bin_and_exe makecert 4.0/makecert
425%bin_and_exe monop 4.0/monop
426%bin_and_exe monop2 2.0/monop
427%bin_and_exe mono-shlib-cop 4.0/mono-shlib-cop
428%bin_and_exe mono-xmltool 4.0/mono-xmltool
429%bin_and_exe pdb2mdb 4.0/pdb2mdb
430%bin_and_exe permview 4.0/permview
431%bin_and_exe resgen 4.0/resgen
432%bin_and_exe resgen2 2.0/resgen
433%bin_and_exe secutil 4.0/secutil
434%bin_and_exe signcode 4.0/signcode
435%{mono_dir}/xbuild
436%{mono_dir}/4.0/xbuild.*
437%{mono_dir}/3.5/xbuild.*
438%{mono_dir}/2.0/xbuild.*
439%{mono_dir}/4.0/culevel.exe*
440%{mono_dir}/2.0/culevel.exe*
441%{mono_dir}/4.0/MSBuild/*.xsd
442%{mono_dir}/3.5/MSBuild/*.xsd
443%{mono_dir}/2.0/MSBuild/*.xsd
444%{mono_dir}/4.0/Microsoft.Build.xsd
445%{mono_dir}/3.5/Microsoft.Build.xsd
446%{mono_dir}/2.0/Microsoft.Build.xsd
447%{mono_dir}/4.0/Microsoft.*.targets
448%{mono_dir}/3.5/Microsoft.*.targets
449%{mono_dir}/2.0/Microsoft.*.targets
450%{mono_dir}/4.0/Microsoft.Common.tasks
451%{mono_dir}/3.5/Microsoft.Common.tasks
452%{mono_dir}/2.0/Microsoft.Common.tasks
453%gac_and_2dll PEAPI 4.0 2.0
454%gac_and_3dll Microsoft.Build.Engine 4.0 3.5 2.0
455%gac_and_3dll Microsoft.Build.Framework 4.0 3.5 2.0
456%gac_and_1dll Microsoft.Build.Tasks 2.0
457%gac_and_1dll Microsoft.Build.Tasks.v4.0 4.0
458%gac_and_1dll Microsoft.Build.Tasks.v3.5 3.5
459%gac_and_1dll Microsoft.Build.Utilities 2.0
460%gac_and_1dll Microsoft.Build.Utilities.v4.0 4.0
461%gac_and_1dll Microsoft.Build.Utilities.v3.5 3.5
462%gac_and_2dll Microsoft.VisualC 4.0 2.0
463%{_libdir}/pkgconfig/dotnet.pc
464%{_libdir}/pkgconfig/mono-cairo.pc
465%{_libdir}/pkgconfig/mono.pc
466%{_libdir}/pkgconfig/mono-2.pc
467%{_libdir}/pkgconfig/cecil.pc
468%{_libdir}/pkgconfig/dotnet35.pc
469%{_libdir}/pkgconfig/mono-lineeditor.pc
470%{_libdir}/pkgconfig/mono-options.pc
471%{_libdir}/pkgconfig/wcf.pc
472%{_includedir}/mono-2.0
473%{_mandir}/man1/al.1.gz
474%{_mandir}/man1/cert2spc.1.gz
475##{_mandir}/man1/cilc.1.gz
476%{_mandir}/man1/dtd2xsd.1.gz
477%{_mandir}/man1/genxs.1.gz
478%{_mandir}/man1/ilasm.1.gz
479%{_mandir}/man1/macpack.1.gz
480%{_mandir}/man1/makecert.1.gz
481%{_mandir}/man1/mkbundle.1.gz
482%{_mandir}/man1/mono-shlib-cop.1.gz
483%{_mandir}/man1/mono-xmltool.1.gz
484%{_mandir}/man1/monodis.1.gz
485%{_mandir}/man1/monop.1.gz
486%{_mandir}/man1/pdb2mdb.1.gz
487%{_mandir}/man1/permview.1.gz
488##{_mandir}/man1/prj2make.1.gz
489%{_mandir}/man1/secutil.1.gz
490%{_mandir}/man1/sgen.1.gz
491%{_mandir}/man1/signcode.1.gz
492%{_mandir}/man1/xbuild.1.gz
493
494%files nunit
495%defattr(-,root,root,-)
496%bin_and_exe nunit-console 4.0/nunit-console
497%bin_and_exe nunit-console2 2.0/nunit-console
498%gac_and_2dll nunit.core 4.0 2.0
499%gac_and_2dll nunit.framework 4.0 2.0
500%gac_and_2dll nunit.util 4.0 2.0
501%gac_and_2dll nunit.mocks 4.0 2.0
502%gac_and_2dll nunit-console-runner 4.0 2.0
503%gac_and_2dll nunit.core.extensions 4.0 2.0
504%gac_and_2dll nunit.core.interfaces 4.0 2.0
505%gac_and_2dll nunit.framework.extensions 4.0 2.0
506%{_libdir}/pkgconfig/mono-nunit.pc
507
508%files locale-extras
509%defattr(-,root,root,-)
510%gac_and_2dll I18N.MidEast 4.0 2.0
511%gac_and_2dll I18N.Rare 4.0 2.0
512%gac_and_2dll I18N.CJK 4.0 2.0
513%gac_and_2dll I18N.Other 4.0 2.0
514
515%files extras
516%defattr(-,root,root,-)
517%{_mandir}/man1/mono-service.1.gz
518%bin_and_exe mono-service 4.0/mono-service
519%bin_and_exe mono-service2 2.0/mono-service
520%{mono_dir}/gac/mono-service
521%gac_and_2dll System.Configuration.Install 4.0 2.0
522%gac_and_2dll System.Management 4.0 2.0
523%gac_and_2dll System.Messaging 4.0 2.0
524%gac_and_2dll System.ServiceProcess 4.0 2.0
525%gac_and_2dll System.ServiceModel 4.0 2.0
526%gac_and_1dll System.ServiceModel.Discovery 4.0
527%gac_and_1dll System.ServiceModel.Routing 4.0
528%gac_and_2dll Mono.Messaging.RabbitMQ 4.0 2.0
529%gac_and_2dll Mono.Messaging 4.0 2.0
530%gac_and_2dll RabbitMQ.Client 4.0 2.0
531%{mono_dir}/4.0/RabbitMQ.Client.Apigen.exe*
532%{mono_dir}/2.0/RabbitMQ.Client.Apigen.exe*
533
534%files winforms
535%defattr(-,root,root,-)
536%gac_and_2dll Accessibility 4.0 2.0
537%gac_and_2dll System.Design 4.0 2.0
538%gac_and_2dll System.Drawing.Design 4.0 2.0
539%gac_and_2dll System.Windows.Forms 4.0 2.0
540%gac_and_1dll System.Windows.Forms.DataVisualization 4.0
541
542%files web
543%defattr(-,root,root,-)
544%{mono_dir}/2.0/xsd.exe*
545%{mono_dir}/compat-2.0/System.Web.Extensions*dll
546%{mono_dir}/compat-2.0/System.Web.Mvc.dll
547%bin_and_exe disco 4.0/disco
548%bin_and_exe soapsuds 4.0/soapsuds
549%bin_and_exe xsd 4.0/xsd
550%bin_and_exe wsdl 4.0/wsdl
551%bin_and_exe wsdl2 2.0/wsdl
552%bin_and_exe httpcfg 4.0/httpcfg
553%gac_and_2dll Mono.Http 4.0 2.0
554%gac_and_2dll Mono.Web 4.0 2.0
555%gac_and_2dll Mono.WebBrowser 4.0 2.0
556%gac_and_2dll System.Runtime.Remoting 4.0 2.0
557%gac_and_2dll System.Runtime.Serialization.Formatters.Soap 4.0 2.0
558%gac_and_2dll System.ServiceModel.Web 4.0 2.0
559%gac_and_2dll System.Web 4.0 2.0
560%gac_and_1dll System.Web.ApplicationServices 4.0
561%gac_and_2dll System.Web.Abstractions 4.0 2.0
562%gac_and_2dll System.Web.DynamicData 4.0 2.0
563%gac_and_1dll System.Web.Mvc 2.0
564%gac_and_2dll System.Web.Routing 4.0 2.0
565%gac_and_2dll System.Web.Services 4.0 2.0
566%gac_and_3dll System.Web.Extensions.Design 4.0 3.5 2.0
567%gac_and_2dll System.Web.Extensions 4.0 2.0
568%{_mandir}/man1/disco.1.gz
569%{_mandir}/man1/soapsuds.1.gz
570%{_mandir}/man1/wsdl.1.gz
571%{_mandir}/man1/xsd.1.gz
572%config (noreplace) %{_sysconfdir}/mono/browscap.ini
573%config (noreplace) %{_sysconfdir}/mono/2.0/Browsers/Compat.browser
574%config (noreplace) %{_sysconfdir}/mono/4.0/DefaultWsdlHelpGenerator.aspx
575%config (noreplace) %{_sysconfdir}/mono/2.0/DefaultWsdlHelpGenerator.aspx
576%config (noreplace) %{_sysconfdir}/mono/4.0/web.config
577%config (noreplace) %{_sysconfdir}/mono/2.0/web.config
578%{_mandir}/man1/httpcfg.1.gz
579%{_libdir}/pkgconfig/mono.web.pc
580%{_libdir}/pkgconfig/system.web.extensions_1.0.pc
581%{_libdir}/pkgconfig/system.web.extensions.design_1.0.pc
582%{_libdir}/pkgconfig/system.web.mvc.pc
583%{_libdir}/pkgconfig/system.web.mvc2.pc
584
585%files data
586%defattr(-,root,root,-)
587%bin_and_exe sqlsharp 4.0/sqlsharp
588%gac_and_2dll System.Data 4.0 2.0
589%gac_and_2dll System.Data.DataSetExtensions 4.0 2.0
590%gac_and_2dll System.Data.Linq 4.0 2.0
591%gac_and_2dll System.Data.Services 4.0 2.0
592%gac_and_2dll Mono.Data.Tds 4.0 2.0
593%gac_and_2dll System.EnterpriseServices 4.0 2.0
594%gac_and_2dll Novell.Directory.Ldap 4.0 2.0
595%gac_and_2dll System.DirectoryServices 4.0 2.0
596%gac_and_2dll System.Transactions 4.0 2.0
597%{mono_dir}/gac/System.Data.Services.Client
598%{_mandir}/man1/sqlsharp.1.gz
599
600%files data-sqlite
601%defattr(-,root,root,-)
602%gac_and_2dll Mono.Data.Sqlite 4.0 2.0
603
604%files data-oracle
605%defattr(-,root,root,-)
606%gac_and_2dll System.Data.OracleClient 4.0 2.0
607
608%files data-postgresql
609%defattr(-,root,root,-)
610%gac_and_2dll Npgsql 4.0 2.0
611
612%files -n ibm-data-db2
613%defattr(-,root,root,-)
614%gac_and_2dll IBM.Data.DB2 4.0 2.0
615
616%files -n monodoc
617%defattr(-, root, root)
618%bin_and_exe mdoc 4.0/mdoc
619%{_bindir}/mdoc-*
620%{_bindir}/mdass*
621%{_bindir}/mdval*
622%{_bindir}/mod
623%{_bindir}/monodoc*
624%{mono_dir}/gac/monodoc
625%{mono_dir}/monodoc/monodoc.dll
626%{mono_doc}/*
627%{_mandir}/man1/md*
628%{_mandir}/man1/monodoc*
629%{_mandir}/man5/mdoc*
630%{_libdir}/pkgconfig/monodoc.pc
631
632
633%changelog
634* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
635- updated mono to 2.8.1
636
637* Sat Nov 06 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-2
638- comment out script that removes prebuilt binaries, because gmcs.exe require
639
640* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
641- updated mono to 2.8
642- modified macros used in %%files
643- removed below:
644  - packages:
645    %{name}-jscript, %{name}-data-sybase, %{name}-data-firebird, bytefx-data-mysql
646  - libraries:
647    ByteFX.Data, FirebirdSql.Data.Firebird
648    Mono.Data Mono.Data.TdsClient, Mono.Data.SybaseClient, Mono.Data.SqliteClient
649    Microsoft.JScript, Microsoft.Vsa
650  - commands:
651    cilc, mjs, prj2make (replaced by xbuild)
652
653* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.6.7-2
654- build with rpm-4.8.1-1 for pkg-config file
655
656* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.7-1
657- updated mono to 2.6.7
658
659* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
660- updated mono to 2.6.4
661
662* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
663- updated mono to 2.6.3
664  added RabbitMQ.Client.Apigen.exe
665
666* Thu Dec 31 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-2
667- unuse _smp_mflags
668
669* Sat Dec 26 2009 Shu KONNO <owa@bg.wakwak.com> 2.6.1-1
670- updated mono to 2.6.1
671- simplified macros
672
673* Mon Dec 14 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-1
674- updated mono to 2.4.3
675  added %%{mono_dir}/2.0/lc.exe*
676  added %%gac_dll System.Web.Mvc
677  added %%{mono_dir}/xbuild/*
678  added %%{_mandir}/man1/lc.1.gz
679  added %%{_mandir}/man1/xbuild.1.gz
680
681* Wed Jul 29 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.3-1
682- updated mono to 2.4.2.3
683
684* Fri Jul 24 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2.2-1
685- updated mono to 2.4.2.2
686
687* Tue Jul 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.4.2.1-1
688- new upstream release
689- build with latest rpm to update mono-dependencies
690
691* Thu Jul 02 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.2-1
692- updated mono to 2.4.2
693
694* Mon Apr 27 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4-3
695- fix temporary workaround against build failure on ppc,
696  from RH bugzilla #494026
697  - statically link mono to libmono: remove "--disable-static" from configure
698  - ensure removing *.a files in the install section
699- remove prebuilt binaries under mcs/class/lib/monolite/ before building
700
701* Sun Apr  5 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
702- fixed paths using %%mono_dir, %%mono_doc macros
703- added Requires:libgluezilla >= 2.4 in monodoc
704
705* Sat Apr  4 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4-1
706- new upstream release
707- added monodoc package (Obsoletes: monodoc-core <= 2.0-1vl5)
708
709* Mon Nov 03 2008 Shu KONNO <owa@bg.wakwak.com> 2.0.1-1
710- new upstream release
711- dropt %%{_bindir}/mono-find-{provides,requires}
712- added --with-libgdiplus=installed
713
714* Mon Oct 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-3
715- update to mono-2.0 released source
716- BR: libgdiplus-devel >= 2.0
717
718* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-2vl5
719- removed *.la
720
721* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1vl5
722- updated mono to 2.0
723- updated url
724- changed macro %%monodir to %%mono_dir
725- dropt mono-1.1.13.4-selinux-ia64.patch
726- dropt mono-1.1.13.4-ppc-threading.patch
727- dropt mono-1.2.3-use-monodir.patch
728
729* Tue Aug 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-1vl5
730- applied new versioning policy, spec in utf-8
731- dropt mono-1.2.5-libdir.patch
732- reverted monodir macro to using %%{_prefix}/lib/mono
733
734* Sat Dec 29 2007 Shu KONNO <owa@bg.wakwak.com> 1.2.5.1-0vl2
735- updated monodir to %%{_libdir}/mono
736
737* Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5.1-0vl1
738- new upstream release
739- splited mono-basic package
740
741* Sat Oct 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.8.1-0vl1
742- new upstream release
743
744* Fri May  5 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.6-0vl1
745- new upstream release
746
747* Thu Apr 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.13.4-2vl2
748- disabled Patch2 on Vine/ppc environment
749
750* Wed Mar 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.13.4-2vl1
751- updated source and sub-packages based on Fedora packages
752  * Tue Feb 22 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.6-0vl1
753  - new upstream version(mono-1.0.6)
754  * Sun Jan 16 2005 Satoshi MACHINO <machino@vinelinux.org> 1.0.5-0vl1
755  - new upstream version(mono-1.0.5)
756  * Sat Nov 06 2004 Satoshi MACHINO <machino@vinelinux.org> 1.0.4-0vl1
757  - new upstream version(mono-1.0.4)
758        -- changed to use configure
759  * Sun Oct 24 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
760  - rebuild for Vine Linux (based on mono.spec inside src archive)
761  - Fixed BuildRequires: gc-devel, libicu-devel
762  - add Japanese translation
763
764* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 1.1.13.4-2
765- rebuild for ppc TLS issue (#184446)
766
767* Fri Mar  3 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.4-1
768- Update to 1.1.13.4
769- Add patch so mono doesn't segfault on PPC SMP machines
770- Minor spec cleanup
771
772* Thu Mar  2 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-5
773- Updated patch from Jakub (1.1.13.2-3 to 1.1.13.2-5 are
774  for bug 182965)
775
776* Tue Feb 28 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-4
777- Updated patch from Paolo Molaro <lupus@ximian.com>
778
779* Mon Feb 27 2006 Ray Strode <rstrode@redhat.com> - 1.1.13.2-3
780- Patch from Jakub to make work with SELinux better
781
782* Sun Feb 12 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-2
783- Rebuild
784
785* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1.13.2-1.1
786- rebuilt for new gcc4.1 snapshot and glibc changes
787
788* Tue Jan 31 2006 Christopher Aillon <caillon@redhat.com> - 1.1.13.2-1
789- Update to 1.1.13.2
790
791* Fri Jan 13 2006 Alexander Larsson <alexl@redhat.com> - 1.1.13-1
792- Update to 1.13
793- Add libgdiplus dep to mono-core
794- Add s390x to build
795
796* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.12.1-1
797- Update to 1.1.12.1
798
799* Mon Jan  9 2006 Alexander Larsson <alexl@redhat.com> - 1.1.10-4
800- rebuild
801
802* Fri Nov 18 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-3
803- Disable s390 due to some build failure
804
805* Thu Nov 17 2005 Alexander Larsson <alexl@redhat.com> 1.1.10-2
806- Build on s390 and x86-64 now
807
808* Tue Nov 15 2005 Alexander Larsson <alexl@redhat.com> - 1.1.10-1
809- Initial version
Note: See TracBrowser for help on using the repository browser.