source: projects/specs/trunk/m/mlt/mlt-vl.spec @ 11360

Revision 11360, 14.6 KB checked in by ara_t, 6 years ago (diff)

mlt: rebuild under current VineSeed

Line 
1%bcond_without ruby
2%bcond_with php
3
4Summary:        Toolkit for broadcasters, video editors, media players, transcoders
5Name:           mlt
6Version:        6.2.0
7Release:        4%{?_dist_release}
8
9# mlt/src/win32/fnmatch.{c,h} are BSD-licensed.
10License:        GPLv3 and LGPLv2+ and BSD
11URL:            http://www.mltframework.org/twiki/bin/view/MLT/
12Group:          System Environment/Libraries
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        https://github.com/mltframework/mlt/archive/v%{version}/%{name}-%{version}.tar.gz
18
19BuildRequires:  frei0r-devel
20BuildRequires:  opencv-devel
21BuildRequires:  qt5-qtsvg-devel
22BuildRequires:  qt5-qt3d-devel
23BuildRequires:  SDL-devel
24BuildRequires:  SDL_image-devel
25BuildRequires:  gtk2-devel
26BuildRequires:  jack-audio-connection-kit-devel
27BuildRequires:  libogg-devel
28#Deprecated dv, kino, and vorbis modules are not built.
29#https://github.com/mltframework/mlt/commit/9d082192a4d79157e963fd7f491da0f8abab683f
30#BuildRequires:  libdv-devel
31#BuildRequires:  libvorbis-devel
32BuildRequires:  libsamplerate-devel
33BuildRequires:  ladspa-devel
34BuildRequires:  libxml2-devel
35BuildRequires:  sox
36BuildRequires:  sox-devel
37BuildRequires:  swig
38BuildRequires:  python-devel
39BuildRequires:  freetype2-devel
40BuildRequires:  libexif-devel
41BuildRequires:  fftw3-devel
42BuildRequires:  pulseaudio-libs-devel
43BuildRequires:  alsa-lib-devel
44
45
46%if %{with ruby}
47BuildRequires:  ruby-devel ruby
48%else
49Obsoletes: mlt-ruby < 0.8.8-5
50%endif
51
52%if %{with php}
53BuildRequires: php-devel
54%endif
55Requires:  opencv-core
56
57%if %{with php}
58%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{php_extdir}/.*\\.so$
59%endif
60
61
62%description
63MLT is an open source multimedia framework, designed and developed for
64television broadcasting.
65
66It provides a toolkit for broadcasters, video editors,media players,
67transcoders, web streamers and many more types of applications. The
68functionality of the system is provided via an assortment of ready to use
69tools, xml authoring components, and an extendible plug-in based API.
70
71
72%package devel
73Summary:        Libraries, includes to develop applications with %{name}
74License:        LGPLv2+
75Group:          Development/Libraries
76Requires:       pkgconfig
77Requires:       %{name}%{?_isa} = %{version}-%{release}
78
79%package python
80Requires: python
81Requires: %{name}%{?_isa} = %{version}-%{release}
82Summary: Python package to work with MLT
83
84%package ruby
85Requires: %{name}%{_isa} = %{version}-%{release}
86Summary: Ruby package to work with MLT
87
88%package php
89Requires: php(zend-abi) = %{php_zend_api}
90Requires: php(api) = %{php_core_api}
91Requires: %{name}%{?_isa} = %{version}-%{release}
92Summary: PHP package to work with MLT
93
94%description devel
95The %{name}-devel package contains the header files and static libraries for
96building applications which use %{name}.
97
98%description python
99This module allows to work with MLT using python.
100
101%description ruby
102This module allows to work with MLT using ruby.
103
104%description php
105This module allows to work with MLT using PHP.
106
107
108%prep
109%setup -q
110
111chmod 644 src/modules/qt/kdenlivetitle_wrapper.cpp
112chmod 644 src/modules/kdenlive/filter_freeze.c
113chmod -x demo/demo
114
115# Don't overoptimize (breaks debugging)
116sed -i -e '/fomit-frame-pointer/d' configure
117sed -i -e '/ffast-math/d' configure
118
119
120%build
121#export STRIP=/bin/true
122%configure \
123        --enable-gpl                            \
124        --enable-gpl3                            \
125        --enable-motion-est                     \
126%ifnarch %{ix86} x86_64
127        --disable-mmx                           \
128        --disable-sse                           \
129        --disable-xine                          \
130%endif
131        --rename-melt=%{name}-melt              \
132        --swig-languages="python %{?with_php: php}%{?with_ruby: ruby}"
133
134make %{?_smp_mflags}
135
136
137%install
138make DESTDIR=%{buildroot} install
139
140# manually do what 'make install' skips
141install -D -pm 0644 src/swig/python/mlt.py %{buildroot}%{python_sitelib}/mlt.py
142install -D -pm 0755 src/swig/python/_mlt.so %{buildroot}%{python_sitearch}/_mlt.so
143
144%if %{with ruby}
145install -D -pm 0755 src/swig/ruby/play.rb %{buildroot}%{ruby_vendorlibdir}/play.rb
146install -D -pm 0755 src/swig/ruby/thumbs.rb %{buildroot}%{ruby_vendorlibdir}/thumbs.rb
147install -D -pm 0755 src/swig/ruby/mlt.so %{buildroot}%{ruby_vendorarchdir}/mlt.so
148%endif
149
150%if %{with php}
151install -D -pm 0755 src/swig/php/mlt.so %{buildroot}%{php_extdir}/mlt.so
152install -d %{buildroot}%{_sysconfdir}/php.d
153cat > %{buildroot}%{_sysconfdir}/php.d/mlt.ini << 'EOF'
154; Enable mlt extension module
155extension=mlt.so
156EOF
157%endif
158
159mv src/modules/motion_est/README README.motion_est
160
161
162%check
163# verify pkg-config version sanity
164export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
165test "$(pkg-config --modversion mlt-framework)" = "%{version}"
166test "$(pkg-config --modversion mlt++)" = "%{version}"
167
168
169%post
170/sbin/ldconfig
171
172%postun
173/sbin/ldconfig
174
175%files
176%doc AUTHORS ChangeLog NEWS README*
177%license COPYING GPL
178%{_bindir}/mlt-melt
179%{_libdir}/mlt/
180%{_libdir}/libmlt++.so.*
181%{_libdir}/libmlt.so.*
182%{_datadir}/mlt/
183
184%files python
185%{python_sitelib}/mlt.py*
186%{python_sitearch}/_mlt.so
187
188%if %{with ruby}
189%files ruby
190%{ruby_vendorlibdir}/play.rb
191%{ruby_vendorlibdir}/thumbs.rb
192%{ruby_vendorarchdir}/mlt.so
193%endif
194
195%if %{with php}
196%files php
197%config(noreplace) %{_sysconfdir}/php.d/mlt.ini
198%{php_extdir}/mlt.so
199%endif
200
201%files devel
202%doc docs/* demo/
203%{_libdir}/pkgconfig/mlt-framework.pc
204%{_libdir}/pkgconfig/mlt++.pc
205%{_libdir}/libmlt.so
206%{_libdir}/libmlt++.so
207%{_includedir}/mlt/
208%{_includedir}/mlt++/
209
210
211%changelog
212* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> - 6.2.0-4
213- rebuild under current VineSeed
214
215* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
216- initial build for Vine Linux.
217
218* Thu Jun 30 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-2
219- Disable the php extension, for now, the PHP 7 landed in rawhide
220
221* Wed May 25 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-1
222- Initial MLT spec on Fedora.
223
224* Tue Mar 29 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-3
225- Use upstream patch to compile Ruby bindings
226
227* Sun Feb 21 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-2
228- Add license tag.
229- More spec modernizations and rpmlint fixes.
230- Configure conditional build for Ruby.
231- Remove old BuilRequires that aren't needed anymore.
232- Remove old config options (avformat-swscale and qimage-libdir) that no longer
233  exist in configure.
234- Fix Ruby build.
235
236* Fri Feb 19 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-1
237- Update 6.0.0 (This is a bugfix and minor enhancement release. Note that our
238  release versioning scheme has changed. We were approaching 1.0 but decided to
239  synchronize release version with the C library ABI version, which is currently
240  at v6)
241- Switch to qt5 to fix rfbz #3810 and copy some BRs from Debian package.
242
243* Wed Nov 18 2015 Sérgio Basto <sergio@serjux.com> - 0.9.8-1
244- Update MLT to 0.9.8
245
246* Mon May 11 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-2
247- Workaround #3523
248
249* Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-1
250- Update mlt to 0.9.6 .
251- Added BuildRequires of libexif-devel .
252
253* Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.2-4
254- Added BuildRequires of opencv-devel, rfbz #3523 .
255
256* Mon Oct 20 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-3
257- Rebuilt for FFmpeg 2.4.3
258
259* Fri Sep 26 2014 Nicolas Chauvet <kwizart@gmail.com> - 0.9.2-2
260- Rebuilt for FFmpeg 2.4.x
261
262* Mon Sep 15 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-1
263- New upstream release.
264
265* Thu Aug 07 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-6
266- Rebuilt for ffmpeg-2.3
267
268* Sat Jul 26 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-5
269- Rebuild for new php, need by mlt-php
270
271* Sun Mar 30 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-4
272- Rebuilt for ffmpeg-2.2 and fix for freetype2 changes.
273
274* Wed Dec 04 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-3
275- Update License tag .
276
277* Wed Nov 20 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-2
278- Enable gplv3 as asked in rfbz #3040
279- Fix a changelog date.
280- Fix Ruby warning with rpmbuild "Use RbConfig instead of obsolete and deprecated Config".
281- Remove obsolete tag %%clean and rm -rf
282
283* Mon Oct 07 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-1
284- Update to 0.9.0
285
286* Wed Oct 02 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-7
287- Rebuilt
288
289* Thu Aug 15 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-6
290- Rebuilt for FFmpeg 2.0.x
291
292* Mon Jun 10 2013 Rex Dieter <rdieter@fedoraproject.org> 0.8.8-5
293- mlt-ruby FTBFS, omit until fixed (#2816)
294
295* Sun May 26 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-4
296- Rebuilt for x264/FFmpeg
297
298* Sun Apr 28 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-3
299- https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
300
301* Fri Feb 1  2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
302- Fix ABI requirement to Ruby 1.9
303
304* Fri Feb 1  2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
305- Update to 0.8.8
306
307* Wed Jan 30 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-2
308- Rebuilt for ffmpeg
309
310* Sun Dec 30 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-1
311- Update to 0.8.6
312
313* Sat Nov 24 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-3
314- Rebuilt for FFmpeg 1.0
315
316* Tue Jun 26 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-2
317- Rebuilt for FFmpeg
318
319* Tue Jun 19 2012 Richard Shaw <hobbes1069@gmail.com> - 0.8.0-1
320- Update to latest upstream release.
321
322* Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-3
323- fix filter
324
325* Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-2
326- update PHP requirement for PHP Guildelines
327- add php extension configuration file
328- filter php private shared so
329
330* Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.8-1
331- 0.7.8
332
333* Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-8
334- rebuild (sox)
335
336* Fri Mar 02 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-7
337- Rebuilt for c++ ABI breakage
338
339* Tue Feb 28 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-6
340- Rebuilt for x264/FFmpeg
341
342* Fri Jan 27 2012 Ryan Rix <ry@n.rix.si> 0.7.6-5
343- Include patch to fix building on gcc47 (upstreaming)
344
345* Wed Jan 25 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-4
346- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
347
348* Thu Dec 29 2011 Ryan Rix <ry@n.rix.si> 0.7.6-3
349- s/%%[?_isa}/%%{?_isa}
350
351* Tue Nov 15 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-2
352- rebuild
353
354* Fri Nov 11 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-1
355- 0.7.6
356- track files/sonames closer
357- tighten subpkg deps via %%{?_isa}
358- drop dup'd %%doc items
359
360* Mon Sep 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.7.4-2
361- Rebuilt for ffmpeg-0.8
362
363* Thu Jul 21 2011 Ryan Rix <ry@n.rix.si> - 0.7.4-1
364- New upstream
365
366* Sun Apr 10 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-2
367- Add SDL_image-devel BR per Kdenlive wiki page
368
369* Thu Apr 7 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-1
370- New upstream
371
372* Tue Dec 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-2
373- Fix build, needed a patch from mlt's git repo.
374
375* Sat Nov 20 2010 Nicolas Chauvet <kwizart@gmail.com> - 0.5.4-1.1
376- rebuilt - was missing in repo
377
378* Wed Apr 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-1
379- New upstream version to fix reported crashes against Kdenlive
380
381* Fri Feb 19 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-2
382- disabled xine module for PPC arch.
383
384* Thu Feb 18 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-1
385- new version
386
387* Wed Dec 09 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.10-1
388- new version
389- added subpackage for ruby
390
391* Wed Oct 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.6-1
392- new version
393- added subpackages for: python, PHP
394
395* Mon Sep 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.4-1
396- new version
397- renamed melt binary to mlt-melt
398
399* Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.2-1
400- new version
401- removed obsolete patches
402
403* Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-3
404- added linker and license patches
405- set license of MLT devel subpackage to LGPLv2+
406
407* Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-2
408- some PPC clearing
409
410* Mon May 18 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-1
411- update to 0.4.0
412
413* Wed May 13 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-2
414- spec cleaning
415
416* Mon May 11 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-1
417- new release
418- MLT++  is now a part of this package
419
420* Fri May  8 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-3
421- unused-direct-shlib-dependency fix
422
423* Fri Apr 17 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-2
424- spec clearing
425- added patches for resolving broken lqt-config, lib64 and execstack
426
427* Wed Apr 15 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-1
428- New release
429
430* Thu Apr  9 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-3
431- Enabled MMX support (not for PPC & PPC64)
432- include demo files
433- some spec cosmetics
434
435* Thu Mar 12 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-2
436- Change URL address
437- devel Requires: pkgconfig
438
439* Fri Feb 20 2009 Levente Farkas <lfarkas@lfarkas.org> - 0.3.6-1
440- Update to 0.3.6
441
442* Wed Nov  5 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.1-0.1.svn1180
443- update to upstream r1180
444- add --avformat-swscale configure option
445
446* Tue Nov  4 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.0-5
447- rebuilt with proper qt4 paths
448
449* Mon Oct 13 2008 jeff <moe@blagblagblag.org> - 0.3.0-4
450- Build without fomit-frame-pointer ffmath
451- Add BuildRequires: prelink
452- clear-execstack libmltgtk2.so
453- Don't strip binaries
454- Group: Development/Libraries
455- Prefix albino, humperdink, and miracle binaries with mlt-
456
457* Sun Oct  5 2008 jeff <moe@blagblagblag.org> - 0.3.0-3
458- License: GPLv2+ and LGPLv2+
459- Group: Development/Tools
460- ExcludeArch: x86_64 s390 s390x ppc ppc64
461- %%defattr(-,root,root)
462- %%doc docs/
463- %%{_libdir}/%%{name} to main package
464
465
466* Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-2
467- Change BuildRoot:
468- Full source URL
469- ExcludeArch: x86_64
470- -devel Requires: pkgconfig, Requires: %%{name} = %%{version}-%%{release}
471
472* Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-1
473- Update to 0.3.0
474- --enable-gpl
475- mlt-filehandler.patch
476
477* Tue Jul  8 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f10
478- Build for blaghead
479
480* Mon Jul  7 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f9
481- Update to svn r1155
482- Remove sox-st.h.patch
483- Add configure --disable-sox as it breaks build
484
485* Sun Nov 11 2007 jeff <moe@blagblagblag.org> - 0.2.4-0blag.f7
486- Update to 0.2.4
487- Clean up spec
488
489* Sat Jun 23 2007 jeff <moe@blagblagblag.org> - 0.2.3-0blag.f7
490- Update to 0.2.3
491
492* Sat Dec 30 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc6
493- Rebuild for 60k
494- Remove --disable-sox
495- Add mlt-0.2.2-sox-st.h.patch
496
497* Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc5
498- Update to 0.2.2
499
500* Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.1-0blag.fc5
501- BLAG'd
502- Removed "olib" from path, name, etc.
503- Add changelog
504- Update summary/description
505
Note: See TracBrowser for help on using the repository browser.