source: projects/specs/trunk/m/mlt/mlt-vl.spec @ 10587

Revision 10587, 14.5 KB checked in by tomop, 8 years ago (diff)

mlt-6.2.0-3

Line 
1%bcond_without ruby
2%bcond_with php
3
4Summary:        Toolkit for broadcasters, video editors, media players, transcoders
5Name:           mlt
6Version:        6.2.0
7Release:        3%{?_dist_release}
8
9# mlt/src/win32/fnmatch.{c,h} are BSD-licensed.
10License:        GPLv3 and LGPLv2+ and BSD
11URL:            http://www.mltframework.org/twiki/bin/view/MLT/
12Group:          System Environment/Libraries
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        https://github.com/mltframework/mlt/archive/v%{version}/%{name}-%{version}.tar.gz
18
19BuildRequires:  frei0r-devel
20BuildRequires:  opencv-devel
21BuildRequires:  qt5-qtsvg-devel
22BuildRequires:  qt5-qt3d-devel
23BuildRequires:  SDL-devel
24BuildRequires:  SDL_image-devel
25BuildRequires:  gtk2-devel
26BuildRequires:  jack-audio-connection-kit-devel
27BuildRequires:  libogg-devel
28#Deprecated dv, kino, and vorbis modules are not built.
29#https://github.com/mltframework/mlt/commit/9d082192a4d79157e963fd7f491da0f8abab683f
30#BuildRequires:  libdv-devel
31#BuildRequires:  libvorbis-devel
32BuildRequires:  libsamplerate-devel
33BuildRequires:  ladspa-devel
34BuildRequires:  libxml2-devel
35BuildRequires:  sox
36BuildRequires:  sox-devel
37BuildRequires:  swig
38BuildRequires:  python-devel
39BuildRequires:  freetype2-devel
40BuildRequires:  libexif-devel
41BuildRequires:  fftw3-devel
42BuildRequires:  pulseaudio-libs-devel
43BuildRequires:  alsa-lib-devel
44
45
46%if %{with ruby}
47BuildRequires:  ruby-devel ruby
48%else
49Obsoletes: mlt-ruby < 0.8.8-5
50%endif
51
52%if %{with php}
53BuildRequires: php-devel
54%endif
55Requires:  opencv-core
56
57%if %{with php}
58%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{php_extdir}/.*\\.so$
59%endif
60
61
62%description
63MLT is an open source multimedia framework, designed and developed for
64television broadcasting.
65
66It provides a toolkit for broadcasters, video editors,media players,
67transcoders, web streamers and many more types of applications. The
68functionality of the system is provided via an assortment of ready to use
69tools, xml authoring components, and an extendible plug-in based API.
70
71
72%package devel
73Summary:        Libraries, includes to develop applications with %{name}
74License:        LGPLv2+
75Group:          Development/Libraries
76Requires:       pkgconfig
77Requires:       %{name}%{?_isa} = %{version}-%{release}
78
79%package python
80Requires: python
81Requires: %{name}%{?_isa} = %{version}-%{release}
82Summary: Python package to work with MLT
83
84%package ruby
85Requires: %{name}%{_isa} = %{version}-%{release}
86Summary: Ruby package to work with MLT
87
88%package php
89Requires: php(zend-abi) = %{php_zend_api}
90Requires: php(api) = %{php_core_api}
91Requires: %{name}%{?_isa} = %{version}-%{release}
92Summary: PHP package to work with MLT
93
94%description devel
95The %{name}-devel package contains the header files and static libraries for
96building applications which use %{name}.
97
98%description python
99This module allows to work with MLT using python.
100
101%description ruby
102This module allows to work with MLT using ruby.
103
104%description php
105This module allows to work with MLT using PHP.
106
107
108%prep
109%setup -q
110
111chmod 644 src/modules/qt/kdenlivetitle_wrapper.cpp
112chmod 644 src/modules/kdenlive/filter_freeze.c
113chmod -x demo/demo
114
115# Don't overoptimize (breaks debugging)
116sed -i -e '/fomit-frame-pointer/d' configure
117sed -i -e '/ffast-math/d' configure
118
119
120%build
121#export STRIP=/bin/true
122%configure \
123        --enable-gpl                            \
124        --enable-gpl3                            \
125        --enable-motion-est                     \
126%ifnarch %{ix86} x86_64
127        --disable-mmx                           \
128        --disable-sse                           \
129        --disable-xine                          \
130%endif
131        --rename-melt=%{name}-melt              \
132        --swig-languages="python %{?with_php: php}%{?with_ruby: ruby}"
133
134make %{?_smp_mflags}
135
136
137%install
138make DESTDIR=%{buildroot} install
139
140# manually do what 'make install' skips
141install -D -pm 0644 src/swig/python/mlt.py %{buildroot}%{python_sitelib}/mlt.py
142install -D -pm 0755 src/swig/python/_mlt.so %{buildroot}%{python_sitearch}/_mlt.so
143
144%if %{with ruby}
145install -D -pm 0755 src/swig/ruby/play.rb %{buildroot}%{ruby_vendorlibdir}/play.rb
146install -D -pm 0755 src/swig/ruby/thumbs.rb %{buildroot}%{ruby_vendorlibdir}/thumbs.rb
147install -D -pm 0755 src/swig/ruby/mlt.so %{buildroot}%{ruby_vendorarchdir}/mlt.so
148%endif
149
150%if %{with php}
151install -D -pm 0755 src/swig/php/mlt.so %{buildroot}%{php_extdir}/mlt.so
152install -d %{buildroot}%{_sysconfdir}/php.d
153cat > %{buildroot}%{_sysconfdir}/php.d/mlt.ini << 'EOF'
154; Enable mlt extension module
155extension=mlt.so
156EOF
157%endif
158
159mv src/modules/motion_est/README README.motion_est
160
161
162%check
163# verify pkg-config version sanity
164export PKG_CONFIG_PATH=%{buildroot}%{_datadir}/pkgconfig:%{buildroot}%{_libdir}/pkgconfig
165test "$(pkg-config --modversion mlt-framework)" = "%{version}"
166test "$(pkg-config --modversion mlt++)" = "%{version}"
167
168
169%post
170/sbin/ldconfig
171
172%postun
173/sbin/ldconfig
174
175%files
176%doc AUTHORS ChangeLog NEWS README*
177%license COPYING GPL
178%{_bindir}/mlt-melt
179%{_libdir}/mlt/
180%{_libdir}/libmlt++.so.*
181%{_libdir}/libmlt.so.*
182%{_datadir}/mlt/
183
184%files python
185%{python_sitelib}/mlt.py*
186%{python_sitearch}/_mlt.so
187
188%if %{with ruby}
189%files ruby
190%{ruby_vendorlibdir}/play.rb
191%{ruby_vendorlibdir}/thumbs.rb
192%{ruby_vendorarchdir}/mlt.so
193%endif
194
195%if %{with php}
196%files php
197%config(noreplace) %{_sysconfdir}/php.d/mlt.ini
198%{php_extdir}/mlt.so
199%endif
200
201%files devel
202%doc docs/* demo/
203%{_libdir}/pkgconfig/mlt-framework.pc
204%{_libdir}/pkgconfig/mlt++.pc
205%{_libdir}/libmlt.so
206%{_libdir}/libmlt++.so
207%{_includedir}/mlt/
208%{_includedir}/mlt++/
209
210
211%changelog
212* Mon Jul 11 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
213- initial build for Vine Linux.
214
215* Thu Jun 30 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-2
216- Disable the php extension, for now, the PHP 7 landed in rawhide
217
218* Wed May 25 2016 Sérgio Basto <sergio@serjux.com> - 6.2.0-1
219- Initial MLT spec on Fedora.
220
221* Tue Mar 29 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-3
222- Use upstream patch to compile Ruby bindings
223
224* Sun Feb 21 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-2
225- Add license tag.
226- More spec modernizations and rpmlint fixes.
227- Configure conditional build for Ruby.
228- Remove old BuilRequires that aren't needed anymore.
229- Remove old config options (avformat-swscale and qimage-libdir) that no longer
230  exist in configure.
231- Fix Ruby build.
232
233* Fri Feb 19 2016 Sérgio Basto <sergio@serjux.com> - 6.0.0-1
234- Update 6.0.0 (This is a bugfix and minor enhancement release. Note that our
235  release versioning scheme has changed. We were approaching 1.0 but decided to
236  synchronize release version with the C library ABI version, which is currently
237  at v6)
238- Switch to qt5 to fix rfbz #3810 and copy some BRs from Debian package.
239
240* Wed Nov 18 2015 Sérgio Basto <sergio@serjux.com> - 0.9.8-1
241- Update MLT to 0.9.8
242
243* Mon May 11 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-2
244- Workaround #3523
245
246* Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.6-1
247- Update mlt to 0.9.6 .
248- Added BuildRequires of libexif-devel .
249
250* Thu May 07 2015 Sérgio Basto <sergio@serjux.com> - 0.9.2-4
251- Added BuildRequires of opencv-devel, rfbz #3523 .
252
253* Mon Oct 20 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-3
254- Rebuilt for FFmpeg 2.4.3
255
256* Fri Sep 26 2014 Nicolas Chauvet <kwizart@gmail.com> - 0.9.2-2
257- Rebuilt for FFmpeg 2.4.x
258
259* Mon Sep 15 2014 Sérgio Basto <sergio@serjux.com> - 0.9.2-1
260- New upstream release.
261
262* Thu Aug 07 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-6
263- Rebuilt for ffmpeg-2.3
264
265* Sat Jul 26 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-5
266- Rebuild for new php, need by mlt-php
267
268* Sun Mar 30 2014 Sérgio Basto <sergio@serjux.com> - 0.9.0-4
269- Rebuilt for ffmpeg-2.2 and fix for freetype2 changes.
270
271* Wed Dec 04 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-3
272- Update License tag .
273
274* Wed Nov 20 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-2
275- Enable gplv3 as asked in rfbz #3040
276- Fix a changelog date.
277- Fix Ruby warning with rpmbuild "Use RbConfig instead of obsolete and deprecated Config".
278- Remove obsolete tag %%clean and rm -rf
279
280* Mon Oct 07 2013 Sérgio Basto <sergio@serjux.com> - 0.9.0-1
281- Update to 0.9.0
282
283* Wed Oct 02 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-7
284- Rebuilt
285
286* Thu Aug 15 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-6
287- Rebuilt for FFmpeg 2.0.x
288
289* Mon Jun 10 2013 Rex Dieter <rdieter@fedoraproject.org> 0.8.8-5
290- mlt-ruby FTBFS, omit until fixed (#2816)
291
292* Sun May 26 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-4
293- Rebuilt for x264/FFmpeg
294
295* Sun Apr 28 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.8-3
296- https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
297
298* Fri Feb 1  2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
299- Fix ABI requirement to Ruby 1.9
300
301* Fri Feb 1  2013 Ryan Rix <ry@n.rix.si> - 0.8.8-1
302- Update to 0.8.8
303
304* Wed Jan 30 2013 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-2
305- Rebuilt for ffmpeg
306
307* Sun Dec 30 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.6-1
308- Update to 0.8.6
309
310* Sat Nov 24 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-3
311- Rebuilt for FFmpeg 1.0
312
313* Tue Jun 26 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.8.0-2
314- Rebuilt for FFmpeg
315
316* Tue Jun 19 2012 Richard Shaw <hobbes1069@gmail.com> - 0.8.0-1
317- Update to latest upstream release.
318
319* Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-3
320- fix filter
321
322* Thu Jun 14 2012 Remi Collet <remi@fedoraproject.org> 0.7.8-2
323- update PHP requirement for PHP Guildelines
324- add php extension configuration file
325- filter php private shared so
326
327* Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.8-1
328- 0.7.8
329
330* Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-8
331- rebuild (sox)
332
333* Fri Mar 02 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-7
334- Rebuilt for c++ ABI breakage
335
336* Tue Feb 28 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-6
337- Rebuilt for x264/FFmpeg
338
339* Fri Jan 27 2012 Ryan Rix <ry@n.rix.si> 0.7.6-5
340- Include patch to fix building on gcc47 (upstreaming)
341
342* Wed Jan 25 2012 Nicolas Chauvet <kwizart@gmail.com> - 0.7.6-4
343- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
344
345* Thu Dec 29 2011 Ryan Rix <ry@n.rix.si> 0.7.6-3
346- s/%%[?_isa}/%%{?_isa}
347
348* Tue Nov 15 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-2
349- rebuild
350
351* Fri Nov 11 2011 Rex Dieter <rdieter@fedoraproject.org> 0.7.6-1
352- 0.7.6
353- track files/sonames closer
354- tighten subpkg deps via %%{?_isa}
355- drop dup'd %%doc items
356
357* Mon Sep 26 2011 Nicolas Chauvet <kwizart@gmail.com> - 0.7.4-2
358- Rebuilt for ffmpeg-0.8
359
360* Thu Jul 21 2011 Ryan Rix <ry@n.rix.si> - 0.7.4-1
361- New upstream
362
363* Sun Apr 10 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-2
364- Add SDL_image-devel BR per Kdenlive wiki page
365
366* Thu Apr 7 2011 Ryan Rix <ry@n.rix.si> - 0.7.0-1
367- New upstream
368
369* Tue Dec 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-2
370- Fix build, needed a patch from mlt's git repo.
371
372* Sat Nov 20 2010 Nicolas Chauvet <kwizart@gmail.com> - 0.5.4-1.1
373- rebuilt - was missing in repo
374
375* Wed Apr 21 2010 Ryan Rix <ry@n.rix.si> - 0.5.4-1
376- New upstream version to fix reported crashes against Kdenlive
377
378* Fri Feb 19 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-2
379- disabled xine module for PPC arch.
380
381* Thu Feb 18 2010 Zarko Pintar <zarko.pintar@gmail.com> - 0.5.0-1
382- new version
383
384* Wed Dec 09 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.10-1
385- new version
386- added subpackage for ruby
387
388* Wed Oct 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.6-1
389- new version
390- added subpackages for: python, PHP
391
392* Mon Sep 07 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.4-1
393- new version
394- renamed melt binary to mlt-melt
395
396* Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.2-1
397- new version
398- removed obsolete patches
399
400* Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-3
401- added linker and license patches
402- set license of MLT devel subpackage to LGPLv2+
403
404* Wed May 20 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-2
405- some PPC clearing
406
407* Mon May 18 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.4.0-1
408- update to 0.4.0
409
410* Wed May 13 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-2
411- spec cleaning
412
413* Mon May 11 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.9-1
414- new release
415- MLT++  is now a part of this package
416
417* Fri May  8 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-3
418- unused-direct-shlib-dependency fix
419
420* Fri Apr 17 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-2
421- spec clearing
422- added patches for resolving broken lqt-config, lib64 and execstack
423
424* Wed Apr 15 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.8-1
425- New release
426
427* Thu Apr  9 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-3
428- Enabled MMX support (not for PPC & PPC64)
429- include demo files
430- some spec cosmetics
431
432* Thu Mar 12 2009 Zarko Pintar <zarko.pintar@gmail.com> - 0.3.6-2
433- Change URL address
434- devel Requires: pkgconfig
435
436* Fri Feb 20 2009 Levente Farkas <lfarkas@lfarkas.org> - 0.3.6-1
437- Update to 0.3.6
438
439* Wed Nov  5 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.1-0.1.svn1180
440- update to upstream r1180
441- add --avformat-swscale configure option
442
443* Tue Nov  4 2008 Arkady L. Shane <ashejn@yandex-team.ru> - 0.3.0-5
444- rebuilt with proper qt4 paths
445
446* Mon Oct 13 2008 jeff <moe@blagblagblag.org> - 0.3.0-4
447- Build without fomit-frame-pointer ffmath
448- Add BuildRequires: prelink
449- clear-execstack libmltgtk2.so
450- Don't strip binaries
451- Group: Development/Libraries
452- Prefix albino, humperdink, and miracle binaries with mlt-
453
454* Sun Oct  5 2008 jeff <moe@blagblagblag.org> - 0.3.0-3
455- License: GPLv2+ and LGPLv2+
456- Group: Development/Tools
457- ExcludeArch: x86_64 s390 s390x ppc ppc64
458- %%defattr(-,root,root)
459- %%doc docs/
460- %%{_libdir}/%%{name} to main package
461
462
463* Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-2
464- Change BuildRoot:
465- Full source URL
466- ExcludeArch: x86_64
467- -devel Requires: pkgconfig, Requires: %%{name} = %%{version}-%%{release}
468
469* Sun Aug 24 2008 jeff <moe@blagblagblag.org> - 0.3.0-1
470- Update to 0.3.0
471- --enable-gpl
472- mlt-filehandler.patch
473
474* Tue Jul  8 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f10
475- Build for blaghead
476
477* Mon Jul  7 2008 jeff <moe@blagblagblag.org> - 0.2.5-0.svn1155.0blag.f9
478- Update to svn r1155
479- Remove sox-st.h.patch
480- Add configure --disable-sox as it breaks build
481
482* Sun Nov 11 2007 jeff <moe@blagblagblag.org> - 0.2.4-0blag.f7
483- Update to 0.2.4
484- Clean up spec
485
486* Sat Jun 23 2007 jeff <moe@blagblagblag.org> - 0.2.3-0blag.f7
487- Update to 0.2.3
488
489* Sat Dec 30 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc6
490- Rebuild for 60k
491- Remove --disable-sox
492- Add mlt-0.2.2-sox-st.h.patch
493
494* Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.2-0blag.fc5
495- Update to 0.2.2
496
497* Sat Oct 21 2006 jeff <moe@blagblagblag.org> - 0.2.1-0blag.fc5
498- BLAG'd
499- Removed "olib" from path, name, etc.
500- Add changelog
501- Update summary/description
502
Note: See TracBrowser for help on using the repository browser.