source: projects/specs/trunk/m/mkinitrd/mkinitrd-vl.spec @ 11134

Revision 11134, 12.2 KB checked in by iwamoto, 7 years ago (diff)

mkinitrd: fix firmware copy error

Line 
1Summary: Creates an initial ramdisk image for preloading modules.
2Summary(ja): モジュールをプリロードするための初期RAMディスク(initramfs)作成ユーティリティ
3Name: mkinitrd
4Version: 6.0.93
5Release: 24%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Base
8
9Source0: mkinitrd-%{version}.tar.bz2
10
11Patch11: mkinitrd-6.0.93-add-drm-whitelist.patch
12Patch12: mkinitrd-6.0.93-fix-detect-usb-storage.patch
13Patch13: mkinitrd-6.0.93-no-daemonize-plymouth.patch
14Patch14: mkinitrd-6.0.93-noselinux.patch
15Patch15: mkinitrd-6.0.93-restrict-udev-messages.patch
16
17Patch20: mkinitrd-6.0.93-tuxonice.patch
18Patch21: mkinitrd-6.0.93-remove-bash4ism.patch
19Patch22: mkinitrd-6.0.93-fix-resolving-library-deps.patch
20Patch23: mkinitrd-6.0.93-add-nouveau-radeon-to-whitelist.patch
21Patch24: mkinitrd-6.0.93-add-drm-drivers-for-hardware-with-no-currently-loaded.patch
22Patch25: mkinitrd-6.0.93-nokmsboot-option.patch
23Patch26: mkinitrd-6.0.93-gcc46.patch
24Patch27: mkinitrd-6.0.93-kmod.patch
25Patch28: mkinitrd-6.0.93-loadusb.patch
26Patch29: mkinitrd-6.0.93-devtmpfs.patch
27Patch30: mkinitrd-6.0.93-create-etc-blkid.patch
28Patch31: mkinitrd/mkinitrd-6.0.93-lvm2-2.02.98.patch
29Patch32: mkinitrd-6.0.93-no_scsi_wait_scan.patch
30Patch33: mkinitrd-6.0.93-resolve-device-name.patch
31Patch34: mkinitrd-6.0.93-firmware_copy_fix.patch
32
33ExclusiveOs: Linux
34URL: git://git.fedoraproject.org/git/hosted/mkinitrd
35Requires: /bin/sh, /sbin/modprobe, /sbin/losetup
36Requires: fileutils, grep, mount, gzip, tar, mktemp
37Requires: lvm2
38Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts
39Requires: coreutils
40Requires: mdadm, elfutils-libelf, isomd5sum, plymouth
41Requires: util-linux-ng
42BuildRequires: popt-devel, elfutils-libelf-devel, elfutils-devel
43BuildRequires: libblkid-devel, parted-devel >= 1.8.5, pkgconfig
44BuildRequires: device-mapper-devel, python-devel
45BuildRequires: python, util-linux-ng, libnl-devel
46BuildRequires: libuuid-devel
47%ifnarch s390 s390x
48Requires: dmraid
49Requires: kbd
50%endif
51Requires: nash = %{version}-%{release}
52Requires: grubby
53BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: daisuke
58
59%description
60mkinitrd creates filesystem images for use as initial ram filesystem
61(initramfs) images.  These images are used to find and mount the root
62filesystem.
63
64%package devel
65Summary: C header files and library for functionality exported by libnash.
66Summary(ja): C header files and library for functionality exported by libnash.
67Group: Development/Libraries
68Requires: glibc-devel, pkgconfig, e2fsprogs-devel, mkinitrd
69Requires: nash = %{version}-%{release}
70
71%package -n libbdevid-python
72Summary: Python bindings for libbdevid
73Summary(ja): Python bindings for libbdevid
74Group: System Environment/Libraries
75Requires: e2fsprogs, device-mapper-libs
76Requires: python, nash = %{version}-%{release}
77
78%package -n nash
79Summary: nash
80Summary(ja): nash
81Group: System Environment/Base
82Requires: parted, device-mapper-libs, e2fsprogs
83Requires: popt
84Requires: openssl, zlib
85Provides: libbdevid = %{version}-%{release}
86Obsoletes: libbdevid < %{version}-%{release}
87
88%description devel
89C header files and library for functionality exported by libnash.
90
91%description -n libbdevid-python
92Python bindings for libbdevid.
93
94%description -n nash
95nash
96
97%prep
98%setup -q -n mkinitrd-%{version}
99%patch11 -p1
100%patch12 -p1
101%patch13 -p1
102%patch14 -p1
103%patch15 -p1
104%patch20 -p1
105%patch21 -p1
106%patch22 -p1
107%patch23 -p1
108%patch24 -p1
109%patch25 -p1
110%patch26 -p1
111%patch27 -p1
112%patch28 -p1
113%patch30 -p1
114%patch34 -p0
115%if "%{_dist_release}" >= "vl7"
116%patch29 -p1
117%patch31 -p1
118%patch32 -p1
119%patch33 -p0
120%endif
121
122find . -name "Makefile*" -exec sed -i 's|-Werror||g' {} \;
123
124%build
125make LIB=%{_lib}
126make LIB=%{_lib} test
127
128%install
129rm -rf $RPM_BUILD_ROOT
130make LIB=%{_lib} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
131rm -f $RPM_BUILD_ROOT/sbin/bdevid $RPM_BUILD_ROOT/%{_includedir}/blkent.h
132
133%clean
134rm -rf $RPM_BUILD_ROOT
135
136%files
137%defattr(-,root,root)
138%attr(755,root,root) /sbin/mkinitrd
139%attr(644,root,root) %{_mandir}/man8/mkinitrd.8*
140%attr(755,root,root) /usr/libexec/mkliveinitrd
141%attr(755,root,root) /usr/libexec/initrd-functions
142
143%files devel
144%defattr(-,root,root)
145%{_libdir}/libnash.so
146%{_libdir}/libbdevid.so
147%{_libdir}/libbdevidprobe.a
148%{_libdir}/pkgconfig/libnash.pc
149%{_libdir}/pkgconfig/libbdevid.pc
150%{_libdir}/pkgconfig/libbdevidprobe.pc
151%{_includedir}/nash.h
152%{_includedir}/nash
153%{_includedir}/bdevid.h
154%{_includedir}/bdevid
155
156%files -n libbdevid-python
157%defattr(-,root,root)
158%{python_sitearch}/bdevid.so
159
160%files -n nash
161%defattr(-,root,root)
162%attr(644,root,root) %{_mandir}/man8/nash.8*
163%attr(755,root,root) /sbin/nash
164%attr(755,root,root) /sbin/lsinitrd
165/%{_lib}/bdevid
166%{_libdir}/libnash.so.*
167%{_libdir}/libbdevid.so.*
168%dir %{_sysconfdir}/kernel
169%dir %{_sysconfdir}/kernel/postinst.d
170%dir %{_sysconfdir}/kernel/prerm.d
171
172%changelog
173* Sat Jul 22 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.0.93-24
174- add patch34 for fix firmware copy error
175- remove ppc if-endif
176- remove too old changelog (has many many date error)
177
178* Sat Nov 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.93-23
179- added Patch33 to fix resolve_device_name().
180
181* Wed Dec 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-22
182- add patch30 to create /etc/blkid
183- add patch31 to support newer lvm2
184- add patch32 to use sleep instead of scsi_wait_scan
185
186* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-21
187- rebuild with parted-3.1
188
189* Sun Jul 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-20
190- add patch29 to mount devtmpfs on /dev (newer udev support)
191
192* Sun Jul 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-19
193- add patch28 to load xhci-hcd and usb-storage by default
194
195* Fri Jul 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-18
196- update kmod patch
197  - install module.{order,builtin} to initrd
198
199* Wed Jul 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-17
200- fix version
201
202* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-16
203- add patch27 to support kmod
204
205* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-15
206- remove R: insmod.static, add R: modprobe
207
208* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-14
209- rebuild with python-2.7.2
210
211* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-13
212- rebuild with parted-3.0
213- add Patch26 (mkinitrd-6.0.93-gcc46.patch)
214
215* Tue Jul 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-12
216- Patch23: add radeon/nouveau to DRM_WHITELIST
217- Patch24: add drm drivers for hardware with no currently loaded
218  drm driver
219- Patch25: do not load KMS driver when booted with nokmsboot or
220  failsage options
221
222* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-11
223- add BuildRequires: libuuid-devel
224
225* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.0.93-10
226- rebuilt with parted 2.3
227
228* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 6.0.93-9
229- rebuilt with rpm-4.8.1 for pkg-config
230
231* Tue May 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-8
232- add Patch22 to fix resolving library dependencies
233
234* Mon Apr 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-7
235- add Patch21 to remove bash4ism
236
237* Thu Mar 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.0.93-6
238- Requires powerpc-utils instead of ppc64-utils
239
240* Tue Mar 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-5
241- fix typo in patch20
242
243* Thu Mar 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-4
244- add Patch20 to support tuxonice
245
246* Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-3
247- fix python module path on x86_64
248
249* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-2
250- add Patch11-15 from mdv
251
252* Mon Feb 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-1
253- initial build for Vine Linux
254
255* Wed Sep  2 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.93-1
256- Move hotplug run to before gpu driver probing (airlied, #520730)
257- Fix (non-fatal) syntax error (katzj, #513414)
258
259* Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 6.0.92-3
260- Convert specfile to UTF-8.
261
262* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.92-2
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
264
265* Mon Jul 20 2009 Jeremy Katz <katzj@redhat.com> - 6.0.92-1
266- Fix live image booting with udev creating /dev/mapper/control
267- Workaround to try to stop the live image dm backing images from showing
268  up in devkit-disks (#495170)
269
270* Fri Jul 10 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 6.0.91-2
271- rebuild against new parted
272
273* Mon Jul  6 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.91-1
274- Allow setting VG_LIST in /etc/sysconfig/mkinitrd (#509709)
275- Fix mkrootdev failing with norelatime option (#509687)
276
277* Tue Jun 30 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.90-1
278- drop e2fsprogs requires (#508407)
279- process all PVs in a required VG (#506189)
280
281* Wed Jun 24 2009 Jeremy Katz <katzj@redhat.com> - 6.0.89-1
282- grubby is now its own source package as we prepare to let people
283  try out dracut more
284
285* Mon Jun 22 2009 Jeremy Katz <katzj@redhat.com> - 6.0.88-1
286- udev has dropped /lib/udev/vol_id, so use blkid instead (#506360)
287- accordingly, require new enough util-linux-ng for blkid -o udev
288
289* Tue Jun 16 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.87-1
290- Fix mkinitrd creating a non booting initrd when parted-devel is installed
291  and the user has made configuration changes resulting in ld.so searching
292  /usr/lib before /lib (#502221)
293- Fix nash' network command not setting the default gateway (#501033)
294
295* Mon Jun 15 2009 Karsten Hopp <karsten@redhat.com> 6.0.86-2.1
296- there is no kbd package on s390x, don't require it there
297- require libblkid-devel instead on e2fsprogs-devel
298
299* Fri May 29 2009 Peter Jones <pjones@redhat.com> - 6.0.86-2
300- Require "kbd" package so keyboard settings will work right after initial
301  installation. (#501584)
302
303* Thu May 21 2009 Bill Nottingham <notting@redhat.com> - 6.0.86-1
304- Reorder font initialization to properly handle KMS
305
306* Tue May 19 2009 Peter Jones <pjones@redhat.com> - 6.0.85-1
307- Handle F9's crypttab format as well (#501198)
308
309* Thu May 14 2009 Peter Jones <pjones@redhat.com> - 6.0.84-1
310- Don't use fixed device names in cryptsetup (#500830)
311
312* Mon Apr 27 2009 Jeremy Katz <katzj@redhat.com> - 6.0.83-1
313- Fix up syntax error in udev rules for live image (#497762)
314
315* Thu Apr 16 2009 Jeremy Katz <katzj@redhat.com> - 6.0.82-1
316- Don't show live snapshot dev with devkit-disks (#495170)
317- grubby: Don't crash showing "other" sections (hans, #491622)
318
319* Mon Mar 16 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.81-1
320- Make mkinitrd work with kernels < 2.6.29 (#487358, #489151)
321- Fix booting of i2o devices (#476277)
322
323* Fri Mar  6 2009 Jeremy Katz <katzj@redhat.com> - 6.0.80-1
324- Fix up a multi live case to work
325
326* Fri Mar  6 2009 Jeremy Katz <katzj@redhat.com> - 6.0.79-1
327- Fix handling of  keymaps which are symlinks (hdegoede, #485615)
328- Show splash later for live images (mccann)
329- Make live initrd boot quieter (#488862)
330- First steps of multiple live medium support (Till Maas)
331
332* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.78-2
333- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
334
335* Mon Feb 23 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.78-1
336- Use dmraid instead of setting up dm tables ourselves, this fixed dmraid10
337  and via dmraid setups (hdegoede)
338- Speed up mkblkdevs (Alexandre Oliva)
339- exit() from nash-hotplug when the parent pid dies (Olivier Blin)
340- Avoid unnecessarily loading raid456 (#312521, Curtis Doty)
341- Fix various segfaults in renameNetworkInterface() (#485309, hdegoede)
342
343* Tue Feb 10 2009 Jeremy Katz <katzj@redhat.com> - 6.0.77-1
344- Fix mkliveinitrd with mtd root (#484496)
345- Minor boot speedup for the live case
346
347* Wed Feb  4 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.76-1
348- Fix configuration of network interfaces for network boot (#481078)
349- Fix iscsi chap password being seen as ********
350- Handle lv root specified as /dev/dm-X properly (#471729)
351- Initial commit of EXTLINUX (no menu) support
352- Do not call dm_resolve_name on dmraidsets names, sometimes it fails, and
353  it is not necessary, this fixes the dmraid boot failure seen on
354  some systems (#476818)
355- Make nash mount support relatime (#296361)
356- FIX: nash unable to find dm devs by uuid or label (#480667)
357
358* Mon Jan 19 2009 Jeremy Katz <katzj@redhat.com> - 6.0.75-1
359- fix live images to be smarter with rootfstype=auto
360
361* Wed Jan 14 2009 Jeremy Katz <katzj@redhat.com> - 6.0.74-1
362- modesetting for live images
363
Note: See TracBrowser for help on using the repository browser.