source: projects/specs/trunk/m/mkinitrd/mkinitrd-vl.spec @ 12227

Revision 12227, 12.5 KB checked in by tomop, 5 years ago (diff)

mkinitrd-6.0.93-25

Line 
1Summary: Creates an initial ramdisk image for preloading modules.
2Summary(ja): モジュールをプリロードするための初期RAMディスク(initramfs)作成ユーティリティ
3Name: mkinitrd
4Version: 6.0.93
5Release: 25%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Base
8
9Source0: mkinitrd-%{version}.tar.bz2
10
11Patch11: mkinitrd-6.0.93-add-drm-whitelist.patch
12Patch12: mkinitrd-6.0.93-fix-detect-usb-storage.patch
13Patch13: mkinitrd-6.0.93-no-daemonize-plymouth.patch
14Patch14: mkinitrd-6.0.93-noselinux.patch
15Patch15: mkinitrd-6.0.93-restrict-udev-messages.patch
16
17Patch20: mkinitrd-6.0.93-tuxonice.patch
18Patch21: mkinitrd-6.0.93-remove-bash4ism.patch
19Patch22: mkinitrd-6.0.93-fix-resolving-library-deps.patch
20Patch23: mkinitrd-6.0.93-add-nouveau-radeon-to-whitelist.patch
21Patch24: mkinitrd-6.0.93-add-drm-drivers-for-hardware-with-no-currently-loaded.patch
22Patch25: mkinitrd-6.0.93-nokmsboot-option.patch
23Patch26: mkinitrd-6.0.93-gcc46.patch
24Patch27: mkinitrd-6.0.93-kmod.patch
25Patch28: mkinitrd-6.0.93-loadusb.patch
26Patch29: mkinitrd-6.0.93-devtmpfs.patch
27Patch30: mkinitrd-6.0.93-create-etc-blkid.patch
28Patch31: mkinitrd/mkinitrd-6.0.93-lvm2-2.02.98.patch
29Patch32: mkinitrd-6.0.93-no_scsi_wait_scan.patch
30Patch33: mkinitrd-6.0.93-resolve-device-name.patch
31Patch34: mkinitrd-6.0.93-firmware_copy_fix.patch
32
33Patch100: mkinitrd-modern-toolchain.patch
34Patch101: mkinitrd-function-adhoc.patch
35
36ExclusiveOs: Linux
37URL: git://git.fedoraproject.org/git/hosted/mkinitrd
38Requires: /bin/sh, /sbin/modprobe, /sbin/losetup
39Requires: fileutils, grep, mount, gzip, tar, mktemp
40Requires: lvm2
41Requires: filesystem >= 2.1.0, cpio, device-mapper, initscripts
42Requires: coreutils
43Requires: mdadm, elfutils-libelf, isomd5sum, plymouth
44Requires: util-linux-ng
45BuildRequires: popt-devel, elfutils-libelf-devel, elfutils-devel
46BuildRequires: libblkid-devel, parted-devel >= 1.8.5, pkgconfig
47BuildRequires: device-mapper-devel, python-devel
48BuildRequires: python, util-linux-ng, libnl-devel
49BuildRequires: libuuid-devel
50%ifnarch s390 s390x
51Requires: dmraid
52Requires: kbd
53%endif
54Requires: nash = %{version}-%{release}
55Requires: grubby
56BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: daisuke
61
62%description
63mkinitrd creates filesystem images for use as initial ram filesystem
64(initramfs) images.  These images are used to find and mount the root
65filesystem.
66
67%package devel
68Summary: C header files and library for functionality exported by libnash.
69Summary(ja): C header files and library for functionality exported by libnash.
70Group: Development/Libraries
71Requires: glibc-devel, pkgconfig, e2fsprogs-devel, mkinitrd
72Requires: nash = %{version}-%{release}
73
74%package -n libbdevid-python
75Summary: Python bindings for libbdevid
76Summary(ja): Python bindings for libbdevid
77Group: System Environment/Libraries
78Requires: e2fsprogs, device-mapper-libs
79Requires: python, nash = %{version}-%{release}
80
81%package -n nash
82Summary: nash
83Summary(ja): nash
84Group: System Environment/Base
85Requires: parted, device-mapper-libs, e2fsprogs
86Requires: popt
87Requires: openssl, zlib
88Provides: libbdevid = %{version}-%{release}
89Obsoletes: libbdevid < %{version}-%{release}
90
91%description devel
92C header files and library for functionality exported by libnash.
93
94%description -n libbdevid-python
95Python bindings for libbdevid.
96
97%description -n nash
98nash
99
100%prep
101%setup -q -n mkinitrd-%{version}
102%patch11 -p1
103%patch12 -p1
104%patch13 -p1
105%patch14 -p1
106%patch15 -p1
107%patch20 -p1
108%patch21 -p1
109%patch22 -p1
110%patch23 -p1
111%patch24 -p1
112%patch25 -p1
113%patch26 -p1
114%patch27 -p1
115%patch28 -p1
116%patch30 -p1
117%patch34 -p0
118%if "%{_dist_release}" >= "vl7"
119%patch29 -p1
120%patch31 -p1
121%patch32 -p1
122%patch33 -p0
123%patch100 -p1
124%patch101 -p1
125%endif
126
127%build
128make LIB=%{_lib}
129make LIB=%{_lib} test
130
131%install
132rm -rf $RPM_BUILD_ROOT
133make LIB=%{_lib} DESTDIR=$RPM_BUILD_ROOT mandir=%{_mandir} install
134rm -f $RPM_BUILD_ROOT/sbin/bdevid $RPM_BUILD_ROOT/%{_includedir}/blkent.h
135
136# conflicts with dracut
137rm -f %{buildroot}/sbin/lsinitrd
138
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%files
144%defattr(-,root,root)
145%attr(755,root,root) /sbin/mkinitrd
146%attr(644,root,root) %{_mandir}/man8/mkinitrd.8*
147%attr(755,root,root) /usr/libexec/mkliveinitrd
148%attr(755,root,root) /usr/libexec/initrd-functions
149
150%files devel
151%defattr(-,root,root)
152%{_libdir}/libnash.so
153%{_libdir}/libbdevid.so
154%{_libdir}/libbdevidprobe.a
155%{_libdir}/pkgconfig/libnash.pc
156%{_libdir}/pkgconfig/libbdevid.pc
157%{_libdir}/pkgconfig/libbdevidprobe.pc
158%{_includedir}/nash.h
159%{_includedir}/nash
160%{_includedir}/bdevid.h
161%{_includedir}/bdevid
162
163%files -n libbdevid-python
164%defattr(-,root,root)
165%{python_sitearch}/bdevid.so
166
167%files -n nash
168%defattr(-,root,root)
169%attr(644,root,root) %{_mandir}/man8/nash.8*
170%attr(755,root,root) /sbin/nash
171/%{_lib}/bdevid
172%{_libdir}/libnash.so.*
173%{_libdir}/libbdevid.so.*
174%dir %{_sysconfdir}/kernel
175%dir %{_sysconfdir}/kernel/postinst.d
176%dir %{_sysconfdir}/kernel/prerm.d
177
178%changelog
179* Wed Sep 25 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.93-25
180- dropped /usr/sbin/lsinitrd: conflicts with dracut.
181- added Patch100 to build with current toolchain.
182- added Patch101.
183
184* Sat Jul 22 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.0.93-24
185- add patch34 for fix firmware copy error
186- remove ppc if-endif
187- remove too old changelog (has many many date error)
188
189* Sat Nov 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.93-23
190- added Patch33 to fix resolve_device_name().
191
192* Wed Dec 12 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-22
193- add patch30 to create /etc/blkid
194- add patch31 to support newer lvm2
195- add patch32 to use sleep instead of scsi_wait_scan
196
197* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-21
198- rebuild with parted-3.1
199
200* Sun Jul 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-20
201- add patch29 to mount devtmpfs on /dev (newer udev support)
202
203* Sun Jul 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-19
204- add patch28 to load xhci-hcd and usb-storage by default
205
206* Fri Jul 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-18
207- update kmod patch
208  - install module.{order,builtin} to initrd
209
210* Wed Jul 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-17
211- fix version
212
213* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-16
214- add patch27 to support kmod
215
216* Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-15
217- remove R: insmod.static, add R: modprobe
218
219* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-14
220- rebuild with python-2.7.2
221
222* Fri Jan 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-13
223- rebuild with parted-3.0
224- add Patch26 (mkinitrd-6.0.93-gcc46.patch)
225
226* Tue Jul 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-12
227- Patch23: add radeon/nouveau to DRM_WHITELIST
228- Patch24: add drm drivers for hardware with no currently loaded
229  drm driver
230- Patch25: do not load KMS driver when booted with nokmsboot or
231  failsage options
232
233* Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.0.93-11
234- add BuildRequires: libuuid-devel
235
236* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.0.93-10
237- rebuilt with parted 2.3
238
239* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 6.0.93-9
240- rebuilt with rpm-4.8.1 for pkg-config
241
242* Tue May 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-8
243- add Patch22 to fix resolving library dependencies
244
245* Mon Apr 12 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-7
246- add Patch21 to remove bash4ism
247
248* Thu Mar 25 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.0.93-6
249- Requires powerpc-utils instead of ppc64-utils
250
251* Tue Mar 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-5
252- fix typo in patch20
253
254* Thu Mar 18 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-4
255- add Patch20 to support tuxonice
256
257* Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-3
258- fix python module path on x86_64
259
260* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-2
261- add Patch11-15 from mdv
262
263* Mon Feb 15 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0.93-1
264- initial build for Vine Linux
265
266* Wed Sep  2 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.93-1
267- Move hotplug run to before gpu driver probing (airlied, #520730)
268- Fix (non-fatal) syntax error (katzj, #513414)
269
270* Mon Aug 10 2009 Ville Skyttä <ville.skytta@iki.fi> - 6.0.92-3
271- Convert specfile to UTF-8.
272
273* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.92-2
274- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
275
276* Mon Jul 20 2009 Jeremy Katz <katzj@redhat.com> - 6.0.92-1
277- Fix live image booting with udev creating /dev/mapper/control
278- Workaround to try to stop the live image dm backing images from showing
279  up in devkit-disks (#495170)
280
281* Fri Jul 10 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 6.0.91-2
282- rebuild against new parted
283
284* Mon Jul  6 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.91-1
285- Allow setting VG_LIST in /etc/sysconfig/mkinitrd (#509709)
286- Fix mkrootdev failing with norelatime option (#509687)
287
288* Tue Jun 30 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.90-1
289- drop e2fsprogs requires (#508407)
290- process all PVs in a required VG (#506189)
291
292* Wed Jun 24 2009 Jeremy Katz <katzj@redhat.com> - 6.0.89-1
293- grubby is now its own source package as we prepare to let people
294  try out dracut more
295
296* Mon Jun 22 2009 Jeremy Katz <katzj@redhat.com> - 6.0.88-1
297- udev has dropped /lib/udev/vol_id, so use blkid instead (#506360)
298- accordingly, require new enough util-linux-ng for blkid -o udev
299
300* Tue Jun 16 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.87-1
301- Fix mkinitrd creating a non booting initrd when parted-devel is installed
302  and the user has made configuration changes resulting in ld.so searching
303  /usr/lib before /lib (#502221)
304- Fix nash' network command not setting the default gateway (#501033)
305
306* Mon Jun 15 2009 Karsten Hopp <karsten@redhat.com> 6.0.86-2.1
307- there is no kbd package on s390x, don't require it there
308- require libblkid-devel instead on e2fsprogs-devel
309
310* Fri May 29 2009 Peter Jones <pjones@redhat.com> - 6.0.86-2
311- Require "kbd" package so keyboard settings will work right after initial
312  installation. (#501584)
313
314* Thu May 21 2009 Bill Nottingham <notting@redhat.com> - 6.0.86-1
315- Reorder font initialization to properly handle KMS
316
317* Tue May 19 2009 Peter Jones <pjones@redhat.com> - 6.0.85-1
318- Handle F9's crypttab format as well (#501198)
319
320* Thu May 14 2009 Peter Jones <pjones@redhat.com> - 6.0.84-1
321- Don't use fixed device names in cryptsetup (#500830)
322
323* Mon Apr 27 2009 Jeremy Katz <katzj@redhat.com> - 6.0.83-1
324- Fix up syntax error in udev rules for live image (#497762)
325
326* Thu Apr 16 2009 Jeremy Katz <katzj@redhat.com> - 6.0.82-1
327- Don't show live snapshot dev with devkit-disks (#495170)
328- grubby: Don't crash showing "other" sections (hans, #491622)
329
330* Mon Mar 16 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.81-1
331- Make mkinitrd work with kernels < 2.6.29 (#487358, #489151)
332- Fix booting of i2o devices (#476277)
333
334* Fri Mar  6 2009 Jeremy Katz <katzj@redhat.com> - 6.0.80-1
335- Fix up a multi live case to work
336
337* Fri Mar  6 2009 Jeremy Katz <katzj@redhat.com> - 6.0.79-1
338- Fix handling of  keymaps which are symlinks (hdegoede, #485615)
339- Show splash later for live images (mccann)
340- Make live initrd boot quieter (#488862)
341- First steps of multiple live medium support (Till Maas)
342
343* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.0.78-2
344- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
345
346* Mon Feb 23 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.78-1
347- Use dmraid instead of setting up dm tables ourselves, this fixed dmraid10
348  and via dmraid setups (hdegoede)
349- Speed up mkblkdevs (Alexandre Oliva)
350- exit() from nash-hotplug when the parent pid dies (Olivier Blin)
351- Avoid unnecessarily loading raid456 (#312521, Curtis Doty)
352- Fix various segfaults in renameNetworkInterface() (#485309, hdegoede)
353
354* Tue Feb 10 2009 Jeremy Katz <katzj@redhat.com> - 6.0.77-1
355- Fix mkliveinitrd with mtd root (#484496)
356- Minor boot speedup for the live case
357
358* Wed Feb  4 2009 Hans de Goede <hdegoede@redhat.com> - 6.0.76-1
359- Fix configuration of network interfaces for network boot (#481078)
360- Fix iscsi chap password being seen as ********
361- Handle lv root specified as /dev/dm-X properly (#471729)
362- Initial commit of EXTLINUX (no menu) support
363- Do not call dm_resolve_name on dmraidsets names, sometimes it fails, and
364  it is not necessary, this fixes the dmraid boot failure seen on
365  some systems (#476818)
366- Make nash mount support relatime (#296361)
367- FIX: nash unable to find dm devs by uuid or label (#480667)
368
369* Mon Jan 19 2009 Jeremy Katz <katzj@redhat.com> - 6.0.75-1
370- fix live images to be smarter with rootfstype=auto
371
372* Wed Jan 14 2009 Jeremy Katz <katzj@redhat.com> - 6.0.74-1
373- modesetting for live images
374
Note: See TracBrowser for help on using the repository browser.