source: projects/specs/trunk/m/minitube/minitube-vl.spec @ 5094

Revision 5094, 3.9 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1# Qt4 version auto-detection -- inagaki
2%define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.1)
3%define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
4
5# Move original binary to libexec dir and replace it by wrapper script
6%define MINITUBE_BIN %{_libexecdir}/%{name}
7
8Summary:        Native YouTube Client
9Summary(ja):    YouTube 専用クライアント
10Name:           minitube
11Version:        1.6
12Release:        1%{?_dist_release}
13Source0:        http://flavio.tordini.org/files/minitube/minitube.tar.gz
14Source10:       minitube.sh
15Source20:       minitube-ja.desktop
16License:        GPLv3+
17Group:          Applications/Multimedia
18URL:            http://flavio.tordini.org/minitube
19
20Requires:       phonon-backend-gstreamer
21Requires(post): desktop-file-utils
22Requires(postun):desktop-file-utils
23BuildRequires:  qt4-devel > 4.5
24BuildRequires:  qt4-designer
25BuildRequires:  phonon-devel
26BuildRequires:  python-devel
27BuildRoot:      %{_tmppath}/%{name}-%{version}-root
28
29Vendor:         Project Vine
30Distribution:   Vine Linux
31
32%description
33Minitube is a native YouTube client. With it you can watch
34YouTube videos in a new way: you type a keyword, Minitube
35gives you an endless video stream. Minitube does not require
36the Flash Player.
37
38Minitube is not about cloning the original YouTube web interface,
39it aims to create a new TV-like experience.
40
41You should install following packages to play videos.
42 - self-build-gstreamer-plugins-bad
43 - self-build-gstreamer-plugins-ffmpeg
44
45%description -l ja
46Minitube は YouTube の新しい視聴方法を提案する、専用のクライ
47アントソフトウェアです。キーワードを入力すると、Minitube は
48関連する動画をエンドレスで再生します。
49また Minitube を使うと Flash Player 無しでビデオが再生できます。
50
51Minitube は YouTube のウェブインターフェースのクローンでは無
52く、新たなテレビ風の視聴スタイルを目指しています。
53
54ビデオの再生には以下のパッケージが必要となります。併せてイン
55ストールしてください。
56 - self-build-gstreamer-plugins-bad
57 - self-build-gstreamer-plugins-ffmpeg
58
59
60%prep
61%setup -q -n %{name}
62
63
64%build
65%{qt4qmake} prefix=%{_prefix}
66%{__make} %{?_smp_mflags}
67
68
69%install
70%{__rm} -rf $RPM_BUILD_ROOT
71%{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
72
73## wrapper
74%{__mkdir_p} $RPM_BUILD_ROOT%{_libexecdir}
75%{__mv} $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{MINITUBE_BIN}
76%{__install} -m 755 %{SOURCE10}  $RPM_BUILD_ROOT%{_bindir}/%{name}
77
78# desktop file with japanese messages
79%{__install} -m 644 %{SOURCE20}  $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
80
81%clean
82%{__rm} -rf $RPM_BUILD_ROOT
83
84
85%post
86update-desktop-database %{_datadir}/applications>& /dev/null ||:
87touch --no-create %{_datadir}/icons/hicolor
88if [ -x /usr/bin/gtk-update-icon-cache ]; then
89  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
90fi
91
92
93%postun
94update-desktop-database %{_datadir}/applications>& /dev/null ||:
95touch --no-create %{_datadir}/icons/hicolor
96if [ -x /usr/bin/gtk-update-icon-cache ]; then
97  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
98fi
99
100
101%files
102%defattr(-,root,root)
103%doc AUTHORS COPYING CHANGES INSTALL TODO
104%{MINITUBE_BIN}
105%{_bindir}/%{name}
106%{_datadir}/applications/%{name}.desktop
107%{_datadir}/icons/hicolor
108%{_datadir}/%{name}/locale
109
110
111%changelog
112* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
113- new upstream release
114
115* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-1
116- new upstream release
117
118* Wed May 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
119- new upstream release
120
121* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-1
122- new upstream release
123
124* Fri Jul 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.1-1
125- new upstream release
126
127* Sat May 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.0-1
128- initial build for Vine Linux
129- add minitube.desktop with japanese translation
130- add wrapper script to check necessary packages at runtime
Note: See TracBrowser for help on using the repository browser.