source: projects/specs/trunk/m/minitube/minitube-vl.spec @ 10766

Revision 10766, 4.6 KB checked in by ara_t, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1# Qt4 version auto-detection -- inagaki
2%define qtver %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.1)
3
4%if "%{?_dist_release}" >= "vl7"
5%define qt4qmake %{_bindir}/qmake
6%else
7%define qt4qmake %{_libdir}/qt-%{qtver}/bin/qmake
8%endif
9
10# Move original binary to libexec dir and replace it by wrapper script
11%define MINITUBE_BIN %{_libexecdir}/%{name}
12
13Summary:        Native YouTube Client
14Summary(ja):    YouTube 専用クライアント
15Name:           minitube
16Version:        2.1.6
17Release:        2%{?_dist_release}
18Source0:        http://flavio.tordini.org/files/minitube/minitube.tar.gz
19Source10:       minitube.sh
20Source20:       minitube-ja.desktop
21License:        GPLv3+
22Group:          Applications/Multimedia
23URL:            http://flavio.tordini.org/minitube
24
25Requires:       phonon-backend-gstreamer
26Requires(post): desktop-file-utils
27Requires(postun):desktop-file-utils
28BuildRequires:  qt4-devel > 4.5
29BuildRequires:  qt4-designer
30BuildRequires:  phonon-devel
31BuildRequires:  python-devel
32BuildRoot:      %{_tmppath}/%{name}-%{version}-root
33
34Vendor:         Project Vine
35Distribution:   Vine Linux
36
37%description
38Minitube is a native YouTube client. With it you can watch
39YouTube videos in a new way: you type a keyword, Minitube
40gives you an endless video stream. Minitube does not require
41the Flash Player.
42
43Minitube is not about cloning the original YouTube web interface,
44it aims to create a new TV-like experience.
45
46You should install following packages to play videos.
47 - self-build-gstreamer-plugins-bad
48 - self-build-gstreamer-plugins-ffmpeg
49
50%description -l ja
51Minitube は YouTube の新しい視聴方法を提案する、専用のクライ
52アントソフトウェアです。キーワードを入力すると、Minitube は
53関連する動画をエンドレスで再生します。
54また Minitube を使うと Flash Player 無しでビデオが再生できます。
55
56Minitube は YouTube のウェブインターフェースのクローンでは無
57く、新たなテレビ風の視聴スタイルを目指しています。
58
59ビデオの再生には以下のパッケージが必要となります。併せてイン
60ストールしてください。
61 - self-build-gstreamer-plugins-bad
62 - self-build-gstreamer-plugins-ffmpeg
63
64
65%prep
66%setup -q -n %{name}
67
68
69%build
70%{qt4qmake} prefix=%{_prefix}
71%{__make} %{?_smp_mflags}
72
73
74%install
75%{__rm} -rf $RPM_BUILD_ROOT
76%{__make} install INSTALL_ROOT=$RPM_BUILD_ROOT
77
78## wrapper
79%{__mkdir_p} $RPM_BUILD_ROOT%{_libexecdir}
80%{__mv} $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{MINITUBE_BIN}
81%{__install} -m 755 %{SOURCE10}  $RPM_BUILD_ROOT%{_bindir}/%{name}
82
83# desktop file with japanese messages
84%{__install} -m 644 %{SOURCE20}  $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
85
86%clean
87%{__rm} -rf $RPM_BUILD_ROOT
88
89
90%post
91update-desktop-database %{_datadir}/applications>& /dev/null ||:
92touch --no-create %{_datadir}/icons/hicolor
93if [ -x /usr/bin/gtk-update-icon-cache ]; then
94  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
95fi
96
97
98%postun
99update-desktop-database %{_datadir}/applications>& /dev/null ||:
100touch --no-create %{_datadir}/icons/hicolor
101if [ -x /usr/bin/gtk-update-icon-cache ]; then
102  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
103fi
104
105
106%files
107%defattr(-,root,root)
108%doc AUTHORS COPYING CHANGES INSTALL TODO
109%{MINITUBE_BIN}
110%{_bindir}/%{name}
111%{_datadir}/applications/%{name}.desktop
112%{_datadir}/icons/hicolor
113%{_datadir}/%{name}/locale
114
115
116%changelog
117* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 2.1.6-2
118- rebuild with gcc-5.4.0
119
120* Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.6-1
121- new upstream release
122
123* Tue Aug 13 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-1
124- new upstream release
125
126* Tue Jan 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9-1
127- new upstream release
128
129* Wed Jul 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
130- new upstream release
131
132* Tue May 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-2
133- fix Source10 (remove gksu)
134
135* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.1-1
136- new upstream release
137
138* Fri Jan 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7-1
139- new upstream release
140
141* Thu Nov 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
142- new upstream release
143
144* Fri Aug 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-1
145- new upstream release
146
147* Wed May 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.3-1
148- new upstream release
149
150* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3-1
151- new upstream release
152
153* Fri Jul 30 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.1-1
154- new upstream release
155
156* Sat May 29 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.0-1
157- initial build for Vine Linux
158- add minitube.desktop with japanese translation
159- add wrapper script to check necessary packages at runtime
Note: See TracBrowser for help on using the repository browser.