source: projects/specs/trunk/m/mew/mew-vl.spec @ 521

Revision 521, 11.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _docdir %{_defaultdocdir}
2%define _noVersionedDependencies        1
3%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4
5%define       origver       6.3
6%define       pkgver        %{origver}
7%define       origname      mew       
8
9%ifarch x86_64
10%define _lib lib
11%endif
12
13
14Summary:       Mew - Messaging in the Emacs World
15Summary(ja):   Emacs でメールを読むためのインターフェース
16Name:          %{origname}
17Version:       %{origver}
18Release:       1%{?_dist_release}
19License:       distributable
20Group:         Applications/Editors/Emacs
21URL:           http://www.mew.org/
22Source0:       http://www.mew.org/Release/mew-%{pkgver}.tar.gz
23Source1:       %{origname}-install.sh
24Source2:       %{origname}-remove.sh
25Source3:       vine.dot.mew
26
27Source4:       %{name}-init.el
28Source5:       vine-default-%{name}.el
29
30Patch11:       mew-2.1-icondir.diff
31
32PreReq:        emacsen
33Requires:      perl >= 5.004_jp-4
34Provides:      %{origname} = %{origver}
35#Conflicts:     %{origname}-el
36Obsoletes:     mew-mule, mew-el
37Obsoletes:     mew-xemacs, mew-xemacs-extra
38Requires:      mew-common = %{version}
39PreReq:        /sbin/install-info
40
41BuildRequires: emacsen
42BuildRoot:     %{_tmppath}/%{name}-%{origver}-root
43
44Vendor:        Project Vine
45Distribution:  Vine Linux
46
47
48%description
49Messaging in the Emacs World.  It provides a very easy user interface
50to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
51
52Please install Perl5 to use mew.
53
54Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
55to your ~/.mew.el file, and modify the site configurations, e.g.
56
57    (setq mew-mail-domain-list '("your mail domain"))
58
59%description -l ja
60電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
61フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
62perlが必要です。
63
64%{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
65し、適切に設定してください。
66
67    (setq mew-mail-domain-list '("your mail domain"))
68
69また、%{_docdir}/mew-common-%{version}/contrib/以下にもいくつかのMewを便利に使う
70為のelispを収録しています。
71
72
73%package -n mew-common
74Summary:     Common files/programs for Mew Emacs/XEmacs
75Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
76Group:       Applications/Internet
77Obsoletes:   mew-xemacs-extra
78
79
80%description -n mew-common
81This package contains common files/programs for Mew Emacs/XEmacs.
82
83%description -n mew-common -l ja
84Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
85
86
87%prep
88%setup -q -n mew-%{pkgver}
89%patch11 -p1
90
91cp %{SOURCE3} .
92
93%build
94%configure
95make PREFIX="/usr" CFLAGS="$RPM_OPT_FLAGS" bin
96
97
98%install
99[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
100
101mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
102mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/install
103mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/remove
104mkdir -p %{buildroot}/usr/info
105mkdir -p %{buildroot}/usr/X11R6/include/X11/pixmaps
106# install el files
107
108
109        # Add here commands to install the package into debian/mew.
110        cp *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
111        cp %{SOURCE4} %{SOURCE5} \
112            %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
113        make install-bin prefix=%{buildroot}%{_prefix} \
114                mandir=%{buildroot}%{_mandir}/man1 \
115                bindir=%{buildroot}%{_bindir}
116
117        # contrib
118        #install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
119        #         $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
120
121        ## install icons
122        cp etc/*.xpm %{buildroot}/usr/X11R6/include/X11/pixmaps
123        cp etc/*.png %{buildroot}/usr/X11R6/include/X11/pixmaps
124        cp etc/*.img %{buildroot}/usr/X11R6/include/X11/pixmaps
125
126        ## install contrib
127        #cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
128
129
130
131
132# install {info,jinfo} for mew-emacs
133make infodir="%{buildroot}%{_infodir}" \
134    INSTALLINFO="/sbin/install-info" install-info install-jinfo
135rm -f %{buildroot}%{_infodir}/dir
136
137gzip -9nf %{buildroot}%{_infodir}/*
138
139%_installemacsenscript %{origname} %{SOURCE1}
140
141%_removeemacsenscript  %{origname} %{SOURCE2}
142
143%post
144
145if [ "$1" = 2 ]; then
146
147%_emacsenPackageRemove %{origname}
148
149fi
150
151%_addemacsenlist %{origname}
152
153%_emacsenPackageInstall %{origname}
154
155
156/sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
157  --section="Message User Agent"
158/sbin/install-info %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
159  --section="Message User Agent"
160
161
162%preun
163if [ "$1" = 0 ]; then
164
165  %_emacsenPackageRemove %{origname}
166
167  %_removeemacsenlist %{origname}
168
169
170  /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
171  --section="Message User Agent"
172  /sbin/install-info --delete %{_infodir}/mew.jis.info.gz %{_infodir}/dir \
173  --section="Message User Agent"
174fi
175
176
177%clean
178[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
179
180
181%files
182%defattr(-,root,root)
183%{_infodir}/mew.info*
184%{_infodir}/mew.jis.info*
185/usr/share/emacs/site-lisp/%{origname}/
186/usr/lib/emacsen-common/packages/install/%{origname}
187/usr/lib/emacsen-common/packages/remove/%{origname}
188/usr/X11R6/include/X11/pixmaps
189
190
191%files -n mew-common
192%defattr(-,root,root)
193%doc 00changes 00copyright 00copyright.jis 00diff 00readme
194%doc mew.dot.emacs vine.dot.mew
195%doc contrib/
196%{_bindir}/*
197%{_mandir}/man1/*
198
199%changelog
200* Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
201- new upstream release
202
203* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
204- fixed mew-init.el
205
206* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
207- added mew-init.el, vine-default-mew.el
208- updated mew-install.sh, mew-remove.sh for vine-default-mew.el
209
210* Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
211- new upstream release
212
213* Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
214- applied new versioning policy
215
216* Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
217- new upstream release
218
219* Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
220- added %%define _lib lib (for x86_64 support)
221
222* Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
223- added support X-Spam-Flag header in vine.dot.mew
224
225* Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
226- new upstream release
227
228* Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
229- new upstream release
230- modified vine.dot.mew for Mew-5.1 feature support
231
232* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
233- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
234
235* Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
236- changed Group to Applications/Editors/EmacsLisp
237- changed common package's Group to Applications/Internet
238
239* Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
240- source update
241
242* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
243- source update
244
245* Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
246- source update
247
248* Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
249- source update
250- update vine.dot.mew
251  Obsoleting the following variables:
252        mew-noreplyto-to-list
253        mew-noreplyto-cc-list
254        mew-replyto-to-list
255        mew-replyto-cc-list
256        mew-fromme-to-list
257        mew-fromme-cc-list
258  And defining the following variables:
259        mew-reply-all-alist
260        mew-reply-sender-alist
261        mew-reply-fromme-alist
262
263* Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
264- added vine.dot.mew(Source3)
265
266* Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
267- source update
268
269* Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
270- update to mew-3.1
271
272* Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
273- test package: update to mew-3.1rc2
274
275* Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
276- test package: update to mew-3.1rc1
277
278* Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
279- changed License to distributable (not GPL2)
280
281* Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
282- incm and man pages are included in common subpackage
283
284* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
285- corrected Group for common subpackage
286
287* Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
288- update to mew-2.2
289
290* Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
291- update to mew-2.2rc4
292
293* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
294- update to mew-2.2rc2
295
296* Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
297- mew-el -> mew
298- added Patch11 to set default icon directory for Vine
299
300* Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
301- added Obsoletes: mew-xemacs, mew-xemacs-extra
302- install-info gzipped info files :)
303
304* Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
305- update 2.1
306
307* Sat Oct  6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
308- change package name ( mew -> mew-el)
309-  apply  emacsenc-oomon
310
311* Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
312- Oops, forgot to add %%defattr for mew-common. Fixed.
313
314* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
315- split mew-common, obsoletes mew-xemacs-extra
316
317* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
318- 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
319- install info files into %%{_infodir}
320
321* Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
322- 2.0-0vl1
323- update
324
325* Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
326- 1.94.2-3
327- fixed %files section to handle compressed info pages
328
329* Wed Jun  7 2000 Toru Sagami <czs14350@nifty.ne.jp>
330- fix description: mess up with mule/emacs/xemacs...
331- added BuildRequires and Conflicts
332
333* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
334- updated 1.94.2
335
336* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
337- added PreReq: /sbin/install-info
338- attrib +x for /usr/bin/uumerge
339- CFLAGS="$RPM_OPT_FLAGS"
340
341* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
342 - 1.94.1-2
343 - changed destination to /usr/share/emacs/site-lisp/mew
344
345* Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
346 - 1.94.1-1
347 - updated in sync with 1.94.1 release
348 - fixed %post and %preun section
349 - Obsoletes: mew now changed to Obsoletes: mew-mule
350
351* Fri Oct  8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
352 - fixed info path & install info
353 - fixed '%description'
354
355* Sat Oct  2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
356 - removed extra packages
357 - fixed char-set "euc" of the spec file.
358 - slight modifications for Vine-1.9
359
360* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
361  - 1.94-3
362  - package name changed from mew-emacs to mew
363  - make info, make jinfo now processed even under emacs
364
365* Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
366- Released as version "1.94-2".
367
368Changed from "mew-emacs 1.94-1".
369- Deleted "NoSource: 0", the definition part of data.
370- Revised some, the definition part of data.
371- Revised some, part of "%post, %postun".
372- Changerd "%postun" => "%preun".
373
374* Mon Sep  6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
375- First release.
Note: See TracBrowser for help on using the repository browser.