source: projects/specs/trunk/m/mew/mew-vl.spec @ 10793

Revision 10793, 11.5 KB checked in by ara_t, 7 years ago (diff)

update to 6.7

Line 
1%define _docdir %{_defaultdocdir}
2%define _noVersionedDependencies        1
3# %define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4
5%define _libdir %{_prefix}/lib
6
7%define       origver       6.7
8%define       pkgver        %{origver}
9%define       origname      mew
10
11
12Summary:       Mew - Messaging in the Emacs World
13Summary(ja):   Emacs でメールを読むためのインターフェース
14Name:          %{origname}
15Version:       %{origver}
16Release:       1%{?_dist_release}
17License:       distributable
18Group:         Applications/Editors/Emacs
19URL:           http://www.mew.org/
20Source0:       http://www.mew.org/Release/mew-%{pkgver}.tar.gz
21Source1:       %{origname}-install.sh
22Source2:       %{origname}-remove.sh
23Source3:       vine.dot.mew
24
25Source4:       %{name}-init.el
26Source5:       vine-default-%{name}.el
27
28Patch11:       mew-6.3-icondir.diff
29
30Requires:      emacsen
31Requires:      perl >= 5.004_jp-4
32Provides:      %{origname} = %{origver}
33#Conflicts:     %{origname}-el
34Obsoletes:     mew-mule, mew-el
35Obsoletes:     mew-xemacs, mew-xemacs-extra
36Requires:      mew-common = %{version}
37# PreReq:        /sbin/install-info
38
39BuildRequires: emacsen
40BuildRequires: zlib-devel
41BuildRoot:     %{_tmppath}/%{name}-%{origver}-root
42
43Vendor:        Project Vine
44Distribution:  Vine Linux
45
46
47%description
48Messaging in the Emacs World.  It provides a very easy user interface
49to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
50
51Please install Perl5 to use mew.
52
53Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
54to your ~/.mew.el file, and modify the site configurations, e.g.
55
56    (setq mew-mail-domain-list '("your mail domain"))
57
58%description -l ja
59電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
60フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
61perlが必要です。
62
63%{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
64し、適切に設定してください。
65
66    (setq mew-mail-domain-list '("your mail domain"))
67
68また、%{_docdir}/mew-common-%{version}/contrib/以下にもいくつかのMewを便利に使う
69為のelispを収録しています。
70#'
71
72
73%package -n mew-common
74Summary:     Common files/programs for Mew Emacs/XEmacs
75Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
76Group:       Applications/Internet
77Obsoletes:   mew-xemacs-extra
78
79
80%description -n mew-common
81This package contains common files/programs for Mew Emacs/XEmacs.
82
83%description -n mew-common -l ja
84Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
85
86
87%prep
88%setup -q -n mew-%{pkgver}
89%patch11 -p1
90
91cp %{SOURCE3} .
92
93%build
94%configure
95make PREFIX="/usr" CFLAGS="$RPM_OPT_FLAGS" bin
96
97
98%install
99[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
100
101mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
102mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/install
103mkdir -p %{buildroot}%{_libdir}/emacsen-common/packages/remove
104mkdir -p %{buildroot}/usr/info
105mkdir -p %{buildroot}%{_datadir}/pixmaps/%{origname}
106# install el files
107
108
109        # Add here commands to install the package into debian/mew.
110        cp *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
111        cp %{SOURCE4} %{SOURCE5} \
112            %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
113        make install-bin prefix=%{buildroot}%{_prefix} \
114                mandir=%{buildroot}%{_mandir}/man1 \
115                bindir=%{buildroot}%{_bindir}
116
117        # contrib
118        #install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
119        #         $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
120
121        ## install icons
122        cp etc/*.xpm %{buildroot}/usr/share/pixmaps/%{origname}
123        cp etc/*.png %{buildroot}/usr/share/pixmaps/%{origname}
124        cp etc/*.img %{buildroot}/usr/share/pixmaps/%{origname}
125
126        ## install contrib
127        #cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
128
129
130
131
132# install {info,jinfo} for mew-emacs
133make infodir="%{buildroot}%{_infodir}" \
134    INSTALLINFO="/sbin/install-info" install-info install-jinfo
135rm -f %{buildroot}%{_infodir}/dir
136
137gzip -9nf %{buildroot}%{_infodir}/*
138
139%_installemacsenscript %{origname} %{SOURCE1}
140
141%_removeemacsenscript  %{origname} %{SOURCE2}
142
143%post
144
145if [ "$1" = 2 ]; then
146
147%_emacsenPackageRemove %{origname}
148
149fi
150
151%_addemacsenlist %{origname}
152
153%_emacsenPackageInstall %{origname}
154
155
156/sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
157  --section="Message User Agent"
158/sbin/install-info %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
159  --section="Message User Agent"
160
161
162%preun
163if [ "$1" = 0 ]; then
164
165  %_emacsenPackageRemove %{origname}
166
167  %_removeemacsenlist %{origname}
168
169
170  /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
171  --section="Message User Agent"
172  /sbin/install-info --delete %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
173  --section="Message User Agent"
174fi
175
176
177%clean
178[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
179
180
181%files
182%defattr(-,root,root)
183%{_infodir}/mew.info*
184%{_infodir}/mew.ja.info*
185%{_datadir}/emacs/site-lisp/%{origname}/
186%{_libdir}/emacsen-common/packages/install/%{origname}
187%{_libdir}/emacsen-common/packages/remove/%{origname}
188%{_datadir}/pixmaps/%{origname}
189
190
191%files -n mew-common
192%defattr(-,root,root)
193%doc 00changes.* 00copyright 00copyright.ja 00diff 00readme
194%doc dot.emacs vine.dot.mew
195# %doc contrib/
196%{_bindir}/*
197%{_mandir}/man1/*
198
199%changelog
200* Thu Nov 03 2016 Toshiaki Ara <ara_t@384.jp> 6.7-1
201- new upstream release
202- add BuildRequires: zlib-devel
203- change %%{_infodir}/mew.jis.info* to %%{_infodir}/mew.ja.info*
204- change encoding of vine.dot.mew to utf-8
205
206* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.3-2
207- rebuild with rpm-4.8.1
208- change pixmap directory
209- fix Patch11
210
211* Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
212- new upstream release
213
214* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
215- fixed mew-init.el
216
217* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
218- added mew-init.el, vine-default-mew.el
219- updated mew-install.sh, mew-remove.sh for vine-default-mew.el
220
221* Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
222- new upstream release
223
224* Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
225- applied new versioning policy
226
227* Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
228- new upstream release
229
230* Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
231- added %%define _lib lib (for x86_64 support)
232
233* Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
234- added support X-Spam-Flag header in vine.dot.mew
235
236* Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
237- new upstream release
238
239* Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
240- new upstream release
241- modified vine.dot.mew for Mew-5.1 feature support
242
243* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
244- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
245
246* Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
247- changed Group to Applications/Editors/EmacsLisp
248- changed common package's Group to Applications/Internet
249
250* Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
251- source update
252
253* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
254- source update
255
256* Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
257- source update
258
259* Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
260- source update
261- update vine.dot.mew
262  Obsoleting the following variables:
263        mew-noreplyto-to-list
264        mew-noreplyto-cc-list
265        mew-replyto-to-list
266        mew-replyto-cc-list
267        mew-fromme-to-list
268        mew-fromme-cc-list
269  And defining the following variables:
270        mew-reply-all-alist
271        mew-reply-sender-alist
272        mew-reply-fromme-alist
273
274* Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
275- added vine.dot.mew(Source3)
276
277* Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
278- source update
279
280* Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
281- update to mew-3.1
282
283* Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
284- test package: update to mew-3.1rc2
285
286* Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
287- test package: update to mew-3.1rc1
288
289* Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
290- changed License to distributable (not GPL2)
291
292* Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
293- incm and man pages are included in common subpackage
294
295* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
296- corrected Group for common subpackage
297
298* Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
299- update to mew-2.2
300
301* Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
302- update to mew-2.2rc4
303
304* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
305- update to mew-2.2rc2
306
307* Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
308- mew-el -> mew
309- added Patch11 to set default icon directory for Vine
310
311* Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
312- added Obsoletes: mew-xemacs, mew-xemacs-extra
313- install-info gzipped info files :)
314
315* Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
316- update 2.1
317
318* Sat Oct  6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
319- change package name ( mew -> mew-el)
320-  apply  emacsenc-oomon
321
322* Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
323- Oops, forgot to add %%defattr for mew-common. Fixed.
324
325* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
326- split mew-common, obsoletes mew-xemacs-extra
327
328* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
329- 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
330- install info files into %%{_infodir}
331
332* Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
333- 2.0-0vl1
334- update
335
336* Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
337- 1.94.2-3
338- fixed %files section to handle compressed info pages
339
340* Wed Jun  7 2000 Toru Sagami <czs14350@nifty.ne.jp>
341- fix description: mess up with mule/emacs/xemacs...
342- added BuildRequires and Conflicts
343
344* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
345- updated 1.94.2
346
347* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
348- added PreReq: /sbin/install-info
349- attrib +x for /usr/bin/uumerge
350- CFLAGS="$RPM_OPT_FLAGS"
351
352* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
353 - 1.94.1-2
354 - changed destination to /usr/share/emacs/site-lisp/mew
355
356* Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
357 - 1.94.1-1
358 - updated in sync with 1.94.1 release
359 - fixed %post and %preun section
360 - Obsoletes: mew now changed to Obsoletes: mew-mule
361
362* Fri Oct  8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
363 - fixed info path & install info
364 - fixed '%description'
365
366* Sat Oct  2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
367 - removed extra packages
368 - fixed char-set "euc" of the spec file.
369 - slight modifications for Vine-1.9
370
371* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
372  - 1.94-3
373  - package name changed from mew-emacs to mew
374  - make info, make jinfo now processed even under emacs
375
376* Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
377- Released as version "1.94-2".
378
379Changed from "mew-emacs 1.94-1".
380- Deleted "NoSource: 0", the definition part of data.
381- Revised some, the definition part of data.
382- Revised some, part of "%post, %postun".
383- Changerd "%postun" => "%preun".
384
385* Mon Sep  6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
386- First release.
Note: See TracBrowser for help on using the repository browser.