source: projects/specs/trunk/m/mew/mew-vl.spec @ 6168

Revision 6168, 11.2 KB checked in by munepi, 12 years ago (diff)

updated mew

Line 
1%define _docdir %{_defaultdocdir}
2%define _noVersionedDependencies        1
3# %define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
4
5%define       origver       6.5
6%define       pkgver        %{origver}
7%define       origname      mew       
8
9
10Summary:       Mew - Messaging in the Emacs World
11Summary(ja):   Emacs でメールを読むためのインターフェース
12Name:          %{origname}
13Version:       %{origver}
14Release:       1%{?_dist_release}
15License:       distributable
16Group:         Applications/Editors/Emacs
17URL:           http://www.mew.org/
18Source0:       http://www.mew.org/Release/mew-%{pkgver}.tar.gz
19Source1:       %{origname}-install.sh
20Source2:       %{origname}-remove.sh
21Source3:       vine.dot.mew
22
23Source4:       %{name}-init.el
24Source5:       vine-default-%{name}.el
25
26Patch11:       mew-6.3-icondir.diff
27
28Requires:      emacsen
29Requires:      perl >= 5.004_jp-4
30Provides:      %{origname} = %{origver}
31#Conflicts:     %{origname}-el
32Obsoletes:     mew-mule, mew-el
33Obsoletes:     mew-xemacs, mew-xemacs-extra
34Requires:      mew-common = %{version}
35# PreReq:        /sbin/install-info
36
37BuildRequires: emacsen
38BuildRoot:     %{_tmppath}/%{name}-%{origver}-root
39
40Vendor:        Project Vine
41Distribution:  Vine Linux
42
43
44%description
45Messaging in the Emacs World.  It provides a very easy user interface
46to e-mail, MIME and PGP (Pretty Good Privacy) on Emacsen.
47
48Please install Perl5 to use mew.
49
50Don't forget to copy %{_docdir}/mew-%{version}/vine.dot.mew
51to your ~/.mew.el file, and modify the site configurations, e.g.
52
53    (setq mew-mail-domain-list '("your mail domain"))
54
55%description -l ja
56電子メールを Emacs / XEmacs 上で簡単に読み書きすることができるインター
57フェース mew です。MIME や PGP にも対応しています。mewを使うためには、
58perlが必要です。
59
60%{_docdir}/mew-common-%{version}/vine.dot.mew を ~/.mew.el としてコピー
61し、適切に設定してください。
62
63    (setq mew-mail-domain-list '("your mail domain"))
64
65
66%package -n mew-common
67Summary:     Common files/programs for Mew Emacs/XEmacs
68Summary(ja): Emacs/XEmacs 用 Mew 両方で利用するファイル/プログラム
69Group:       Applications/Internet
70Obsoletes:   mew-xemacs-extra
71
72
73%description -n mew-common
74This package contains common files/programs for Mew Emacs/XEmacs.
75
76%description -n mew-common -l ja
77Emacs/XEmacs 用 Mew に共通するファイル/プログラムです.
78
79
80%prep
81%setup -q -n mew-%{pkgver}
82%patch11 -p1 -b .vine
83
84%__cp -a %{SOURCE3} .
85
86%build
87%configure
88%__make PREFIX=%_prefix CFLAGS="$RPM_OPT_FLAGS" bin
89
90
91%install
92[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
93
94%__mkdir_p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
95%__mkdir_p %{buildroot}%{emacsen_pkgdir}/install
96%__mkdir_p %{buildroot}%{emacsen_pkgdir}/remove
97%__mkdir_p %{buildroot}%{_infodir}
98%__mkdir_p %{buildroot}%{_datadir}/pixmaps/%{origname}
99
100# install el files
101
102# Add here commands to install the package into debian/mew.
103%__cp -a *.el %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
104%__cp -a %{SOURCE4} %{SOURCE5} \
105     %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
106%__make install-bin prefix=%{buildroot}%{_prefix} \
107    mandir=%{buildroot}%{_mandir}/man1 \
108    bindir=%{buildroot}%{_bindir}
109
110# contrib
111#install -m 755 contrib/mewinc contrib/incdir contrib/incmbox \
112# $RPM_BUILD_ROOT/%{_docdir}/%{origname}/contrib/
113
114## install icons
115%__cp -a etc/*.xpm %{buildroot}/usr/share/pixmaps/%{origname}
116%__cp -a etc/*.png %{buildroot}/usr/share/pixmaps/%{origname}
117%__cp -a etc/*.img %{buildroot}/usr/share/pixmaps/%{origname}
118
119## install contrib
120#%__cp -a contrib $(CURDIR)/debian/mew/usr/share/doc/mew
121
122
123
124
125# install {info,jinfo} for mew-emacs
126%__make infodir="%{buildroot}%{_infodir}" \
127    INSTALLINFO="/sbin/install-info" install-info install-jinfo
128%__rm -f %{buildroot}%{_infodir}/dir
129
130gzip -9nf %{buildroot}%{_infodir}/*
131
132%_installemacsenscript %{origname} %{SOURCE1}
133
134%_removeemacsenscript  %{origname} %{SOURCE2}
135
136%post
137
138if [ "$1" = 2 ]; then
139
140%_emacsenPackageRemove %{origname}
141
142fi
143
144%_addemacsenlist %{origname}
145
146%_emacsenPackageInstall %{origname}
147
148/sbin/install-info %{_infodir}/mew.info.gz %{_infodir}/dir \
149  --section="Message User Agent"
150/sbin/install-info %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
151  --section="Message User Agent"
152
153
154%preun
155if [ "$1" = 0 ]; then
156
157  %_emacsenPackageRemove %{origname}
158
159  %_removeemacsenlist %{origname}
160
161
162  /sbin/install-info --delete %{_infodir}/mew.info.gz %{_infodir}/dir \
163  --section="Message User Agent"
164  /sbin/install-info --delete %{_infodir}/mew.ja.info.gz %{_infodir}/dir \
165  --section="Message User Agent"
166fi
167
168
169%clean
170[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
171
172
173%files
174%defattr(-,root,root)
175%{_infodir}/mew.info*
176%{_infodir}/mew.ja.info*
177%{_datadir}/emacs/site-lisp/%{origname}/
178%{emacsen_pkgdir}/install/%{origname}
179%{emacsen_pkgdir}/remove/%{origname}
180%{_datadir}/pixmaps/%{origname}
181
182
183%files -n mew-common
184%defattr(-,root,root)
185%doc 00api 00changes* 00copyright* 00diff 00readme
186%doc dot.emacs dot.mew dot.theme vine.dot.mew
187%{_bindir}/*
188%{_mandir}/man1/*
189
190%changelog
191* Tue May 08 2012 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.5-1
192- new upstream release
193
194* Tue Mar 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 6.4-1
195- new upstream release
196- apply new vine-default
197  - update mew-init.el, vine-default-mew.el
198- use %%emacsen_pkgdir macro
199- encode vine.dot.new to UTF-8
200
201* Fri Apr 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 6.3-2
202- rebuild with rpm-4.8.1
203- change pixmap directory
204- fix Patch11
205
206* Mon Dec 21 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.3-1
207- new upstream release
208
209* Tue Apr 21 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-3
210- fixed mew-init.el
211
212* Sat Apr 11 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 6.2-2
213- added mew-init.el, vine-default-mew.el
214- updated mew-install.sh, mew-remove.sh for vine-default-mew.el
215
216* Fri Jan 16 2009 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.2-1
217- new upstream release
218
219* Sun Jun 15 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-1
220- applied new versioning policy
221
222* Tue Jun 10 2008 KOBAYASHI Taizo <tkoba@vinelinux.org> 6.1-0vl1
223- new upstream release
224
225* Thu Aug 30 2007 Shu KONNO <owa@bg.wakwak.com> 5.2-0vl3
226- added %%define _lib lib (for x86_64 support)
227
228* Mon Mar 05 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl2
229- added support X-Spam-Flag header in vine.dot.mew
230
231* Tue Jan 23 2007 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.2-0vl1
232- new upstream release
233
234* Mon Nov 26 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 5.1-0vl1
235- new upstream release
236- modified vine.dot.mew for Mew-5.1 feature support
237
238* Mon Sep 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl3
239- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
240
241* Tue Jul 11 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.2-0vl2
242- changed Group to Applications/Editors/EmacsLisp
243- changed common package's Group to Applications/Internet
244
245* Mon Feb 14 2005 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.2-0vl1
246- source update
247
248* Mon Oct 18 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.1-0vl1
249- source update
250
251* Mon Jul 28 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.3-0vl1
252- source update
253
254* Thu Mar 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.2-0vl1
255- source update
256- update vine.dot.mew
257  Obsoleting the following variables:
258        mew-noreplyto-to-list
259        mew-noreplyto-cc-list
260        mew-replyto-to-list
261        mew-replyto-cc-list
262        mew-fromme-to-list
263        mew-fromme-cc-list
264  And defining the following variables:
265        mew-reply-all-alist
266        mew-reply-sender-alist
267        mew-reply-fromme-alist
268
269* Sat Jan 11 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl3
270- added vine.dot.mew(Source3)
271
272* Wed Dec 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl2
273- source update
274
275* Tue Dec 03 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl1
276- update to mew-3.1
277
278* Thu Nov 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.2
279- test package: update to mew-3.1rc2
280
281* Fri Nov 01 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.1-0vl0.1
282- test package: update to mew-3.1rc1
283
284* Mon Mar 18 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2-0vl4
285- changed License to distributable (not GPL2)
286
287* Mon Mar 18 2002 Hironobu MORIGUCHI <moriguti@luna.email.ne.jp> 2.2-0vl3
288- incm and man pages are included in common subpackage
289
290* Fri Mar 01 2002 Toru Sagami <sagami@vinelinux.org> 2.2-0vl2
291- corrected Group for common subpackage
292
293* Mon Feb 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.2-0vl1
294- update to mew-2.2
295
296* Thu Feb 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1.99.4-0vl1
297- update to mew-2.2rc4
298
299* Sun Jan 27 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2..99.2-0vl1
300- update to mew-2.2rc2
301
302* Sun Dec 30 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl3
303- mew-el -> mew
304- added Patch11 to set default icon directory for Vine
305
306* Wed Dec 12 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1-0vl2
307- added Obsoletes: mew-xemacs, mew-xemacs-extra
308- install-info gzipped info files :)
309
310* Thu Nov 01 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.1-0vl1
311- update 2.1
312
313* Sat Oct  6 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.0-0vl5
314- change package name ( mew -> mew-el)
315-  apply  emacsenc-oomon
316
317* Thu Sep 06 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl4
318- Oops, forgot to add %%defattr for mew-common. Fixed.
319
320* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0-0vl3
321- split mew-common, obsoletes mew-xemacs-extra
322
323* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
324- 2.0-0vl2: eliminate executable bit in %%doc and bin files install 755
325- install info files into %%{_infodir}
326
327* Sun Aug 20 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
328- 2.0-0vl1
329- update
330
331* Tue Oct 24 2000 Tomoya TAKA <tomoya@olive.plala.or.jp>
332- 1.94.2-3
333- fixed %files section to handle compressed info pages
334
335* Wed Jun  7 2000 Toru Sagami <czs14350@nifty.ne.jp>
336- fix description: mess up with mule/emacs/xemacs...
337- added BuildRequires and Conflicts
338
339* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
340- updated 1.94.2
341
342* Wed Apr 26 2000 Toru Sagami <czs14350@nifty.ne.jp>
343- added PreReq: /sbin/install-info
344- attrib +x for /usr/bin/uumerge
345- CFLAGS="$RPM_OPT_FLAGS"
346
347* Fri Jan 07 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
348 - 1.94.1-2
349 - changed destination to /usr/share/emacs/site-lisp/mew
350
351* Sat Nov 27 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
352 - 1.94.1-1
353 - updated in sync with 1.94.1 release
354 - fixed %post and %preun section
355 - Obsoletes: mew now changed to Obsoletes: mew-mule
356
357* Fri Oct  8 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
358 - fixed info path & install info
359 - fixed '%description'
360
361* Sat Oct  2 1999 Yasushi Karino <kari-p@mc.kcom.ne.jp>
362 - removed extra packages
363 - fixed char-set "euc" of the spec file.
364 - slight modifications for Vine-1.9
365
366* Wed Sep 29 1999 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rins.st.ryukoku.ac.jp>
367  - 1.94-3
368  - package name changed from mew-emacs to mew
369  - make info, make jinfo now processed even under emacs
370
371* Thu Sep 16 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
372- Released as version "1.94-2".
373
374Changed from "mew-emacs 1.94-1".
375- Deleted "NoSource: 0", the definition part of data.
376- Revised some, the definition part of data.
377- Revised some, part of "%post, %postun".
378- Changerd "%postun" => "%preun".
379
380* Mon Sep  6 1999 Ushio Tadaaki <t-ushio@fb3.so-net.ne.jp>
381- First release.
Note: See TracBrowser for help on using the repository browser.