source: projects/specs/trunk/m/metacity/metacity-vl.spec @ 4124

Revision 4124, 14.3 KB checked in by daisuke, 13 years ago (diff)

metacity: revert a commit which breaks compiz window decoration. (patch20)

Line 
1%define gettext_package metacity
2
3Summary: Metacity window manager
4Summary(ja): Metacity ウインドウマネージャ
5Name: metacity
6Version: 2.34.0
7Release: 3%{?_dist_release}
8URL: http://ftp.gnome.org/pub/gnome/sources/metacity/
9License: GPL
10Group: User Interface/Desktops
11
12Source0: http://ftp.gnome.org/pub/GNOME/sources/metacity/2.34/%{name}-%{version}.tar.bz2
13Source10: metacity-theme-vine-6.tar.bz2
14
15# update ja.po from git
16# http://git.gnome.org/browse/metacity/commit/?id=8c407025fb3c83262c17bbb28fe175a416fb29ab
17Source20: metacity-2.34.0-ja.po
18
19# change default theme to Vine
20Patch0: metacity-2.34.0-default-theme.patch
21# ctrl-alt-del call logout session
22Patch1: metacity-2.26.0-ctrlaltdel.patch
23# change default number of workspace
24# Patch2: metacity-2.26.0-num_workspace.patch
25# http://bugzilla.gnome.org/show_bug.cgi?id=558723
26Patch4: stop-spamming-xsession-errors.patch
27# enable compositing_manager
28Patch10: metacity-2.30.3-enable-compositing-manager.patch
29# change deafult (revert to 2.30 default)
30Patch11: metacity-2.34.0-revert-default-setting.patch
31
32# revert patch to work with compiz
33# http://git.gnome.org/browse/metacity/commit/?id=6a52883c2b670ad645257373515d1e704408b93d
34Patch20: metacity-2.34.0-revert-6a5288.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37BuildRequires: gtk2-devel >= 2.20
38BuildRequires: pango-devel >= 1.28.0
39BuildRequires: GConf2-devel >= 2.28.0
40BuildRequires: desktop-file-utils >= 0.3
41BuildRequires: intltool >= 0.22
42BuildRequires: startup-notification-devel >= 0.7
43BuildRequires: libtool, automake, autoconf
44BuildRequires: xorg-x11-proto-devel
45BuildRequires: libSM-devel, libICE-devel, libX11-devel
46BuildRequires: libXext-devel, libXinerama-devel, libXrandr-devel
47BuildRequires: libXcursor-devel, libXrender-devel
48BuildRequires: libXcomposite-devel, libXdamage-devel
49BuildRequires: zenity
50BuildRequires: libcanberra-devel
51BuildRequires: libgtop2-devel
52BuildRequires: gnome-doc-utils
53Requires(post): GConf2
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: daisuke
58
59%description
60Metacity is a simple window manager that integrates nicely with
61the GNOME desktop.
62
63%package devel
64Summary: Development files for metacity
65Group: Development/Libraries
66Requires: gtk2-devel, libX11-devel
67Requires: pkgconfig
68Requires: %{name} = %{version}-%{release}
69
70%description devel
71This package contains the files needed for compiling programs using
72the metacity-private library. Note that you are not supposed to write
73programs using the metacity-private library, since it is a private
74API. This package exists purely for technical reasons.
75
76%prep
77%setup -q
78
79%patch0 -p1 -b .default-theme
80%patch1 -p1 -b .ctrlaltdel
81# patch2 -p1 -b .num_workspace
82%patch4 -p1 -b .stop-spamming-xsession-errors
83%patch10 -p1 -b .enable-compositing-manager
84%patch11 -p1 -b .revert-default-settings
85
86%patch20 -p1 -b .revert-6a5288
87
88cp -a %{SOURCE20} po/ja.po
89
90%build
91intltoolize --copy --force
92libtoolize --copy --force
93autoreconf
94%configure
95%__make %{?_smp_mflags} INTLTOOL_MERGE=/usr/bin/intltool-merge
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
101make install DESTDIR=$RPM_BUILD_ROOT
102unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
103
104/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
105/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
106
107# install Vine Theme (default theme)
108tar xzvf %{SOURCE10} -C $RPM_BUILD_ROOT%{_datadir}/themes
109
110%find_lang %{gettext_package}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
117SCHEMAS="metacity.schemas"
118for S in $SCHEMAS; do
119  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
120done
121
122%files -f %{gettext_package}.lang
123%defattr(-,root,root)
124%doc README AUTHORS COPYING NEWS HACKING doc/theme-format.txt doc/metacity-theme.dtd
125%{_bindir}/metacity
126%{_bindir}/metacity-message
127#{_libexecdir}/*
128%{_sysconfdir}/gconf/schemas/*.schemas
129%{_datadir}/metacity
130%{_datadir}/themes
131%{_libdir}/lib*.so.*
132%{_mandir}/man1/metacity.1.gz
133%{_mandir}/man1/metacity-message.1.gz
134%{_datadir}/gnome-control-center/keybindings/*
135%{_datadir}/applications/metacity.desktop
136%{_datadir}/gnome/wm-properties/metacity-wm.desktop
137%{_datadir}/gnome/help/creating-metacity-themes
138
139%files devel
140%defattr(-,root,root)
141%{_bindir}/metacity-theme-viewer
142%{_bindir}/metacity-window-demo
143%{_includedir}/*
144%{_libdir}/lib*.so
145%{_libdir}/pkgconfig/*
146%{_mandir}/man1/metacity-theme-viewer.1.gz
147%{_mandir}/man1/metacity-window-demo.1.gz
148
149%changelog
150* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-3
151- add patch20 (revert patch)
152  - this commit breaks compiz window decoration.
153
154* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-2
155- update ja.po from git
156
157* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-1
158- update to 2.34.0
159- add patch11 to revert default settings
160  - default title font to Sans Bold 10
161  - add icon menu on titlebar
162- disable patch2 to change workspace num to 4 (factory default).
163
164* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-3
165- update metacity theme
166
167* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-2
168- update metacity theme
169- drop old old theme
170- add patch10 to enable compositing_manager by default
171
172* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
173- new upstream release
174
175* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
176- rebuild with rpm-4.8.1 for pkg-config file
177- add BuildRequires: gnome-doc-utils
178
179* Fri Apr 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-1
180- updated metacity to 2.30.1
181  - fixed crash when right-clicking on window frame
182
183* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
184- new upstream release
185
186* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.28.0-2
187- add BR: libgtop2-devel
188
189* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
190- new upstream release
191- dropped Patch5, 6 and 7 (merged into upstream)
192- removed BR: libglade2-devel
193
194* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-4
195- added BuildRequires: zenity, libcanberra-devel
196
197* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
198- Patch4: don't spam .xsession-errors so hard
199- Patch5: use libcanberra to play the alert sound
200- Patch6: don't force bell
201- Patch7: fix interaction with autohide panels
202
203* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
204- update Patch0,1,2
205  - apply patches to ".in.in" insread of ".in"
206
207* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
208- new upstream release
209- split development file to -devel subpackage
210  - remove static libs
211
212* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
213- new upstream release
214
215* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-2
216- rebuild to fix strange color problem.
217
218* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
219- new upstream release
220
221* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
222- new upstream release
223- added Requires(post): GConf2
224
225* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
226- new upstream release
227
228* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.13-0vl1
229- new upstream release
230
231* Mon Jun 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.5-0vl1
232- new upstream release
233
234* Sun Apr 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
235- new upstream release
236- remove Patch20 which is merged in upstream
237- include ClearVine theme as default theme.
238
239* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
240- new upstream release
241
242* Fri Apr 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
243- add Patch20 to make configurable new window focus (bug 326159)
244
245* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
246- new upstream release
247
248* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.144-0vl1
249- new upstream release
250
251* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
252- new upstream release
253
254* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
255- new upstream release
256
257* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
258- new upstream release
259
260* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
261- new upstream release
262
263* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.1-0vl1
264- new upstream release
265
266* Sun Jul 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
267- new upstream release
268
269* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
270- new upstream version
271- include Vine metacity theme as default theme.
272- update Patch0 to change deafult theme.
273
274* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl2
275- update NeoVine metacity theme.
276
277* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl1
278- new upstream release
279
280* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
281- new upstream release
282
283* Sun Jun 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
284- new upstream release
285- add BuildRequires: libtoo,automake14, autoconf
286
287* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.6.3-0vl1
288- new upstream release
289- build with new toolchain
290
291* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
292- new upstream release
293
294* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
295- new upstream release
296
297* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl2
298- fixed missing locale files
299
300* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
301- new upstream release
302
303* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl2
304- add patch10 to increase workspaces (4->6).
305
306* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
307- new upstream release
308
309* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
310- new upstream release
311
312* Mon Jun 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl2
313- update ja.po
314- update NeoVine theme
315
316* Sat May 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl1
317- new upstream release
318
319* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
320- fixed typo
321- NeoVine Metatheme moved to gnome-themes package.
322
323* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
324- new upstream release
325- add patch2 from rawhide.
326- drop patch1, merged in upstream.
327
328* Fri Jan 31 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.21-0vl2
329- add Patch1 to fix hang on all 64-bit platforms
330
331* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.21-0vl1
332- new upstream release
333
334* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl3
335- update NeoVine metatheme (use gnome default icons)
336
337* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl2
338- update neovine theme
339
340* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl1
341- new upstream release
342
343* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
344- drop patch0 to use system fonts.
345
346* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
347- update ja.po
348
349* Fri Dec 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl5
350- fixed NeoVine theme
351
352* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl4
353- add NeoVine theme ported from sawfish.
354- use neoVine as default theme. (Patch0)
355
356* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl3
357- change URL
358- add BuildRequires
359
360* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl2
361- add include files
362
363* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
364- build for Vine Linux
365- new upstream release from gnome-2.1.4
366
367* Tue Oct 29 2002 Havoc Pennington <hp@redhat.com>
368- 2.4.3
369- remove patches that have gone upstream
370
371* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
372- fix shaded window decorations in Bluecurve theme
373
374* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
375- fix the mplayer-disappears-on-de-fullscreen bug
376
377* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
378- add some fixes from CVS for #71163 #72379 #72478 #72513
379
380* Thu Aug 22 2002 Havoc Pennington <hp@redhat.com>
381- patch .schemas.in instead of .schemas so we get right default theme/fonts
382
383* Tue Aug 20 2002 Havoc Pennington <hp@redhat.com>
384- grow size of top resize, and display proper cursor on enter notify
385- require latest intltool to try and fix metacity.schemas by
386  regenerating it in non-UTF-8 locale
387
388* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
389- default to Sans Bold font, fixes #70920 and matches graphic design spec
390
391* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
392- 2.4.0.91 with raise/lower keybindings for msf, fixes to fullscreen
393- more apps that probably intend to be, fix for changing number of
394  workspaces, fix for moving windows in multihead
395
396* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
397- update build requires
398
399* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
400- upgrade to cvs snap 2.4.0.90 with pile of bugfixes from
401  this weekend
402- change default theme to bluecurve and require new redhat-artwork
403
404* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
405- 2.4.0
406- themes are moved, require appropriate redhat-artwork
407
408* Thu Aug  1 2002 Havoc Pennington <hp@redhat.com>
409- munge the desktop file to be in toplevel menus and
410  not show in KDE
411
412* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
413- don't use system font by default as metacity's
414  font is now in the system font dialog
415
416* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
417- 2.3.987.92 cvs snap
418
419* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
420- 2.3.987.91 cvs snap
421
422* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
423- 2.3.987.90 cvs snap
424
425* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
426- automated rebuild
427
428* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
429- rebuild for new libraries
430
431* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
432- rebuild in different environment
433
434* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
435- 2.3.987
436- default to redhat theme
437
438* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
439- rebuild in different environment
440
441* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
442- 2.3.610.90 cvs snap
443
444* Sun May 26 2002 Tim Powers <timp@redhat.com>
445- automated rebuild
446
447* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
448- rebuild in different environment
449
450* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
451- 2.3.377
452
453* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
454- 2.3.233
455
456* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
457- rebuild in different environment
458- add gconf schemas boilerplate
459
460* Mon Apr 15 2002 Havoc Pennington <hp@pobox.com>
461- 2.3.89
462
463* Tue Oct 30 2001 Havoc Pennington <hp@redhat.com>
464- 2.3.34
465
466* Fri Oct 13 2001 Havoc Pennington <hp@redhat.com>
467- 2.3.21
468
469* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
470- 2.3.8
471- 2.3.13
472
473* Wed Sep  5 2001 Havoc Pennington <hp@redhat.com>
474- Initial build.
475
476
Note: See TracBrowser for help on using the repository browser.