source: projects/specs/trunk/m/metacity/metacity-vl.spec @ 4195

Revision 4195, 14.4 KB checked in by daisuke, 13 years ago (diff)

metacity: update themes

Line 
1%define gettext_package metacity
2
3Summary: Metacity window manager
4Summary(ja): Metacity ウインドウマネージャ
5Name: metacity
6Version: 2.34.0
7Release: 4%{?_dist_release}
8URL: http://ftp.gnome.org/pub/gnome/sources/metacity/
9License: GPL
10Group: User Interface/Desktops
11
12Source0: http://ftp.gnome.org/pub/GNOME/sources/metacity/2.34/%{name}-%{version}.tar.bz2
13Source10: metacity-theme-vine-6.tar.bz2
14
15# update ja.po from git
16# http://git.gnome.org/browse/metacity/commit/?id=8c407025fb3c83262c17bbb28fe175a416fb29ab
17Source20: metacity-2.34.0-ja.po
18
19# change default theme to Vine
20Patch0: metacity-2.34.0-default-theme.patch
21# ctrl-alt-del call logout session
22Patch1: metacity-2.26.0-ctrlaltdel.patch
23# change default number of workspace
24# Patch2: metacity-2.26.0-num_workspace.patch
25# http://bugzilla.gnome.org/show_bug.cgi?id=558723
26Patch4: stop-spamming-xsession-errors.patch
27# enable compositing_manager
28Patch10: metacity-2.30.3-enable-compositing-manager.patch
29# change deafult (revert to 2.30 default)
30Patch11: metacity-2.34.0-revert-default-setting.patch
31
32# revert patch to work with compiz
33# http://git.gnome.org/browse/metacity/commit/?id=6a52883c2b670ad645257373515d1e704408b93d
34Patch20: metacity-2.34.0-revert-6a5288.patch
35
36BuildRoot: %{_tmppath}/%{name}-%{version}-root
37BuildRequires: gtk2-devel >= 2.20
38BuildRequires: pango-devel >= 1.28.0
39BuildRequires: GConf2-devel >= 2.28.0
40BuildRequires: desktop-file-utils >= 0.3
41BuildRequires: intltool >= 0.22
42BuildRequires: startup-notification-devel >= 0.7
43BuildRequires: libtool, automake, autoconf
44BuildRequires: xorg-x11-proto-devel
45BuildRequires: libSM-devel, libICE-devel, libX11-devel
46BuildRequires: libXext-devel, libXinerama-devel, libXrandr-devel
47BuildRequires: libXcursor-devel, libXrender-devel
48BuildRequires: libXcomposite-devel, libXdamage-devel
49BuildRequires: zenity
50BuildRequires: libcanberra-devel
51BuildRequires: libgtop2-devel
52BuildRequires: gnome-doc-utils
53Requires(post): GConf2
54
55Vendor: Project Vine
56Distribution: Vine Linux
57Packager: daisuke
58
59%description
60Metacity is a simple window manager that integrates nicely with
61the GNOME desktop.
62
63%package devel
64Summary: Development files for metacity
65Group: Development/Libraries
66Requires: gtk2-devel, libX11-devel
67Requires: pkgconfig
68Requires: %{name} = %{version}-%{release}
69
70%description devel
71This package contains the files needed for compiling programs using
72the metacity-private library. Note that you are not supposed to write
73programs using the metacity-private library, since it is a private
74API. This package exists purely for technical reasons.
75
76%prep
77%setup -q
78
79%patch0 -p1 -b .default-theme
80%patch1 -p1 -b .ctrlaltdel
81# patch2 -p1 -b .num_workspace
82%patch4 -p1 -b .stop-spamming-xsession-errors
83%patch10 -p1 -b .enable-compositing-manager
84%patch11 -p1 -b .revert-default-settings
85
86%patch20 -p1 -b .revert-6a5288
87
88cp -a %{SOURCE20} po/ja.po
89
90%build
91intltoolize --copy --force
92libtoolize --copy --force
93autoreconf
94%configure
95%__make %{?_smp_mflags} INTLTOOL_MERGE=/usr/bin/intltool-merge
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
101make install DESTDIR=$RPM_BUILD_ROOT
102unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
103
104/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
105/bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
106
107# install Vine Theme (default theme)
108tar xzvf %{SOURCE10} -C $RPM_BUILD_ROOT%{_datadir}/themes
109
110%find_lang %{gettext_package}
111
112%clean
113rm -rf $RPM_BUILD_ROOT
114
115%post
116export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
117SCHEMAS="metacity.schemas"
118for S in $SCHEMAS; do
119  gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S > /dev/null
120done
121
122%files -f %{gettext_package}.lang
123%defattr(-,root,root)
124%doc README AUTHORS COPYING NEWS HACKING doc/theme-format.txt doc/metacity-theme.dtd
125%{_bindir}/metacity
126%{_bindir}/metacity-message
127#{_libexecdir}/*
128%{_sysconfdir}/gconf/schemas/*.schemas
129%{_datadir}/metacity
130%{_datadir}/themes
131%{_libdir}/lib*.so.*
132%{_mandir}/man1/metacity.1.gz
133%{_mandir}/man1/metacity-message.1.gz
134%{_datadir}/gnome-control-center/keybindings/*
135%{_datadir}/applications/metacity.desktop
136%{_datadir}/gnome/wm-properties/metacity-wm.desktop
137%{_datadir}/gnome/help/creating-metacity-themes
138
139%files devel
140%defattr(-,root,root)
141%{_bindir}/metacity-theme-viewer
142%{_bindir}/metacity-window-demo
143%{_includedir}/*
144%{_libdir}/lib*.so
145%{_libdir}/pkgconfig/*
146%{_mandir}/man1/metacity-theme-viewer.1.gz
147%{_mandir}/man1/metacity-window-demo.1.gz
148
149%changelog
150* Wed Jun 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-4
151- update metacity theme
152
153* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-3
154- add patch20 (revert patch)
155  - this commit breaks compiz window decoration.
156
157* Sun Jun 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-2
158- update ja.po from git
159
160* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.34.0-1
161- update to 2.34.0
162- add patch11 to revert default settings
163  - default title font to Sans Bold 10
164  - add icon menu on titlebar
165- disable patch2 to change workspace num to 4 (factory default).
166
167* Sat Jun 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-3
168- update metacity theme
169
170* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.3-2
171- update metacity theme
172- drop old old theme
173- add patch10 to enable compositing_manager by default
174
175* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
176- new upstream release
177
178* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
179- rebuild with rpm-4.8.1 for pkg-config file
180- add BuildRequires: gnome-doc-utils
181
182* Fri Apr 30 2010 Shu KONNO <owa@bg.wakwak.com> 2.30.1-1
183- updated metacity to 2.30.1
184  - fixed crash when right-clicking on window frame
185
186* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
187- new upstream release
188
189* Mon Nov 02 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.28.0-2
190- add BR: libgtop2-devel
191
192* Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
193- new upstream release
194- dropped Patch5, 6 and 7 (merged into upstream)
195- removed BR: libglade2-devel
196
197* Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.0-4
198- added BuildRequires: zenity, libcanberra-devel
199
200* Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
201- Patch4: don't spam .xsession-errors so hard
202- Patch5: use libcanberra to play the alert sound
203- Patch6: don't force bell
204- Patch7: fix interaction with autohide panels
205
206* Wed Mar 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-2
207- update Patch0,1,2
208  - apply patches to ".in.in" insread of ".in"
209
210* Sat Mar 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
211- new upstream release
212- split development file to -devel subpackage
213  - remove static libs
214
215* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
216- new upstream release
217
218* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-2
219- rebuild to fix strange color problem.
220
221* Tue Mar 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
222- new upstream release
223
224* Wed Dec 12 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-0vl1
225- new upstream release
226- added Requires(post): GConf2
227
228* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-0vl1
229- new upstream release
230
231* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.13-0vl1
232- new upstream release
233
234* Mon Jun 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.5-0vl1
235- new upstream release
236
237* Sun Apr 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl1
238- new upstream release
239- remove Patch20 which is merged in upstream
240- include ClearVine theme as default theme.
241
242* Wed Apr 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
243- new upstream release
244
245* Fri Apr 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
246- add Patch20 to make configurable new window focus (bug 326159)
247
248* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
249- new upstream release
250
251* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.144-0vl1
252- new upstream release
253
254* Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
255- new upstream release
256
257* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
258- new upstream release
259
260* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
261- new upstream release
262
263* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.2-0vl1
264- new upstream release
265
266* Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.11.1-0vl1
267- new upstream release
268
269* Sun Jul 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
270- new upstream release
271
272* Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
273- new upstream version
274- include Vine metacity theme as default theme.
275- update Patch0 to change deafult theme.
276
277* Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl2
278- update NeoVine metacity theme.
279
280* Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.0-0vl1
281- new upstream release
282
283* Wed Nov 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
284- new upstream release
285
286* Sun Jun 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
287- new upstream release
288- add BuildRequires: libtoo,automake14, autoconf
289
290* Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.6.3-0vl1
291- new upstream release
292- build with new toolchain
293
294* Sat Oct 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
295- new upstream release
296
297* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
298- new upstream release
299
300* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl2
301- fixed missing locale files
302
303* Wed Sep 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.0-0vl1
304- new upstream release
305
306* Mon Sep 08 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl2
307- add patch10 to increase workspaces (4->6).
308
309* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.5-0vl1
310- new upstream release
311
312* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.3-0vl1
313- new upstream release
314
315* Mon Jun 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl2
316- update ja.po
317- update NeoVine theme
318
319* Sat May 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2-0vl1
320- new upstream release
321
322* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
323- fixed typo
324- NeoVine Metatheme moved to gnome-themes package.
325
326* Sat Feb 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.34-0vl1
327- new upstream release
328- add patch2 from rawhide.
329- drop patch1, merged in upstream.
330
331* Fri Jan 31 2003 Tomoya TAKA <taka@vinelinux.org> 2.4.21-0vl2
332- add Patch1 to fix hang on all 64-bit platforms
333
334* Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.21-0vl1
335- new upstream release
336
337* Wed Jan 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl3
338- update NeoVine metatheme (use gnome default icons)
339
340* Sun Jan 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl2
341- update neovine theme
342
343* Sat Jan 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.13-0vl1
344- new upstream release
345
346* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
347- drop patch0 to use system fonts.
348
349* Sat Dec 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl6
350- update ja.po
351
352* Fri Dec 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl5
353- fixed NeoVine theme
354
355* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl4
356- add NeoVine theme ported from sawfish.
357- use neoVine as default theme. (Patch0)
358
359* Mon Dec 16 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl3
360- change URL
361- add BuildRequires
362
363* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl2
364- add include files
365
366* Sun Dec 15 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
367- build for Vine Linux
368- new upstream release from gnome-2.1.4
369
370* Tue Oct 29 2002 Havoc Pennington <hp@redhat.com>
371- 2.4.3
372- remove patches that have gone upstream
373
374* Tue Aug 27 2002 Havoc Pennington <hp@redhat.com>
375- fix shaded window decorations in Bluecurve theme
376
377* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
378- fix the mplayer-disappears-on-de-fullscreen bug
379
380* Sat Aug 24 2002 Havoc Pennington <hp@redhat.com>
381- add some fixes from CVS for #71163 #72379 #72478 #72513
382
383* Thu Aug 22 2002 Havoc Pennington <hp@redhat.com>
384- patch .schemas.in instead of .schemas so we get right default theme/fonts
385
386* Tue Aug 20 2002 Havoc Pennington <hp@redhat.com>
387- grow size of top resize, and display proper cursor on enter notify
388- require latest intltool to try and fix metacity.schemas by
389  regenerating it in non-UTF-8 locale
390
391* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
392- default to Sans Bold font, fixes #70920 and matches graphic design spec
393
394* Thu Aug 15 2002 Havoc Pennington <hp@redhat.com>
395- 2.4.0.91 with raise/lower keybindings for msf, fixes to fullscreen
396- more apps that probably intend to be, fix for changing number of
397  workspaces, fix for moving windows in multihead
398
399* Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
400- update build requires
401
402* Mon Aug 12 2002 Havoc Pennington <hp@redhat.com>
403- upgrade to cvs snap 2.4.0.90 with pile of bugfixes from
404  this weekend
405- change default theme to bluecurve and require new redhat-artwork
406
407* Tue Aug  6 2002 Havoc Pennington <hp@redhat.com>
408- 2.4.0
409- themes are moved, require appropriate redhat-artwork
410
411* Thu Aug  1 2002 Havoc Pennington <hp@redhat.com>
412- munge the desktop file to be in toplevel menus and
413  not show in KDE
414
415* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
416- don't use system font by default as metacity's
417  font is now in the system font dialog
418
419* Tue Jul 23 2002 Havoc Pennington <hp@redhat.com>
420- 2.3.987.92 cvs snap
421
422* Fri Jul 12 2002 Havoc Pennington <hp@redhat.com>
423- 2.3.987.91 cvs snap
424
425* Mon Jun 24 2002 Havoc Pennington <hp@redhat.com>
426- 2.3.987.90 cvs snap
427
428* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
429- automated rebuild
430
431* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
432- rebuild for new libraries
433
434* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
435- rebuild in different environment
436
437* Mon Jun 10 2002 Havoc Pennington <hp@redhat.com>
438- 2.3.987
439- default to redhat theme
440
441* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
442- rebuild in different environment
443
444* Tue Jun  4 2002 Havoc Pennington <hp@redhat.com>
445- 2.3.610.90 cvs snap
446
447* Sun May 26 2002 Tim Powers <timp@redhat.com>
448- automated rebuild
449
450* Mon May 20 2002 Havoc Pennington <hp@redhat.com>
451- rebuild in different environment
452
453* Fri May 17 2002 Havoc Pennington <hp@redhat.com>
454- 2.3.377
455
456* Thu May  2 2002 Havoc Pennington <hp@redhat.com>
457- 2.3.233
458
459* Thu Apr 25 2002 Havoc Pennington <hp@redhat.com>
460- rebuild in different environment
461- add gconf schemas boilerplate
462
463* Mon Apr 15 2002 Havoc Pennington <hp@pobox.com>
464- 2.3.89
465
466* Tue Oct 30 2001 Havoc Pennington <hp@redhat.com>
467- 2.3.34
468
469* Fri Oct 13 2001 Havoc Pennington <hp@redhat.com>
470- 2.3.21
471
472* Mon Sep 17 2001 Havoc Pennington <hp@redhat.com>
473- 2.3.8
474- 2.3.13
475
476* Wed Sep  5 2001 Havoc Pennington <hp@redhat.com>
477- Initial build.
478
479
Note: See TracBrowser for help on using the repository browser.