source: projects/specs/trunk/m/meson/meson-vl.spec @ 11350

Revision 11350, 9.6 KB checked in by tomop, 6 years ago (diff)

meson-0.44.0-1

Line 
1%{!?rpmmacrodir:%global rpmmacrodir %{_sysconfdir}/rpm}
2
3%global libname mesonbuild
4
5Name:           meson
6Version:        0.44.0
7Release:        1%{?_dist_release}
8Group:          Development/Tools
9Summary:        High productivity build system
10
11License:        ASL 2.0
12URL:            http://mesonbuild.com/
13Source0:        https://github.com/mesonbuild/meson/archive/%{version}/%{name}-%{version}.tar.gz
14
15BuildArch:      noarch
16Obsoletes:      %{name}-gui < 0.31.0-3
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: tomop
21
22BuildRequires:  python3-devel
23BuildRequires:  python3-setuptools
24BuildRequires:  python-rpm-macros
25BuildRequires:  python3-rpm-macros
26BuildRequires:  ninja
27# Various languages
28BuildRequires:  gcc
29BuildRequires:  libasan
30BuildRequires:  gcc-c++
31BuildRequires:  gcc-objc
32BuildRequires:  gcc-objc++
33BuildRequires:  rust
34
35# Various libs support
36BuildRequires:  libboost-devel
37BuildRequires:  vala
38BuildRequires:  flex
39BuildRequires:  bison
40BuildRequires:  gettext
41BuildRequires:  git-core
42#BuildRequires:  pkgconfig(glib-2.0)
43#BuildRequires:  pkgconfig(gobject-introspection-1.0)
44#BuildRequires:  itstool
45BuildRequires:  zlib-devel
46BuildRequires:  llvm-devel
47BuildRequires:  cups-devel
48Requires:       ninja
49
50%description
51Meson is a build system designed to optimize programmer
52productivity. It aims to do this by providing simple, out-of-the-box
53support for modern software development tools and practices, such as
54unit tests, coverage reports, Valgrind, CCache and the like.
55
56%prep
57%autosetup -p1
58find -type f -name '*.py' -executable -exec sed -i -e '1s|.*|#!%{__python3}|' {} ';'
59# Remove MPI tests for now because it is complicated to run
60rm -rf "test cases/frameworks/17 mpi"
61
62%build
63%py3_build
64#python3 setup.py build
65
66%install
67%py3_install
68#python3 setup.py install --root %{buildroot}
69
70install -Dpm0644 data/macros.%{name} %{buildroot}%{rpmmacrodir}/macros.%{name}
71
72%check
73export MESON_PRINT_TEST_OUTPUT=1
74#python3 ./run_tests.py ||:
75
76%files
77%license COPYING
78%{_bindir}/%{name}
79%{_bindir}/%{name}conf
80%{_bindir}/%{name}introspect
81%{_bindir}/%{name}test
82%{_bindir}/wraptool
83%{python3_sitelib}/%{libname}/
84%{python3_sitelib}/%{name}-*.egg-info/
85%{_mandir}/man1/%{name}.1*
86%{_mandir}/man1/%{name}conf.1*
87%{_mandir}/man1/%{name}introspect.1*
88%{_mandir}/man1/%{name}test.1*
89%{_mandir}/man1/wraptool.1*
90%{rpmmacrodir}/macros.*
91
92%changelog
93* Sun Jan 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.44.0-1
94- updated to 0.44.0.
95
96* Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.42.0-1
97- initial build for Vine Linux.
98
99* Fri Aug 18 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.42.0-1
100- Update to 0.42.0
101
102* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.41.2-2
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
104
105* Wed Jul 19 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.2-1
106- Update to 0.41.2
107
108* Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 0.41.1-3
109- Backport various gtk-doc fixes from upstream
110
111* Thu Jul 13 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.41.1-2
112- Strip trailing slash from pkg-config files
113
114* Mon Jun 19 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.1-1
115- Update to 0.41.1
116
117* Tue Jun 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.41.0-1
118- Update to 0.41.0
119
120* Wed May 31 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-2
121- Don't run ldc tests
122
123* Fri Apr 28 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.1-1
124- Update to 0.40.1
125
126* Sun Apr 23 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.40.0-1
127- Update to 0.40.0
128
129* Thu Apr 13 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-2
130- Exclude ldc for module builds
131
132* Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.39.1-1
133- Update to 0.39.1
134
135* Mon Mar 06 2017 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.39.0-1
136- Update to 0.39.0
137
138* Tue Feb 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.1-1
139- Update to 0.38.1
140
141* Sun Jan 29 2017 Igor Gnatenko <ignatenko@redhat.com> - 0.38.0-1
142- Update to 0.38.0
143
144* Thu Dec 22 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.1-2
145- Rebuild for Python 3.6
146
147* Tue Dec 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.1-1
148- Update to 0.37.1
149
150* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.37.0-2
151- Rebuild for Python 3.6
152
153* Sun Dec 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.37.0-1
154- Update to 0.37.0
155
156* Thu Dec 15 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-4
157- Backport more RPM macro fixes (FPC ticket #655)
158
159* Tue Dec 13 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-3
160- Backport fixes to RPM macros
161
162* Sat Dec 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-2
163- Print test output during build
164
165* Mon Nov 14 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.36.0-1
166- Update to 0.36.0
167
168* Tue Oct 18 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.1-1
169- Update to 0.35.1 (RHBZ #1385986)
170
171* Tue Oct 11 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-3
172- Backport couple of fixes
173
174* Wed Oct 05 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-2
175- Apply patch to fix FTBFS
176
177* Mon Oct 03 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.35.0-1
178- Update to 0.35.0
179
180* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-2
181- Run D test suite
182
183* Wed Sep 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.34.0-1
184- Update to 0.34.0
185
186* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-2
187- Obsoletes fix.
188
189* Tue Aug 09 2016 Jon Ciesla <limburgher@gmail.com> - 0.33.0-1
190- 0.33.0
191- GUI dropped upstream.
192
193* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31.0-2
194- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
195
196* Thu Apr 14 2016 Igor Gnatenko <ignatenko@redhat.com> - 0.31.0-1
197- Update to 0.31.0
198
199* Sun Mar 20 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.30.0-1
200- Update to 0.30.0
201
202* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.29.0-2
203- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
204
205* Sun Jan 24 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.29.0-1
206- Update to 0.29.0
207
208* Fri Jan 15 2016 Jonathan Wakely <jwakely@redhat.com> - 0.28.0-2
209- Rebuilt for Boost 1.60
210
211* Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.28.0-1
212- 0.28.0
213
214* Wed Nov 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.27.0-1
215- 0.27.0
216
217* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26.0-3
218- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
219
220* Fri Oct 30 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-2
221- Fix rpm macros for using optflags
222
223* Sun Sep 13 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.26.0-1
224- 0.26.0
225
226* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.25.0-4
227- Rebuilt for Boost 1.59
228
229* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25.0-3
230- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
231
232* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.25.0-2
233- rebuild for Boost 1.58
234
235* Sun Jul 12 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.25.0-1
236- 0.25.0
237
238* Sat Jul 11 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-3
239- Update URLs
240- drop unneded hacks in install section
241- enable print test output for tests
242
243* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24.0-2
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
245
246* Mon May 25 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.24.0-1
247- Update to 0.24.0
248
249* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3.20150328git0ba1d54
250- Update to latest git
251
252* Thu May 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-3
253- Add patch to accept .S files
254
255* Wed Apr 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-2
256- Add python3 to Requires (Thanks to Ilya Kyznetsov)
257
258* Tue Mar 31 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.23.0-1
259- 0.23.0
260
261* Sat Mar 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150328git3b49b71
262- Update to latest git
263
264* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150325git18550fe
265- Update to latest git
266- Include mesonintrospect
267
268* Mon Mar 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-9.20150322git78d31ca
269- Fix filelists for mesongui (python-bytecode-without-source)
270
271* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-8.20150322git78d31ca
272- Enable C# tests
273
274* Sun Mar 22 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150322git78d31ca
275- update to latest git
276- fix tests on arm
277
278* Sat Mar 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150321gita084a8e
279- update to latest git
280
281* Mon Mar 16 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150316gitfa2c659
282- update to latest git
283
284* Tue Mar 10 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-7.20150310gitf9f51b1
285- today's git snapshot with support for cool GNOME features
286- re-enable wxGTK3 tests, package fixed in rawhide
287
288* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-6.git7581895
289- split gui to subpkg
290- update to latest snapshot
291- enable tests
292
293* Thu Feb 26 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-5.gitc6dbf98
294- Fix packaging style
295- Make package noarch
296
297* Mon Feb 23 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-4.git.c6dbf98
298- Use development version
299
300* Sat Feb 21 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 0.22.0-3
301- Add ninja-build to requires
302
303* Thu Jan 22 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-2
304- fix shebang in python files
305
306* Wed Jan 21 2015 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.22.0-1
307- Initial package
Note: See TracBrowser for help on using the repository browser.