source: projects/specs/trunk/m/mercurial/mercurial-vl.spec @ 8099

Revision 8099, 11.4 KB checked in by iwaim, 10 years ago (diff)

mercurial 2.5.2-1

Line 
1Summary: A fast, lightweight distributed source control management system
2Summary(ja): 軽量で高速な分散構成管理システム
3Name: mercurial
4Version: 2.5.2
5Release: 1%{?_dist_release}
6License: GPLv2
7Group: Development/Tools
8URL: http://mercurial.selenic.com/
9Source0: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
10Source1: mercurial-init.el
11Source10: mercurial-el-install.sh
12Source11: mercurial-el-remove.sh
13Patch0: mercurial-i18n.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: python python-devel
16%if %{?_dist_release} == "vl5"
17BuildRequires: docutils
18%else
19BuildRequires: python-docutils
20%endif
21BuildRequires: emacsen-common pkgconfig
22Requires: python
23Provides: hg = %{version}-%{release}
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: iwaim, daisuke
28
29%description
30Mercurial is a fast, lightweight source control management system designed
31for efficient handling of very large distributed projects.
32
33Quick start: http://www.selenic.com/mercurial/wiki/index.cgi/QuickStart
34Tutorial: http://www.selenic.com/mercurial/wiki/index.cgi/Tutorial
35Extensions: http://www.selenic.com/mercurial/wiki/index.cgi/CategoryExtension
36
37
38%package el
39Summary:        Mercurial version control system support for Emacs
40Summary(ja):    Mercurial バージョン管理システム用 Emacs サポート
41Group:          Applications/Editors
42Requires:       hg = %{version}-%{release}, emacsen-common
43Requires:       emacsen
44
45
46%description el
47Contains byte compiled elisp packages for mercurial.
48To get started: start emacs, load hg-mode with M-x hg-mode, and show
49help with C-c h h
50
51
52%package hgk
53Summary:        Hgk interface for mercurial
54Summary(ja):    Mercurial 用 Hgk インタフェース
55Group:          Development/Tools
56Requires:       hg = %{version}-%{release}, tk
57
58
59%description hgk
60A Mercurial extension for displaying the change history graphically
61using Tcl/Tk.  Displays branches and merges in an easily
62understandable way and shows diffs for each revision.  Based on
63gitk for the git SCM.
64
65Adds the "hg view" command.  See
66http://www.selenic.com/mercurial/wiki/index.cgi/UsingHgk for more
67documentation.
68
69
70%prep
71%setup -q
72%patch0 -p0
73
74%build
75make all
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80%{__python} setup.py install -O1 --root $RPM_BUILD_ROOT --prefix %{_prefix} --record=%{name}.files
81make install-doc DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir}
82
83grep -v 'hgk.py*' < %{name}.files > %{name}-base.files
84grep 'hgk.py*' < %{name}.files > %{name}-hgk.files
85
86install -D contrib/hgk       $RPM_BUILD_ROOT%{_libexecdir}/mercurial/hgk
87install contrib/convert-repo $RPM_BUILD_ROOT%{_bindir}/mercurial-convert-repo
88install contrib/hg-ssh       $RPM_BUILD_ROOT%{_bindir}
89
90bash_completion_dir=$RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
91mkdir -p $bash_completion_dir
92install -m 644 contrib/bash_completion $bash_completion_dir/mercurial.sh
93
94zsh_completion_dir=$RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
95mkdir -p $zsh_completion_dir
96install -m 644 contrib/zsh_completion $zsh_completion_dir/_mercurial
97
98mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/mercurial
99
100pushd contrib
101for file in mercurial.el mq.el %{SOURCE1}; do
102  install -p -m 644 $file $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
103done
104popd
105
106%__mkdir_p %{buildroot}%{_prefix}/lib/emacsen-common/packages/install
107%__mkdir_p %{buildroot}%{_prefix}/lib/emacsen-common/packages/remove
108
109%_installemacsenscript %{name} %{SOURCE10}
110
111%_removeemacsenscript  %{name} %{SOURCE11}
112
113
114mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/mercurial/hgrc.d
115
116cat >hgk.rc <<EOF
117[extensions]
118# enable hgk extension ('hg help' shows 'view' as a command)
119hgk=
120
121[hgk]
122path=%{_libexecdir}/mercurial/hgk
123EOF
124install hgk.rc $RPM_BUILD_ROOT/%{_sysconfdir}/mercurial/hgrc.d
125
126install contrib/mergetools.hgrc $RPM_BUILD_ROOT%{_sysconfdir}/mercurial/hgrc.d/mergetools.rc.sample
127
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132
133%post el
134if [ $1 = 2 ] ; then
135        %_emacsenPackageRemove %{name}
136
137fi
138%_addemacsenlist %{name}
139
140%_emacsenPackageInstall %{name}
141
142
143%preun el
144if [ $1 = 0 ] ; then
145        %_emacsenPackageRemove %{name}
146
147        %_removeemacsenlist %{name}
148
149fi
150
151
152%files -f %{name}-base.files
153%defattr(-,root,root,-)
154%doc CONTRIBUTORS COPYING doc/README doc/hg*.txt doc/hg*.html *.cgi contrib/*.fcgi
155%doc %attr(644,root,root) %{_mandir}/man?/hg*.gz
156%doc %attr(644,root,root) contrib/*.svg contrib/sample.hgrc
157%{_sysconfdir}/bash_completion.d/mercurial.sh
158%{_datadir}/zsh/site-functions/_mercurial
159%{_bindir}/hg-ssh
160%{_bindir}/mercurial-convert-repo
161%dir %{_sysconfdir}/mercurial
162%dir %{_sysconfdir}/mercurial/hgrc.d
163%{_sysconfdir}/mercurial/hgrc.d/mergetools.rc.sample
164%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
165%dir %{python_sitearch}/mercurial
166%dir %{python_sitearch}/hgext
167
168
169%files el
170%{_datadir}/emacs/site-lisp/mercurial
171%{_prefix}/lib/emacsen-common/packages/*/mercurial
172
173
174%files hgk -f %{name}-hgk.files
175%{_libexecdir}/mercurial/
176%{_sysconfdir}/mercurial/hgrc.d/hgk.rc
177
178
179#%%check
180#cd tests && %{__python} run-tests.py
181
182
183%changelog
184* Sun Mar  3 2013 IWAI, Masaharu <iwai@alib.jp> 2.5.2-1
185- update to 2.5.2
186
187* Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-1
188- update to 2.1.1
189
190* Sat Feb 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-1
191- update to 2.1
192- add i18n patch
193
194* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
195- new upstream release
196- add BuildRequires: python-docutils
197- remove git-viz: upstream removed in 1.6
198- drop doc/ja in doc: upstream removed
199- update URL value: upstream moved
200- add Vendor and Distribution tags
201
202* Fri Feb 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-1
203- update to 1.4.3
204
205* Tue Jan  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.2-3
206- initial build for VineSeed
207- add el subpackage for adapting emacsen-common way of handling emacs support
208
209* Thu Jan  1 2009 Neal Becker <ndbecker2@gmail.com> - 1.1.2-2
210- Rename mergetools.rc -> mergetools.rc.sample
211
212* Thu Jan  1 2009 Neal Becker <ndbecker2@gmail.com> - 1.1.2-1
213- Update to 1.1.2
214
215* Wed Dec 24 2008 Neal Becker <ndbecker2@gmail.com> - 1.1.1-3
216- Install mergetools.rc as mergetools.rc.sample
217
218* Sun Dec 21 2008 Neal Becker <ndbecker2@gmail.com> - 1.1.1-2
219- Fix typo
220
221* Sun Dec 21 2008 Neal Becker <ndbecker2@gmail.com> - 1.1.1-1
222- Update to 1.1.1
223
224* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.1-2
225- Rebuild for Python 2.6
226
227* Tue Dec  2 2008 Neal Becker <ndbecker2@gmail.com> - 1.1-1
228- Update to 1.1
229
230* Mon Dec  1 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.2-4
231- Bump tag
232
233* Mon Dec  1 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.2-3
234- Remove BR asciidoc
235- Use macro for python executable
236
237* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.2-2
238- Rebuild for Python 2.6
239
240* Fri Aug 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.2-1
241- Update to 1.0.2
242
243* Sun Jun 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.1-4
244- Bitten by expansion of commented out macro (again)
245
246* Sun Jun 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.1-3
247- Add BR pkgconfig
248
249* Sun Jun 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.1-2
250- Update to 1.0.1
251- Fix emacs_version, etc macros (need expand)
252- Remove patch0
253
254* Mon Jun  2 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-15
255- Bump release tag
256
257* Thu Apr 17 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-14
258- Oops, fix %%files due to last change
259
260* Wed Apr 16 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-13
261- install mergetools.hgrc as mergetools.rc
262
263* Sat Apr 12 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-12
264- Remove xemacs pkg - this is moved to xemacs-extras
265- Own %{python_sitearch}/{mercurial,hgext} dirs
266
267* Thu Apr 10 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-11
268- Use install -p to install .el{c} files
269- Don't (load mercurial) by default.
270
271* Wed Apr  9 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-10
272- Patch to hgk from Mads Kiilerich <mads@kiilerich.com>
273
274* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-9
275- Add '-l mercurial.el' for emacs also
276
277* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-8
278- BR xemacs-packages-extra
279
280* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-7
281- Various fixes
282
283* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-6
284- fix to comply with emacs packaging guidelines
285
286* Thu Mar 27 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-5
287- Move hgk-related py files to hgk
288- Put mergetools.hgrc in /etc/mercurial/hgrc.d
289- Add hgk.rc and put in /etc/mercurial/hgrc.d
290
291* Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-4
292- Rename mercurial-site-start -> mercurial-site-start.el
293
294* Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-3
295- Incorprate suggestions from hopper@omnifarious.org
296
297* Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-2
298- Add site-start
299
300* Tue Mar 25 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-1
301- Update to 1.0
302- Disable check for now - 1 test fails
303- Move emacs to separate package
304- Add check
305
306* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.5-7
307- Autorebuild for GCC 4.3
308
309* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-6
310- rpmlint fixes
311
312* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-5
313- /etc/mercurial/hgrc.d missing
314
315* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-3
316- Fix to last change
317
318* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-2
319- mkdir /etc/mercurial/hgrc.d for plugins
320
321* Tue Oct 23 2007  <ndbecker2@gmail.com> - 0.9.5-2
322- Bump tag to fix confusion
323
324* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-1
325- Sync with spec file from mercurial
326
327* Sat Sep 22 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-8
328- Just cp contrib tree.
329- Revert install -O2
330
331* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-7
332- Change setup.py install to -O2 to get bytecompile on EL-4
333
334* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-6
335- Revert last change.
336
337* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-5
338- Use {ghost} on contrib, otherwise EL-4 build fails
339
340* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-4
341- remove {_datadir}/contrib stuff for now
342
343* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-3
344- Fix mercurial-install-contrib.patch (/usr/share/mercurial->/usr/share/mercurial/contrib)
345
346* Wed Aug 29 2007 Jonathan Shapiro <shap@eros-os.com> - 0.9.4-2
347- update to 0.9.4-2
348- install contrib directory
349- set up required path for hgk
350- install man5 man pages
351
352* Thu Aug 23 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-1
353- update to 0.9.4
354
355* Wed Jan  3 2007 Jeremy Katz <katzj@redhat.com> - 0.9.3-1
356- update to 0.9.3
357- remove asciidoc files now that we have them as manpages
358
359* Mon Dec 11 2006 Jeremy Katz <katzj@redhat.com> - 0.9.2-1
360- update to 0.9.2
361
362* Mon Aug 28 2006 Jeremy Katz <katzj@redhat.com> - 0.9.1-2
363- rebuild
364
365* Tue Jul 25 2006 Jeremy Katz <katzj@redhat.com> - 0.9.1-1
366- update to 0.9.1
367
368* Fri May 12 2006 Mihai Ibanescu <misa@redhat.com> - 0.9-1
369- update to 0.9
370
371* Mon Apr 10 2006 Jeremy Katz <katzj@redhat.com> - 0.8.1-1
372- update to 0.8.1
373- add man pages (#188144)
374
375* Fri Mar 17 2006 Jeremy Katz <katzj@redhat.com> - 0.8-3
376- rebuild
377
378* Fri Feb 17 2006 Jeremy Katz <katzj@redhat.com> - 0.8-2
379- rebuild
380
381* Mon Jan 30 2006 Jeremy Katz <katzj@redhat.com> - 0.8-1
382- update to 0.8
383
384* Thu Sep 22 2005 Jeremy Katz <katzj@redhat.com>
385- add contributors to %%doc
386
387* Tue Sep 20 2005 Jeremy Katz <katzj@redhat.com> - 0.7
388- update to 0.7
389
390* Mon Aug 22 2005 Jeremy Katz <katzj@redhat.com> - 0.6c
391- update to 0.6c
392
393* Tue Jul 12 2005 Jeremy Katz <katzj@redhat.com> - 0.6b
394- update to new upstream 0.6b
395
396* Fri Jul  1 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1
397- Initial build.
398
Note: See TracBrowser for help on using the repository browser.