source: projects/specs/trunk/m/mercurial/mercurial-vl.spec @ 5830

Revision 5830, 11.3 KB checked in by daisuke, 12 years ago (diff)

update to 2.1.1

Line 
1Summary: A fast, lightweight distributed source control management system
2Summary(ja): 軽量で高速な分散構成管理システム
3Name: mercurial
4Version: 2.1.1
5Release: 1%{?_dist_release}
6License: GPLv2
7Group: Development/Tools
8URL: http://mercurial.selenic.com/
9Source0: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
10Source1: mercurial-init.el
11Source10: mercurial-el-install.sh
12Source11: mercurial-el-remove.sh
13Patch0: mercurial-i18n.patch
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: python python-devel
16%if %{?_dist_release} == "vl5"
17BuildRequires: docutils
18%else
19BuildRequires: python-docutils
20%endif
21BuildRequires: emacsen-common pkgconfig
22Requires: python
23Provides: hg = %{version}-%{release}
24
25Vendor: Project Vine
26Distribution: Vine Linux
27Packager: iwaim, daisuke
28
29%description
30Mercurial is a fast, lightweight source control management system designed
31for efficient handling of very large distributed projects.
32
33Quick start: http://www.selenic.com/mercurial/wiki/index.cgi/QuickStart
34Tutorial: http://www.selenic.com/mercurial/wiki/index.cgi/Tutorial
35Extensions: http://www.selenic.com/mercurial/wiki/index.cgi/CategoryExtension
36
37
38%package el
39Summary:        Mercurial version control system support for Emacs
40Summary(ja):    Mercurial バージョン管理システム用 Emacs サポート
41Group:          Applications/Editors
42Requires:       hg = %{version}-%{release}, emacsen-common
43Requires:       emacsen
44
45
46%description el
47Contains byte compiled elisp packages for mercurial.
48To get started: start emacs, load hg-mode with M-x hg-mode, and show
49help with C-c h h
50
51
52%package hgk
53Summary:        Hgk interface for mercurial
54Summary(ja):    Mercurial 用 Hgk インタフェース
55Group:          Development/Tools
56Requires:       hg = %{version}-%{release}, tk
57
58
59%description hgk
60A Mercurial extension for displaying the change history graphically
61using Tcl/Tk.  Displays branches and merges in an easily
62understandable way and shows diffs for each revision.  Based on
63gitk for the git SCM.
64
65Adds the "hg view" command.  See
66http://www.selenic.com/mercurial/wiki/index.cgi/UsingHgk for more
67documentation.
68
69
70%prep
71%setup -q
72%patch0 -p0
73
74%build
75make all
76
77
78%install
79rm -rf $RPM_BUILD_ROOT
80%{__python} setup.py install -O1 --root $RPM_BUILD_ROOT --prefix %{_prefix} --record=%{name}.files
81make install-doc DESTDIR=$RPM_BUILD_ROOT MANDIR=%{_mandir}
82
83grep -v 'hgk.py*' < %{name}.files > %{name}-base.files
84grep 'hgk.py*' < %{name}.files > %{name}-hgk.files
85
86install -D contrib/hgk       $RPM_BUILD_ROOT%{_libexecdir}/mercurial/hgk
87install contrib/convert-repo $RPM_BUILD_ROOT%{_bindir}/mercurial-convert-repo
88install contrib/hg-ssh       $RPM_BUILD_ROOT%{_bindir}
89
90bash_completion_dir=$RPM_BUILD_ROOT%{_sysconfdir}/bash_completion.d
91mkdir -p $bash_completion_dir
92install -m 644 contrib/bash_completion $bash_completion_dir/mercurial.sh
93
94zsh_completion_dir=$RPM_BUILD_ROOT%{_datadir}/zsh/site-functions
95mkdir -p $zsh_completion_dir
96install -m 644 contrib/zsh_completion $zsh_completion_dir/_mercurial
97
98mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/mercurial
99
100pushd contrib
101for file in mercurial.el mq.el %{SOURCE1}; do
102  install -p -m 644 $file $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{name}/
103done
104popd
105
106%__mkdir_p %{buildroot}%{_prefix}/lib/emacsen-common/packages/install
107%__mkdir_p %{buildroot}%{_prefix}/lib/emacsen-common/packages/remove
108
109%_installemacsenscript %{name} %{SOURCE10}
110
111%_removeemacsenscript  %{name} %{SOURCE11}
112
113
114mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/mercurial/hgrc.d
115
116cat >hgk.rc <<EOF
117[extensions]
118# enable hgk extension ('hg help' shows 'view' as a command)
119hgk=
120
121[hgk]
122path=%{_libexecdir}/mercurial/hgk
123EOF
124install hgk.rc $RPM_BUILD_ROOT/%{_sysconfdir}/mercurial/hgrc.d
125
126install contrib/mergetools.hgrc $RPM_BUILD_ROOT%{_sysconfdir}/mercurial/hgrc.d/mergetools.rc.sample
127
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132
133%post el
134if [ $1 = 2 ] ; then
135        %_emacsenPackageRemove %{name}
136
137fi
138%_addemacsenlist %{name}
139
140%_emacsenPackageInstall %{name}
141
142
143%preun el
144if [ $1 = 0 ] ; then
145        %_emacsenPackageRemove %{name}
146
147        %_removeemacsenlist %{name}
148
149fi
150
151
152%files -f %{name}-base.files
153%defattr(-,root,root,-)
154%doc CONTRIBUTORS COPYING doc/README doc/hg*.txt doc/hg*.html *.cgi contrib/*.fcgi
155%doc %attr(644,root,root) %{_mandir}/man?/hg*.gz
156%doc %attr(644,root,root) contrib/*.svg contrib/sample.hgrc
157%{_sysconfdir}/bash_completion.d/mercurial.sh
158%{_datadir}/zsh/site-functions/_mercurial
159%{_bindir}/hg-ssh
160%{_bindir}/mercurial-convert-repo
161%dir %{_sysconfdir}/mercurial
162%dir %{_sysconfdir}/mercurial/hgrc.d
163%{_sysconfdir}/mercurial/hgrc.d/mergetools.rc.sample
164%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
165%dir %{python_sitearch}/mercurial
166%dir %{python_sitearch}/hgext
167
168
169%files el
170%{_datadir}/emacs/site-lisp/mercurial
171%{_prefix}/lib/emacsen-common/packages/*/mercurial
172
173
174%files hgk -f %{name}-hgk.files
175%{_libexecdir}/mercurial/
176%{_sysconfdir}/mercurial/hgrc.d/hgk.rc
177
178
179#%%check
180#cd tests && %{__python} run-tests.py
181
182
183%changelog
184* Mon Mar 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.1-1
185- update to 2.1.1
186
187* Sat Feb 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1-1
188- update to 2.1
189- add i18n patch
190
191* Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.8.1-1
192- new upstream release
193- add BuildRequires: python-docutils
194- remove git-viz: upstream removed in 1.6
195- drop doc/ja in doc: upstream removed
196- update URL value: upstream moved
197- add Vendor and Distribution tags
198
199* Fri Feb 19 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.3-1
200- update to 1.4.3
201
202* Tue Jan  6 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.2-3
203- initial build for VineSeed
204- add el subpackage for adapting emacsen-common way of handling emacs support
205
206* Thu Jan  1 2009 Neal Becker <ndbecker2@gmail.com> - 1.1.2-2
207- Rename mergetools.rc -> mergetools.rc.sample
208
209* Thu Jan  1 2009 Neal Becker <ndbecker2@gmail.com> - 1.1.2-1
210- Update to 1.1.2
211
212* Wed Dec 24 2008 Neal Becker <ndbecker2@gmail.com> - 1.1.1-3
213- Install mergetools.rc as mergetools.rc.sample
214
215* Sun Dec 21 2008 Neal Becker <ndbecker2@gmail.com> - 1.1.1-2
216- Fix typo
217
218* Sun Dec 21 2008 Neal Becker <ndbecker2@gmail.com> - 1.1.1-1
219- Update to 1.1.1
220
221* Thu Dec 04 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.1-2
222- Rebuild for Python 2.6
223
224* Tue Dec  2 2008 Neal Becker <ndbecker2@gmail.com> - 1.1-1
225- Update to 1.1
226
227* Mon Dec  1 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.2-4
228- Bump tag
229
230* Mon Dec  1 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.2-3
231- Remove BR asciidoc
232- Use macro for python executable
233
234* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.2-2
235- Rebuild for Python 2.6
236
237* Fri Aug 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.2-1
238- Update to 1.0.2
239
240* Sun Jun 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.1-4
241- Bitten by expansion of commented out macro (again)
242
243* Sun Jun 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.1-3
244- Add BR pkgconfig
245
246* Sun Jun 15 2008 Neal Becker <ndbecker2@gmail.com> - 1.0.1-2
247- Update to 1.0.1
248- Fix emacs_version, etc macros (need expand)
249- Remove patch0
250
251* Mon Jun  2 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-15
252- Bump release tag
253
254* Thu Apr 17 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-14
255- Oops, fix %%files due to last change
256
257* Wed Apr 16 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-13
258- install mergetools.hgrc as mergetools.rc
259
260* Sat Apr 12 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-12
261- Remove xemacs pkg - this is moved to xemacs-extras
262- Own %{python_sitearch}/{mercurial,hgext} dirs
263
264* Thu Apr 10 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-11
265- Use install -p to install .el{c} files
266- Don't (load mercurial) by default.
267
268* Wed Apr  9 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-10
269- Patch to hgk from Mads Kiilerich <mads@kiilerich.com>
270
271* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-9
272- Add '-l mercurial.el' for emacs also
273
274* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-8
275- BR xemacs-packages-extra
276
277* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-7
278- Various fixes
279
280* Tue Apr  8 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-6
281- fix to comply with emacs packaging guidelines
282
283* Thu Mar 27 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-5
284- Move hgk-related py files to hgk
285- Put mergetools.hgrc in /etc/mercurial/hgrc.d
286- Add hgk.rc and put in /etc/mercurial/hgrc.d
287
288* Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-4
289- Rename mercurial-site-start -> mercurial-site-start.el
290
291* Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-3
292- Incorprate suggestions from hopper@omnifarious.org
293
294* Wed Mar 26 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-2
295- Add site-start
296
297* Tue Mar 25 2008 Neal Becker <ndbecker2@gmail.com> - 1.0-1
298- Update to 1.0
299- Disable check for now - 1 test fails
300- Move emacs to separate package
301- Add check
302
303* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.5-7
304- Autorebuild for GCC 4.3
305
306* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-6
307- rpmlint fixes
308
309* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-5
310- /etc/mercurial/hgrc.d missing
311
312* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-3
313- Fix to last change
314
315* Fri Nov  9 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-2
316- mkdir /etc/mercurial/hgrc.d for plugins
317
318* Tue Oct 23 2007  <ndbecker2@gmail.com> - 0.9.5-2
319- Bump tag to fix confusion
320
321* Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.5-1
322- Sync with spec file from mercurial
323
324* Sat Sep 22 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-8
325- Just cp contrib tree.
326- Revert install -O2
327
328* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-7
329- Change setup.py install to -O2 to get bytecompile on EL-4
330
331* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-6
332- Revert last change.
333
334* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-5
335- Use {ghost} on contrib, otherwise EL-4 build fails
336
337* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-4
338- remove {_datadir}/contrib stuff for now
339
340* Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-3
341- Fix mercurial-install-contrib.patch (/usr/share/mercurial->/usr/share/mercurial/contrib)
342
343* Wed Aug 29 2007 Jonathan Shapiro <shap@eros-os.com> - 0.9.4-2
344- update to 0.9.4-2
345- install contrib directory
346- set up required path for hgk
347- install man5 man pages
348
349* Thu Aug 23 2007 Neal Becker <ndbecker2@gmail.com> - 0.9.4-1
350- update to 0.9.4
351
352* Wed Jan  3 2007 Jeremy Katz <katzj@redhat.com> - 0.9.3-1
353- update to 0.9.3
354- remove asciidoc files now that we have them as manpages
355
356* Mon Dec 11 2006 Jeremy Katz <katzj@redhat.com> - 0.9.2-1
357- update to 0.9.2
358
359* Mon Aug 28 2006 Jeremy Katz <katzj@redhat.com> - 0.9.1-2
360- rebuild
361
362* Tue Jul 25 2006 Jeremy Katz <katzj@redhat.com> - 0.9.1-1
363- update to 0.9.1
364
365* Fri May 12 2006 Mihai Ibanescu <misa@redhat.com> - 0.9-1
366- update to 0.9
367
368* Mon Apr 10 2006 Jeremy Katz <katzj@redhat.com> - 0.8.1-1
369- update to 0.8.1
370- add man pages (#188144)
371
372* Fri Mar 17 2006 Jeremy Katz <katzj@redhat.com> - 0.8-3
373- rebuild
374
375* Fri Feb 17 2006 Jeremy Katz <katzj@redhat.com> - 0.8-2
376- rebuild
377
378* Mon Jan 30 2006 Jeremy Katz <katzj@redhat.com> - 0.8-1
379- update to 0.8
380
381* Thu Sep 22 2005 Jeremy Katz <katzj@redhat.com>
382- add contributors to %%doc
383
384* Tue Sep 20 2005 Jeremy Katz <katzj@redhat.com> - 0.7
385- update to 0.7
386
387* Mon Aug 22 2005 Jeremy Katz <katzj@redhat.com> - 0.6c
388- update to 0.6c
389
390* Tue Jul 12 2005 Jeremy Katz <katzj@redhat.com> - 0.6b
391- update to new upstream 0.6b
392
393* Fri Jul  1 2005 Jeremy Katz <katzj@redhat.com> - 0.6-1
394- Initial build.
395
Note: See TracBrowser for help on using the repository browser.