source: projects/specs/trunk/m/medit/medit-vl.spec @ 634

Revision 634, 4.5 KB checked in by kudoh, 14 years ago (diff)
Line 
1%define name     medit
2%define version  0.10.1
3
4Name:        %{name}
5Version:     %{version}
6Release:     1%{?_dist_release}
7Summary:     Multiplatform GTK+2 text editor
8Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
9Group:       Applications/Editors
10License:     GPLv2+
11URL:         http://mooedit.sourceforge.net/
12Source0:     http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
13#Patch1:      medit-0.9.2-do-not-update-system-files.patch
14BuildRoot:   %{_tmppath}/%{name}-%{version}-root
15
16BuildRequires:   cmake
17BuildRequires:   desktop-file-utils
18BuildRequires:   gtk2-devel glib2-devel
19BuildRequires:   intltool
20BuildRequires:   libxml2-devel
21BuildRequires:   libXext-devel libICE-devel
22BuildRequires:   pcre-devel
23BuildRequires:   python-devel
24BuildRequires:   pygtk2-devel
25
26%description
27Medit is a multiplatform GTK+2 text editor.
28
29Features:
30 * Configurable syntax highlighting.
31 * Configurable keyboard accelerators.
32 * Multiplatform - works both on unix and windows.
33 * Plugins: can be written in C or Python.
34 * Configurable tools available from the main and context menus.
35   They can be written in Python or Lua, or it can be a shell script.
36 * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
37
38%description -l ja
39Medit はマルチプラットフォームな GTK+2 テキストエディタです。
40
41機能一覧:
42 * 設定可能な構文強調機能。
43 * 設定可能なキーボードアクセラレータ。
44 * マルチプラットフォーム - unix と windows の両者で動作。
45 * プラグイン: C あるいは Python で作成可能。
46 * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
47   Python あるいは lua 、シェルスクリプトで作成可能。
48 * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
49
50
51%prep
52%setup -q
53#%patch1 -p1
54
55%build
56cmake -D CMAKE_INSTALL_PREFIX=/usr .
57make %{?_smp_mflags}
58
59%install
60rm -rf %buildroot
61make install DESTDIR=$RPM_BUILD_ROOT
62
63desktop-file-install --vendor=""                          \
64        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications   \
65        --mode 0644                                       \
66        $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
67
68%post
69update-desktop-database %{_datadir}/applications
70touch --no-create %{_datadir}/icons/hicolor
71if [ -x /usr/bin/gtk-update-icon-cache ]; then
72  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
73fi
74
75%postun
76update-desktop-database %{_datadir}/applications
77touch --no-create %{_datadir}/icons/hicolor
78if [ -x /usr/bin/gtk-update-icon-cache ]; then
79  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
80fi
81
82%clean
83rm -rf %buildroot
84
85%files
86%defattr(-,root,root)
87%doc COPYING README
88%{_bindir}/*
89%{_datadir}/applications/%{name}.desktop
90%{_datadir}/moo
91%{_datadir}/pixmaps/*
92%{_datadir}/icons/hicolor/*
93%{_datadir}/locale/*
94%{_docdir}/%{name}/*
95
96%changelog
97* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
98- new upstream release
99- applied new naming policy to spec
100
101* Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
102- initial build for VineSeed
103
104* Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
105+ Revision: 155675
106- New version 0.9.2
107- rediff patch0
108
109  + Olivier Blin <oblin@mandriva.com>
110    - restore BuildRoot
111
112  + Thierry Vignaud <tvignaud@mandriva.com>
113    - kill re-definition of %%buildroot on Pixel's request
114
115* Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
116+ Revision: 114221
117- New version 0.9.0
118
119* Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
120+ Revision: 109208
121- New release 0.8.11
122
123* Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
124+ Revision: 59667
125- New version 0.8.10
126
127* Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
128+ Revision: 57568
129- New version 0.8.9
130
131* Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
132+ Revision: 51500
133- Fix file list
134- New version
135
136* Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
137+ Revision: 39539
138- SILent renew tarball
139- New version
140- New version
141  add dirty patch that skips update-icon-cache and mime database when building
142
143  + Jérôme Soyer <saispo@mandriva.org>
144    - Import medit
145
146
147
148
149* Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
150- new release
151
152* Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
153- first spec for Mandriva
Note: See TracBrowser for help on using the repository browser.