source: projects/specs/trunk/m/medit/medit-vl.spec @ 2681

Revision 2681, 5.4 KB checked in by kudoh, 13 years ago (diff)
Line 
1%define name     medit
2%define version  1.0.0
3
4Name:        %{name}
5Version:     %{version}
6Release:     1%{?_dist_release}
7Summary:     Multiplatform GTK+2 text editor
8Summary(ja): マルチプラットフォームな GTK+2 テキストエディタ
9Group:       Applications/Editors
10License:     GPLv2+
11URL:         http://mooedit.sourceforge.net/
12Source0:     http://prdownloads.sourceforge.net/mooedit/%{name}-%{version}.tar.bz2
13Source1:     medit_ja.po
14
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16
17Buildrequires:   cairo-devel
18BuildRequires:   desktop-file-utils
19BuildRequires:   gettext
20BuildRequires:   gtk2-devel glib2-devel
21BuildRequires:   intltool
22BuildRequires:   libxml2-devel
23BuildRequires:   libX11-devel libXext-devel libICE-devel
24BuildRequires:   libSM-devel
25Buildrequires:   perl-XML-Parser pango-devel
26BuildRequires:   pcre-devel
27BuildRequires:   python-devel
28BuildRequires:   pygtk2-devel
29
30%description
31Medit is a multiplatform GTK+2 text editor.
32
33Features:
34 * Configurable syntax highlighting.
35 * Configurable keyboard accelerators.
36 * Multiplatform - works both on unix and windows.
37 * Plugins: can be written in C or Python.
38 * Configurable tools available from the main and context menus.
39   They can be written in Python or Lua, or it can be a shell script.
40 * Regular expression search/replace, grep and find frontends, builtin file selector, etc.
41
42%description -l ja
43Medit はマルチプラットフォームな GTK+2 テキストエディタです。
44
45機能一覧:
46 * 設定可能な構文強調機能。
47 * 設定可能なキーボードアクセラレータ。
48 * マルチプラットフォーム - unix と windows の両者で動作。
49 * プラグイン: C あるいは Python で作成可能。
50 * メインメニューおよびコンテキストメニューから設定可能なツールを利用可能。
51   Python あるいは lua 、シェルスクリプトで作成可能。
52 * 正規表現による検索/置換、grep と find のフロントエンド、組み込みファイルセレクタなどなど。
53
54
55%prep
56%setup -q
57sed -i 's|fr|fr\nja|g' po/LINGUAS
58
59%__cp -f %{SOURCE1} po/ja.po
60
61%build
62#cmake -D CMAKE_INSTALL_PREFIX=/usr .
63%configure
64make %{?_smp_mflags}
65
66%install
67rm -rf %{buildroot}
68make install DESTDIR=$RPM_BUILD_ROOT
69
70desktop-file-install --vendor=""                          \
71        --dir=${RPM_BUILD_ROOT}%{_datadir}/applications   \
72        --mode 0644                                       \
73        $RPM_BUILD_ROOT/%{_datadir}/applications/%{name}.desktop
74
75%post
76update-desktop-database %{_datadir}/applications
77touch --no-create %{_datadir}/icons/hicolor
78if [ -x /usr/bin/gtk-update-icon-cache ]; then
79  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
80fi
81
82%postun
83update-desktop-database %{_datadir}/applications
84touch --no-create %{_datadir}/icons/hicolor
85if [ -x /usr/bin/gtk-update-icon-cache ]; then
86  gtk-update-icon-cache -q %{_datadir}/icons/hicolor ||:
87fi
88
89%clean
90rm -rf %{buildroot}
91
92%files
93%defattr(-,root,root)
94%doc COPYING README
95%{_bindir}/*
96%{_datadir}/applications/%{name}.desktop
97%{_datadir}/%{name}-1/*
98%{_datadir}/icons/hicolor/48x48/
99%exclude %{_datadir}/icons/hicolor/icon-theme.cache
100%{_datadir}/locale/*
101%{_docdir}/%{name}-1/*
102%{_mandir}/man?/
103
104%changelog
105* Sat Feb 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.0-1
106- new upstream release
107- updated Source1
108- dropt BuildRequires: cmake
109- added BuildRequires: libSM-devel
110- fixed %%files
111
112* Sun Oct 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-2
113- updated Source1
114
115* Fri Oct 8 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.5-1
116- new upstream release
117- cleaned up spec
118
119* Sat Jul 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-2
120- updated Source1
121- added BuildRequires: cairo-devel, gettext, libX11-devel, perl-XML-Parser, pango-devel
122- changed BuildRequires: cmake >= 2.6
123
124* Wed May 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.4-1
125- new upstream release
126- added Japanese language file
127- added man directory in %files
128
129* Sun Mar 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.1-1
130- new upstream release
131- applied new naming policy to spec
132
133* Fri Mar 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.10.0-1
134- initial build for VineSeed
135
136* Mon Jan 21 2008 Funda Wang <fundawang@mandriva.org> 0.9.2-1mdv2008.1
137+ Revision: 155675
138- New version 0.9.2
139- rediff patch0
140
141  + Olivier Blin <oblin@mandriva.com>
142    - restore BuildRoot
143
144  + Thierry Vignaud <tvignaud@mandriva.com>
145    - kill re-definition of %%buildroot on Pixel's request
146
147* Sat Dec 01 2007 Funda Wang <fundawang@mandriva.org> 0.9.0-1mdv2008.1
148+ Revision: 114221
149- New version 0.9.0
150
151* Sat Nov 17 2007 Jérôme Soyer <saispo@mandriva.org> 0.8.11-1mdv2008.1
152+ Revision: 109208
153- New release 0.8.11
154
155* Tue Aug 07 2007 Funda Wang <fundawang@mandriva.org> 0.8.10-1mdv2008.0
156+ Revision: 59667
157- New version 0.8.10
158
159* Wed Aug 01 2007 Funda Wang <fundawang@mandriva.org> 0.8.9-1mdv2008.0
160+ Revision: 57568
161- New version 0.8.9
162
163* Thu Jul 12 2007 Funda Wang <fundawang@mandriva.org> 0.8.8-1mdv2008.0
164+ Revision: 51500
165- Fix file list
166- New version
167
168* Thu Jun 14 2007 Funda Wang <fundawang@mandriva.org> 0.8.6-1mdv2008.0
169+ Revision: 39539
170- SILent renew tarball
171- New version
172- New version
173  add dirty patch that skips update-icon-cache and mime database when building
174
175  + Jérôme Soyer <saispo@mandriva.org>
176    - Import medit
177
178
179
180
181* Tue May 09 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.98-1mdk
182- new release
183
184* Mon May 08 2006 UTUMI Hirosi <utuhiro78@dummy.org> 0.6.97-1mdk
185- first spec for Mandriva
Note: See TracBrowser for help on using the repository browser.