source: projects/specs/trunk/m/maxima/maxima-vl.spec @ 10803

Revision 10803, 6.2 KB checked in by ara_t, 8 years ago (diff)

update to 5.38.1-2

Line 
1# -*- mode: rpm-spec -*-
2
3# By default, this spec file will generate RPMs for Clisp and SBCL.
4# This can be changed by modifying the variables below.
5%define enable_clisp 0
6%define enable_sbcl 1
7
8# Inhibit automatic compressing of info files. Compressed info
9# files break maxima's internal help.
10%define __spec_install_post /bin/true
11
12Summary: Maxima Symbolic Computation Program
13Summary(ja): 数式処理プログラム Maxima
14Name: maxima
15Version: 5.38.1
16Release: 2%{?_dist_release}
17
18License: GPL
19Group:   Applications/Engineering
20URL:     http://maxima.sourceforge.net
21Source0: %{name}-%{version}.tar.gz
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25# Requires: maxima_exec = %{version}-%{release}
26%if %{enable_clisp}
27BuildRequires: clisp
28Requires: clisp
29%endif
30%if %{enable_sbcl}
31BuildRequires: sbcl
32Requires: sbcl
33%endif
34BuildRequires: texinfo
35Requires(post): /sbin/install-info
36Requires(preun): /sbin/install-info
37
38Obsoletes: %{name}-exec-clisp
39Obsoletes: %{name}-exec-sbcl
40
41Vendor:       Project Vine
42Distribution: Vine Linux
43
44
45%description
46Maxima is a full symbolic computation program.  It is full featured
47doing symbolic manipulation of polynomials, matrices, rational
48functions, integration, Todd-coxeter, graphing, bigfloats.  It has a
49symbolic debugger source level debugger for maxima code.  Maxima is
50based on the original Macsyma developed at MIT in the 1970's.  It is
51quite reliable, and has good garbage collection, and no memory leaks.
52It comes with hundreds of self tests.
53#'
54
55%description -l ja
56Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
57有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
58も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
59ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
60Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
61ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
62信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
63%if %{enable_sbcl}
64SBCLではコマンドライン履歴を使用することができません。
65コマンドライン履歴を使用する場合には rlwrap パッケージを
66インストールして、
67rlwrap maxima
68のように起動して下さい。
69%endif
70
71
72%package xmaxima
73Summary: Tcl/Tk interface to Maxima
74Summary(ja): Maxima 用 Tcl/Tk インターフェース
75Group: Applications/Engineering
76Requires: %{name} = %{version}-%{release}
77Requires: tk > 8.1
78Provides: xmaxima
79
80%description xmaxima
81Tcl/Tk interface to Maxima.
82
83# %if %{enable_clisp}
84# %package exec-clisp
85# Summary: Maxima compiled with clisp
86# Group: Applications/Engineering
87# BuildRequires: clisp
88# Requires: clisp
89# Provides: maxima_exec
90# Obsoletes: %{name}-exec-sbcl
91# %description exec-clisp
92# Maxima compiled with clisp.
93# %endif
94
95# %if %{enable_sbcl}
96# %package exec-sbcl
97# Summary: Maxima compiled with SBCL
98# Group: Applications/Engineering
99# BuildRequires: sbcl
100# Requires: sbcl
101# Provides: maxima_exec
102# Obsoletes: %{name}-exec-clisp
103# %description exec-sbcl
104# Maxima compiled with SBCL.
105# %endif
106
107%prep
108%setup -q
109%{configure} \
110%if %{enable_clisp}
111    --enable-clisp \
112%endif
113%if %{enable_sbcl}
114    --enable-sbcl \
115%endif
116    ;
117
118%build
119%{__make} %{?_smp_mflags}
120
121%install
122%{__rm} -rf %{buildroot}
123%{makeinstall}
124
125%{__rm} -f $RPM_BUILD_ROOT%{_infodir}/dir
126
127%post
128/sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
129
130%preun
131if [ "$1" = 0 ]; then
132    /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
133fi
134
135%clean
136%{__rm} -rf %{buildroot}
137
138
139%files
140%defattr(-,root,root,-)
141%doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
142%{_bindir}/maxima
143%{_bindir}/rmaxima
144%dir %{_libdir}/maxima/%{version}
145%if %{enable_clisp}
146%{_libdir}/maxima/%{version}/binary-clisp
147%endif
148%if %{enable_sbcl}
149%{_libdir}/maxima/%{version}/binary-sbcl
150%endif
151%{_libexecdir}/maxima/%{version}
152%{_datadir}/maxima/%{version}
153%{_datadir}/mime/packages/*
154%{_mandir}/man1/*
155%{_infodir}/*
156
157%files xmaxima
158%{_bindir}/xmaxima
159
160
161%changelog
162* Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-2
163- delete maxima-exec-{clisp,sbcl} subpackages
164- add Vendor and Distribution
165
166* Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-1
167- New upstream release
168- add build option (SBCL)
169- delete build options (GCL and CMUCL)
170
171* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.36.1-1
172- update to 5.36.1
173- add BuildRequires: texinfo
174
175* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.16.3-3
176- rebuild with Vine6 environment
177
178* Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
179- rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
180
181* Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
182- new upstream release
183
184* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
185- applied new versioning policy, spec in utf-8
186
187* Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
188- New upstream release
189- Change Group
190
191* Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
192- Japanese Summary and description by rpmSpecTranslate project
193
194* Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
195- New upstream release (for diff() bug fix)
196- Tidy up spec file
197
198* Sun Feb  1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
199- Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
200
201* Sat Aug  2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
202- Add exec-clisp BuildPreReq clisp
203- Add xmaxima Requires tk > 8.1
204- Remove xmaxima-olderTcl patch
205
206* Fri Jun  6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
207- Rebuild for clisp-2.29-0vl1
208
209* Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
210- Enable clisp only, disable cmucl and gcl
211- Add xmaxima-olderTcl patch (for tclversion older than 8.1)
212- Remove %{_infodir}/dir file
213
214* Sat Jan  4 2003 James Amundson <amundson@fnal.gov>
215- Added doc files
216- Added explicit clisp version
217- Added conditional to postun
218- Renamed exec_* packages to exec-*
219- Use rpm macros instead of hard-coded paths
220- Thanks to Rex Dieter for helpful suggestions
221
222* Sun Sep  8 2002 James Amundson <amundson@fnal.gov>
223- Initial build.
Note: See TracBrowser for help on using the repository browser.