source: projects/specs/trunk/m/maxima/maxima-vl.spec @ 10794

Revision 10794, 5.8 KB checked in by ara_t, 8 years ago (diff)

update to 5.38.1

Line 
1# -*- mode: rpm-spec -*-
2
3# By default, this spec file will generate RPMs for Clisp and SBCL.
4# This can be changed by modifying the variables below.
5%define enable_clisp 0
6%define enable_sbcl 1
7
8# Inhibit automatic compressing of info files. Compressed info
9# files break maxima's internal help.
10%define __spec_install_post /bin/true
11
12Summary: Maxima Symbolic Computation Program
13Summary(ja): 数式処理プログラム Maxima
14Name: maxima
15Version: 5.38.1
16Release: 1%{?_dist_release}
17License: GPL
18Group: Applications/Engineering
19URL: http://maxima.sourceforge.net
20Source0: %{name}-%{version}.tar.gz
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Requires: maxima_exec = %{version}-%{release}
23BuildRequires: texinfo
24Requires(post): /sbin/install-info
25Requires(preun): /sbin/install-info
26
27%description
28Maxima is a full symbolic computation program.  It is full featured
29doing symbolic manipulation of polynomials, matrices, rational
30functions, integration, Todd-coxeter, graphing, bigfloats.  It has a
31symbolic debugger source level debugger for maxima code.  Maxima is
32based on the original Macsyma developed at MIT in the 1970's.  It is
33quite reliable, and has good garbage collection, and no memory leaks.
34It comes with hundreds of self tests.
35#'
36
37%description -l ja
38Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
39有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
40も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
41ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
42Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
43ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
44信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
45%if %{enable_sbcl}
46SBCLではコマンドライン履歴を使用することができません。
47コマンドライン履歴を使用する場合には rlwrap パッケージを
48インストールして、
49rlwrap maxima
50のように起動して下さい。
51%endif
52
53
54%package xmaxima
55Summary: Tcl/Tk interface to Maxima
56Summary(ja): Maxima 用 Tcl/Tk インターフェース
57Group: Applications/Engineering
58Requires: %{name} = %{version}-%{release}
59Requires: tk > 8.1
60Provides: xmaxima
61
62%description xmaxima
63Tcl/Tk interface to Maxima.
64
65%if %{enable_clisp}
66%package exec-clisp
67Summary: Maxima compiled with clisp
68Group: Applications/Engineering
69BuildRequires: clisp
70Requires: clisp
71Provides: maxima_exec
72Obsoletes: %{name}-exec-sbcl
73%description exec-clisp
74Maxima compiled with clisp.
75%endif
76
77%if %{enable_sbcl}
78%package exec-sbcl
79Summary: Maxima compiled with SBCL
80Group: Applications/Engineering
81BuildRequires: sbcl
82Requires: sbcl
83Provides: maxima_exec
84Obsoletes: %{name}-exec-clisp
85%description exec-sbcl
86Maxima compiled with SBCL.
87%endif
88
89%prep
90%setup -q
91%configure \
92%if %{enable_clisp}
93    --enable-clisp \
94%endif
95%if %{enable_sbcl}
96    --enable-sbcl \
97%endif
98    ;
99
100%build
101%__make %{?_smp_mflags}
102
103%install
104%__rm -rf %{buildroot}
105%makeinstall
106
107rm -f $RPM_BUILD_ROOT%{_infodir}/dir
108
109%post
110/sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
111
112%preun
113if [ "$1" = 0 ]; then
114        /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
115fi
116
117%clean
118%__rm -rf %{buildroot}
119
120%files
121%defattr(-,root,root,-)
122%{_datadir}/maxima/%{version}
123%dir %{_libdir}/maxima/%{version}
124%{_libexecdir}/maxima/%{version}
125%{_infodir}/*
126%{_mandir}/man1/*
127%{_bindir}/*
128%doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
129
130%files xmaxima
131%{_bindir}/xmaxima
132
133%if %{enable_clisp}
134%files exec-clisp
135%{_libdir}/maxima/%{version}/binary-clisp
136%endif
137
138%if %{enable_sbcl}
139%files exec-sbcl
140%{_libdir}/maxima/%{version}/binary-sbcl
141%endif
142
143
144%changelog
145* Sat Nov 05 2016 Toshiaki Ara <ara_t@384.jp> 5.38.1-1
146- New upstream release
147- add build option (SBCL)
148- delete build options (GCL and CMUCL)
149
150* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.36.1-1
151- update to 5.36.1
152- add BuildRequires: texinfo
153
154* Sun Jun 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.16.3-3
155- rebuild with Vine6 environment
156
157* Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
158- rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
159
160* Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
161- new upstream release
162
163* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
164- applied new versioning policy, spec in utf-8
165
166* Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
167- New upstream release
168- Change Group
169
170* Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
171- Japanese Summary and description by rpmSpecTranslate project
172
173* Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
174- New upstream release (for diff() bug fix)
175- Tidy up spec file
176
177* Sun Feb  1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
178- Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
179
180* Sat Aug  2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
181- Add exec-clisp BuildPreReq clisp
182- Add xmaxima Requires tk > 8.1
183- Remove xmaxima-olderTcl patch
184
185* Fri Jun  6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
186- Rebuild for clisp-2.29-0vl1
187
188* Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
189- Enable clisp only, disable cmucl and gcl
190- Add xmaxima-olderTcl patch (for tclversion older than 8.1)
191- Remove %{_infodir}/dir file
192
193* Sat Jan  4 2003 James Amundson <amundson@fnal.gov>
194- Added doc files
195- Added explicit clisp version
196- Added conditional to postun
197- Renamed exec_* packages to exec-*
198- Use rpm macros instead of hard-coded paths
199- Thanks to Rex Dieter for helpful suggestions
200
201* Sun Sep  8 2002 James Amundson <amundson@fnal.gov>
202- Initial build.
Note: See TracBrowser for help on using the repository browser.