source: projects/specs/trunk/m/maxima/maxima-vl.spec @ 9684

Revision 9684, 5.6 KB checked in by Takemikaduchi, 9 years ago (diff)

gnumeric, goffice, libgsf, maxima, gnupg: update
others: rebuild

Line 
1# -*- mode: rpm-spec -*-
2
3# By default, this spec file will generate RPMs for Clisp, CMUCL
4# and GCL. This can be changed by modifying the variables below.
5%define enable_clisp 1
6%define clisp_flags --enable-clisp
7%define enable_cmucl 0
8%define cmucl_flags --disable-cmucl
9%define enable_gcl 0
10%define gcl_flags --disable-gcl
11
12# Inhibit automatic compressing of info files. Compressed info
13# files break maxima's internal help.
14%define __spec_install_post /bin/true
15
16Summary: Maxima Symbolic Computation Program
17Summary(ja): 数式処理プログラム Maxima
18Name: maxima
19Version: 5.36.1
20Release: 1%{?_dist_release}
21License: GPL
22Group: Applications/Engineering
23URL: http://maxima.sourceforge.net
24Source0: %{name}-%{version}.tar.gz
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: texinfo
27Requires: maxima_exec = %{version}-%{release}
28Requires(post): /sbin/install-info
29Requires(preun): /sbin/install-info
30
31%description
32Maxima is a full symbolic computation program.  It is full featured
33doing symbolic manipulation of polynomials, matrices, rational
34functions, integration, Todd-coxeter, graphing, bigfloats.  It has a
35symbolic debugger source level debugger for maxima code.  Maxima is
36based on the original Macsyma developed at MIT in the 1970's.  It is
37quite reliable, and has good garbage collection, and no memory leaks.
38It comes with hundreds of self tests.
39
40%description -l ja
41Maxima は高機能な数式処理プログラムです。Maximaを使えば、多項式、行列、
42有理関数、積分、Todd-coxeter、グラフ描画、高精度浮動小数点といった演算
43も簡単にこなせます。Maxima のコードに対応したソースレベルの数式デバッ
44ガも備えています。Maxima は MIT で1970年台に開発されたオリジナルの
45Macsyma がベースとなっています。Maxima はとても信頼性が高く、すぐれた
46ガーベッジコレクションを搭載しており、メモリリークを起こしません。この
47信頼性は、数百件に及ぶセルフテストによってもたらされたものです。
48
49%package xmaxima
50Summary: Tcl/Tk interface to Maxima
51Summary(ja): Maxima 用 Tcl/Tk インターフェース
52Group: Applications/Engineering
53Requires: %{name} = %{version}-%{release}
54Requires: tk > 8.1
55Provides: xmaxima
56
57%description xmaxima
58Tcl/Tk interface to Maxima.
59
60%if %{enable_clisp}
61%package exec-clisp
62Summary: Maxima compiled with clisp
63Group: Applications/Engineering
64Requires: clisp
65BuildRequires: clisp
66Provides: maxima_exec
67%description exec-clisp
68Maxima compiled with clisp.
69%endif
70
71%if %{enable_cmucl}
72%package exec-cmucl
73Summary: Maxima compiled with CMUCL
74Group: Applications/Engineering
75Requires: cmucl
76BuildRequires: cmucl
77Provides: maxima_exec
78%description exec-cmucl
79Maxima compiled with CMUCL.
80%endif
81
82%if %{enable_gcl}
83%package exec-gcl
84Summary: Maxima compiled with GCL
85Group: Applications/Engineering
86Requires: gcl
87BuildRequires: gcl
88Provides: maxima_exec
89%description exec-gcl
90Maxima compiled with Gnu Common Lisp.
91%endif
92
93%prep
94%setup -q
95%configure  %{?cmucl_flags:} %{?gcl_flags:} %{?clisp_flags:}
96
97%build
98%__make
99
100%install
101%__rm -rf %{buildroot}
102%makeinstall
103
104rm -f $RPM_BUILD_ROOT%{_infodir}/dir
105
106%post
107/sbin/install-info %{_infodir}/maxima.info %{_infodir}/dir
108
109%preun
110if [ "$1" = 0 ]; then
111        /sbin/install-info --delete %{_infodir}/maxima.info %{_infodir}/dir
112fi
113
114%clean
115%__rm -rf %{buildroot}
116
117%files
118%defattr(-,root,root,-)
119%{_datadir}/maxima/%{version}
120%dir %{_libdir}/maxima/%{version}
121%{_libexecdir}/maxima/%{version}
122%{_infodir}/*
123%{_mandir}/man1/*
124%{_bindir}/*
125%doc AUTHORS COPYING ChangeLog INSTALL* NEWS README*
126
127%files xmaxima
128%{_bindir}/xmaxima
129
130%if %{enable_clisp}
131%files exec-clisp
132%{_libdir}/maxima/%{version}/binary-clisp
133%endif
134
135%if %{enable_cmucl}
136%files exec-cmucl
137%{_libdir}/maxima/%{version}/binary-cmucl
138%endif
139
140%if %{enable_gcl}
141%files exec-gcl
142%{_libdir}/maxima/%{version}/binary-gcl
143%endif
144
145%changelog
146* Fri Jul 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.36.1-1
147- update to 5.36.1
148- add BuildRequires: texinfo
149
150* Sat Mar 06 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-2
151- rebuilt with new toolchain, libsigsev-2.8 and clisp-2.48
152
153* Sun Oct 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.16.3-1vl5
154- new upstream release
155
156* Sat Oct 04 2008 Shu KONNO <owa@bg.wakwak.com> 5.11.0-1vl5
157- applied new versioning policy, spec in utf-8
158
159* Mon Mar 19 2007 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.11.0-0vl1
160- New upstream release
161- Change Group
162
163* Fri May 20 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl2
164- Japanese Summary and description by rpmSpecTranslate project
165
166* Sat Apr 23 2005 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.1-0vl1
167- New upstream release (for diff() bug fix)
168- Tidy up spec file
169
170* Sun Feb  1 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl4
171- Change Requires and BuildPreReq clisp (= 2.29 -> >= 2.29)
172
173* Sat Aug  2 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 5.9.0-0vl3
174- Add exec-clisp BuildPreReq clisp
175- Add xmaxima Requires tk > 8.1
176- Remove xmaxima-olderTcl patch
177
178* Fri Jun  6 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl2
179- Rebuild for clisp-2.29-0vl1
180
181* Fri May 30 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> 5.9.0-0vl1
182- Enable clisp only, disable cmucl and gcl
183- Add xmaxima-olderTcl patch (for tclversion older than 8.1)
184- Remove %{_infodir}/dir file
185
186* Sat Jan  4 2003 James Amundson <amundson@fnal.gov>
187- Added doc files
188- Added explicit clisp version
189- Added conditional to postun
190- Renamed exec_* packages to exec-*
191- Use rpm macros instead of hard-coded paths
192- Thanks to Rex Dieter for helpful suggestions
193
194* Sun Sep  8 2002 James Amundson <amundson@fnal.gov>
195- Initial build.
Note: See TracBrowser for help on using the repository browser.