source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 8068

Revision 8068, 6.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.6.1
4Release:        3%{?_dist_release}
5
6Source0:        http://pub.mate-desktop.org/releases/1.6/%{name}-%{version}.tar.xz
7Source1:        panel-default-layout.mate.vine
8
9# for Vine
10Patch2000:      mate-panel-1.6.1-about-vine.patch
11
12License:        GPLv2
13Group:          User Interface/Desktops
14URL:            http://mate-desktop.org/
15
16BuildRequires:  mate-common
17BuildRequires:  mate-doc-utils
18BuildRequires:  mate-desktop-devel
19BuildRequires:  mate-menus-devel
20BuildRequires:  libmateweather-devel
21BuildRequires:  gtk2-devel
22BuildRequires:  libSM-devel
23BuildRequires:  libcanberra-devel
24BuildRequires:  dbus-glib-devel
25BuildRequires:  libmatewnck-devel
26BuildRequires:  librsvg2-devel
27BuildRequires:  evolution-data-server-devel
28BuildRequires:  NetworkManager-devel
29BuildRequires:  dconf-devel
30BuildRequires:  gtk-doc
31BuildRequires:  autoconf
32BuildRequires:  automake
33
34Requires:               vine-menus
35Requires(posttrans,postun):     glib2
36Requires(post,postun):  gtk2
37Requires(post,postun):  desktop-file-utils
38
39BuildRoot:      %{_tmppath}/%{name}-%{version}-root
40
41Vendor:         Project Vine
42Distribution:   Vine Linux
43Packager:       Takemikaduchi
44
45
46%description
47mate-panel contains the MATE panel, the libmate-panel-applet library and
48several applets:
49
50  + the MATE panel is the area on your desktop from which you can run
51    applications and applets, and perform other tasks.
52
53  + the libmate-panel-applet library allows to develop small applications
54    which may be embedded in the panel. These are called applets.
55    Documentation for the API is available with gtk-doc.
56
57  + the applets supplied here include the Workspace Switcher, the Window
58    List, the Window Selector, the Notification Area, the Clock and the
59    infamous 'Wanda the Fish'.
60
61
62%package        devel
63Summary:        Development tools for mate-panel
64Summary(ja):    mate-panel の開発環境
65Group:          Development/Libraries
66Requires:       %{name} = %{version}-%{release}
67Requires:       pkgconfig
68
69%description    devel
70Header files and libraries for building a extension library for the
71mate-panel.
72
73
74%package        doc
75Summary:        Documentation for mate-panel
76Summary(ja):    mate-panel 用のドキュメント
77Group:          Documentation
78Requires:       %{name} = %{version}-%{release}
79BuildArch:      noarch
80
81%description    doc
82This package contains documentation for mate-panel.
83
84
85%prep
86%setup -q
87%patch2000 -p1 -b .vine
88
89cp -f %{SOURCE1} data/panel-default-layout.mate
90
91%build
92(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
93%configure \
94        --libexecdir=%{_libexecdir}/mate \
95        --disable-static \
96        --disable-scrollkeeper \
97        --enable-introspection \
98        --enable-matecomponent
99
100%{__make} %{?_smp_mflags}
101
102
103%install
104%{__rm} -rf ${RPM_BUILD_ROOT}
105
106%{__make} install DESTDIR=${RPM_BUILD_ROOT}
107
108find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
109find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
110
111%find_lang %{name}
112
113
114%clean
115%{__rm} -rf ${RPM_BUILD_ROOT}
116
117
118%post
119/sbin/ldconfig
120update-desktop-database %{_datadir}/applications >& /dev/null ||:
121touch --no-create %{_datadir}/icons/hicolor
122gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
123
124%postun
125/sbin/ldconfig
126if [ $1 -eq 0 ]; then
127  update-desktop-database %{_datadir}/applications >& /dev/null ||:
128  touch --no-create %{_datadir}/icons/hicolor
129  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
130  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
131fi
132
133%posttrans
134glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
135
136
137%files -f %{name}.lang
138%defattr(-,root,root,-)
139%doc COPYING ChangeLog NEWS README
140%{_bindir}/mate-desktop-item-edit
141%{_bindir}/mate-panel
142%{_bindir}/mate-panel-test-applets
143%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
144%{_libdir}/libmate-panel-applet-*.so.*
145%{_libexecdir}/mate/clock-applet
146%{_libexecdir}/mate/fish-applet
147%{_libexecdir}/mate/notification-area-applet
148%{_libexecdir}/mate/wnck-applet
149%{_datadir}//MateConf/gsettings/mate-panel.convert
150%{_datadir}/applications/mate-panel.desktop
151%{_datadir}/dbus-1/services/*.service
152%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
153%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
154%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
155%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
156%{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
157%{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
158%{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
159%{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
160%{_datadir}/icons/hicolor/*/*/*
161%{_datadir}/mate/help
162%{_datadir}/mate-panel
163%{_datadir}/omf/mate-applet-clock
164%{_datadir}/omf/mate-applet-fish
165%{_mandir}/man1/mate-panel.1.gz
166%{_mandir}/man1/mate-desktop-item-edit.1.gz
167%{_mandir}/man1/mate-panel-test-applets.1.gz
168
169%files devel
170%defattr(-,root,root,-)
171%{_includedir}/mate-panel-4.0/
172%{_libdir}/libmate-panel-applet-*.so
173%{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
174%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
175
176%files doc
177%defattr(-,root,root,-)
178%{_datadir}/gtk-doc/html/mate-panel-applet
179
180
181%changelog
182* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
183- rebuild with VineSeed environment
184
185* Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
186- change Source1 (panel-default-layout.mate.vine)
187- add Patch2000 (mate-panel-1.6.1-about-vine.patch)
188- add Requires: vine-menus
189
190* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
191- new upstream release
192
193* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
194- new upstream release
195- remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
196- add BuildRequires: dconf-devel
197
198* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
199- new upstream release
200- remove Patch0 (mate-panel-1.2.1-configure.patch)
201- change BuildRequires: libmatewnck-devel instead of libwnck-devel
202
203* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
204- new upstream release
205- add Patch0 (mate-panel-1.2.1-configure.patch)
206
207* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
208- change category
209
210* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
211- initial build for Vine Linux
212
Note: See TracBrowser for help on using the repository browser.