source: projects/specs/trunk/m/mate-panel/mate-panel-vl.spec @ 8359

Revision 8359, 6.2 KB checked in by Takemikaduchi, 10 years ago (diff)

MATE-1.8.0

Line 
1Summary:        The MATE Panel
2Name:           mate-panel
3Version:        1.8.0
4Release:        1%{?_dist_release}
5
6Source0:        http://pub.mate-desktop.org/releases/1.8/%{name}-%{version}.tar.xz
7Source1:        panel-default-layout.mate.vine
8
9# for Vine
10Patch2000:      mate-panel-1.6.1-about-vine.patch
11
12License:        GPLv2
13Group:          User Interface/Desktops
14URL:            http://mate-desktop.org/
15
16BuildRequires:  mate-common
17BuildRequires:  mate-doc-utils
18BuildRequires:  mate-desktop-devel
19BuildRequires:  mate-menus-devel
20BuildRequires:  libmateweather-devel
21BuildRequires:  gtk2-devel
22BuildRequires:  libSM-devel
23BuildRequires:  libcanberra-devel
24BuildRequires:  dbus-glib-devel
25BuildRequires:  libwnck-devel
26BuildRequires:  librsvg2-devel
27BuildRequires:  evolution-data-server-devel
28BuildRequires:  NetworkManager-devel
29BuildRequires:  dconf-devel
30BuildRequires:  gtk-doc
31BuildRequires:  itstool
32BuildRequires:  autoconf
33BuildRequires:  automake
34
35Requires:               vine-menus
36Requires(posttrans,postun):     glib2
37Requires(post,postun):  gtk2
38Requires(post,postun):  desktop-file-utils
39
40BuildRoot:      %{_tmppath}/%{name}-%{version}-root
41
42Vendor:         Project Vine
43Distribution:   Vine Linux
44Packager:       Takemikaduchi
45
46
47%description
48mate-panel contains the MATE panel, the libmate-panel-applet library and
49several applets:
50
51  + the MATE panel is the area on your desktop from which you can run
52    applications and applets, and perform other tasks.
53
54  + the libmate-panel-applet library allows to develop small applications
55    which may be embedded in the panel. These are called applets.
56    Documentation for the API is available with gtk-doc.
57
58  + the applets supplied here include the Workspace Switcher, the Window
59    List, the Window Selector, the Notification Area, the Clock and the
60    infamous 'Wanda the Fish'.
61
62
63%package        devel
64Summary:        Development tools for mate-panel
65Summary(ja):    mate-panel の開発環境
66Group:          Development/Libraries
67Requires:       %{name} = %{version}-%{release}
68Requires:       pkgconfig
69
70%description    devel
71Header files and libraries for building a extension library for the
72mate-panel.
73
74
75%package        doc
76Summary:        Documentation for mate-panel
77Summary(ja):    mate-panel 用のドキュメント
78Group:          Documentation
79Requires:       %{name} = %{version}-%{release}
80BuildArch:      noarch
81
82%description    doc
83This package contains documentation for mate-panel.
84
85
86%prep
87%setup -q
88%patch2000 -p1 -b .vine
89
90cp -f %{SOURCE1} data/panel-default-layout.mate
91
92%build
93(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
94%configure \
95        --libexecdir=%{_libexecdir}/mate \
96        --disable-static \
97        --disable-scrollkeeper \
98        --enable-introspection \
99        --enable-matecomponent
100
101%{__make} %{?_smp_mflags}
102
103
104%install
105%{__rm} -rf ${RPM_BUILD_ROOT}
106
107%{__make} install DESTDIR=${RPM_BUILD_ROOT}
108
109find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
110find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
111
112%find_lang %{name}
113
114
115%clean
116%{__rm} -rf ${RPM_BUILD_ROOT}
117
118
119%post
120/sbin/ldconfig
121update-desktop-database %{_datadir}/applications >& /dev/null ||:
122touch --no-create %{_datadir}/icons/hicolor
123gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
124
125%postun
126/sbin/ldconfig
127if [ $1 -eq 0 ]; then
128  update-desktop-database %{_datadir}/applications >& /dev/null ||:
129  touch --no-create %{_datadir}/icons/hicolor
130  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
131  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
132fi
133
134%posttrans
135glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
136
137
138%files -f %{name}.lang
139%defattr(-,root,root,-)
140%doc COPYING ChangeLog NEWS README
141%{_bindir}/mate-desktop-item-edit
142%{_bindir}/mate-panel
143%{_bindir}/mate-panel-test-applets
144%{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
145%{_libdir}/libmate-panel-applet-*.so.*
146%{_libexecdir}/mate/clock-applet
147%{_libexecdir}/mate/fish-applet
148%{_libexecdir}/mate/notification-area-applet
149%{_libexecdir}/mate/wnck-applet
150%{_datadir}//MateConf/gsettings/mate-panel.convert
151%{_datadir}/applications/mate-panel.desktop
152%{_datadir}/dbus-1/services/*.service
153%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.clock.gschema.xml
154%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.fish.gschema.xml
155%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.window-list.gschema.xml
156%{_datadir}/glib-2.0/schemas/org.mate.panel.applet.workspace-switcher.gschema.xml
157%{_datadir}/glib-2.0/schemas/org.mate.panel.enums.xml
158%{_datadir}/glib-2.0/schemas/org.mate.panel.gschema.xml
159%{_datadir}/glib-2.0/schemas/org.mate.panel.menubar.gschema.xml
160%{_datadir}/glib-2.0/schemas/org.mate.panel.object.gschema.xml
161%{_datadir}/glib-2.0/schemas/org.mate.panel.toplevel.gschema.xml
162%{_datadir}/icons/hicolor/*/*/*
163%{_datadir}/help
164%{_datadir}/mate-panel
165%{_mandir}/man1/mate-panel.1.gz
166%{_mandir}/man1/mate-desktop-item-edit.1.gz
167%{_mandir}/man1/mate-panel-test-applets.1.gz
168
169%files devel
170%defattr(-,root,root,-)
171%{_includedir}/mate-panel-4.0/
172%{_libdir}/libmate-panel-applet-*.so
173%{_libdir}/pkgconfig/libmatepanelapplet-4.0.pc
174%{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
175
176%files doc
177%defattr(-,root,root,-)
178%{_datadir}/gtk-doc/html/mate-panel-applet
179
180
181%changelog
182* Tue Apr 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
183- new upstream release
184- change BuildRequires: libwnck-devel instead of libmatewnck-devel
185- add BuildRequires: itstool
186
187* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-3
188- rebuild with VineSeed environment
189
190* Wed Sep 25 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-2
191- change Source1 (panel-default-layout.mate.vine)
192- add Patch2000 (mate-panel-1.6.1-about-vine.patch)
193- add Requires: vine-menus
194
195* Sun Sep 22 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
196- new upstream release
197
198* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
199- new upstream release
200- remove BuildRequires: mate-conf-devel, libmatecomponentui-devel
201- add BuildRequires: dconf-devel
202
203* Wed Aug 01 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
204- new upstream release
205- remove Patch0 (mate-panel-1.2.1-configure.patch)
206- change BuildRequires: libmatewnck-devel instead of libwnck-devel
207
208* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
209- new upstream release
210- add Patch0 (mate-panel-1.2.1-configure.patch)
211
212* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
213- change category
214
215* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
216- initial build for Vine Linux
217
Note: See TracBrowser for help on using the repository browser.