source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 9133

Revision 9133, 29.4 KB checked in by tomop, 9 years ago (diff)

mariadb-10.0.15-1

Line 
1%bcond_with source
2
3%define mysqld_user             mysql
4%define mysqld_group            mysql
5%define mysqldatadir /var/lib/mysql
6
7# Working around perl dependency problem
8%global __perl_requires %{SOURCE998}
9%global __perllib_requires %{SOURCE998}
10
11%define _unpackaged_files_terminate_build 1
12
13%define mariadb_base_version    10.0
14%define mariadb_version         10.0.15
15%define mroonga_version         4.06
16%define client_version          18
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager:       tomop
21
22Name: mariadb
23Summary:        MariaDB: a very fast and robust SQL database server
24Version:        %{mariadb_version}
25Release:        1%{_dist_release}
26
27Group:          Applications/Databases
28License:        GPL2
29URL:            http://www.mariadb.org/
30
31Source:         mariadb-%{version}.tar.gz
32# Don't depend on lib::mtr*
33Source998:      perl-requires.sh
34Source1000:     macros.mariadb.in
35Patch0:         mysql-5.5.15-jp-all.patch
36
37Patch100:       mysql-srv_buf_size.patch
38
39BuildRoot:              %{_tmppath}/%{name}-%{version}-root
40BuildRequires:  bison, cmake, gcc-c++, groff
41BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
42BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
43BuildRequires:  zlib-devel
44BuildRequires:  mecab-devel
45Requires:               fileutils sh-utils
46Provides:               msqlormysql MySQL mysql
47Obsoletes:              mysql MySQL5
48
49# From the manual
50%description
51MariaDB: a very fast and robust SQL database server
52
53It is GPL v2 licensed, which means you can use the it free of charge under the
54conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
55
56MariaDB documentation can be found at http://kb.askmonty.org/
57MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
58
59
60%package server
61Version:        %{mariadb_version}
62Release: %{release}
63Summary:        MariaDB: a very fast and robust SQL database server
64Group:          Applications/Databases
65Requires:       fileutils sh-utils net-tools mariadb-common
66Requires(post): mariadb-common
67Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
68Obsoletes:      MySQL mysql mysql-server
69Obsoletes:      MySQL-server < 5.6.0
70
71%description server
72MariaDB: a very fast and robust SQL database server
73
74It is GPL v2 licensed, which means you can use the it free of charge under the
75conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
76
77MariaDB documentation can be found at http://kb.askmonty.org/
78MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
79
80%package mroonga
81##Version: %{mroonga_version}
82Version:        %{mariadb_version}
83Summary:        A fast fulltext searchable storage engine for MariaDB.
84Group:          Applications/Databases
85Requires(pre):  mariadb-server = %{mariadb_version}-%{release}
86Requires:       mariadb-server = %{mariadb_version}-%{release}
87Obsoletes:      mariadb-mroonga-doc < 4.07
88
89%description mroonga
90Mroonga is a fast fulltext searchable storage plugin for MariaDB.
91It is based on groonga that is a fast fulltext search engine and
92column store. Groonga is good at real-time update.
93
94%package client
95Version:        %{mariadb_version}
96Summary: MariaDB - Client
97Group: Applications/Databases
98Obsoletes: mysql-client MySQL-client < 5.6.0
99Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
100
101%description client
102This package contains the standard MariaDB clients and administration tools.
103
104
105%package devel
106Version:        %{mariadb_version}
107Summary: MariaDB - Development libraries and headers
108Group: Development/Libraries
109Requires: %{name}-static, openssl-devel, zlib-devel
110Conflicts: MySQL-devel < 5.6.0
111Conflicts: libmysqlclient-devel
112
113%description devel
114This package contains the development libraries and headers to develop
115MariaDB server components (e.g. plugins or embedded applications).
116
117
118%package static
119Version:        %{mariadb_version}
120Summary: MariaDB - static libraries
121Group: Development/Libraries
122Requires: %{name}-devel
123
124%description static
125This package provides static libraries of MariaDB.
126
127%if %{with source}
128%package source
129Version:        %{mariadb_version}
130Summary: MariaDB - Source
131Group: Development/Libraries
132Requires: mariadb-devel = %{version}-%{release}
133Obsoletes: MySQL-source < 5.6.0
134AutoReqProv: no
135
136%description source
137This package contains the sources files of MariaDB.
138
139%endif
140
141%package test
142Version:        %{mariadb_version}
143Requires: %{name}-client = %{version}-%{release} perl-DBI perl
144Summary: MariaDB - Test suite
145Group: Applications/Databases
146Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
147Provides: perl(mtr_misc.pl)
148
149%description test
150This package contains the MariaDB regression test suite.
151
152
153%package embedded
154Version:        %{mariadb_version}
155Summary: MariaDB as an embeddable library
156Group: System Environment/Libraries
157Obsoletes: mysql-embedded MySQL-embedded
158Provides: mysql-embedded MySQL-embedded
159
160%description embedded
161This package contains a version of the MariaDB server that can be embedded
162into a client application instead of running as a separate process.
163
164
165%prep
166%setup -q
167#%patch0 -p1 -b .jp
168%patch100 -p1 -b .srv_buf_size
169
170%build
171
172# Be strict about variables, bail at earliest opportunity, etc.
173set -eu
174
175# Optional package files
176touch optional-files-devel
177
178export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
179export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
180
181# Build full release
182mkdir release
183(
184  cd release
185  cmake ../ \
186      -DINSTALL_LAYOUT=RPM \
187      -DBUILD_CONFIG=mysql_release \
188      -DCMAKE_BUILD_TYPE=Release \
189      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
190      -DMANUFACTURER="Vine Linux" \
191      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
192      -DWITH_PIC="ON" \
193      -DWITH_EMBEDDED_SERVER="ON" \
194      -DWITH_ZLIB="system" \
195      -DWITH_LIBEVENT="system" \
196      -DWITH_LOCALES="yes" \
197      -DWITH_UNIT_TESTS="no" \
198      -DWITH_CONNECT_STORAGE_ENGINE="ON" \
199      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
200      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
201      -DWITHOUT_TOKUDB=1 \
202      -DWITH_JEMALLOC="no" \
203      -DGRN_WITH_MECAB="yes"
204
205#      -DWITH_PCRE="system"
206
207  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
208  make %{?_smp_mflags} VERBOSE=1
209)
210
211
212%install
213rm -rf %{buildroot}
214
215install -d %{buildroot}%{mysqldatadir}/mysql
216install -d %{buildroot}%{_infodir}
217
218# Install all binaries
219(
220  cd release
221  make DESTDIR=%{buildroot} install
222)
223
224install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
225rm -rf ./doc
226mv -f %{buildroot}%{_docdir} ./
227
228%if %{with source}
229mkdir -p %{buildroot}%{_datadir}/%{name}-source
230pushd %{buildroot}%{_datadir}/%{name}-source
231tar zxf %{SOURCE0}
232find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
233popd
234%endif
235
236install -d %{buildroot}%{_sysconfdir}/rpm
237sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
238
239rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
240rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
241rm -f %{buildroot}%{_sysconfdir}/my.cnf
242rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
243rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
244rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
245
246# force linking statically.
247perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
248perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
249
250##############################################################################
251
252%pre server
253# Create a MySQL user and group. Do not report any problems if it already
254# exists.
255datadir=/var/lib/mysql
256
257groupadd -r mysql 2> /dev/null || true
258useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
259# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
260usermod -g mysql mysql 2> /dev/null || true
261
262%post server
263
264# Make MySQL start/shutdown automatically when the machine does it.
265if [ $1 = 1 ] ; then
266  if [ -x /sbin/chkconfig ] ; then
267          /sbin/chkconfig --add mysql
268  fi
269
270  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
271  if [ -z "$basedir" ] ; then
272    basedir=/usr
273  fi
274
275  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
276  if [ -z "$datadir" ] ; then
277    datadir=/var/lib/mysql
278  else
279    # datadir may be relative to a basedir!
280    if ! expr $datadir : / > /dev/null; then
281      datadir=$basedir/$datadir
282    fi
283  fi
284
285  # Change permissions so that the user that will run the MySQL daemon
286  # owns all database files.
287  chown -R mysql:mysql $datadir
288
289  if [ ! -e $datadir/mysql ]; then
290    # Create data directory
291    mkdir -p $datadir/{mysql,test}
292
293    # Initiate databases
294    /usr/bin/mysql_install_db --rpm --user=mysql
295  fi
296
297  # Change permissions again to fix any new files.
298  chown -R mysql:mysql $datadir
299
300  # Fix permissions for the permission database so that only the user
301  # can read them.
302  chmod -R og-rw $datadir/mysql
303fi
304
305%preun server
306if [ $1 = 0 ] ; then
307        # Stop MySQL before uninstalling it
308        if [ -x /etc/init.d/mysql ] ; then
309                /etc/init.d/mysql stop > /dev/null
310        fi
311        # Don't start it automatically anymore
312        if [ -x /sbin/chkconfig ] ; then
313                /sbin/chkconfig --del mysql
314        fi
315fi
316
317%postun server
318if [ $1 -ge 1 ]; then
319  if [ -x /etc/init.d/mysql ] ; then
320    # only restart the server if it was alredy running
321    /etc/init.d/mysql status > /dev/null 2>&1 && \
322    /etc/init.d/mysql restart
323  fi
324fi
325
326%pre mroonga
327if [ $1 -gt 1 ]; then
328/usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql || cat <<EOF
329An error occured when to register plugin.
330Please run a command below:
331
332  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/uninstall.sql
333
334EOF
335
336fi
337
338%post mroonga
339if [ $1 -eq 1 ] ; then
340        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
341An error occured when to register plugin.
342Please run a command below:
343
344  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
345
346EOF
347fi
348
349%postun mroonga
350if [ $1 -gt 0 ] ; then
351        /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql || cat <<EOF
352An error occured when to register plugin.
353Please run a command below:
354
355  /usr/bin/mysql -u root < %{_datadir}/mysql/mroonga/install.sql
356
357EOF
358fi
359
360# Clean up the BuildRoot
361%clean
362[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
363
364%files server
365%defattr(-,root,root)
366
367%doc doc/*
368%doc release/support-files/my-*.cnf
369%doc %{_infodir}/mysql.info*
370
371%doc %{_mandir}/man1/aria_*.1*
372%doc %{_mandir}/man1/innochecksum.1*
373%doc %{_mandir}/man1/my_print_defaults.1*
374%doc %{_mandir}/man1/myisam_ftdump.1*
375%doc %{_mandir}/man1/myisamchk.1*
376%doc %{_mandir}/man1/myisamlog.1*
377%doc %{_mandir}/man1/myisampack.1*
378%doc %{_mandir}/man1/mysql_convert_table_format.1*
379%doc %{_mandir}/man1/mysql_fix_extensions.1*
380%doc %{_mandir}/man8/mysqld.8*
381%doc %{_mandir}/man1/mysqld_multi.1*
382%doc %{_mandir}/man1/mysqld_safe.1*
383%doc %{_mandir}/man1/mysqldumpslow.1*
384%doc %{_mandir}/man1/mysql_install_db.1*
385%doc %{_mandir}/man1/mysql_plugin.1*
386%doc %{_mandir}/man1/mysql_secure_installation.1*
387%doc %{_mandir}/man1/mysql_setpermission.1*
388%doc %{_mandir}/man1/mysql_upgrade.1*
389%doc %{_mandir}/man1/mysqlhotcopy.1*
390%doc %{_mandir}/man1/mysql.server.1*
391%doc %{_mandir}/man1/mysqltest.1*
392%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
393%doc %{_mandir}/man1/mysql_zap.1*
394%doc %{_mandir}/man1/mysqlbug.1*
395%doc %{_mandir}/man1/perror.1*
396%doc %{_mandir}/man1/replace.1*
397%doc %{_mandir}/man1/resolve_stack_dump.1*
398%doc %{_mandir}/man1/resolveip.1*
399%{_bindir}/aria_*
400%{_bindir}/innochecksum
401%{_bindir}/my_print_defaults
402%{_bindir}/myisam_ftdump
403%{_bindir}/myisamchk
404%{_bindir}/myisamlog
405%{_bindir}/myisampack
406%{_bindir}/mysql_convert_table_format
407%{_bindir}/mysql_fix_extensions
408%{_bindir}/mysql_install_db
409%{_bindir}/mysql_plugin
410%{_bindir}/mysql_secure_installation
411%{_bindir}/mysql_setpermission
412%{_bindir}/mysql_tzinfo_to_sql
413%{_bindir}/mysql_upgrade
414%{_bindir}/mysql_zap
415%{_bindir}/mysqlbug
416%{_bindir}/mysqld_multi
417%{_bindir}/mysqld_safe
418%{_bindir}/mysqldumpslow
419%{_bindir}/mysqlhotcopy
420%{_bindir}/mysqltest
421%{_bindir}/perror
422%{_bindir}/replace
423%{_bindir}/resolve_stack_dump
424%{_bindir}/resolveip
425#%{_bindir}/tokuftdump
426%{_sbindir}/mysqld
427%exclude %{_libdir}/mysql/plugin/ha_mroonga.so
428%exclude %{_datadir}/mysql/mroonga
429%{_libdir}/mysql
430%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
431#%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
432%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
433%{_sysconfdir}/init.d/mysql
434%{_datadir}/mysql
435%attr(755, mysql, mysql) %dir %{mysqldatadir}
436
437%files mroonga
438%defattr(-, root, root)
439%{_libdir}/mysql/plugin/ha_mroonga.so
440%{_datadir}/mysql/mroonga
441
442%files client
443%defattr(-, root, root)
444%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
445%{_bindir}/msql2mysql
446%{_bindir}/mysql
447%{_bindir}/mysql_find_rows
448%{_bindir}/mysql_waitpid
449%{_bindir}/mysqlaccess
450%{_bindir}/mysqladmin
451%{_bindir}/mysqlbinlog
452%{_bindir}/mysqlcheck
453%{_bindir}/mysqldump
454%{_bindir}/mysqlimport
455%{_bindir}/mysqlshow
456%{_bindir}/mysqlslap
457%{_bindir}/mytop
458
459%doc %{_mandir}/man1/msql2mysql.1*
460%doc %{_mandir}/man1/mysql.1*
461%doc %{_mandir}/man1/mysql_find_rows.1*
462%doc %{_mandir}/man1/mysql_waitpid.1*
463%doc %{_mandir}/man1/mysqlaccess.1*
464%doc %{_mandir}/man1/mysqladmin.1*
465%doc %{_mandir}/man1/mysqlbinlog.1*
466%doc %{_mandir}/man1/mysqlcheck.1*
467%doc %{_mandir}/man1/mysqldump.1*
468%doc %{_mandir}/man1/mysqlimport.1*
469%doc %{_mandir}/man1/mysqlshow.1*
470%doc %{_mandir}/man1/mysqlslap.1*
471
472%files devel -f optional-files-devel
473%defattr(-, root, root)
474%doc %{_mandir}/man1/mysql_config.1*
475%{_bindir}/mysql_config
476%{_includedir}/mysql
477%{_datadir}/aclocal/mysql.m4
478%{_libdir}/*.so
479%{_sysconfdir}/rpm/*
480%{_bindir}/mysql_embedded
481
482%files static
483%defattr(-,root,root)
484%{_libdir}/lib*.a
485
486%if %{with source}
487%files source
488%defattr(-, root, root)
489%{_datadir}/mariadb-source
490%endif
491
492%files test
493%defattr(-, root, root)
494%attr(-, root, root) %{_datadir}/mysql-test
495%{_bindir}/mysql_client_test
496%{_bindir}/mysql_client_test_embedded
497%{_bindir}/mysqltest_embedded
498%doc %{_mandir}/man1/mysql_client_test.1*
499%doc %{_mandir}/man1/mysql-stress-test.pl.1*
500%doc %{_mandir}/man1/mysql-test-run.pl.1*
501%doc %{_mandir}/man1/mysql_client_test_embedded.1*
502%doc %{_mandir}/man1/mysqltest_embedded.1*
503
504%files embedded
505%defattr(-,root,root)
506%{_libdir}/libmysqld.so.*
507
508
509%changelog
510* Wed Nov 26 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.15-1
511- new upstream release.
512- enabled bundled Mroonga.
513
514* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
515- new upstream release.
516
517* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
518- new upstream release.
519
520* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
521- fixed Conflicts: and Obsoletes:.
522
523* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
524- new upstream release.
525
526* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
527- new upstream release.
528
529* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
530- new upstream release.
531
532* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
533- removed duplicated files.
534
535* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
536- switched to MariaDB.
537
538* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
539- new upstream release.
540
541* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
542- new upstream release.
543
544* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
545- new upstream release.
546- added a sub-package 'MySQL-source".
547- added some macros for rpm.
548
549* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
550- new upstream release.
551
552* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
553- new upstream release.
554
555* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
556- new upstream release.
557- added "Vendor:" and "Distribution:" tag.
558
559* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
560- new upstream release.
561- removed NDB cluster support.
562
563* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
564- Added "BR: zlib-devel" to MySQL-devel.
565
566* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
567- Added "BR: openssl-devel" to MySQL-devel.
568
569* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
570- new upstream release.
571
572* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
573- new upstream release.
574- updated jp-patch.
575- added ssl support.
576
577* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
578- new upstream release.
579- replaced '%%__find_requires' to '%%__perl_requires'.
580- updated jp-patch.
581
582* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
583- added mysql-5.1.44-lib64.patch (on x86_64)
584- added -fPIC (on x86_64)
585
586* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
587- made embedded package again
588
589* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
590- new upstream release.
591- updated jp-patch.
592
593* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
594- VineSeed: rebuilt with new toolchain.
595
596* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
597- new upstream release.
598  - fixed CVE-2009-4484.
599
600* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
601- new upstream release.
602
603* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
604- added net-tools to 'Requires'.
605- added groff to 'BuildRequires'.
606- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
607
608* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
609- new upstream release.
610
611* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
612- new upstream release.
613
614* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
615- new upstream release.
616- dropped %%Patch100 (fixed in upstream).
617
618* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
619- new upstream release.
620- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
621
622* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
623- new upstream release.
624- rename 'MySQL-bench' to 'MySQL-test'.
625- update Patch0.
626- change default charset to 'utf8'.
627
628* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
629- new upstream release.
630- update Patch0.
631- add "--with-client-charset=ujis".
632- sync %%files to official RPM.
633- remove MySQL-Max.
634
635* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
636- for VineSeed
637
638* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
639- move shared library from /usr/lib/ to /usr/lib/mysql/
640- add /etc/ld.so.conf.d/*.conf
641- fix broken libmysqlcient*.la files (or should we remove them permanently?)
642
643* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
644- rebuild <BTS:VineLinux:534>
645
646* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
647- added -fPIC
648
649* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
650- fixed dependency. <BTS:338>
651
652* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
653- add %%Patch1. <BTS:320>
654
655* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
656- new upstream release.
657
658* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
659- new upstream release.
660
661* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
662- new upstream release.
663
664* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
665- release++.
666
667* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
668- new upstream release.
669- for VineSeed.
670
671* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
672- new upstream release.
673- replace Patch0 for MySQL-4.1.16.
674
675* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
676- new upstream release.
677- add Patch0.
678
679* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
680- new upstream version
681        -- mysql-4.0.25
682
683* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
684- new upstream version
685        -- mysql-4.0.23
686
687* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
688- new upstream version
689        -- mysql-4.0.22
690 
691* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
692- new upstream version
693        -- mysql-4.0.21
694 
695* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
696- new upstream version
697        -- mysql-4.0.20
698 
699* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
700- modify CFLAGS, CXXFLAGS and configure options for alpha
701
702* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
703- Upgraded to MySQL-4
704- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
705- merged to MySQL Official packages
706        -- renamed package "MySQL" to "MySQL-server"
707        -- when using gcc, _always_ use CXX=gcc
708        -- replaced Copyright with License field (Copyright is obsolete)
709        -- added myisam_ftdump to the Server package
710        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
711        -- fixed file permissions (BUG 1672)
712        -- removed dependency on MySQL-client from the MySQL-devel subpackage
713        -- as it is not really required. (BUG 1610)
714        -- Fixed BUG 1162 (removed macro names from the changelog)
715        -- Really fixed BUG 998 (disable the checking for installed but
716        --  unpackaged files)
717        -- Fixed BUG 959 (libmysqld not being compiled properly)
718        -- Fixed BUG 998 (RPM build errors): added missing files to the
719        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
720        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
721        -- removed the GIF Icon (file was not included in the sources anyway)
722        -- removed unused variable shared_lib_version
723        -- do not run automake before building the standard binary
724        --  (should not be necessary)
725        -- add server suffix '-standard' to standard binary (to be in line
726        -- with the binary tarball distributions)
727        -- allow overriding CC and CXX (required when building
728        -- with other compilers)
729
730* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
731- added BuildRequires:  automake16
732                                                                               
733* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
734- add '-fPIC -DPIC' to CFLAGS on alpha
735- little fix of spec file
736                                                                               
737* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
738- enable MySQL-shared subpackage for alpha
739- delete 'BuildPrereq: kernel24-headers' for alpha
740- fix shared %files (exclude sparc)
741                                                                               
742* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
743- new upstream version
744                                                                               
745* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
746- fixed devel %files (dropped *.la files)
747                                                                               
748* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
749- new upstream version
750- fixed document permission
751                                                                               
752* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
753- new upstream version
754                                                                               
755* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
756- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
757        -- don't work
758                                                                               
759* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
760- new upstream version
761- diseble-assembler in configure on sparc,sparc64,alpha
762                                                                               
763* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
764- new upstream version
765- moved some man files to main package
766- added enable-local-infile in configure
767- changed --with-extra-charsets=all in configure
768                                                                               
769* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
770- fixed changelog
771                                                                               
772* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
773- updated to mysql-3.23.51
774                                                                               
775* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
776- rebuild on zlib-1.1.4(security fix.)
777                                                                               
778* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
779- updated to mysql-2.23.49
780                                                                               
781* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
782- add 'BuildPrereq: kernel24-headers' on alpha
783- remove shared library and max on alpha
784                                                                               
785* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
786- updated to mysql-3.23.48
787                                                                               
788* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
789- updated to mysql-3.23.47
790                                                                               
791* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
792- updated to mysql-3.23.46
793                                                                               
794* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
795- updated to mysql-3.23.45
796                                                                               
797* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
798- updated to mysql-3.23.44
799                                                                               
800* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
801- updated to mysql-3.23.43
802- removed shared library and max on sparc
803                                                                               
804* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
805- updated to mysql-3.23.42
806- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
807                                                                               
808* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
809- updated to mysql-3.23.41
810                                                                               
811* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
812- updated to mysql-3.23.40
813                                                                               
814* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
815- updated to mysql-3.23.39
816
817* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
818- added configure --with-charset=ujis
819                                                                               
820* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
821- used some rpmmacro
822                                                                               
823* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
824- updated to MySQL-3.23.38
825                                                                               
826* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
827- removed Bench pakages
828                                                                               
829* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
830- removed pt_BR locale
831- build on Vine Linux
832- partially used rpmmacros
833- added %clean tag
834                                                                               
835* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
836- Added separate libmysql_r directory; now both a threaded
837  and non-threaded library is shipped.
838                                                                               
839* Tue Sep 28 1999 David Axmark <davida@mysql.com>
840- Added the support-files/my-example.cnf to the docs directory.
841- Removed devel dependency on base since it is about client
842  development.
843                                                                               
844* Wed Sep 8 1999 David Axmark <davida@mysql.com>
845- Cleaned up some for 3.23.
846                                                                               
847* Thu Jul 1 1999 David Axmark <davida@mysql.com>
848- Added support for shared libraries in a separate sub
849  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
850- The --enable-assembler switch is now automatically disables on
851  platforms there assembler code is unavailable. This should allow
852  building this RPM on non i386 systems.
853                                                                               
854* Mon Feb 22 1999 David Axmark <david@detron.se>
855- Removed unportable cc switches from the spec file. The defaults can
856  now be overridden with environment variables. This feature is used
857  to compile the official RPM with optimal (but compiler version
858  specific) switches.
859- Removed the repetitive description parts for the sub rpms. Maybe add
860  again if RPM gets a multiline macro capability.
861- Added support for a pt_BR translation. Translation contributed by
862  Jorge Godoy <jorge@bestway.com.br>.
863                                                                               
864* Wed Nov 4 1998 David Axmark <david@detron.se>
865- A lot of changes in all the rpm and install scripts. This may even
866  be a working RPM :-)
867                                                                               
868* Sun Aug 16 1998 David Axmark <david@detron.se>
869- A developers changelog for MySQL is available in the source RPM. And
870  there is a history of major user visible changed in the Reference
871  Manual.  Only RPM specific changes will be documented here.
872
Note: See TracBrowser for help on using the repository browser.