source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 8991

Revision 8991, 27.4 KB checked in by tomop, 10 years ago (diff)

mariadb-10.0.14-1

Line 
1%define mysqld_user             mysql
2%define mysqld_group            mysql
3%define mysqldatadir /var/lib/mysql
4
5# Working around perl dependency problem
6%global __perl_requires %{SOURCE998}
7%global __perllib_requires %{SOURCE998}
8
9%define _unpackaged_files_terminate_build 1
10
11%define mariadb_base_version    10.0
12%define mariadb_version         10.0.14
13%define client_version          18
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager:       tomop
18
19Name: mariadb
20Summary:        MariaDB: a very fast and robust SQL database server
21Version:        %{mariadb_version}
22Release:        1%{_dist_release}
23
24Group:          Applications/Databases
25License:        GPL2
26URL:            http://www.mariadb.org/
27
28Source:         mariadb-%{version}.tar.gz
29# Don't depend on lib::mtr*
30Source998:      perl-requires.sh
31Source1000:     macros.mariadb.in
32Patch0:         mysql-5.5.15-jp-all.patch
33
34Patch100:       mysql-srv_buf_size.patch
35
36BuildRoot:              %{_tmppath}/%{name}-%{version}-root
37BuildRequires:  bison, cmake, gcc-c++, groff
38BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
39BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
40BuildRequires:  zlib-devel
41Requires:               fileutils sh-utils
42Provides:               msqlormysql MySQL mysql
43Obsoletes:              mysql MySQL5
44
45# From the manual
46%description
47MariaDB: a very fast and robust SQL database server
48
49It is GPL v2 licensed, which means you can use the it free of charge under the
50conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
51
52MariaDB documentation can be found at http://kb.askmonty.org/
53MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
54
55
56%package server
57Release: %{release}
58Summary:        MariaDB: a very fast and robust SQL database server
59Group:          Applications/Databases
60Requires:       fileutils sh-utils net-tools mariadb-common
61Requires(post): mariadb-common
62Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
63Obsoletes:      MySQL mysql mysql-server
64Obsoletes:      MySQL-server < 5.6.0
65
66%description server
67MariaDB: a very fast and robust SQL database server
68
69It is GPL v2 licensed, which means you can use the it free of charge under the
70conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
71
72MariaDB documentation can be found at http://kb.askmonty.org/
73MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
74
75
76%package client
77Summary: MariaDB - Client
78Group: Applications/Databases
79Obsoletes: mysql-client MySQL-client < 5.6.0
80Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
81
82%description client
83This package contains the standard MariaDB clients and administration tools.
84
85
86%package devel
87Summary: MariaDB - Development libraries and headers
88Group: Development/Libraries
89Requires: %{name}-static, openssl-devel, zlib-devel
90Conflicts: MySQL-devel < 5.6.0
91Conflicts: libmysqlclient-devel
92
93%description devel
94This package contains the development libraries and headers to develop
95MariaDB server components (e.g. plugins or embedded applications).
96
97
98%package static
99Summary: MariaDB - static libraries
100Group: Development/Libraries
101Requires: %{name}-devel
102
103%description static
104This package provides static libraries of MariaDB.
105
106
107%package source
108Summary: MariaDB - Source
109Group: Development/Libraries
110Requires: mariadb-devel = %{version}-%{release}
111Obsoletes: MySQL-source < 5.6.0
112AutoReqProv: no
113
114%description source
115This package contains the sources files of MariaDB.
116
117
118%package test
119Requires: %{name}-client = %{version}-%{release} perl-DBI perl
120Summary: MariaDB - Test suite
121Group: Applications/Databases
122Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
123Provides: perl(mtr_misc.pl)
124
125%description test
126This package contains the MariaDB regression test suite.
127
128
129%package embedded
130Summary: MariaDB as an embeddable library
131Group: System Environment/Libraries
132Obsoletes: mysql-embedded MySQL-embedded
133Provides: mysql-embedded MySQL-embedded
134
135%description embedded
136This package contains a version of the MariaDB server that can be embedded
137into a client application instead of running as a separate process.
138
139
140%prep
141%setup -q
142#%patch0 -p1 -b .jp
143%patch100 -p1 -b .srv_buf_size
144
145%build
146
147# Be strict about variables, bail at earliest opportunity, etc.
148set -eu
149
150# Optional package files
151touch optional-files-devel
152
153export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
154export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
155
156# Build full release
157mkdir release
158(
159  cd release
160  cmake ../ \
161      -DINSTALL_LAYOUT=RPM \
162      -DBUILD_CONFIG=mysql_release \
163      -DCMAKE_BUILD_TYPE=Release \
164      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
165      -DMANUFACTURER="Vine Linux" \
166      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
167      -DWITH_PIC="ON" \
168      -DWITH_EMBEDDED_SERVER="ON" \
169      -DWITH_ZLIB="system" \
170      -DWITH_LIBEVENT="system" \
171      -DWITH_LOCALES="yes" \
172      -DWITH_UNIT_TESTS="no" \
173      -DWITH_CONNECT_STORAGE_ENGINE="ON" \
174      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
175      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
176      -DWITHOUT_TOKUDB=1 \
177          -DWITH_JEMALLOC="no"
178
179#      -DWITH_PCRE="system"
180
181  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
182  make %{?_smp_mflags} VERBOSE=1
183)
184
185
186%install
187rm -rf %{buildroot}
188
189install -d %{buildroot}%{mysqldatadir}/mysql
190install -d %{buildroot}%{_infodir}
191
192# Install all binaries
193(
194  cd release
195  make DESTDIR=%{buildroot} install
196)
197
198install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
199rm -rf ./doc
200mv -f %{buildroot}%{_docdir} ./
201
202mkdir -p %{buildroot}%{_datadir}/%{name}-source
203pushd %{buildroot}%{_datadir}/%{name}-source
204tar zxf %{SOURCE0}
205find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
206popd
207
208install -d %{buildroot}%{_sysconfdir}/rpm
209sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
210
211rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
212rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
213rm -f %{buildroot}%{_sysconfdir}/my.cnf
214rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
215rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
216rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
217
218# force linking statically.
219perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
220perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
221
222##############################################################################
223
224%pre server
225# Create a MySQL user and group. Do not report any problems if it already
226# exists.
227datadir=/var/lib/mysql
228
229groupadd -r mysql 2> /dev/null || true
230useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
231# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
232usermod -g mysql mysql 2> /dev/null || true
233
234%post server
235
236# Make MySQL start/shutdown automatically when the machine does it.
237if [ $1 = 1 ] ; then
238  if [ -x /sbin/chkconfig ] ; then
239          /sbin/chkconfig --add mysql
240  fi
241
242  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
243  if [ -z "$basedir" ] ; then
244    basedir=/usr
245  fi
246
247  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
248  if [ -z "$datadir" ] ; then
249    datadir=/var/lib/mysql
250  else
251    # datadir may be relative to a basedir!
252    if ! expr $datadir : / > /dev/null; then
253      datadir=$basedir/$datadir
254    fi
255  fi
256
257  # Change permissions so that the user that will run the MySQL daemon
258  # owns all database files.
259  chown -R mysql:mysql $datadir
260
261  if [ ! -e $datadir/mysql ]; then
262    # Create data directory
263    mkdir -p $datadir/{mysql,test}
264
265    # Initiate databases
266    /usr/bin/mysql_install_db --rpm --user=mysql
267  fi
268
269  # Change permissions again to fix any new files.
270  chown -R mysql:mysql $datadir
271
272  # Fix permissions for the permission database so that only the user
273  # can read them.
274  chmod -R og-rw $datadir/mysql
275fi
276
277%preun server
278if [ $1 = 0 ] ; then
279        # Stop MySQL before uninstalling it
280        if [ -x /etc/init.d/mysql ] ; then
281                /etc/init.d/mysql stop > /dev/null
282        fi
283        # Don't start it automatically anymore
284        if [ -x /sbin/chkconfig ] ; then
285                /sbin/chkconfig --del mysql
286        fi
287fi
288
289%postun server
290if [ $1 -ge 1 ]; then
291  if [ -x /etc/init.d/mysql ] ; then
292    # only restart the server if it was alredy running
293    /etc/init.d/mysql status > /dev/null 2>&1 && \
294    /etc/init.d/mysql restart
295  fi
296fi
297
298# Clean up the BuildRoot
299%clean
300[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
301
302%files server
303%defattr(-,root,root)
304
305%doc doc/*
306%doc release/support-files/my-*.cnf
307%doc %{_infodir}/mysql.info*
308
309%doc %{_mandir}/man1/aria_*.1*
310%doc %{_mandir}/man1/innochecksum.1*
311%doc %{_mandir}/man1/my_print_defaults.1*
312%doc %{_mandir}/man1/myisam_ftdump.1*
313%doc %{_mandir}/man1/myisamchk.1*
314%doc %{_mandir}/man1/myisamlog.1*
315%doc %{_mandir}/man1/myisampack.1*
316%doc %{_mandir}/man1/mysql_convert_table_format.1*
317%doc %{_mandir}/man1/mysql_fix_extensions.1*
318%doc %{_mandir}/man8/mysqld.8*
319%doc %{_mandir}/man1/mysqld_multi.1*
320%doc %{_mandir}/man1/mysqld_safe.1*
321%doc %{_mandir}/man1/mysqldumpslow.1*
322%doc %{_mandir}/man1/mysql_install_db.1*
323%doc %{_mandir}/man1/mysql_plugin.1*
324%doc %{_mandir}/man1/mysql_secure_installation.1*
325%doc %{_mandir}/man1/mysql_setpermission.1*
326%doc %{_mandir}/man1/mysql_upgrade.1*
327%doc %{_mandir}/man1/mysqlhotcopy.1*
328%doc %{_mandir}/man1/mysql.server.1*
329%doc %{_mandir}/man1/mysqltest.1*
330%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
331%doc %{_mandir}/man1/mysql_zap.1*
332%doc %{_mandir}/man1/mysqlbug.1*
333%doc %{_mandir}/man1/perror.1*
334%doc %{_mandir}/man1/replace.1*
335%doc %{_mandir}/man1/resolve_stack_dump.1*
336%doc %{_mandir}/man1/resolveip.1*
337%{_bindir}/aria_*
338%{_bindir}/innochecksum
339%{_bindir}/my_print_defaults
340%{_bindir}/myisam_ftdump
341%{_bindir}/myisamchk
342%{_bindir}/myisamlog
343%{_bindir}/myisampack
344%{_bindir}/mysql_convert_table_format
345%{_bindir}/mysql_fix_extensions
346%{_bindir}/mysql_install_db
347%{_bindir}/mysql_plugin
348%{_bindir}/mysql_secure_installation
349%{_bindir}/mysql_setpermission
350%{_bindir}/mysql_tzinfo_to_sql
351%{_bindir}/mysql_upgrade
352%{_bindir}/mysql_zap
353%{_bindir}/mysqlbug
354%{_bindir}/mysqld_multi
355%{_bindir}/mysqld_safe
356%{_bindir}/mysqldumpslow
357%{_bindir}/mysqlhotcopy
358%{_bindir}/mysqltest
359%{_bindir}/perror
360%{_bindir}/replace
361%{_bindir}/resolve_stack_dump
362%{_bindir}/resolveip
363#%{_bindir}/tokuftdump
364%{_sbindir}/mysqld
365%{_libdir}/mysql
366%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
367#%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
368%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
369%{_sysconfdir}/init.d/mysql
370%{_datadir}/mysql
371%attr(755, mysql, mysql) %dir %{mysqldatadir}
372
373%files client
374%defattr(-, root, root)
375%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
376%{_bindir}/msql2mysql
377%{_bindir}/mysql
378%{_bindir}/mysql_find_rows
379%{_bindir}/mysql_waitpid
380%{_bindir}/mysqlaccess
381%{_bindir}/mysqladmin
382%{_bindir}/mysqlbinlog
383%{_bindir}/mysqlcheck
384%{_bindir}/mysqldump
385%{_bindir}/mysqlimport
386%{_bindir}/mysqlshow
387%{_bindir}/mysqlslap
388%{_bindir}/mytop
389
390%doc %{_mandir}/man1/msql2mysql.1*
391%doc %{_mandir}/man1/mysql.1*
392%doc %{_mandir}/man1/mysql_find_rows.1*
393%doc %{_mandir}/man1/mysql_waitpid.1*
394%doc %{_mandir}/man1/mysqlaccess.1*
395%doc %{_mandir}/man1/mysqladmin.1*
396%doc %{_mandir}/man1/mysqlbinlog.1*
397%doc %{_mandir}/man1/mysqlcheck.1*
398%doc %{_mandir}/man1/mysqldump.1*
399%doc %{_mandir}/man1/mysqlimport.1*
400%doc %{_mandir}/man1/mysqlshow.1*
401%doc %{_mandir}/man1/mysqlslap.1*
402
403%files devel -f optional-files-devel
404%defattr(-, root, root)
405%doc %{_mandir}/man1/mysql_config.1*
406%{_bindir}/mysql_config
407%{_includedir}/mysql
408%{_datadir}/aclocal/mysql.m4
409%{_libdir}/*.so
410%{_sysconfdir}/rpm/*
411%{_bindir}/mysql_embedded
412
413%files static
414%defattr(-,root,root)
415%{_libdir}/lib*.a
416
417%files source
418%defattr(-, root, root)
419%{_datadir}/mariadb-source
420
421%files test
422%defattr(-, root, root)
423%attr(-, root, root) %{_datadir}/mysql-test
424%{_bindir}/mysql_client_test
425%{_bindir}/mysql_client_test_embedded
426%{_bindir}/mysqltest_embedded
427%doc %{_mandir}/man1/mysql_client_test.1*
428%doc %{_mandir}/man1/mysql-stress-test.pl.1*
429%doc %{_mandir}/man1/mysql-test-run.pl.1*
430%doc %{_mandir}/man1/mysql_client_test_embedded.1*
431%doc %{_mandir}/man1/mysqltest_embedded.1*
432
433%files embedded
434%defattr(-,root,root)
435%{_libdir}/libmysqld.so.*
436
437
438%changelog
439* Mon Sep 29 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.14-1
440- new upstream release.
441
442* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
443- new upstream release.
444
445* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
446- fixed Conflicts: and Obsoletes:.
447
448* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
449- new upstream release.
450
451* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
452- new upstream release.
453
454* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
455- new upstream release.
456
457* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
458- removed duplicated files.
459
460* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
461- switched to MariaDB.
462
463* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
464- new upstream release.
465
466* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
467- new upstream release.
468
469* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
470- new upstream release.
471- added a sub-package 'MySQL-source".
472- added some macros for rpm.
473
474* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
475- new upstream release.
476
477* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
478- new upstream release.
479
480* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
481- new upstream release.
482- added "Vendor:" and "Distribution:" tag.
483
484* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
485- new upstream release.
486- removed NDB cluster support.
487
488* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
489- Added "BR: zlib-devel" to MySQL-devel.
490
491* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
492- Added "BR: openssl-devel" to MySQL-devel.
493
494* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
495- new upstream release.
496
497* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
498- new upstream release.
499- updated jp-patch.
500- added ssl support.
501
502* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
503- new upstream release.
504- replaced '%%__find_requires' to '%%__perl_requires'.
505- updated jp-patch.
506
507* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
508- added mysql-5.1.44-lib64.patch (on x86_64)
509- added -fPIC (on x86_64)
510
511* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
512- made embedded package again
513
514* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
515- new upstream release.
516- updated jp-patch.
517
518* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
519- VineSeed: rebuilt with new toolchain.
520
521* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
522- new upstream release.
523  - fixed CVE-2009-4484.
524
525* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
526- new upstream release.
527
528* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
529- added net-tools to 'Requires'.
530- added groff to 'BuildRequires'.
531- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
532
533* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
534- new upstream release.
535
536* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
537- new upstream release.
538
539* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
540- new upstream release.
541- dropped %%Patch100 (fixed in upstream).
542
543* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
544- new upstream release.
545- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
546
547* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
548- new upstream release.
549- rename 'MySQL-bench' to 'MySQL-test'.
550- update Patch0.
551- change default charset to 'utf8'.
552
553* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
554- new upstream release.
555- update Patch0.
556- add "--with-client-charset=ujis".
557- sync %%files to official RPM.
558- remove MySQL-Max.
559
560* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
561- for VineSeed
562
563* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
564- move shared library from /usr/lib/ to /usr/lib/mysql/
565- add /etc/ld.so.conf.d/*.conf
566- fix broken libmysqlcient*.la files (or should we remove them permanently?)
567
568* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
569- rebuild <BTS:VineLinux:534>
570
571* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
572- added -fPIC
573
574* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
575- fixed dependency. <BTS:338>
576
577* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
578- add %%Patch1. <BTS:320>
579
580* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
581- new upstream release.
582
583* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
584- new upstream release.
585
586* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
587- new upstream release.
588
589* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
590- release++.
591
592* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
593- new upstream release.
594- for VineSeed.
595
596* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
597- new upstream release.
598- replace Patch0 for MySQL-4.1.16.
599
600* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
601- new upstream release.
602- add Patch0.
603
604* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
605- new upstream version
606        -- mysql-4.0.25
607
608* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
609- new upstream version
610        -- mysql-4.0.23
611
612* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
613- new upstream version
614        -- mysql-4.0.22
615 
616* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
617- new upstream version
618        -- mysql-4.0.21
619 
620* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
621- new upstream version
622        -- mysql-4.0.20
623 
624* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
625- modify CFLAGS, CXXFLAGS and configure options for alpha
626
627* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
628- Upgraded to MySQL-4
629- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
630- merged to MySQL Official packages
631        -- renamed package "MySQL" to "MySQL-server"
632        -- when using gcc, _always_ use CXX=gcc
633        -- replaced Copyright with License field (Copyright is obsolete)
634        -- added myisam_ftdump to the Server package
635        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
636        -- fixed file permissions (BUG 1672)
637        -- removed dependency on MySQL-client from the MySQL-devel subpackage
638        -- as it is not really required. (BUG 1610)
639        -- Fixed BUG 1162 (removed macro names from the changelog)
640        -- Really fixed BUG 998 (disable the checking for installed but
641        --  unpackaged files)
642        -- Fixed BUG 959 (libmysqld not being compiled properly)
643        -- Fixed BUG 998 (RPM build errors): added missing files to the
644        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
645        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
646        -- removed the GIF Icon (file was not included in the sources anyway)
647        -- removed unused variable shared_lib_version
648        -- do not run automake before building the standard binary
649        --  (should not be necessary)
650        -- add server suffix '-standard' to standard binary (to be in line
651        -- with the binary tarball distributions)
652        -- allow overriding CC and CXX (required when building
653        -- with other compilers)
654
655* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
656- added BuildRequires:  automake16
657                                                                               
658* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
659- add '-fPIC -DPIC' to CFLAGS on alpha
660- little fix of spec file
661                                                                               
662* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
663- enable MySQL-shared subpackage for alpha
664- delete 'BuildPrereq: kernel24-headers' for alpha
665- fix shared %files (exclude sparc)
666                                                                               
667* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
668- new upstream version
669                                                                               
670* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
671- fixed devel %files (dropped *.la files)
672                                                                               
673* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
674- new upstream version
675- fixed document permission
676                                                                               
677* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
678- new upstream version
679                                                                               
680* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
681- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
682        -- don't work
683                                                                               
684* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
685- new upstream version
686- diseble-assembler in configure on sparc,sparc64,alpha
687                                                                               
688* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
689- new upstream version
690- moved some man files to main package
691- added enable-local-infile in configure
692- changed --with-extra-charsets=all in configure
693                                                                               
694* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
695- fixed changelog
696                                                                               
697* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
698- updated to mysql-3.23.51
699                                                                               
700* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
701- rebuild on zlib-1.1.4(security fix.)
702                                                                               
703* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
704- updated to mysql-2.23.49
705                                                                               
706* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
707- add 'BuildPrereq: kernel24-headers' on alpha
708- remove shared library and max on alpha
709                                                                               
710* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
711- updated to mysql-3.23.48
712                                                                               
713* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
714- updated to mysql-3.23.47
715                                                                               
716* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
717- updated to mysql-3.23.46
718                                                                               
719* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
720- updated to mysql-3.23.45
721                                                                               
722* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
723- updated to mysql-3.23.44
724                                                                               
725* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
726- updated to mysql-3.23.43
727- removed shared library and max on sparc
728                                                                               
729* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
730- updated to mysql-3.23.42
731- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
732                                                                               
733* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
734- updated to mysql-3.23.41
735                                                                               
736* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
737- updated to mysql-3.23.40
738                                                                               
739* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
740- updated to mysql-3.23.39
741
742* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
743- added configure --with-charset=ujis
744                                                                               
745* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
746- used some rpmmacro
747                                                                               
748* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
749- updated to MySQL-3.23.38
750                                                                               
751* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
752- removed Bench pakages
753                                                                               
754* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
755- removed pt_BR locale
756- build on Vine Linux
757- partially used rpmmacros
758- added %clean tag
759                                                                               
760* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
761- Added separate libmysql_r directory; now both a threaded
762  and non-threaded library is shipped.
763                                                                               
764* Tue Sep 28 1999 David Axmark <davida@mysql.com>
765- Added the support-files/my-example.cnf to the docs directory.
766- Removed devel dependency on base since it is about client
767  development.
768                                                                               
769* Wed Sep 8 1999 David Axmark <davida@mysql.com>
770- Cleaned up some for 3.23.
771                                                                               
772* Thu Jul 1 1999 David Axmark <davida@mysql.com>
773- Added support for shared libraries in a separate sub
774  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
775- The --enable-assembler switch is now automatically disables on
776  platforms there assembler code is unavailable. This should allow
777  building this RPM on non i386 systems.
778                                                                               
779* Mon Feb 22 1999 David Axmark <david@detron.se>
780- Removed unportable cc switches from the spec file. The defaults can
781  now be overridden with environment variables. This feature is used
782  to compile the official RPM with optimal (but compiler version
783  specific) switches.
784- Removed the repetitive description parts for the sub rpms. Maybe add
785  again if RPM gets a multiline macro capability.
786- Added support for a pt_BR translation. Translation contributed by
787  Jorge Godoy <jorge@bestway.com.br>.
788                                                                               
789* Wed Nov 4 1998 David Axmark <david@detron.se>
790- A lot of changes in all the rpm and install scripts. This may even
791  be a working RPM :-)
792                                                                               
793* Sun Aug 16 1998 David Axmark <david@detron.se>
794- A developers changelog for MySQL is available in the source RPM. And
795  there is a history of major user visible changed in the Reference
796  Manual.  Only RPM specific changes will be documented here.
797
Note: See TracBrowser for help on using the repository browser.