source: projects/specs/trunk/m/mariadb/mariadb-vl.spec @ 8523

Revision 8523, 27.3 KB checked in by tomop, 10 years ago (diff)

mariadb-10.0.11-1, mariadb-mroonga-4.03-1

Line 
1%define mysqld_user             mysql
2%define mysqld_group            mysql
3%define mysqldatadir /var/lib/mysql
4
5# Working around perl dependency problem
6%global __perl_requires %{SOURCE998}
7%global __perllib_requires %{SOURCE998}
8
9%define _unpackaged_files_terminate_build 1
10
11%define mariadb_base_version    10.0
12%define mariadb_version         10.0.11
13%define client_version          18
14
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager:       tomop
18
19Name: mariadb
20Summary:        MariaDB: a very fast and robust SQL database server
21Version:        %{mariadb_version}
22Release:        1%{_dist_release}
23
24Group:          Applications/Databases
25License:        GPL2
26URL:            http://www.mariadb.org/
27
28Source:         mariadb-%{version}.tar.gz
29# Don't depend on lib::mtr*
30Source998:      perl-requires.sh
31Source1000:     macros.mariadb.in
32Patch0:         mysql-5.5.15-jp-all.patch
33
34Patch100:       mysql-srv_buf_size.patch
35
36BuildRoot:              %{_tmppath}/%{name}-%{version}-root
37BuildRequires:  bison, cmake, gcc-c++, groff
38BuildRequires:  libaio-devel, libboost-devel, libevent-devel, libxml2-devel
39BuildRequires:  ncurses-devel, perl, openssl-devel, readline-devel
40BuildRequires:  zlib-devel
41Requires:               fileutils sh-utils
42Provides:               msqlormysql MySQL mysql
43Obsoletes:              mysql MySQL5
44
45# From the manual
46%description
47MariaDB: a very fast and robust SQL database server
48
49It is GPL v2 licensed, which means you can use the it free of charge under the
50conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
51
52MariaDB documentation can be found at http://kb.askmonty.org/
53MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
54
55
56%package server
57Release: %{release}
58Summary:        MariaDB: a very fast and robust SQL database server
59Group:          Applications/Databases
60Requires:       fileutils sh-utils net-tools mariadb-common
61Requires(post): mariadb-common
62Provides:       mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
63Obsoletes:      MySQL mysql mysql-server
64Obsoletes:      MySQL-server < 5.6.0
65
66%description server
67MariaDB: a very fast and robust SQL database server
68
69It is GPL v2 licensed, which means you can use the it free of charge under the
70conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
71
72MariaDB documentation can be found at http://kb.askmonty.org/
73MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
74
75
76%package client
77Summary: MariaDB - Client
78Group: Applications/Databases
79Obsoletes: mysql-client MySQL-client < 5.6.0
80Provides: mysql-client MySQL-client  mariadbclient-%{mariadb_base_version}
81
82%description client
83This package contains the standard MariaDB clients and administration tools.
84
85
86%package devel
87Summary: MariaDB - Development libraries and headers
88Group: Development/Libraries
89Requires: %{name}-static, openssl-devel, zlib-devel
90Conflicts: MySQL-devel < 5.6.0
91Conflicts: libmysqlclient-devel
92
93%description devel
94This package contains the development libraries and headers to develop
95MariaDB server components (e.g. plugins or embedded applications).
96
97
98%package static
99Summary: MariaDB - static libraries
100Group: Development/Libraries
101Requires: %{name}-devel
102
103%description static
104This package provides static libraries of MariaDB.
105
106
107%package source
108Summary: MariaDB - Source
109Group: Development/Libraries
110Requires: mariadb-devel = %{version}-%{release}
111Obsoletes: MySQL-source < 5.6.0
112AutoReqProv: no
113
114%description source
115This package contains the sources files of MariaDB.
116
117
118%package test
119Requires: %{name}-client = %{version}-%{release} perl-DBI perl
120Summary: MariaDB - Test suite
121Group: Applications/Databases
122Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
123Provides: perl(mtr_misc.pl)
124
125%description test
126This package contains the MariaDB regression test suite.
127
128
129%package embedded
130Summary: MariaDB as an embeddable library
131Group: System Environment/Libraries
132Obsoletes: mysql-embedded MySQL-embedded
133Provides: mysql-embedded MySQL-embedded
134
135%description embedded
136This package contains a version of the MariaDB server that can be embedded
137into a client application instead of running as a separate process.
138
139
140%prep
141%setup -q
142#%patch0 -p1 -b .jp
143%patch100 -p1 -b .srv_buf_size
144
145%build
146
147# Be strict about variables, bail at earliest opportunity, etc.
148set -eu
149
150# Optional package files
151touch optional-files-devel
152
153export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
154export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
155
156# Build full release
157mkdir release
158(
159  cd release
160  cmake ../ \
161      -DINSTALL_LAYOUT=RPM \
162      -DBUILD_CONFIG=mysql_release \
163      -DCMAKE_BUILD_TYPE=Release \
164      -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
165      -DMANUFACTURER="Vine Linux" \
166      -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
167      -DWITH_PIC="ON" \
168      -DWITH_EMBEDDED_SERVER="ON" \
169      -DWITH_ZLIB="system" \
170      -DWITH_LIBEVENT="system" \
171      -DWITH_LOCALES="yes" \
172      -DWITH_UNIT_TESTS="no" \
173      -DWITH_CONNECT_STORAGE_ENGINE="ON" \
174      -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
175      -DWITH_XTRADB_STORAGE_ENGINE="ON" \
176      -DWITHOUT_TOKUDB=1
177
178#      -DWITH_PCRE="system"
179
180  echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
181  make %{?_smp_mflags} VERBOSE=1
182)
183
184
185%install
186rm -rf %{buildroot}
187
188install -d %{buildroot}%{mysqldatadir}/mysql
189install -d %{buildroot}%{_infodir}
190
191# Install all binaries
192(
193  cd release
194  make DESTDIR=%{buildroot} install
195)
196
197install -m 0644  Docs/mysql.info %{buildroot}%{_infodir}
198rm -rf ./doc
199mv -f %{buildroot}%{_docdir} ./
200
201mkdir -p %{buildroot}%{_datadir}/%{name}-source
202pushd %{buildroot}%{_datadir}/%{name}-source
203tar zxf %{SOURCE0}
204find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
205popd
206
207install -d %{buildroot}%{_sysconfdir}/rpm
208sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
209
210rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
211rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
212rm -f %{buildroot}%{_sysconfdir}/my.cnf
213rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
214rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
215rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
216
217# force linking statically.
218perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
219perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
220
221##############################################################################
222
223%pre server
224# Create a MySQL user and group. Do not report any problems if it already
225# exists.
226datadir=/var/lib/mysql
227
228groupadd -r mysql 2> /dev/null || true
229useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
230# The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
231usermod -g mysql mysql 2> /dev/null || true
232
233%post server
234
235# Make MySQL start/shutdown automatically when the machine does it.
236if [ $1 = 1 ] ; then
237  if [ -x /sbin/chkconfig ] ; then
238          /sbin/chkconfig --add mysql
239  fi
240
241  basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
242  if [ -z "$basedir" ] ; then
243    basedir=/usr
244  fi
245
246  datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
247  if [ -z "$datadir" ] ; then
248    datadir=/var/lib/mysql
249  else
250    # datadir may be relative to a basedir!
251    if ! expr $datadir : / > /dev/null; then
252      datadir=$basedir/$datadir
253    fi
254  fi
255
256  # Change permissions so that the user that will run the MySQL daemon
257  # owns all database files.
258  chown -R mysql:mysql $datadir
259
260  if [ ! -e $datadir/mysql ]; then
261    # Create data directory
262    mkdir -p $datadir/{mysql,test}
263
264    # Initiate databases
265    /usr/bin/mysql_install_db --rpm --user=mysql
266  fi
267
268  # Change permissions again to fix any new files.
269  chown -R mysql:mysql $datadir
270
271  # Fix permissions for the permission database so that only the user
272  # can read them.
273  chmod -R og-rw $datadir/mysql
274fi
275
276%preun server
277if [ $1 = 0 ] ; then
278        # Stop MySQL before uninstalling it
279        if [ -x /etc/init.d/mysql ] ; then
280                /etc/init.d/mysql stop > /dev/null
281        fi
282        # Don't start it automatically anymore
283        if [ -x /sbin/chkconfig ] ; then
284                /sbin/chkconfig --del mysql
285        fi
286fi
287
288%postun server
289if [ $1 -ge 1 ]; then
290  if [ -x /etc/init.d/mysql ] ; then
291    # only restart the server if it was alredy running
292    /etc/init.d/mysql status > /dev/null 2>&1 && \
293    /etc/init.d/mysql restart
294  fi
295fi
296
297# Clean up the BuildRoot
298%clean
299[ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
300
301%files server
302%defattr(-,root,root)
303
304%doc doc/*
305%doc release/support-files/my-*.cnf
306%doc %{_infodir}/mysql.info*
307
308%doc %{_mandir}/man1/innochecksum.1*
309%doc %{_mandir}/man1/my_print_defaults.1*
310%doc %{_mandir}/man1/myisam_ftdump.1*
311%doc %{_mandir}/man1/myisamchk.1*
312%doc %{_mandir}/man1/myisamlog.1*
313%doc %{_mandir}/man1/myisampack.1*
314%doc %{_mandir}/man1/mysql_convert_table_format.1*
315%doc %{_mandir}/man1/mysql_fix_extensions.1*
316%doc %{_mandir}/man8/mysqld.8*
317%doc %{_mandir}/man1/mysqld_multi.1*
318%doc %{_mandir}/man1/mysqld_safe.1*
319%doc %{_mandir}/man1/mysqldumpslow.1*
320%doc %{_mandir}/man1/mysql_install_db.1*
321%doc %{_mandir}/man1/mysql_plugin.1*
322%doc %{_mandir}/man1/mysql_secure_installation.1*
323%doc %{_mandir}/man1/mysql_setpermission.1*
324%doc %{_mandir}/man1/mysql_upgrade.1*
325%doc %{_mandir}/man1/mysqlhotcopy.1*
326%doc %{_mandir}/man1/mysqlman.1*
327%doc %{_mandir}/man1/mysql.server.1*
328%doc %{_mandir}/man1/mysqltest.1*
329%doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
330%doc %{_mandir}/man1/mysql_zap.1*
331%doc %{_mandir}/man1/mysqlbug.1*
332%doc %{_mandir}/man1/perror.1*
333%doc %{_mandir}/man1/replace.1*
334%doc %{_mandir}/man1/resolve_stack_dump.1*
335%doc %{_mandir}/man1/resolveip.1*
336%{_bindir}/aria_*
337%{_bindir}/innochecksum
338%{_bindir}/my_print_defaults
339%{_bindir}/myisam_ftdump
340%{_bindir}/myisamchk
341%{_bindir}/myisamlog
342%{_bindir}/myisampack
343%{_bindir}/mysql_convert_table_format
344%{_bindir}/mysql_fix_extensions
345%{_bindir}/mysql_install_db
346%{_bindir}/mysql_plugin
347%{_bindir}/mysql_secure_installation
348%{_bindir}/mysql_setpermission
349%{_bindir}/mysql_tzinfo_to_sql
350%{_bindir}/mysql_upgrade
351%{_bindir}/mysql_zap
352%{_bindir}/mysqlbug
353%{_bindir}/mysqld_multi
354%{_bindir}/mysqld_safe
355%{_bindir}/mysqldumpslow
356%{_bindir}/mysqlhotcopy
357%{_bindir}/mysqltest
358%{_bindir}/perror
359%{_bindir}/replace
360%{_bindir}/resolve_stack_dump
361%{_bindir}/resolveip
362#%{_bindir}/tokuftdump
363%{_sbindir}/mysqld
364%{_libdir}/mysql
365%config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
366#%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
367%config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
368%{_sysconfdir}/init.d/mysql
369%{_datadir}/mysql
370%attr(755, mysql, mysql) %dir %{mysqldatadir}
371
372%files client
373%defattr(-, root, root)
374%config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
375%{_bindir}/msql2mysql
376%{_bindir}/mysql
377%{_bindir}/mysql_find_rows
378%{_bindir}/mysql_waitpid
379%{_bindir}/mysqlaccess
380%{_bindir}/mysqladmin
381%{_bindir}/mysqlbinlog
382%{_bindir}/mysqlcheck
383%{_bindir}/mysqldump
384%{_bindir}/mysqlimport
385%{_bindir}/mysqlshow
386%{_bindir}/mysqlslap
387%{_bindir}/mytop
388
389%doc %{_mandir}/man1/msql2mysql.1*
390%doc %{_mandir}/man1/mysql.1*
391%doc %{_mandir}/man1/mysql_find_rows.1*
392%doc %{_mandir}/man1/mysql_waitpid.1*
393%doc %{_mandir}/man1/mysqlaccess.1*
394%doc %{_mandir}/man1/mysqladmin.1*
395%doc %{_mandir}/man1/mysqlbinlog.1*
396%doc %{_mandir}/man1/mysqlcheck.1*
397%doc %{_mandir}/man1/mysqldump.1*
398%doc %{_mandir}/man1/mysqlimport.1*
399%doc %{_mandir}/man1/mysqlshow.1*
400%doc %{_mandir}/man1/mysqlslap.1*
401
402%files devel -f optional-files-devel
403%defattr(-, root, root)
404%doc %{_mandir}/man1/mysql_config.1*
405%{_bindir}/mysql_config
406%{_includedir}/mysql
407%{_datadir}/aclocal/mysql.m4
408%{_libdir}/*.so
409%{_sysconfdir}/rpm/*
410%{_bindir}/mysql_embedded
411
412%files static
413%defattr(-,root,root)
414%{_libdir}/lib*.a
415
416%files source
417%defattr(-, root, root)
418%{_datadir}/mariadb-source
419
420%files test
421%defattr(-, root, root)
422%attr(-, root, root) %{_datadir}/mysql-test
423%{_bindir}/mysql_client_test
424%{_bindir}/mysql_client_test_embedded
425%{_bindir}/mysqltest_embedded
426%doc %{_mandir}/man1/mysql_client_test.1*
427%doc %{_mandir}/man1/mysql-stress-test.pl.1*
428%doc %{_mandir}/man1/mysql-test-run.pl.1*
429%doc %{_mandir}/man1/mysql_client_test_embedded.1*
430%doc %{_mandir}/man1/mysqltest_embedded.1*
431
432%files embedded
433%defattr(-,root,root)
434%{_libdir}/libmysqld.so.*
435
436
437%changelog
438* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
439- new upstream release.
440
441* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
442- fixed Conflicts: and Obsoletes:.
443
444* Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
445- new upstream release.
446
447* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
448- new upstream release.
449
450* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
451- new upstream release.
452
453* Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
454- removed duplicated files.
455
456* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
457- switched to MariaDB.
458
459* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
460- new upstream release.
461
462* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
463- new upstream release.
464
465* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
466- new upstream release.
467- added a sub-package 'MySQL-source".
468- added some macros for rpm.
469
470* Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
471- new upstream release.
472
473* Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
474- new upstream release.
475
476* Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
477- new upstream release.
478- added "Vendor:" and "Distribution:" tag.
479
480* Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
481- new upstream release.
482- removed NDB cluster support.
483
484* Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
485- Added "BR: zlib-devel" to MySQL-devel.
486
487* Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
488- Added "BR: openssl-devel" to MySQL-devel.
489
490* Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
491- new upstream release.
492
493* Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
494- new upstream release.
495- updated jp-patch.
496- added ssl support.
497
498* Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
499- new upstream release.
500- replaced '%%__find_requires' to '%%__perl_requires'.
501- updated jp-patch.
502
503* Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
504- added mysql-5.1.44-lib64.patch (on x86_64)
505- added -fPIC (on x86_64)
506
507* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
508- made embedded package again
509
510* Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
511- new upstream release.
512- updated jp-patch.
513
514* Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
515- VineSeed: rebuilt with new toolchain.
516
517* Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
518- new upstream release.
519  - fixed CVE-2009-4484.
520
521* Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
522- new upstream release.
523
524* Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
525- added net-tools to 'Requires'.
526- added groff to 'BuildRequires'.
527- renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
528
529* Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
530- new upstream release.
531
532* Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
533- new upstream release.
534
535* Sun Jul  5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
536- new upstream release.
537- dropped %%Patch100 (fixed in upstream).
538
539* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
540- new upstream release.
541- add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
542
543* Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
544- new upstream release.
545- rename 'MySQL-bench' to 'MySQL-test'.
546- update Patch0.
547- change default charset to 'utf8'.
548
549* Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
550- new upstream release.
551- update Patch0.
552- add "--with-client-charset=ujis".
553- sync %%files to official RPM.
554- remove MySQL-Max.
555
556* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
557- for VineSeed
558
559* Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
560- move shared library from /usr/lib/ to /usr/lib/mysql/
561- add /etc/ld.so.conf.d/*.conf
562- fix broken libmysqlcient*.la files (or should we remove them permanently?)
563
564* Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
565- rebuild <BTS:VineLinux:534>
566
567* Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
568- added -fPIC
569
570* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
571- fixed dependency. <BTS:338>
572
573* Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
574- add %%Patch1. <BTS:320>
575
576* Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
577- new upstream release.
578
579* Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
580- new upstream release.
581
582* Sat Jun  3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
583- new upstream release.
584
585* Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
586- release++.
587
588* Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
589- new upstream release.
590- for VineSeed.
591
592* Wed Feb  8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
593- new upstream release.
594- replace Patch0 for MySQL-4.1.16.
595
596* Thu Oct  6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
597- new upstream release.
598- add Patch0.
599
600* Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
601- new upstream version
602        -- mysql-4.0.25
603
604* Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
605- new upstream version
606        -- mysql-4.0.23
607
608* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
609- new upstream version
610        -- mysql-4.0.22
611 
612* Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
613- new upstream version
614        -- mysql-4.0.21
615 
616* Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
617- new upstream version
618        -- mysql-4.0.20
619 
620* Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
621- modify CFLAGS, CXXFLAGS and configure options for alpha
622
623* Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
624- Upgraded to MySQL-4
625- added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
626- merged to MySQL Official packages
627        -- renamed package "MySQL" to "MySQL-server"
628        -- when using gcc, _always_ use CXX=gcc
629        -- replaced Copyright with License field (Copyright is obsolete)
630        -- added myisam_ftdump to the Server package
631        -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
632        -- fixed file permissions (BUG 1672)
633        -- removed dependency on MySQL-client from the MySQL-devel subpackage
634        -- as it is not really required. (BUG 1610)
635        -- Fixed BUG 1162 (removed macro names from the changelog)
636        -- Really fixed BUG 998 (disable the checking for installed but
637        --  unpackaged files)
638        -- Fixed BUG 959 (libmysqld not being compiled properly)
639        -- Fixed BUG 998 (RPM build errors): added missing files to the
640        -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
641        -- mysql_fix_privilege_tables.1), removed "-n" from install section.
642        -- removed the GIF Icon (file was not included in the sources anyway)
643        -- removed unused variable shared_lib_version
644        -- do not run automake before building the standard binary
645        --  (should not be necessary)
646        -- add server suffix '-standard' to standard binary (to be in line
647        -- with the binary tarball distributions)
648        -- allow overriding CC and CXX (required when building
649        -- with other compilers)
650
651* Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
652- added BuildRequires:  automake16
653                                                                               
654* Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
655- add '-fPIC -DPIC' to CFLAGS on alpha
656- little fix of spec file
657                                                                               
658* Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
659- enable MySQL-shared subpackage for alpha
660- delete 'BuildPrereq: kernel24-headers' for alpha
661- fix shared %files (exclude sparc)
662                                                                               
663* Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
664- new upstream version
665                                                                               
666* Sun Mar  9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
667- fixed devel %files (dropped *.la files)
668                                                                               
669* Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
670- new upstream version
671- fixed document permission
672                                                                               
673* Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
674- new upstream version
675                                                                               
676* Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
677- dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
678        -- don't work
679                                                                               
680* Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
681- new upstream version
682- diseble-assembler in configure on sparc,sparc64,alpha
683                                                                               
684* Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
685- new upstream version
686- moved some man files to main package
687- added enable-local-infile in configure
688- changed --with-extra-charsets=all in configure
689                                                                               
690* Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
691- fixed changelog
692                                                                               
693* Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
694- updated to mysql-3.23.51
695                                                                               
696* Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
697- rebuild on zlib-1.1.4(security fix.)
698                                                                               
699* Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
700- updated to mysql-2.23.49
701                                                                               
702* Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
703- add 'BuildPrereq: kernel24-headers' on alpha
704- remove shared library and max on alpha
705                                                                               
706* Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
707- updated to mysql-3.23.48
708                                                                               
709* Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
710- updated to mysql-3.23.47
711                                                                               
712* Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
713- updated to mysql-3.23.46
714                                                                               
715* Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
716- updated to mysql-3.23.45
717                                                                               
718* Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
719- updated to mysql-3.23.44
720                                                                               
721* Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
722- updated to mysql-3.23.43
723- removed shared library and max on sparc
724                                                                               
725* Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
726- updated to mysql-3.23.42
727- changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
728                                                                               
729* Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
730- updated to mysql-3.23.41
731                                                                               
732* Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
733- updated to mysql-3.23.40
734                                                                               
735* Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
736- updated to mysql-3.23.39
737
738* Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
739- added configure --with-charset=ujis
740                                                                               
741* Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
742- used some rpmmacro
743                                                                               
744* Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
745- updated to MySQL-3.23.38
746                                                                               
747* Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
748- removed Bench pakages
749                                                                               
750* Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
751- removed pt_BR locale
752- build on Vine Linux
753- partially used rpmmacros
754- added %clean tag
755                                                                               
756* Fri Aug 18 2000 Tim Smith <tim@mysql.com>
757- Added separate libmysql_r directory; now both a threaded
758  and non-threaded library is shipped.
759                                                                               
760* Tue Sep 28 1999 David Axmark <davida@mysql.com>
761- Added the support-files/my-example.cnf to the docs directory.
762- Removed devel dependency on base since it is about client
763  development.
764                                                                               
765* Wed Sep 8 1999 David Axmark <davida@mysql.com>
766- Cleaned up some for 3.23.
767                                                                               
768* Thu Jul 1 1999 David Axmark <davida@mysql.com>
769- Added support for shared libraries in a separate sub
770  package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
771- The --enable-assembler switch is now automatically disables on
772  platforms there assembler code is unavailable. This should allow
773  building this RPM on non i386 systems.
774                                                                               
775* Mon Feb 22 1999 David Axmark <david@detron.se>
776- Removed unportable cc switches from the spec file. The defaults can
777  now be overridden with environment variables. This feature is used
778  to compile the official RPM with optimal (but compiler version
779  specific) switches.
780- Removed the repetitive description parts for the sub rpms. Maybe add
781  again if RPM gets a multiline macro capability.
782- Added support for a pt_BR translation. Translation contributed by
783  Jorge Godoy <jorge@bestway.com.br>.
784                                                                               
785* Wed Nov 4 1998 David Axmark <david@detron.se>
786- A lot of changes in all the rpm and install scripts. This may even
787  be a working RPM :-)
788                                                                               
789* Sun Aug 16 1998 David Axmark <david@detron.se>
790- A developers changelog for MySQL is available in the source RPM. And
791  there is a history of major user visible changed in the Reference
792  Manual.  Only RPM specific changes will be documented here.
793
Note: See TracBrowser for help on using the repository browser.