source: projects/specs/trunk/m/mariadb-mroonga/mariadb-mroonga-vl.spec @ 8523

Revision 8523, 7.1 KB checked in by tomop, 10 years ago (diff)

mariadb-10.0.11-1, mariadb-mroonga-4.03-1

Line 
1%{!?use_system_mysql:%define use_system_mysql 0}
2
3%define mysql_base_version %{__mariadb_base_version}
4%define mysql_version %{__mariadb_version}
5%define mysql_release %{__mariadb_release}
6
7%define groonga_required_version 4.0.2
8
9Name:           mariadb-mroonga
10Version:        4.03
11Release:        1%{?_dist_release}
12Summary:        A fast fulltext searchable storage engine for MariaDB.
13
14Group:          Applications/Databases
15License:        LGPLv2.1
16URL:            http://mroonga.github.com/
17Source0:        http://github.com/downloads/mroonga/mroonga/mroonga-%{version}.tar.gz
18### the next release may include the follwing patches.
19#Patch0:                4a3d6c77a9.patch
20#Patch1:                171fa019d4.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
23BuildRequires:  groonga-devel >= %{groonga_required_version}
24BuildRequires:  groonga-normalizer-mysql-devel pcre-devel
25BuildRequires:  mariadb-source
26%if "%{?mysql_version}" != ""
27Requires:       mariadbserver-%{mysql_base_version}
28Requires:       mariadbclient-%{mysql_base_version}
29%endif
30Requires:       groonga-libs >= %{groonga_required_version}
31Requires:       groonga-normalizer-mysql
32Obsoletes: MySQL-mroonga < 4.00
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: tomop
37
38%description
39Mroonga is a fast fulltext searchable storage plugin for MariaDB.
40It is based on groonga that is a fast fulltext search engine and
41column store. Groonga is good at real-time update.
42
43%package doc
44Summary:        Documentation for mroonga
45Group:          Documentation
46License:        LGPLv2.1
47
48%description doc
49Documentation for mroonga
50
51
52%prep
53%setup -q -n mroonga-%{version}
54#%patch0 -p1 -b .private
55#%patch1 -p1 -b .LOCK_open
56
57%build
58mysql_source=%{_datadir}/mariadb-source/mariadb-%{mysql_version}
59%configure --disable-static --with-mysql-source=${mysql_source} \
60    %{?mroonga_configure_options}
61make %{?_smp_mflags}
62
63
64%install
65rm -rf %{buildroot}
66make install DESTDIR=%{buildroot}
67rm -f %{buildroot}%{_libdir}/mysql/plugin/*.la
68mv -f %{buildroot}%{_datadir}/doc/mroonga/ mysql-mroonga-doc/
69
70%clean
71rm -rf %{buildroot}
72
73%post
74if [ "$1" = 1 ] ; then
75        /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql || cat <<EOF
76An error occured when to register plugin.
77Please run a command below:
78
79  /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql
80
81EOF
82fi
83
84%preun
85/usr/bin/mysql -u root < %{_datadir}/mroonga/uninstall.sql || cat <<EOF
86An error occured when to register plugin.
87Please run a command below:
88
89  /usr/bin/mysql -u root < %{_datadir}/mroonga/uninstall.sql
90
91EOF
92
93if [ "$1" != 0 ]; then
94
95    /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql || cat <<EOF
96An error occured when to register plugin.
97Please run a command below:
98
99  /usr/bin/mysql -u root < %{_datadir}/mroonga/install.sql
100
101EOF
102fi
103
104%files
105%defattr(-,root,root,-)
106%{_libdir}/mysql/plugin/*
107%{_datadir}/man/man1/*
108%{_datadir}/man/*/man1/*
109%{_datadir}/mroonga
110
111%files doc
112%defattr(-,root,root,-)
113%doc README COPYING
114%doc mysql-mroonga-doc/*
115
116%changelog
117* Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.03-1
118- new upstream release.
119- removed Patch0 and Patch1.
120
121* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.01-2
122- fixed %%post and %%preun scripts.
123
124* Fri Apr 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.01-1
125- new upstream release.
126- added Patch0 and Patch1.
127
128* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.00-2
129- rebuilt with mariadb-10.0.9.
130
131* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.00-1
132- new upstream release.
133
134* Wed Dec 18 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10-2
135- added "BR: groonga-normalizer-mysql-devel".
136
137* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10-1
138- new upstream release.
139- built with MariaDB.
140
141* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.00-1
142- new upstream release.
143- fixed dates of old %%changelog.
144
145* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.08-1
146- new upstream release.
147
148* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.06-1
149- initial build for Vine Linux.
150
151* Wed Aug 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.06-0
152- new upstream release.
153- make MySQL spec file name customizable.
154- make mroonga configure options customizable.
155- add missing mysql-devel BuildRequires. Reported by wing. Thanks!!!
156- use MySQL 5.5.27.
157
158* Sun Jul 29 2012 HAYASHI Kentaro <hayashi@clear-code.com> - 2.05-0
159- new upstream release.
160- use MySQL 5.5.25a.
161
162* Fri Jun 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.04-0
163- new upstream release.
164- ensure deleting mroonga plugin before install.
165  Suggested by Kazuhiro Isobe. Thanks!!!
166- use MySQL 5.5.25.
167
168* Tue May 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.03-0
169- new upstream release.
170- use MySQL 5.5.24.
171- make mysql_* variables customizable
172- require groonga 2.0.3 or later.
173
174* Sun Apr 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.02-0
175- new upstream release.
176- use MySQL 5.5.23.
177- require groonga 2.0.2 or later.
178
179* Thu Mar 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.01-0
180- new upstream release.
181- ensure plugin is uninstalled by closing all tables use mroonga.
182
183* Wed Feb 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.00-0
184- new upstream release.
185- always install/uninstall plugin.
186- use MySQL 5.1.61 and 5.5.21.
187- require groonga 2.0.0 or later.
188
189* Sun Jan 29 2012 Kouhei Sutou <kou@clear-code.com> - 1.20-0
190- new upstream release.
191- require groonga 1.3.0.
192- groonga -> mroonga.
193- use MySQL 5.5.20.
194
195* Thu Dec 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.11-0
196- new upstream release.
197
198* Sat Oct 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.10-0
199- new upstream release.
200- groonga storage engine -> mroonga.
201
202* Thu Sep 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.0.0-0
203- new upstream release.
204
205* Mon Aug 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.9-0
206- new upstream release.
207
208* Fri Jul 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.8-0
209- new upstream release.
210
211* Wed Jun 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.7-0
212- new upstream release.
213
214* Sun May 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.6-0
215- new upstream release.
216
217* Tue May 17 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-2
218- use MySQL 5.5.12.
219
220* Tue Mar 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-1
221- new upstream release.
222
223* Sat Jan 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-4
224- do not remove plugin on upgrade.
225
226* Wed Jan 12 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-3
227- rebuild without debug symbol.
228
229* Thu Dec 30 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-2
230- use MySQL 5.5.8-1.
231- fix SQL literal notation.
232
233* Mon Nov 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-1
234- use the latest MySQL.
235- new upstream release.
236
237* Sun Nov 21 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-2
238- install user define function.
239
240* Fri Oct 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-1
241- new upstream release.
242
243* Fri Oct 08 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-2
244- specify target MySQL version.
245- use %{version}.
246
247* Wed Sep 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-1
248- new upstream release.
249
250* Sun Sep 12 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-3
251- require MySQL-client-community.
252
253* Fri Sep 10 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-2
254- use MySQL-devel-community.
255
256* Fri Sep 03 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-1
257- initial packaging for CentOS.
Note: See TracBrowser for help on using the repository browser.