source: projects/specs/trunk/m/mariadb-mroonga/mariadb-mroonga-vl.spec @ 8459

Revision 8459, 7.7 KB checked in by tomop, 10 years ago (diff)

mariadb-10.0.10-2, mariadb-mroonga-4.01-2

Line 
1%{!?use_system_mysql:%define use_system_mysql 0}
2
3%define mysql_base_version %{__mariadb_base_version}
4%define mysql_version %{__mariadb_version}
5%define mysql_release %{__mariadb_release}
6
7%define groonga_required_version 4.0.1
8
9Name:           mariadb-mroonga
10Version:        4.01
11Release:        2%{?_dist_release}
12Summary:        A fast fulltext searchable storage engine for MariaDB.
13
14Group:          Applications/Databases
15License:        LGPLv2.1
16URL:            http://mroonga.github.com/
17Source0:        http://github.com/downloads/mroonga/mroonga/mroonga-%{version}.tar.gz
18### the next release may include the follwing patches.
19Patch0:         4a3d6c77a9.patch
20Patch1:         171fa019d4.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-%(%{__id_u} -n)
23BuildRequires:  groonga-devel >= %{groonga_required_version}
24BuildRequires:  groonga-normalizer-mysql-devel pcre-devel
25BuildRequires:  mariadb-source
26%if "%{?mysql_version}" != ""
27Requires:       mariadbserver-%{mysql_base_version}
28Requires:       mariadbclient-%{mysql_base_version}
29%endif
30Requires:       groonga-libs >= %{groonga_required_version}
31Requires:       groonga-normalizer-mysql
32Obsoletes: MySQL-mroonga < 4.00
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: tomop
37
38%description
39Mroonga is a fast fulltext searchable storage plugin for MariaDB.
40It is based on groonga that is a fast fulltext search engine and
41column store. Groonga is good at real-time update.
42
43%package doc
44Summary:        Documentation for mroonga
45Group:          Documentation
46License:        LGPLv2.1
47
48%description doc
49Documentation for mroonga
50
51
52%prep
53%setup -q -n mroonga-%{version}
54%patch0 -p1 -b .private
55%patch1 -p1 -b .LOCK_open
56
57%build
58mysql_source=%{_datadir}/mariadb-source/mariadb-%{mysql_version}
59%configure --disable-static --with-mysql-source=${mysql_source} \
60    %{?mroonga_configure_options}
61make %{?_smp_mflags}
62
63
64%install
65rm -rf %{buildroot}
66make install DESTDIR=%{buildroot}
67rm -f %{buildroot}%{_libdir}/mysql/plugin/*.la
68mv -f %{buildroot}%{_datadir}/doc/mroonga/ mysql-mroonga-doc/
69
70%clean
71rm -rf %{buildroot}
72
73%post
74if [ "$1" = 2 ] ; then
75    sql="
76USE mysql;
77DROP FUNCTION IF EXISTS mroonga_snippet;
78DROP FUNCTION IF EXISTS last_insert_grn_id;
79DROP FUNCTION IF EXISTS mroonga_command;
80DROP FUNCTION IF EXISTS mroonga_escape;
81UNINSTALL PLUGIN mroonga;
82FLUSH TABLES;
83"
84    command="/usr/bin/mysql -u root -e \"$sql\""
85    echo $command
86    eval $command || \
87          (echo "run the following command to unregister mroonga:"; \
88           echo "  $command")
89fi
90sql="
91DELETE IGNORE FROM mysql.plugin WHERE name = 'mroonga';
92INSTALL PLUGIN mroonga SONAME 'ha_mroonga.so';
93CREATE FUNCTION last_insert_grn_id RETURNS INTEGER SONAME 'ha_mroonga.so';
94CREATE FUNCTION mroonga_snippet RETURNS STRING SONAME 'ha_mroonga.so';
95CREATE FUNCTION mroonga_command RETURNS STRING SONAME 'ha_mroonga.so';
96CREATE FUNCTION mroonga_escape RETURNS STRING SONAME 'ha_mroonga.so';
97"
98command="/usr/bin/mysql -u root -e \"$sql\""
99echo $command
100eval $command || \
101        (echo "run the following command to register mroonga:"; \
102         echo "  $command")
103
104%preun
105if [ "$1" = 0 ]; then
106    sql="
107USE mysql;
108DROP FUNCTION IF EXISTS mroonga_snippet;
109DROP FUNCTION IF EXISTS last_insert_grn_id;
110DROP FUNCTION IF EXISTS mroonga_command;
111DROP FUNCTION IF EXISTS mroonga_escape;
112UNINSTALL PLUGIN mroonga;
113FLUSH TABLES;
114"
115    command="/usr/bin/mysql -u root -e \"$sql\""
116    echo $command
117    eval $command || \
118          (echo "run the following command to unregister mroonga:"; \
119           echo "  $command")
120fi
121
122%files
123%defattr(-,root,root,-)
124%{_libdir}/mysql/plugin/*
125%{_datadir}/man/man1/*
126%{_datadir}/man/*/man1/*
127
128%files doc
129%defattr(-,root,root,-)
130%doc README COPYING
131%doc mysql-mroonga-doc/*
132
133%changelog
134* Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.01-2
135- fixed %%post and %%preun scripts.
136
137* Fri Apr 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.01-1
138- new upstream release.
139- added Patch0 and Patch1.
140
141* Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.00-2
142- rebuilt with mariadb-10.0.9.
143
144* Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.00-1
145- new upstream release.
146
147* Wed Dec 18 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10-2
148- added "BR: groonga-normalizer-mysql-devel".
149
150* Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10-1
151- new upstream release.
152- built with MariaDB.
153
154* Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.00-1
155- new upstream release.
156- fixed dates of old %%changelog.
157
158* Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.08-1
159- new upstream release.
160
161* Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.06-1
162- initial build for Vine Linux.
163
164* Wed Aug 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.06-0
165- new upstream release.
166- make MySQL spec file name customizable.
167- make mroonga configure options customizable.
168- add missing mysql-devel BuildRequires. Reported by wing. Thanks!!!
169- use MySQL 5.5.27.
170
171* Sun Jul 29 2012 HAYASHI Kentaro <hayashi@clear-code.com> - 2.05-0
172- new upstream release.
173- use MySQL 5.5.25a.
174
175* Fri Jun 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.04-0
176- new upstream release.
177- ensure deleting mroonga plugin before install.
178  Suggested by Kazuhiro Isobe. Thanks!!!
179- use MySQL 5.5.25.
180
181* Tue May 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.03-0
182- new upstream release.
183- use MySQL 5.5.24.
184- make mysql_* variables customizable
185- require groonga 2.0.3 or later.
186
187* Sun Apr 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.02-0
188- new upstream release.
189- use MySQL 5.5.23.
190- require groonga 2.0.2 or later.
191
192* Thu Mar 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.01-0
193- new upstream release.
194- ensure plugin is uninstalled by closing all tables use mroonga.
195
196* Wed Feb 29 2012 Kouhei Sutou <kou@clear-code.com> - 2.00-0
197- new upstream release.
198- always install/uninstall plugin.
199- use MySQL 5.1.61 and 5.5.21.
200- require groonga 2.0.0 or later.
201
202* Sun Jan 29 2012 Kouhei Sutou <kou@clear-code.com> - 1.20-0
203- new upstream release.
204- require groonga 1.3.0.
205- groonga -> mroonga.
206- use MySQL 5.5.20.
207
208* Thu Dec 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.11-0
209- new upstream release.
210
211* Sat Oct 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.10-0
212- new upstream release.
213- groonga storage engine -> mroonga.
214
215* Thu Sep 29 2011 Kouhei Sutou <kou@clear-code.com> - 1.0.0-0
216- new upstream release.
217
218* Mon Aug 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.9-0
219- new upstream release.
220
221* Fri Jul 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.8-0
222- new upstream release.
223
224* Wed Jun 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.7-0
225- new upstream release.
226
227* Sun May 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.6-0
228- new upstream release.
229
230* Tue May 17 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-2
231- use MySQL 5.5.12.
232
233* Tue Mar 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.5-1
234- new upstream release.
235
236* Sat Jan 29 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-4
237- do not remove plugin on upgrade.
238
239* Wed Jan 12 2011 Kouhei Sutou <kou@clear-code.com> - 0.4-3
240- rebuild without debug symbol.
241
242* Thu Dec 30 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-2
243- use MySQL 5.5.8-1.
244- fix SQL literal notation.
245
246* Mon Nov 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.4-1
247- use the latest MySQL.
248- new upstream release.
249
250* Sun Nov 21 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-2
251- install user define function.
252
253* Fri Oct 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.3-1
254- new upstream release.
255
256* Fri Oct 08 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-2
257- specify target MySQL version.
258- use %{version}.
259
260* Wed Sep 29 2010 Kouhei Sutou <kou@clear-code.com> - 0.2-1
261- new upstream release.
262
263* Sun Sep 12 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-3
264- require MySQL-client-community.
265
266* Fri Sep 10 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-2
267- use MySQL-devel-community.
268
269* Fri Sep 03 2010 Kouhei Sutou <kou@clear-code.com> - 0.1-1
270- initial packaging for CentOS.
Note: See TracBrowser for help on using the repository browser.