source: projects/specs/trunk/m/make/make-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     A GNU tool which simplifies the build process for users.
2Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
3Name: make
4Epoch: 1
5Version: 3.81
6Release: 7%{?_dist_release}
7License: GPL
8Group: Development/Tools
9URL: http://www.gnu.org/software/make/
10Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
11Source1: make-3.81-ja.po
12
13Patch: make-3.80-noclock_gettime.patch
14Patch2: make-3.80-siglist.patch
15Patch3: make-3.80-cvs.patch
16Patch4: make-3.80-j8k.patch
17Patch5: make-3.80-getcwd.patch
18Patch6: make-3.81-err-reporting.patch
19Patch7: make-3.81-memory.patch
20Patch8: make-3.81-rlimit.patch
21Patch9: make-3.81-newlines.patch
22
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24Requires(post): /sbin/install-info
25Requires(preun): /sbin/install-info
26BuildRequires: automake >= 1.7.3
27BuildRequires: perl
28
29%description
30A GNU tool for controlling the generation of executables and other
31non-source files of a program from the program's source files.  Make
32allows users to build and install packages without any significant
33knowledge about the details of the build process.  The details about
34how the program should be built are provided for make in the program's
35makefile.
36
37The GNU make tool should be installed on your system because it is
38commonly used to simplify the process of installing programs.
39
40
41%description -l ja
42プログラムのソースファイルから実行ファイル及びその他のファイルを
43生成する GNU ツールです.Make を使うことでユーザは build 時の
44細かいプロセスを気にせず build しインストールすることが出来ます.
45プログラムがどの様に build されるのかは,プログラムの Makefile に
46書かれています.
47
48GNU make ツールは,プログラムのインストールを容易にするのに
49非常によく使われますので,このパッケージは是非インストールして下さい.
50
51
52%prep
53%setup -q
54%patch -p1
55%patch4 -p1
56%patch5 -p1
57%patch6 -p1
58%patch7 -p1
59%patch8 -p1
60%patch9 -p1
61cp %{SOURCE1} po/ja.po
62
63%build
64config/missing --run aclocal -I config
65config/missing --run automake --gnu Makefile
66config/missing --run autoconf
67%configure
68make
69
70%install
71rm -rf $RPM_BUILD_ROOT
72%makeinstall
73
74pushd $RPM_BUILD_ROOT
75  ln -sf make .%{_bindir}/gmake
76#  gzip -9nf .%{_infodir}/make.info*
77  rm -f .%{_infodir}/dir
78popd
79
80%find_lang %name
81
82
83%check
84echo ============TESTING===============
85/usr/bin/env LANG=C make check
86echo ============END TESTING===========
87
88
89%clean
90rm -rf ${RPM_BUILD_ROOT}
91
92%post
93/sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
94
95%preun
96if [ $1 = 0 ]; then
97   /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
98fi
99
100
101%files -f %{name}.lang
102%defattr(-,root,root)
103%doc NEWS README
104%{_bindir}/*
105%{_mandir}/man*/*
106%{_infodir}/*.info*
107#%{_datadir}/locale/*/LC_MESSAGES/make*
108
109%changelog
110* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
111- applied new versioning policy
112- added BuildRequires: perl (for %%check)
113- spec in UTF-8
114
115* Tue Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
116- updated to 3.81 based on Fedora packages
117  * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
118  - Always run testsuite with C locale.
119  - Resolves: #232607
120  * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
121  - Fix newline handling for quoted SHELL.
122  - Resolves: #219409
123  * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
124  - Upstream 3.81:
125    - Contains several backwards incompatible changes.  See NEWS inside
126      the source package to find out more.
127  - memory patch and error reporting patch were ported to this version.
128- updated ja.po
129
130* Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
131- added URL
132- s/Copyright/License/
133- added some patches from fedora development 3.80-8
134  * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
135  - make sure errno for error reporting is not lost accross _() calls
136  - report EOF on read pipe differently from read returning < 0 reporting
137  * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
138  - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
139  * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
140  - add important bug-fixes from make home-page
141
142* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
143- some patches was included from 3.79.1-17
144
145* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
146- update ja.po
147
148* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
149- new upstream release
150
151* Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
152- 3.79.1-5vl1
153- based on 3.79.1-5 from Rawhide
154- rebuilt for Vine Linux
155- added Japanese summary and description
156
157* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
158- change info-dir entry so that 'info make' works (#15029).
159
160* Tue Aug  1 2000 Jakub Jelinek <jakub@redhat.com>
161- assume we don't have clock_gettime in configure, so that
162  make is not linked against -lpthread (and thus does not
163  limit stack to 2MB).
164
165* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
166- add locale files (#14362).
167
168* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
169- automatic rebuild
170
171* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
172- 3.79.1 bugfix release
173
174* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
175- FHS packaging.
176
177* Sun May  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
178- Fix build for some odd situations, such as
179  - previously installed make != GNU make
180  - /bin/sh != bash
181
182* Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
183- update to 3.79
184
185* Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
186- add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
187  builds)
188
189* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
190- compress man page.
191
192* Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
193- apply patch to fix a /tmp race condition from Thomas Biege
194- simplify %install
195
196* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
197- update to 3.78.1.
198
199* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
200- added a serial tag so it upgrades right
201
202* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
203- auto rebuild in the new build environment (release 5)
204
205* Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
206- added a patch for large file support in glob
207 
208* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
209- update to 3.77
210
211* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
212- translations modified for de, fr, tr
213
214* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
215- udpated from 3.75 to 3.76
216- various spec file cleanups
217- added install-info support
218
219* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
220- built against glibc
Note: See TracBrowser for help on using the repository browser.