source: projects/specs/trunk/m/make/make-vl.spec @ 12546

Revision 12546, 7.7 KB checked in by tomop, 3 years ago (diff)

updated 28 packages

autoconf-2.71-1

automake-1.16.3-1

bison-3.7.5-1

e2fsprogs-1.46.1-1

findutils-4.8.0-1

galera-26.4.7-1

gawk-5.1.0-1

gdbm-1.19-1

gjs-1.66.2-1

gnome-initial-setup-3.36.4-2

grep-3.6-1

help2man-1.48.1-1

ipvsadm-1.31-1

less-563-1

libidn-1.36-1

make-4.3-1

mariadb-10.5.9-1

mozjs78-78.7.0-1

mpfr-4.1.0-1

nettle-3.7.1-1

parted-3.4-1

pcre2-10.36-1

polkit-0.118-1

strongswan-5.9.1-1

tar-1.34-1

trousers-0.3.15-1

wget-1.21-1

wireshark-3.4.3-1

Line 
1Summary:     A GNU tool which simplifies the build process for users.
2Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
3Name: make
4Epoch: 1
5Version: 4.3
6Release: 1%{?_dist_release}
7Group: programming
8Vendor: Project Vine
9Distribution: Vine Linux
10
11License: GPL
12URL: http://www.gnu.org/software/make/
13Source: https://ftp.gnu.org/gnu/make/make-%{version}.tar.gz
14Source1: http://translationproject.org/PO-files/ja/make-4.2.93.ja.po
15Patch0: make-4.3-getcwd.patch
16
17# Assume we don't have clock_gettime in configure, so that
18# make is not linked against -lpthread (and thus does not
19# limit stack to 2MB).
20Patch2: make-4.0-noclock_gettime.patch
21
22# BZs #142691, #17374
23Patch3: make-4.3-j8k.patch
24
25# https://bugzilla.redhat.com/show_bug.cgi?id=1827850
26# https://savannah.gnu.org/bugs/?58232
27# Remove on next make rebase
28Patch4: make-4.3-cloexec.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31Requires(post): /sbin/install-info
32Requires(preun): /sbin/install-info
33BuildRequires: automake >= 1.7.3
34BuildRequires: guile-devel
35BuildRequires: perl
36BuildRequires: procps
37BuildRequires: texinfo
38
39%description
40A GNU tool for controlling the generation of executables and other
41non-source files of a program from the program's source files.  Make
42allows users to build and install packages without any significant
43knowledge about the details of the build process.  The details about
44how the program should be built are provided for make in the program's
45makefile.
46
47The GNU make tool should be installed on your system because it is
48commonly used to simplify the process of installing programs.
49
50
51%description -l ja
52プログラムのソースファイルから実行ファイル及びその他のファイルを
53生成する GNU ツールです.Make を使うことでユーザは build 時の
54細かいプロセスを気にせず build しインストールすることが出来ます.
55プログラムがどの様に build されるのかは,プログラムの Makefile に
56書かれています.
57
58GNU make ツールは,プログラムのインストールを容易にするのに
59非常によく使われますので,このパッケージは是非インストールして下さい.
60
61
62%debug_package
63
64
65%prep
66%autosetup -p1
67
68rm -f tests/scripts/features/parallelism.orig
69
70cp -f %{SOURCE1} po/ja.po
71
72%build
73autoreconf -vfi
74
75%configure --with-guile
76make -C po ja.gmo
77make %{?_smp_mflags}
78
79%install
80rm -rf ${RPM_BUILD_ROOT}
81make DESTDIR=$RPM_BUILD_ROOT install
82ln -sf make ${RPM_BUILD_ROOT}/%{_bindir}/gmake
83ln -sf make.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/gmake.1
84rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
85
86%find_lang %name
87
88%check
89echo ============TESTING===============
90/usr/bin/env LANG=C make check
91echo ============END TESTING===========
92
93
94%clean
95rm -rf ${RPM_BUILD_ROOT}
96
97%post
98/sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
99
100%preun
101if [ $1 = 0 ]; then
102   /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
103fi
104
105
106%files -f %{name}.lang
107%defattr(-,root,root)
108%doc NEWS README COPYING AUTHORS
109%{_bindir}/*
110%{_mandir}/man*/*
111%{_infodir}/*.info*
112%{_includedir}/gnumake.h
113
114%changelog
115* Wed Feb 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.3-1
116- new upstream release.
117- updated ja.po.
118- dropped Patch1, 4-9.
119- updated Patch0 and 3.
120- imported Patch4 from rawhide.
121
122* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.1-1
123- new upstream release.
124- updated patches.
125- updated ja.po.
126
127* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
128- new upstream release.
129- dropped all patches.
130- imported patches from rawhide.
131- added Patch1000 to fix ja.po.
132
133* Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-2
134- rebuild with VineSeed environment
135
136* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
137- new upstream release
138
139* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
140- rebuild for Vine6
141
142* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
143- applied new versioning policy
144- added BuildRequires: perl (for %%check)
145- spec in UTF-8
146
147* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
148- updated to 3.81 based on Fedora packages
149  * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
150  - Always run testsuite with C locale.
151  - Resolves: #232607
152  * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
153  - Fix newline handling for quoted SHELL.
154  - Resolves: #219409
155  * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
156  - Upstream 3.81:
157    - Contains several backwards incompatible changes.  See NEWS inside
158      the source package to find out more.
159  - memory patch and error reporting patch were ported to this version.
160- updated ja.po
161
162* Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
163- added URL
164- s/Copyright/License/
165- added some patches from fedora development 3.80-8
166  * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
167  - make sure errno for error reporting is not lost accross _() calls
168  - report EOF on read pipe differently from read returning < 0 reporting
169  * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
170  - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
171  * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
172  - add important bug-fixes from make home-page
173
174* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
175- some patches was included from 3.79.1-17
176
177* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
178- update ja.po
179
180* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
181- new upstream release
182
183* Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
184- 3.79.1-5vl1
185- based on 3.79.1-5 from Rawhide
186- rebuilt for Vine Linux
187- added Japanese summary and description
188
189* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
190- change info-dir entry so that 'info make' works (#15029).
191
192* Tue Aug  1 2000 Jakub Jelinek <jakub@redhat.com>
193- assume we don't have clock_gettime in configure, so that
194  make is not linked against -lpthread (and thus does not
195  limit stack to 2MB).
196
197* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
198- add locale files (#14362).
199
200* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
201- automatic rebuild
202
203* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
204- 3.79.1 bugfix release
205
206* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
207- FHS packaging.
208
209* Sun May  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
210- Fix build for some odd situations, such as
211  - previously installed make != GNU make
212  - /bin/sh != bash
213
214* Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
215- update to 3.79
216
217* Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
218- add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
219  builds)
220
221* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
222- compress man page.
223
224* Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
225- apply patch to fix a /tmp race condition from Thomas Biege
226- simplify %install
227
228* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
229- update to 3.78.1.
230
231* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
232- added a serial tag so it upgrades right
233
234* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
235- auto rebuild in the new build environment (release 5)
236
237* Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
238- added a patch for large file support in glob
239 
240* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
241- update to 3.77
242
243* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
244- translations modified for de, fr, tr
245
246* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
247- udpated from 3.75 to 3.76
248- various spec file cleanups
249- added install-info support
250
251* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
252- built against glibc
Note: See TracBrowser for help on using the repository browser.