source: projects/specs/trunk/m/make/make-vl.spec @ 12199

Revision 12199, 8.3 KB checked in by tomop, 5 years ago (diff)

updated guile and pkgs depends on guile

Line 
1Summary:     A GNU tool which simplifies the build process for users.
2Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
3Name: make
4Epoch: 1
5Version: 4.2.1
6Release: 1%{?_dist_release}
7License: GPL
8Group: Development/Tools
9URL: http://www.gnu.org/software/make/
10Source: https://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
11Source1: http://translationproject.org/PO-files/ja/make-%{version}.ja.po
12Patch0: make-4.2-getcwd.patch
13Patch1: make-4.0-newlines.patch
14
15# Assume we don't have clock_gettime in configure, so that
16# make is not linked against -lpthread (and thus does not
17# limit stack to 2MB).
18Patch2: make-4.0-noclock_gettime.patch
19
20# BZs #142691, #17374
21Patch3: make-4.2-j8k.patch
22
23# Upstream: https://savannah.gnu.org/bugs/?30748
24# The default value of .SHELL_FLAGS is -c.
25Patch4: make-4.0-weird-shell.patch
26
27# Upstream patch: https://git.savannah.gnu.org/cgit/make.git/patch/?id=193f1e81edd6b1b56b0eb0ff8aa4b41c7b4257b4
28# Fixes wrong assumptions of glibc's glob internals.
29Patch5: make-4.2.1-glob-fix-2.patch
30# Upstream patch: https://git.savannah.gnu.org/cgit/make.git/patch/?id=48c8a116a914a325a0497721f5d8b58d5bba34d4
31# Fixes incorrect use of glibc 2.27 glob internals.
32Patch6: make-4.2.1-glob-fix.patch
33Patch7: make-4.2.1-glob-fix-3.patch
34# Perl 5.26 removed the implicit CWD in @INC.
35Patch8: make-4.2.1-test-driver.patch
36
37# Upstream patch: https://git.savannah.gnu.org/cgit/make.git/commit/?id=fbf71ec25a5986d9003ac16ee9e23675feac9053
38# Adds support of guile 2.2
39Patch9: 0001-configure.ac-SV-50648-Detect-Guile-2.2-packages.patch
40
41Buildroot: %{_tmppath}/%{name}-%{version}-root
42Requires(post): /sbin/install-info
43Requires(preun): /sbin/install-info
44BuildRequires: automake >= 1.7.3
45BuildRequires: guile-devel
46BuildRequires: perl
47BuildRequires: procps
48BuildRequires: texinfo
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54A GNU tool for controlling the generation of executables and other
55non-source files of a program from the program's source files.  Make
56allows users to build and install packages without any significant
57knowledge about the details of the build process.  The details about
58how the program should be built are provided for make in the program's
59makefile.
60
61The GNU make tool should be installed on your system because it is
62commonly used to simplify the process of installing programs.
63
64
65%description -l ja
66プログラムのソースファイルから実行ファイル及びその他のファイルを
67生成する GNU ツールです.Make を使うことでユーザは build 時の
68細かいプロセスを気にせず build しインストールすることが出来ます.
69プログラムがどの様に build されるのかは,プログラムの Makefile に
70書かれています.
71
72GNU make ツールは,プログラムのインストールを容易にするのに
73非常によく使われますので,このパッケージは是非インストールして下さい.
74
75%prep
76%autosetup -p1
77
78rm -f tests/scripts/features/parallelism.orig
79
80cp -f %{SOURCE1} po/ja.po
81
82%build
83autoreconf -vfi
84
85%if %{?_dist_release} == "vl6"
86%configure
87%else
88%configure --with-guile
89%endif
90make -C po ja.gmo
91make %{?_smp_mflags}
92
93%install
94rm -rf ${RPM_BUILD_ROOT}
95make DESTDIR=$RPM_BUILD_ROOT install
96ln -sf make ${RPM_BUILD_ROOT}/%{_bindir}/gmake
97ln -sf make.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/gmake.1
98rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
99
100%find_lang %name
101
102%check
103echo ============TESTING===============
104/usr/bin/env LANG=C make check
105echo ============END TESTING===========
106
107
108%clean
109rm -rf ${RPM_BUILD_ROOT}
110
111%post
112/sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
113
114%preun
115if [ $1 = 0 ]; then
116   /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
117fi
118
119
120%files -f %{name}.lang
121%defattr(-,root,root)
122%doc NEWS README COPYING AUTHORS
123%{_bindir}/*
124%{_mandir}/man*/*
125%{_infodir}/*.info*
126%{_includedir}/gnumake.h
127
128%changelog
129* Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.2.1-1
130- new upstream release.
131- updated patches.
132- updated ja.po.
133
134* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
135- new upstream release.
136- dropped all patches.
137- imported patches from rawhide.
138- added Patch1000 to fix ja.po.
139
140* Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-2
141- rebuild with VineSeed environment
142
143* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
144- new upstream release
145
146* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
147- rebuild for Vine6
148
149* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
150- applied new versioning policy
151- added BuildRequires: perl (for %%check)
152- spec in UTF-8
153
154* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
155- updated to 3.81 based on Fedora packages
156  * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
157  - Always run testsuite with C locale.
158  - Resolves: #232607
159  * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
160  - Fix newline handling for quoted SHELL.
161  - Resolves: #219409
162  * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
163  - Upstream 3.81:
164    - Contains several backwards incompatible changes.  See NEWS inside
165      the source package to find out more.
166  - memory patch and error reporting patch were ported to this version.
167- updated ja.po
168
169* Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
170- added URL
171- s/Copyright/License/
172- added some patches from fedora development 3.80-8
173  * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
174  - make sure errno for error reporting is not lost accross _() calls
175  - report EOF on read pipe differently from read returning < 0 reporting
176  * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
177  - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
178  * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
179  - add important bug-fixes from make home-page
180
181* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
182- some patches was included from 3.79.1-17
183
184* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
185- update ja.po
186
187* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
188- new upstream release
189
190* Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
191- 3.79.1-5vl1
192- based on 3.79.1-5 from Rawhide
193- rebuilt for Vine Linux
194- added Japanese summary and description
195
196* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
197- change info-dir entry so that 'info make' works (#15029).
198
199* Tue Aug  1 2000 Jakub Jelinek <jakub@redhat.com>
200- assume we don't have clock_gettime in configure, so that
201  make is not linked against -lpthread (and thus does not
202  limit stack to 2MB).
203
204* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
205- add locale files (#14362).
206
207* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
208- automatic rebuild
209
210* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
211- 3.79.1 bugfix release
212
213* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
214- FHS packaging.
215
216* Sun May  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
217- Fix build for some odd situations, such as
218  - previously installed make != GNU make
219  - /bin/sh != bash
220
221* Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
222- update to 3.79
223
224* Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
225- add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
226  builds)
227
228* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
229- compress man page.
230
231* Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
232- apply patch to fix a /tmp race condition from Thomas Biege
233- simplify %install
234
235* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
236- update to 3.78.1.
237
238* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
239- added a serial tag so it upgrades right
240
241* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
242- auto rebuild in the new build environment (release 5)
243
244* Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
245- added a patch for large file support in glob
246 
247* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
248- update to 3.77
249
250* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
251- translations modified for de, fr, tr
252
253* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
254- udpated from 3.75 to 3.76
255- various spec file cleanups
256- added install-info support
257
258* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
259- built against glibc
Note: See TracBrowser for help on using the repository browser.