source: projects/specs/trunk/m/make/make-vl.spec @ 10332

Revision 10332, 7.6 KB checked in by tomop, 8 years ago (diff)

make-4.1-1

Line 
1Summary:     A GNU tool which simplifies the build process for users.
2Summary(ja): ユーザのビルド手続きを平易にする GNU ツール
3Name: make
4Epoch: 1
5Version: 4.1
6Release: 1%{?_dist_release}
7License: GPL
8Group: Development/Tools
9URL: http://www.gnu.org/software/make/
10Source: ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
11
12Patch0: make-4.0-getcwd.patch
13Patch1: make-4.0-newlines.patch
14
15# Assume we don't have clock_gettime in configure, so that
16# make is not linked against -lpthread (and thus does not
17# limit stack to 2MB).
18Patch2: make-4.0-noclock_gettime.patch
19
20# BZs #142691, #17374
21Patch3: make-4.0-j8k.patch
22
23# make sure errno for error reporting is not lost accross _() calls
24Patch4: make-4.0-err-reporting.patch
25
26# Upstream: https://savannah.gnu.org/bugs/?30748
27# The default value of .SHELL_FLAGS is -c.
28Patch5: make-4.0-weird-shell.patch
29
30# make seg faults when run with no arguments
31Patch6: make-4.1-rh1277968.patch
32
33# fix ja.po
34Patch1000: make-4.1-ja.po.patch
35
36Buildroot: %{_tmppath}/%{name}-%{version}-root
37Requires(post): /sbin/install-info
38Requires(preun): /sbin/install-info
39BuildRequires: automake >= 1.7.3
40BuildRequires: guile-devel
41BuildRequires: perl
42BuildRequires: procps
43BuildRequires: texinfo
44
45Vendor: Project Vine
46Distribution: Vine Linux
47
48%description
49A GNU tool for controlling the generation of executables and other
50non-source files of a program from the program's source files.  Make
51allows users to build and install packages without any significant
52knowledge about the details of the build process.  The details about
53how the program should be built are provided for make in the program's
54makefile.
55
56The GNU make tool should be installed on your system because it is
57commonly used to simplify the process of installing programs.
58
59
60%description -l ja
61プログラムのソースファイルから実行ファイル及びその他のファイルを
62生成する GNU ツールです.Make を使うことでユーザは build 時の
63細かいプロセスを気にせず build しインストールすることが出来ます.
64プログラムがどの様に build されるのかは,プログラムの Makefile に
65書かれています.
66
67GNU make ツールは,プログラムのインストールを容易にするのに
68非常によく使われますので,このパッケージは是非インストールして下さい.
69
70%prep
71%setup -q
72
73%patch0 -p1
74%patch1 -p1
75%patch2 -p1
76%patch3 -p1
77%patch4 -p1
78%patch5 -p1
79%patch6 -p1
80
81rm -f tests/scripts/features/parallelism.orig
82
83%patch1000 -p1 -b .po
84
85%build
86%if %{?_dist_release} == "vl6"
87%configure
88%else
89%configure --with-guile
90%endif
91make %{?_smp_mflags}
92
93%install
94rm -rf ${RPM_BUILD_ROOT}
95make DESTDIR=$RPM_BUILD_ROOT install
96ln -sf make ${RPM_BUILD_ROOT}/%{_bindir}/gmake
97ln -sf make.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/gmake.1
98rm -f ${RPM_BUILD_ROOT}/%{_infodir}/dir
99
100%find_lang %name
101
102%check
103echo ============TESTING===============
104/usr/bin/env LANG=C make check
105echo ============END TESTING===========
106
107
108%clean
109rm -rf ${RPM_BUILD_ROOT}
110
111%post
112/sbin/install-info %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
113
114%preun
115if [ $1 = 0 ]; then
116   /sbin/install-info --delete %{_infodir}/make.info.gz %{_infodir}/dir --entry="* Make: (make).                 The GNU make utility." || :
117fi
118
119
120%files -f %{name}.lang
121%defattr(-,root,root)
122%doc NEWS README COPYING AUTHORS
123%{_bindir}/*
124%{_mandir}/man*/*
125%{_infodir}/*.info*
126%{_includedir}/gnumake.h
127
128%changelog
129* Wed May 25 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.1-1
130- new upstream release.
131- dropped all patches.
132- imported patches from rawhide.
133- added Patch1000 to fix ja.po.
134
135* Sun Feb 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.82-2
136- rebuild with VineSeed environment
137
138* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.82-1
139- new upstream release
140
141* Wed Apr 13 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 3.81-8
142- rebuild for Vine6
143
144* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-7
145- applied new versioning policy
146- added BuildRequires: perl (for %%check)
147- spec in UTF-8
148
149* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.81-6vl1
150- updated to 3.81 based on Fedora packages
151  * Fri Mar 16 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-6
152  - Always run testsuite with C locale.
153  - Resolves: #232607
154  * Thu Feb 22 2007 Petr Machata <pmachata@redhat.com> - 1:3.81-5
155  - Fix newline handling for quoted SHELL.
156  - Resolves: #219409
157  * Tue May 23 2006 Petr Machata <pmachata@redhat.com> - 1:3.81-1
158  - Upstream 3.81:
159    - Contains several backwards incompatible changes.  See NEWS inside
160      the source package to find out more.
161  - memory patch and error reporting patch were ported to this version.
162- updated ja.po
163
164* Tue Dec 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.80-0vl4
165- added URL
166- s/Copyright/License/
167- added some patches from fedora development 3.80-8
168  * Mon Aug 22 2005 Jakub Jelinek <jakub@redhat.com> 3.80-8
169  - make sure errno for error reporting is not lost accross _() calls
170  - report EOF on read pipe differently from read returning < 0 reporting
171  * Mon Dec 13 2004 Jakub Jelinek <jakub@redhat.com> 3.80-6
172  - refuse -jN where N is bigger than PIPE_BUF (#142691, #17374)
173  * Tue Dec 02 2003 Florian La Roche <Florian.LaRoche@redhat.de>
174  - add important bug-fixes from make home-page
175
176* Wed Apr 09 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.80-0vl3
177- some patches was included from 3.79.1-17
178
179* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl2
180- update ja.po
181
182* Wed Nov 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.80-0vl1
183- new upstream release
184
185* Fri Dec 22 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
186- 3.79.1-5vl1
187- based on 3.79.1-5 from Rawhide
188- rebuilt for Vine Linux
189- added Japanese summary and description
190
191* Mon Aug  7 2000 Tim Waugh <twaugh@redhat.com>
192- change info-dir entry so that 'info make' works (#15029).
193
194* Tue Aug  1 2000 Jakub Jelinek <jakub@redhat.com>
195- assume we don't have clock_gettime in configure, so that
196  make is not linked against -lpthread (and thus does not
197  limit stack to 2MB).
198
199* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
200- add locale files (#14362).
201
202* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
203- automatic rebuild
204
205* Sat Jun 24 2000 Preston Brown <pbrown@redhat.com>
206- 3.79.1 bugfix release
207
208* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
209- FHS packaging.
210
211* Sun May  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
212- Fix build for some odd situations, such as
213  - previously installed make != GNU make
214  - /bin/sh != bash
215
216* Mon Apr 17 2000 Florian La Roche <Florian.LaRoche@redhat.com>
217- update to 3.79
218
219* Thu Feb 24 2000 Cristian Gafton <gafton@redhat.com>
220- add patch from Andreas Jaeger to fix dtype lookups (for glibc 2.1.3
221  builds)
222
223* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
224- compress man page.
225
226* Fri Jan 21 2000 Cristian Gafton <gafton@redhat.com>
227- apply patch to fix a /tmp race condition from Thomas Biege
228- simplify %install
229
230* Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
231- update to 3.78.1.
232
233* Thu Apr 15 1999 Bill Nottingham <notting@redhat.com>
234- added a serial tag so it upgrades right
235
236* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
237- auto rebuild in the new build environment (release 5)
238
239* Wed Sep 16 1998 Cristian Gafton <gafton@redhat.com>
240- added a patch for large file support in glob
241 
242* Tue Aug 18 1998 Jeff Johnson <jbj@redhat.com>
243- update to 3.77
244
245* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
246- translations modified for de, fr, tr
247
248* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
249- udpated from 3.75 to 3.76
250- various spec file cleanups
251- added install-info support
252
253* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
254- built against glibc
Note: See TracBrowser for help on using the repository browser.