source: projects/specs/trunk/lib/libx/libxslt/libxslt-vl.spec @ 8353

Revision 8353, 11.0 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library providing the Gnome XSLT engine
4Summary(ja): XSLT エンジンライブラリ
5Name: libxslt
6Version: 1.1.28
7Release: 1%{_dist_release}
8License: MIT
9Group: System Environment/Libraries
10URL: http://xmlsoft.org/XSLT/
11Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: libxml2-devel >= 2.6.27
15BuildRequires: zlib-devel >= 1.1.4
16BuildRequires: python python-devel perl libxml2-python
17Requires: libxml2 >= 2.6.27
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23This C library allows to transform XML files into other XML files
24(or HTML, text, ...) using the standard XSLT stylesheet transformation
25mechanism. To use it you need to have a version of libxml2 >= 2.6.15
26installed. The xsltproc command is a command line interface to the XSLT engine
27
28%description -l ja
29XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
30
31%package devel
32Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
33Summary(ja): XSLT 開発用ファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: libxml2-devel >= 2.6.27
37
38%description devel
39This C library allows to transform XML files into other XML files
40(or HTML, text, ...) using the standard XSLT stylesheet transformation
41mechanism. To use it you need to have a version of libxml2 >= 2.6.15
42installed.
43
44%description devel -l ja
45XSLTのための開発用ファイルです。
46
47%package static
48Summary: Static library for %{name}
49Summary(ja): %{name} のスタティックライブラリ
50Group: Development/Libraries
51Requires: libxslt-devel = %{version}-%{release}
52
53%description static
54The libxslt-static package contains the static library for libxslt.
55
56%package python
57Summary: Python bindings for the libxslt library
58Group: Development/Libraries
59Requires: libxslt = %{version}-%{release}
60Requires: libxml2 >= 2.6.27
61Requires: python
62
63%description python
64The libxslt-python package contains a module that permits applications
65written in the Python programming language to use the interface
66supplied by the libxslt library to apply XSLT transformations.
67
68This library allows to parse sytlesheets, uses the libxml2-python
69to load and save XML and HTML files. Direct access to XPath and
70the XSLT transformation context are possible to extend the XSLT language
71with XPath functions written in Python.
72
73# compat32
74%package -n compat32-%{name}
75Summary: Library providing the Gnome XSLT engine
76Summary(ja): XSLT エンジンライブラリ
77Group: System Environment/Libraries
78Requires: %{name} = %{version}-%{release}
79Requires: compat32-libxml2 >= 2.6.27
80
81%description -n compat32-%{name}
82This C library allows to transform XML files into other XML files
83(or HTML, text, ...) using the standard XSLT stylesheet transformation
84mechanism. To use it you need to have a version of libxml2 >= 2.6.15
85installed. The xsltproc command is a command line interface to the XSLT engine
86
87%description -n compat32-%{name} -l ja
88XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
89
90%package -n compat32-%{name}-devel
91Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
92Summary(ja): XSLT 開発用ファイル
93Group: Development/Libraries
94Requires: %{name}-devel = %{version}-%{release}
95Requires: compat32-%{name} = %{version}-%{release}
96Requires: compat32-libxml2-devel >= 2.6.27
97
98%description -n compat32-%{name}-devel
99This C library allows to transform XML files into other XML files
100(or HTML, text, ...) using the standard XSLT stylesheet transformation
101mechanism. To use it you need to have a version of libxml2 >= 2.6.15
102installed.
103
104%description -n compat32-%{name}-devel -l ja
105XSLTのための開発用ファイルです。
106
107%prep
108%setup -q
109
110%build
111%configure --without-crypto
112make %{?_smp_mflags}
113
114%install
115[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
116
117make DESTDIR=$RPM_BUILD_ROOT install
118
119rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
120rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.{a,la}
121
122#
123# this is a bit ugly but tries to generate the bindings for all versions
124# of python installed
125#for i in %{prefix}/include/python*
126#do
127#    py_version=`echo $i | sed "s+%{prefix}/include/python++"`
128#    if test -x %{prefix}/bin/python$py_version
129#    then
130#        echo generating bindings for Python $py_version
131#        (cd python ; make clean ; \
132#         make PYTHON="%{prefix}/bin/python$py_version" \
133#              PYTHON_VERSION="$py_version"; \
134#         make PYTHON="%{prefix}/bin/python$py_version" \
135#              PYTHON_VERSION="$py_version" \
136#              prefix=$RPM_BUILD_ROOT%{prefix} \
137#              mandir=$RPM_BUILD_ROOT%{_mandir} install)
138#    fi
139#done
140
141%clean
142[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
143
144%post -p /sbin/ldconfig
145
146%postun -p /sbin/ldconfig
147
148%post -n compat32-%{name} -p /sbin/ldconfig
149
150%postun -n compat32-%{name} -p /sbin/ldconfig
151
152%files
153%defattr(-, root, root)
154%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
155%doc doc/*.html doc/html doc/tutorial doc/EXSLT
156%{_bindir}/xsltproc
157%{_libdir}/lib*.so.*
158%{_mandir}/man1/xsltproc.1*
159
160%files devel
161%defattr(-, root, root)
162%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
163%{_includedir}/*
164%{_libdir}/lib*.so
165%{_libdir}/*.sh
166%{_libdir}/pkgconfig/*.pc
167%{_bindir}/xslt-config
168%{_datadir}/aclocal/*.m4
169%{_mandir}/man3/*
170
171%files static
172%defattr(-, root, root)
173%{_libdir}/lib*.a
174
175%files python
176%defattr(-, root, root)
177%doc AUTHORS ChangeLog NEWS README Copyright FEATURES
178%doc python/TODO
179%doc python/libxsltclass.txt
180%doc python/tests/*.py
181%doc python/tests/*.xml
182%doc python/tests/*.xsl
183%{_libdir}/python*/site-packages/libxslt.py
184%{_libdir}/python*/site-packages/libxsltmod*
185
186# compat32
187%if %{build_compat32}
188%files -n compat32-%{name}
189%defattr(-, root, root)
190%{_libdir}/lib*.so.*
191
192%files -n compat32-%{name}-devel
193%defattr(-, root, root)
194%{_libdir}/lib*.so
195%{_libdir}/lib*.a
196%{_libdir}/*.sh
197%endif
198
199%changelog
200* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-1
201- update to 1.1.28
202
203* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-2
204- rebuild with VineSeed environment
205
206* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-1
207- new upstream release
208
209* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
210- rebuild with python-2.7.2
211
212* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
213- build with rpm-4.8.1-1 for pkg-config file
214
215* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
216- rebuilt with gcc-4.4.3-3 on ppc
217
218* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
219- removed %%{_libdir}/python*/site-packages/*.{a,la}
220
221* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
222- rebuild with python-2.6
223
224* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
225- rebuilt with new toolchain
226
227* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
228- new upstream release
229- split static libraries to subpackage
230
231* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
232- added compat32 package for x86_64 arch support
233
234* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
235- rebuilt with python-2.5.2
236
237* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
238- new upstream release
239- remove *.la file from devel package
240
241* Wed Oct  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
242- new upstream release
243
244* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
245- new upstream release
246- updated BuildRequires: libxml2-devel >= 2.6.27
247- updated Requires: libxml2 >= 2.6.27
248
249* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
250- added --libdir=%%{_libdir} to ./configure option
251
252* Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
253- new upstream release
254- updated libxml2 dependancy
255
256* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
257- new upstream release
258
259* Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
260- new upstream release
261
262* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
263- rebuild with python-2.4.1-0vl1
264
265* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
266- build without libgcrypt (add --without-crypto to configure option)
267- remove lines about snapshot release
268- use %%makeinstall
269- add %%{_libdir}/python*/site-packages/libxsltmod* to python package
270
271* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
272- source upgrade (security fix)
273- BuildPrereq: libxml2-devel >= 2.6.15
274- Requires: libxml2 >= 2.6.15
275- add doc/EXSLT to %%doc
276
277* Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
278- new upstream version
279
280* Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
281- source upgrade
282- BuildPrereq: libxml2-devel >= 2.6.8
283- Requires: libxml2 >= 2.6.8
284
285* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
286- rebuild with python-2.3.3-0vl1
287
288* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
289- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
290
291* Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
292- new upstream release
293
294* Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
295- new upstream release
296- BuildPrereq: libxml2-devel >= 2.6.3
297- Requires: libxml2 >= 2.6.3
298
299* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
300- new upstream release
301
302* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
303- source upgrade
304
305* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
306- source upgrade
307
308* Mon Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
309- source upgrade
310- BuildPrereq: libxml2-devel >= 2.5.2
311- Requires: libxml2 >= 2.5.2
312
313* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
314- source upgrade
315- build with new toolchains
316
317* Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
318- source update to 1.0.22
319- BuildPrereq: libxml2-devel >= 2.4.23
320- Requires: libxml2 >= 2.4.23
321
322* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
323- merged with 1.0.17-1
324 -- Fri Feb  8 2002 Daniel.Veillard <veillard@redhat.com>
325  - added the python module
326- clean up spec
327- BuildPrereq: libxml2-devel >= 2.4.17
328- Requires: libxml2 >= 2.4.17
329
330* Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
331- changed License to MIT (not LGPL)
332- add BuildPrereq: zlib-devel >= 1.1.4 perl
333
334* Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
335- source update
336- BuildPrereq: libxml2-devel >= 2.4.13
337
338* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
339- add gtk-doc to BuildPrereq
340
341* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
342- 1.0.1-1vl2
343- Build for VineSeed
344
345* Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
346- 1.0.1-1vl1
347- cleaning
348
349* Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
350- 1.0.1-1vl0
351- modify for Vine Linux 2.1x
352
353* Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
354- created based on libxml2 spec file
Note: See TracBrowser for help on using the repository browser.