source: projects/specs/trunk/lib/libx/libxslt/libxslt-vl.spec @ 8084

Revision 8084, 10.9 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Library providing the Gnome XSLT engine
4Summary(ja): XSLT エンジンライブラリ
5Name: libxslt
6Version: 1.1.27
7Release: 2%{_dist_release}
8License: MIT
9Group: System Environment/Libraries
10URL: http://xmlsoft.org/XSLT/
11Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: libxml2-devel >= 2.6.27
15BuildRequires: zlib-devel >= 1.1.4
16BuildRequires: python python-devel perl libxml2-python
17Requires: libxml2 >= 2.6.27
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23This C library allows to transform XML files into other XML files
24(or HTML, text, ...) using the standard XSLT stylesheet transformation
25mechanism. To use it you need to have a version of libxml2 >= 2.6.15
26installed. The xsltproc command is a command line interface to the XSLT engine
27
28%description -l ja
29XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
30
31%package devel
32Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
33Summary(ja): XSLT 開発用ファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36Requires: libxml2-devel >= 2.6.27
37
38%description devel
39This C library allows to transform XML files into other XML files
40(or HTML, text, ...) using the standard XSLT stylesheet transformation
41mechanism. To use it you need to have a version of libxml2 >= 2.6.15
42installed.
43
44%description devel -l ja
45XSLTのための開発用ファイルです。
46
47%package static
48Summary: Static library for %{name}
49Summary(ja): %{name} のスタティックライブラリ
50Group: Development/Libraries
51Requires: libxslt-devel = %{version}-%{release}
52
53%description static
54The libxslt-static package contains the static library for libxslt.
55
56%package python
57Summary: Python bindings for the libxslt library
58Group: Development/Libraries
59Requires: libxslt = %{version}-%{release}
60Requires: libxml2 >= 2.6.27
61Requires: python
62
63%description python
64The libxslt-python package contains a module that permits applications
65written in the Python programming language to use the interface
66supplied by the libxslt library to apply XSLT transformations.
67
68This library allows to parse sytlesheets, uses the libxml2-python
69to load and save XML and HTML files. Direct access to XPath and
70the XSLT transformation context are possible to extend the XSLT language
71with XPath functions written in Python.
72
73# compat32
74%package -n compat32-%{name}
75Summary: Library providing the Gnome XSLT engine
76Summary(ja): XSLT エンジンライブラリ
77Group: System Environment/Libraries
78Requires: %{name} = %{version}-%{release}
79Requires: compat32-libxml2 >= 2.6.27
80
81%description -n compat32-%{name}
82This C library allows to transform XML files into other XML files
83(or HTML, text, ...) using the standard XSLT stylesheet transformation
84mechanism. To use it you need to have a version of libxml2 >= 2.6.15
85installed. The xsltproc command is a command line interface to the XSLT engine
86
87%description -n compat32-%{name} -l ja
88XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
89
90%package -n compat32-%{name}-devel
91Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
92Summary(ja): XSLT 開発用ファイル
93Group: Development/Libraries
94Requires: %{name}-devel = %{version}-%{release}
95Requires: compat32-%{name} = %{version}-%{release}
96Requires: compat32-libxml2-devel >= 2.6.27
97
98%description -n compat32-%{name}-devel
99This C library allows to transform XML files into other XML files
100(or HTML, text, ...) using the standard XSLT stylesheet transformation
101mechanism. To use it you need to have a version of libxml2 >= 2.6.15
102installed.
103
104%description -n compat32-%{name}-devel -l ja
105XSLTのための開発用ファイルです。
106
107%prep
108%setup -q
109
110%build
111%configure --without-crypto
112make %{?_smp_mflags}
113
114%install
115[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
116
117make DESTDIR=$RPM_BUILD_ROOT install
118
119rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
120rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.{a,la}
121
122#
123# this is a bit ugly but tries to generate the bindings for all versions
124# of python installed
125#for i in %{prefix}/include/python*
126#do
127#    py_version=`echo $i | sed "s+%{prefix}/include/python++"`
128#    if test -x %{prefix}/bin/python$py_version
129#    then
130#        echo generating bindings for Python $py_version
131#        (cd python ; make clean ; \
132#         make PYTHON="%{prefix}/bin/python$py_version" \
133#              PYTHON_VERSION="$py_version"; \
134#         make PYTHON="%{prefix}/bin/python$py_version" \
135#              PYTHON_VERSION="$py_version" \
136#              prefix=$RPM_BUILD_ROOT%{prefix} \
137#              mandir=$RPM_BUILD_ROOT%{_mandir} install)
138#    fi
139#done
140
141%clean
142[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
143
144%post -p /sbin/ldconfig
145
146%postun -p /sbin/ldconfig
147
148%post -n compat32-%{name} -p /sbin/ldconfig
149
150%postun -n compat32-%{name} -p /sbin/ldconfig
151
152%files
153%defattr(-, root, root)
154%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
155%doc doc/*.html doc/html doc/tutorial doc/EXSLT
156%{_bindir}/xsltproc
157%{_libdir}/lib*.so.*
158%{_mandir}/man1/xsltproc.1*
159
160%files devel
161%defattr(-, root, root)
162%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
163%{_includedir}/*
164%{_libdir}/lib*.so
165%{_libdir}/*.sh
166%{_libdir}/pkgconfig/*.pc
167%{_bindir}/xslt-config
168%{_datadir}/aclocal/*.m4
169%{_mandir}/man3/*
170
171%files static
172%defattr(-, root, root)
173%{_libdir}/lib*.a
174
175%files python
176%defattr(-, root, root)
177%doc AUTHORS ChangeLog NEWS README Copyright FEATURES
178%doc python/TODO
179%doc python/libxsltclass.txt
180%doc python/tests/*.py
181%doc python/tests/*.xml
182%doc python/tests/*.xsl
183%{_libdir}/python*/site-packages/libxslt.py
184%{_libdir}/python*/site-packages/libxsltmod*
185
186# compat32
187%if %{build_compat32}
188%files -n compat32-%{name}
189%defattr(-, root, root)
190%{_libdir}/lib*.so.*
191
192%files -n compat32-%{name}-devel
193%defattr(-, root, root)
194%{_libdir}/lib*.so
195%{_libdir}/lib*.a
196%{_libdir}/*.sh
197%endif
198
199%changelog
200* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-2
201- rebuild with VineSeed environment
202
203* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-1
204- new upstream release
205
206* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
207- rebuild with python-2.7.2
208
209* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
210- build with rpm-4.8.1-1 for pkg-config file
211
212* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
213- rebuilt with gcc-4.4.3-3 on ppc
214
215* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
216- removed %%{_libdir}/python*/site-packages/*.{a,la}
217
218* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
219- rebuild with python-2.6
220
221* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
222- rebuilt with new toolchain
223
224* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
225- new upstream release
226- split static libraries to subpackage
227
228* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
229- added compat32 package for x86_64 arch support
230
231* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
232- rebuilt with python-2.5.2
233
234* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
235- new upstream release
236- remove *.la file from devel package
237
238* Wed Oct  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
239- new upstream release
240
241* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
242- new upstream release
243- updated BuildRequires: libxml2-devel >= 2.6.27
244- updated Requires: libxml2 >= 2.6.27
245
246* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
247- added --libdir=%%{_libdir} to ./configure option
248
249* Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
250- new upstream release
251- updated libxml2 dependancy
252
253* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
254- new upstream release
255
256* Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
257- new upstream release
258
259* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
260- rebuild with python-2.4.1-0vl1
261
262* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
263- build without libgcrypt (add --without-crypto to configure option)
264- remove lines about snapshot release
265- use %%makeinstall
266- add %%{_libdir}/python*/site-packages/libxsltmod* to python package
267
268* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
269- source upgrade (security fix)
270- BuildPrereq: libxml2-devel >= 2.6.15
271- Requires: libxml2 >= 2.6.15
272- add doc/EXSLT to %%doc
273
274* Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
275- new upstream version
276
277* Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
278- source upgrade
279- BuildPrereq: libxml2-devel >= 2.6.8
280- Requires: libxml2 >= 2.6.8
281
282* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
283- rebuild with python-2.3.3-0vl1
284
285* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
286- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
287
288* Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
289- new upstream release
290
291* Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
292- new upstream release
293- BuildPrereq: libxml2-devel >= 2.6.3
294- Requires: libxml2 >= 2.6.3
295
296* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
297- new upstream release
298
299* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
300- source upgrade
301
302* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
303- source upgrade
304
305* Mon Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
306- source upgrade
307- BuildPrereq: libxml2-devel >= 2.5.2
308- Requires: libxml2 >= 2.5.2
309
310* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
311- source upgrade
312- build with new toolchains
313
314* Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
315- source update to 1.0.22
316- BuildPrereq: libxml2-devel >= 2.4.23
317- Requires: libxml2 >= 2.4.23
318
319* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
320- merged with 1.0.17-1
321 -- Fri Feb  8 2002 Daniel.Veillard <veillard@redhat.com>
322  - added the python module
323- clean up spec
324- BuildPrereq: libxml2-devel >= 2.4.17
325- Requires: libxml2 >= 2.4.17
326
327* Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
328- changed License to MIT (not LGPL)
329- add BuildPrereq: zlib-devel >= 1.1.4 perl
330
331* Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
332- source update
333- BuildPrereq: libxml2-devel >= 2.4.13
334
335* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
336- add gtk-doc to BuildPrereq
337
338* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
339- 1.0.1-1vl2
340- Build for VineSeed
341
342* Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
343- 1.0.1-1vl1
344- cleaning
345
346* Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
347- 1.0.1-1vl0
348- modify for Vine Linux 2.1x
349
350* Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
351- created based on libxml2 spec file
Note: See TracBrowser for help on using the repository browser.