source: projects/specs/trunk/lib/libx/libxslt/libxslt-vl.spec @ 11328

Revision 11328, 11.3 KB checked in by tomop, 6 years ago (diff)

libxslt-1.1.32-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary: Library providing the Gnome XSLT engine
5Summary(ja): XSLT エンジンライブラリ
6Name: libxslt
7Version: 1.1.32
8Release: 1%{_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://xmlsoft.org/XSLT/
12Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libxml2-devel >= 2.6.27
16BuildRequires: zlib-devel >= 1.1.4
17BuildRequires: python python-devel perl libxml2-python
18Requires: libxml2 >= 2.6.27
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24This C library allows to transform XML files into other XML files
25(or HTML, text, ...) using the standard XSLT stylesheet transformation
26mechanism. To use it you need to have a version of libxml2 >= 2.6.15
27installed. The xsltproc command is a command line interface to the XSLT engine
28
29%description -l ja
30XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
31
32%package devel
33Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
34Summary(ja): XSLT 開発用ファイル
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: libxml2-devel >= 2.6.27
38
39%description devel
40This C library allows to transform XML files into other XML files
41(or HTML, text, ...) using the standard XSLT stylesheet transformation
42mechanism. To use it you need to have a version of libxml2 >= 2.6.15
43installed.
44
45%description devel -l ja
46XSLTのための開発用ファイルです。
47
48%package static
49Summary: Static library for %{name}
50Summary(ja): %{name} のスタティックライブラリ
51Group: Development/Libraries
52Requires: libxslt-devel = %{version}-%{release}
53
54%description static
55The libxslt-static package contains the static library for libxslt.
56
57%package python
58Summary: Python bindings for the libxslt library
59Group: Development/Libraries
60Requires: libxslt = %{version}-%{release}
61Requires: libxml2 >= 2.6.27
62Requires: python
63
64%description python
65The libxslt-python package contains a module that permits applications
66written in the Python programming language to use the interface
67supplied by the libxslt library to apply XSLT transformations.
68
69This library allows to parse sytlesheets, uses the libxml2-python
70to load and save XML and HTML files. Direct access to XPath and
71the XSLT transformation context are possible to extend the XSLT language
72with XPath functions written in Python.
73
74# compat32
75%package -n compat32-%{name}
76Summary: Library providing the Gnome XSLT engine
77Summary(ja): XSLT エンジンライブラリ
78Group: System Environment/Libraries
79Requires: %{name} = %{version}-%{release}
80Requires: compat32-libxml2 >= 2.6.27
81
82%description -n compat32-%{name}
83This C library allows to transform XML files into other XML files
84(or HTML, text, ...) using the standard XSLT stylesheet transformation
85mechanism. To use it you need to have a version of libxml2 >= 2.6.15
86installed. The xsltproc command is a command line interface to the XSLT engine
87
88%description -n compat32-%{name} -l ja
89XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
90
91%package -n compat32-%{name}-devel
92Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
93Summary(ja): XSLT 開発用ファイル
94Group: Development/Libraries
95Requires: %{name}-devel = %{version}-%{release}
96Requires: compat32-%{name} = %{version}-%{release}
97Requires: compat32-libxml2-devel >= 2.6.27
98
99%description -n compat32-%{name}-devel
100This C library allows to transform XML files into other XML files
101(or HTML, text, ...) using the standard XSLT stylesheet transformation
102mechanism. To use it you need to have a version of libxml2 >= 2.6.15
103installed.
104
105%description -n compat32-%{name}-devel -l ja
106XSLTのための開発用ファイルです。
107
108%prep
109%setup -q
110
111%build
112%configure --without-crypto
113make %{?_smp_mflags}
114
115%install
116[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
117
118make DESTDIR=$RPM_BUILD_ROOT install
119
120rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
121rm -f $RPM_BUILD_ROOT%{_libdir}/python*/site-packages/*.{a,la}
122
123#
124# this is a bit ugly but tries to generate the bindings for all versions
125# of python installed
126#for i in %{prefix}/include/python*
127#do
128#    py_version=`echo $i | sed "s+%{prefix}/include/python++"`
129#    if test -x %{prefix}/bin/python$py_version
130#    then
131#        echo generating bindings for Python $py_version
132#        (cd python ; make clean ; \
133#         make PYTHON="%{prefix}/bin/python$py_version" \
134#              PYTHON_VERSION="$py_version"; \
135#         make PYTHON="%{prefix}/bin/python$py_version" \
136#              PYTHON_VERSION="$py_version" \
137#              prefix=$RPM_BUILD_ROOT%{prefix} \
138#              mandir=$RPM_BUILD_ROOT%{_mandir} install)
139#    fi
140#done
141
142%clean
143[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
144
145%post -p /sbin/ldconfig
146
147%postun -p /sbin/ldconfig
148
149%post -n compat32-%{name} -p /sbin/ldconfig
150
151%postun -n compat32-%{name} -p /sbin/ldconfig
152
153%files
154%defattr(-, root, root)
155%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
156%doc doc/*.html doc/html doc/tutorial doc/EXSLT
157%{_bindir}/xsltproc
158%{_libdir}/lib*.so.*
159%{_mandir}/man1/xsltproc.1*
160
161%files devel
162%defattr(-, root, root)
163%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
164%{_includedir}/*
165%{_libdir}/lib*.so
166%{_libdir}/*.sh
167%{_libdir}/pkgconfig/*.pc
168%{_bindir}/xslt-config
169%{_datadir}/aclocal/*.m4
170%{_mandir}/man3/*
171
172%files static
173%defattr(-, root, root)
174%{_libdir}/lib*.a
175
176%files python
177%defattr(-, root, root)
178%doc AUTHORS ChangeLog NEWS README Copyright FEATURES
179%doc python/TODO
180%doc python/libxsltclass.txt
181%doc python/tests/*.py
182%doc python/tests/*.xml
183%doc python/tests/*.xsl
184%{_libdir}/python*/site-packages/libxslt.py
185%{_libdir}/python*/site-packages/libxsltmod*
186
187# compat32
188%if %{build_compat32}
189%files -n compat32-%{name}
190%defattr(-, root, root)
191%{_libdir}/lib*.so.*
192
193%files -n compat32-%{name}-devel
194%defattr(-, root, root)
195%{_libdir}/lib*.so
196%{_libdir}/lib*.a
197%{_libdir}/*.sh
198%endif
199
200%changelog
201* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.32-1
202- updated to 1.1.32.
203
204* Wed Jun  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
205- updated to 1.1.29.
206- dropped Patch0.
207
208* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-2
209- add Patch0 (libxslt-1.1.28-CVE-2015-7995.patch)
210
211* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-1
212- update to 1.1.28
213
214* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-2
215- rebuild with VineSeed environment
216
217* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-1
218- new upstream release
219
220* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
221- rebuild with python-2.7.2
222
223* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
224- build with rpm-4.8.1-1 for pkg-config file
225
226* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
227- rebuilt with gcc-4.4.3-3 on ppc
228
229* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
230- removed %%{_libdir}/python*/site-packages/*.{a,la}
231
232* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
233- rebuild with python-2.6
234
235* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
236- rebuilt with new toolchain
237
238* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
239- new upstream release
240- split static libraries to subpackage
241
242* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
243- added compat32 package for x86_64 arch support
244
245* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
246- rebuilt with python-2.5.2
247
248* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
249- new upstream release
250- remove *.la file from devel package
251
252* Wed Oct  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
253- new upstream release
254
255* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
256- new upstream release
257- updated BuildRequires: libxml2-devel >= 2.6.27
258- updated Requires: libxml2 >= 2.6.27
259
260* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
261- added --libdir=%%{_libdir} to ./configure option
262
263* Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
264- new upstream release
265- updated libxml2 dependancy
266
267* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
268- new upstream release
269
270* Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
271- new upstream release
272
273* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
274- rebuild with python-2.4.1-0vl1
275
276* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
277- build without libgcrypt (add --without-crypto to configure option)
278- remove lines about snapshot release
279- use %%makeinstall
280- add %%{_libdir}/python*/site-packages/libxsltmod* to python package
281
282* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
283- source upgrade (security fix)
284- BuildPrereq: libxml2-devel >= 2.6.15
285- Requires: libxml2 >= 2.6.15
286- add doc/EXSLT to %%doc
287
288* Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
289- new upstream version
290
291* Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
292- source upgrade
293- BuildPrereq: libxml2-devel >= 2.6.8
294- Requires: libxml2 >= 2.6.8
295
296* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
297- rebuild with python-2.3.3-0vl1
298
299* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
300- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
301
302* Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
303- new upstream release
304
305* Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
306- new upstream release
307- BuildPrereq: libxml2-devel >= 2.6.3
308- Requires: libxml2 >= 2.6.3
309
310* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
311- new upstream release
312
313* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
314- source upgrade
315
316* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
317- source upgrade
318
319* Mon Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
320- source upgrade
321- BuildPrereq: libxml2-devel >= 2.5.2
322- Requires: libxml2 >= 2.5.2
323
324* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
325- source upgrade
326- build with new toolchains
327
328* Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
329- source update to 1.0.22
330- BuildPrereq: libxml2-devel >= 2.4.23
331- Requires: libxml2 >= 2.4.23
332
333* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
334- merged with 1.0.17-1
335 -- Fri Feb  8 2002 Daniel.Veillard <veillard@redhat.com>
336  - added the python module
337- clean up spec
338- BuildPrereq: libxml2-devel >= 2.4.17
339- Requires: libxml2 >= 2.4.17
340
341* Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
342- changed License to MIT (not LGPL)
343- add BuildPrereq: zlib-devel >= 1.1.4 perl
344
345* Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
346- source update
347- BuildPrereq: libxml2-devel >= 2.4.13
348
349* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
350- add gtk-doc to BuildPrereq
351
352* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
353- 1.0.1-1vl2
354- Build for VineSeed
355
356* Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
357- 1.0.1-1vl1
358- cleaning
359
360* Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
361- 1.0.1-1vl0
362- modify for Vine Linux 2.1x
363
364* Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
365- created based on libxml2 spec file
Note: See TracBrowser for help on using the repository browser.