source: projects/specs/trunk/lib/libx/libxslt/libxslt-vl.spec @ 12087

Revision 12087, 12.8 KB checked in by tomop, 5 years ago (diff)

libxslt-1.1.33-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define _unpackaged_files_terminate_build 1
3
4Summary: Library providing the Gnome XSLT engine
5Summary(ja): XSLT エンジンライブラリ
6Name: libxslt
7Version: 1.1.33
8Release: 1%{_dist_release}
9License: MIT
10Group: System Environment/Libraries
11URL: http://xmlsoft.org/XSLT/
12Source0: ftp://xmlsoft.org/XSLT/%{name}-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: libtirpc-devel
16BuildRequires: libxcrypt-devel
17BuildRequires: libxml2-devel >= 2.9.9
18BuildRequires: zlib-devel >= 1.1.4
19BuildRequires: perl
20BuildRequires: python python-devel python-rpm-macros libxml2-python
21%if %{with python3}
22BuildRequires: python3 python3-devel python3-rpm-macros python3-libxml2
23%endif
24Requires: libxml2 >= 2.9.9
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29%description
30This C library allows to transform XML files into other XML files
31(or HTML, text, ...) using the standard XSLT stylesheet transformation
32mechanism. To use it you need to have a version of libxml2 >= 2.6.15
33installed. The xsltproc command is a command line interface to the XSLT engine
34
35%description -l ja
36XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
37
38%package devel
39Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
40Summary(ja): XSLT 開発用ファイル
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43Requires: libxml2-devel >= 2.6.27
44
45%description devel
46This C library allows to transform XML files into other XML files
47(or HTML, text, ...) using the standard XSLT stylesheet transformation
48mechanism. To use it you need to have a version of libxml2 >= 2.6.15
49installed.
50
51%description devel -l ja
52XSLTのための開発用ファイルです。
53
54%package static
55Summary: Static library for %{name}
56Summary(ja): %{name} のスタティックライブラリ
57Group: Development/Libraries
58Requires: libxslt-devel = %{version}-%{release}
59
60%description static
61The libxslt-static package contains the static library for libxslt.
62
63%package python
64Summary: Python bindings for the libxslt library
65Group: Development/Libraries
66Requires: libxslt = %{version}-%{release}
67Requires: libxml2 >= 2.9.9
68Requires: python
69
70%description python
71The libxslt-python package contains a module that permits applications
72written in the Python programming language to use the interface
73supplied by the libxslt library to apply XSLT transformations.
74
75This library allows to parse sytlesheets, uses the libxml2-python
76to load and save XML and HTML files. Direct access to XPath and
77the XSLT transformation context are possible to extend the XSLT language
78with XPath functions written in Python.
79
80%if %{with python3}
81%package -n python3-%{name}
82Summary: Python bindings for the libxslt library
83Group: Development/Libraries
84Requires: libxslt = %{version}-%{release}
85Requires: libxml2 >= 2.9.9
86Requires: python3
87
88%description -n python3-%{name}
89The libxslt-python package contains a module that permits applications
90written in the Python programming language to use the interface
91supplied by the libxslt library to apply XSLT transformations.
92
93This library allows to parse sytlesheets, uses the libxml2-python
94to load and save XML and HTML files. Direct access to XPath and
95the XSLT transformation context are possible to extend the XSLT language
96with XPath functions written in Python.
97
98%endif
99
100# compat32
101%package -n compat32-%{name}
102Summary: Library providing the Gnome XSLT engine
103Summary(ja): XSLT エンジンライブラリ
104Group: System Environment/Libraries
105Requires: %{name} = %{version}-%{release}
106Requires: compat32-libxml2 >= 2.6.27
107
108%description -n compat32-%{name}
109This C library allows to transform XML files into other XML files
110(or HTML, text, ...) using the standard XSLT stylesheet transformation
111mechanism. To use it you need to have a version of libxml2 >= 2.6.15
112installed. The xsltproc command is a command line interface to the XSLT engine
113
114%description -n compat32-%{name} -l ja
115XSLTスタイルシートを使ってXML型式をHTML型式に変換するためのライブラリです。
116
117%package -n compat32-%{name}-devel
118Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
119Summary(ja): XSLT 開発用ファイル
120Group: Development/Libraries
121Requires: %{name}-devel = %{version}-%{release}
122Requires: compat32-%{name} = %{version}-%{release}
123Requires: compat32-libxml2-devel >= 2.6.27
124
125%description -n compat32-%{name}-devel
126This C library allows to transform XML files into other XML files
127(or HTML, text, ...) using the standard XSLT stylesheet transformation
128mechanism. To use it you need to have a version of libxml2 >= 2.6.15
129installed.
130
131%description -n compat32-%{name}-devel -l ja
132XSLTのための開発用ファイルです。
133
134%prep
135%setup -q
136chmod 644 python/tests/*
137
138%build
139perl -pi -e 's|sysconfig\.get_python_lib\(\)|sysconfig.get_python_lib(1)|' configure
140
141mkdir py2 py3
142%global _configure ../configure
143%global _configure_disable_silent_rules 1
144( export PYTHON_SITE_PACKAGES=%{python_sitearch}; cd py2 && %configure --without-crypto --cache-file=../config.cache --with-python=%{__python} )
145make %{?_smp_mflags} -C py2
146
147%if %{with python3}
148( cd py3 && %configure --without-crypto --cache-file=../config.cache --with-python=%{__python3} )
149make %{?_smp_mflags} -C py3
150%endif
151
152%install
153[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
154
155make install -C py2 DESTDIR=$RPM_BUILD_ROOT
156
157find %{buildroot}%{python_sitearch} -name '*.a' -print -delete
158
159%if %{with python3}
160make install -C py3 DESTDIR=$RPM_BUILD_ROOT
161find %{buildroot}%{python3_sitearch} -name '*.a' -print -delete
162%endif
163
164find %{buildroot} -name '*.la' -print -delete
165
166# multiarch crazyness on timestamp differences
167touch -m --reference=%{buildroot}%{_includedir}/libxslt/xslt.h %{buildroot}%{_bindir}/xslt-config
168rm -vrf %{buildroot}%{_docdir}
169
170%clean
171[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
172
173%post -p /sbin/ldconfig
174
175%postun -p /sbin/ldconfig
176
177%post -n compat32-%{name} -p /sbin/ldconfig
178
179%postun -n compat32-%{name} -p /sbin/ldconfig
180
181%files
182%defattr(-, root, root)
183%license Copyright
184%doc AUTHORS ChangeLog NEWS README TODO FEATURES
185%doc doc/*.html doc/html doc/tutorial doc/EXSLT
186%{_bindir}/xsltproc
187%{_libdir}/lib*.so.*
188%{_mandir}/man1/xsltproc.1*
189
190%files devel
191%defattr(-, root, root)
192%license Copyright
193%doc AUTHORS ChangeLog NEWS README TODO FEATURES
194%{_includedir}/*
195%{_libdir}/lib*.so
196%{_libdir}/*.sh
197%{_libdir}/pkgconfig/*.pc
198%{_bindir}/xslt-config
199%{_datadir}/aclocal/*.m4
200%{_mandir}/man3/*
201
202%files static
203%defattr(-, root, root)
204%{_libdir}/lib*.a
205
206%files python
207%defattr(-, root, root)
208%license Copyright
209%doc AUTHORS ChangeLog NEWS README FEATURES
210%doc python/TODO
211%doc python/libxsltclass.txt
212%doc python/tests/*.py
213%doc python/tests/*.xml
214%doc python/tests/*.xsl
215%{python_sitearch}/libxslt.py
216%{python_sitearch}/libxsltmod*
217
218%if %{with python3}
219%files -n python3-%{name}
220%defattr(-, root, root)
221%license Copyright
222%doc AUTHORS ChangeLog NEWS README FEATURES
223%doc python/TODO
224%doc python/libxsltclass.txt
225%doc python/tests/*.py
226%doc python/tests/*.xml
227%doc python/tests/*.xsl
228%{python3_sitearch}/libxslt.py
229%{python3_sitearch}/libxsltmod*
230%endif
231
232# compat32
233%if %{build_compat32}
234%files -n compat32-%{name}
235%defattr(-, root, root)
236%{_libdir}/lib*.so.*
237
238%files -n compat32-%{name}-devel
239%defattr(-, root, root)
240%{_libdir}/lib*.so
241%{_libdir}/lib*.a
242%{_libdir}/*.sh
243%endif
244
245%changelog
246* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.33-1
247- updated to 1.1.33.
248- added a sub-package "python3-libxslt".
249- added BR:libxcrypt-devel.
250- added BR:libtirpc-devel.
251
252* Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.32-1
253- updated to 1.1.32.
254
255* Wed Jun  8 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.29-1
256- updated to 1.1.29.
257- dropped Patch0.
258
259* Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-2
260- add Patch0 (libxslt-1.1.28-CVE-2015-7995.patch)
261
262* Sat Mar 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.28-1
263- update to 1.1.28
264
265* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-2
266- rebuild with VineSeed environment
267
268* Thu Sep 27 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.27-1
269- new upstream release
270
271* Thu Feb 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.26-7
272- rebuild with python-2.7.2
273
274* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.1.26-6
275- build with rpm-4.8.1-1 for pkg-config file
276
277* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-5
278- rebuilt with gcc-4.4.3-3 on ppc
279
280* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-4
281- removed %%{_libdir}/python*/site-packages/*.{a,la}
282
283* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.26-3
284- rebuild with python-2.6
285
286* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.1.26-2
287- rebuilt with new toolchain
288
289* Wed Jan 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.26-1
290- new upstream release
291- split static libraries to subpackage
292
293* Mon Jul 13 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.23-3
294- added compat32 package for x86_64 arch support
295
296* Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.23-2
297- rebuilt with python-2.5.2
298
299* Tue Apr 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.23-1
300- new upstream release
301- remove *.la file from devel package
302
303* Wed Oct  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.22-0vl1
304- new upstream release
305
306* Sun Feb  4 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-0vl1
307- new upstream release
308- updated BuildRequires: libxml2-devel >= 2.6.27
309- updated Requires: libxml2 >= 2.6.27
310
311* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.17-0vl1
312- added --libdir=%%{_libdir} to ./configure option
313
314* Fri Jul 14 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.17-0vl1
315- new upstream release
316- updated libxml2 dependancy
317
318* Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.15-0vl1
319- new upstream release
320
321* Tue Apr 12 2005 Satoshi MACHINO <machino@vinelinux.org> 1.1.14-0vl1
322- new upstream release
323
324* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 1.1.12-0vl3
325- rebuild with python-2.4.1-0vl1
326
327* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl2
328- build without libgcrypt (add --without-crypto to configure option)
329- remove lines about snapshot release
330- use %%makeinstall
331- add %%{_libdir}/python*/site-packages/libxsltmod* to python package
332
333* Thu Nov 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.12-0vl1
334- source upgrade (security fix)
335- BuildPrereq: libxml2-devel >= 2.6.15
336- Requires: libxml2 >= 2.6.15
337- add doc/EXSLT to %%doc
338
339* Tue Sep 07 2004 Satoshi MACHINO <machino@vinelinux.org> 1.1.9-0vl1
340- new upstream version
341
342* Tue Apr 27 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.6-0vl1
343- source upgrade
344- BuildPrereq: libxml2-devel >= 2.6.8
345- Requires: libxml2 >= 2.6.8
346
347* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl2
348- rebuild with python-2.3.3-0vl1
349
350* Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 1.1.4-0vl1.1
351- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
352
353* Thu Mar 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.4-0vl1
354- new upstream release
355
356* Thu Jan 29 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.2-0vl1
357- new upstream release
358- BuildPrereq: libxml2-devel >= 2.6.3
359- Requires: libxml2 >= 2.6.3
360
361* Fri Sep 05 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.32-0vl1
362- new upstream release
363
364* Sun Jul 20 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.31-0vl1
365- source upgrade
366
367* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.30-0vl1
368- source upgrade
369
370* Mon Feb 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.26-0vl1
371- source upgrade
372- BuildPrereq: libxml2-devel >= 2.5.2
373- Requires: libxml2 >= 2.5.2
374
375* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.23-0vl1
376- source upgrade
377- build with new toolchains
378
379* Tue Oct 29 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.22-0vl1
380- source update to 1.0.22
381- BuildPrereq: libxml2-devel >= 2.4.23
382- Requires: libxml2 >= 2.4.23
383
384* Sun May 26 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.17-1vl1
385- merged with 1.0.17-1
386 -- Fri Feb  8 2002 Daniel.Veillard <veillard@redhat.com>
387  - added the python module
388- clean up spec
389- BuildPrereq: libxml2-devel >= 2.4.17
390- Requires: libxml2 >= 2.4.17
391
392* Mon Mar 18 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl2
393- changed License to MIT (not LGPL)
394- add BuildPrereq: zlib-devel >= 1.1.4 perl
395
396* Sun Feb 24 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.10-0vl1
397- source update
398- BuildPrereq: libxml2-devel >= 2.4.13
399
400* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.0.9-0vl1
401- add gtk-doc to BuildPrereq
402
403* Thu Oct 11 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com>
404- 1.0.1-1vl2
405- Build for VineSeed
406
407* Fri Aug 24 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
408- 1.0.1-1vl1
409- cleaning
410
411* Fri Jul 27 2001 Tuscus Pino-potamus Japonus <ursragna@hotmail.com>
412- 1.0.1-1vl0
413- modify for Vine Linux 2.1x
414
415* Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
416- created based on libxml2 spec file
Note: See TracBrowser for help on using the repository browser.