source: projects/specs/trunk/lib/libx/libxfce4ui/libxfce4ui-vl.spec @ 8068

Revision 8068, 5.1 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%global xfceversion 4.10
2
3Name:           libxfce4ui
4Summary:        Commonly used Xfce widgets
5Version:        4.10.0
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://xfce.org/
11
12Source0:        http://archive.xfce.org/src/xfce/%{name}/%{xfceversion}/%{name}-%{version}.tar.bz2
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  gettext
16BuildRequires:  glib2-devel >= 2.12.0
17BuildRequires:  gtk-doc
18BuildRequires:  gtk2-devel >= 2.12.0
19BuildRequires:  intltool
20BuildRequires:  libSM-devel
21BuildRequires:  libxfce4util-devel >= %{xfceversion}
22BuildRequires:  startup-notification-devel >= 0.4
23BuildRequires:  xfconf-devel >= %{xfceversion}
24# FIXME: Enable libglade again one day
25#BuildRequires:  glade3-libgladeui-devel >= 3.5.0
26# FIXME: obsolete libxfcegui4 one day
27#Provides:       libxfcegui4 = %{version}
28#Obsoletes:      libxfcegui4 < %{version}
29
30Obsoletes:      xfce-utils < 4.9
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36Libxfce4ui is used to share commonly used Xfce widgets among the Xfce
37applications.
38
39%package        devel
40Summary:        Development files for %{name}
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       gtk2-devel
44Requires:       libxfce4util-devel
45# FIXME: Enable libglade again one day
46#Requires:       glade3-libgladeui-devel
47Requires:       pkgconfig
48# FIXME: obsolete libxfcegui4 one day
49#Provides:       libxfcegui4-devel = %{version}
50#Obsoletes:      libxfcegui4-devel < %{version}
51
52%description    devel
53The %{name}-devel package contains libraries and header files for
54developing applications that use %{name}.
55
56
57%prep
58%setup -q
59
60
61%build
62# FIXME: Enable libglade again one day
63%configure --enable-gtk-doc --disable-static --disable-gladeui
64# Remove rpaths
65sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
66sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
67
68# The LD_LIBRARY_PATH hack is needed for --enable-gtk-doc
69# because lt-libxfce4ui-scan is linked against libxfce4ui
70export LD_LIBRARY_PATH=$( pwd )/libxfce4ui/.libs
71
72make %{?_smp_mflags} V=1
73
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
78find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
79%find_lang %{name}
80
81
82%clean
83rm -rf $RPM_BUILD_ROOT
84
85
86%post
87/sbin/ldconfig
88touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
89gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
90update-desktop-database %{_datadir}/applications &> /dev/null || :
91
92%postun
93/sbin/ldconfig
94if [ $1 -eq 0 ]; then
95    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
96    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
97fi
98update-desktop-database %{_datadir}/applications &> /dev/null || :
99
100
101
102%files -f %{name}.lang
103%defattr(-,root,root,-)
104%doc AUTHORS COPYING NEWS README THANKS
105%config(noreplace) %{_sysconfdir}/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
106%{_bindir}/xfce4-about
107%{_libdir}/*.so.*
108%{_datadir}/applications/xfce4-about.desktop
109%{_datadir}/icons/hicolor/48x48/apps/xfce4-logo.png
110
111%files devel
112%defattr(-,root,root,-)
113%doc TODO
114%{_includedir}/*
115%{_libdir}/*.so
116%{_libdir}/pkgconfig/*.pc
117%doc %{_datadir}/gtk-doc/
118
119%changelog
120* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.10.0-2
121- rebuild with VineSeed environment
122
123* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.10.0-1
124- new upstream release
125- remove Patch0
126- add Obsoletes: xfce-utils < 4.9
127
128* Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.8.0-6
129- Initial build for Vine Linux
130
131* Wed Mar 16 2011 Christoph Wickert <cwickert@fedoraproject.org> - 4.8.0-5
132- Remove requirements for libxfcegui4-devel now that glade support was omitted
133
134* Tue Feb 22 2011 Rakesh Pandit <rakesh@fedoraproject.org> - 4.8.0-4
135- Disable glade as it still uses old API
136
137* Tue Feb 22 2011 Rakesh Pandit <rakesh@fedoraproject.org> - 4.8.0-3
138- Rebuild for new glade
139
140* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8.0-2
141- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
142
143* Sun Jan 16 2011 Kevin Fenzi <kevin@tummy.com> - 4.8.0-1
144- Update to 4.8.0 final.
145
146* Sun Jan 02 2011 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.6-1
147- Update to 4.7.6
148
149* Mon Nov 29 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.5-1
150- Update to 4.7.5
151
152* Mon Nov 08 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.4-1
153- Update to 4.7.4
154
155* Sun Sep 05 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.3-1
156- Update to 4.7.3
157- Drop dependency on gtk-doc (#604399)
158
159* Tue Jul 27 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.2-2
160- Fix file conflict with libxfce4gui (#618719)
161
162* Fri May 21 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.2-1
163- Update to 4.7.2
164
165* Wed May 19 2010 Kevin Fenzi <kevin@tummy.com> - 4.7.1-3
166- Rebuild for new glade version.
167
168* Tue Jan 12 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.1-2
169- Fix license tag
170- Build gtk-doc
171
172* Tue Jan 05 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.1-1
173- Initial spec file, based on libxfcegui4.spec
174
Note: See TracBrowser for help on using the repository browser.