source: projects/specs/trunk/lib/libx/libxfce4ui/libxfce4ui-vl.spec @ 6284

Revision 6284, 5.0 KB checked in by Takemikaduchi, 12 years ago (diff)

Xfce-4.10.0 + thunderbird-13.0

Line 
1%global xfceversion 4.10
2
3Name:           libxfce4ui
4Summary:        Commonly used Xfce widgets
5Version:        4.10.0
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        LGPLv2+
10URL:            http://xfce.org/
11
12Source0:        http://archive.xfce.org/src/xfce/%{name}/%{xfceversion}/%{name}-%{version}.tar.bz2
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  gettext
16BuildRequires:  glib2-devel >= 2.12.0
17BuildRequires:  gtk-doc
18BuildRequires:  gtk2-devel >= 2.12.0
19BuildRequires:  intltool
20BuildRequires:  libSM-devel
21BuildRequires:  libxfce4util-devel >= %{xfceversion}
22BuildRequires:  startup-notification-devel >= 0.4
23BuildRequires:  xfconf-devel >= %{xfceversion}
24# FIXME: Enable libglade again one day
25#BuildRequires:  glade3-libgladeui-devel >= 3.5.0
26# FIXME: obsolete libxfcegui4 one day
27#Provides:       libxfcegui4 = %{version}
28#Obsoletes:      libxfcegui4 < %{version}
29
30Obsoletes:      xfce-utils < 4.9
31
32%description
33Libxfce4ui is used to share commonly used Xfce widgets among the Xfce
34applications.
35
36%package        devel
37Summary:        Development files for %{name}
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       gtk2-devel
41Requires:       libxfce4util-devel
42# FIXME: Enable libglade again one day
43#Requires:       glade3-libgladeui-devel
44Requires:       pkgconfig
45# FIXME: obsolete libxfcegui4 one day
46#Provides:       libxfcegui4-devel = %{version}
47#Obsoletes:      libxfcegui4-devel < %{version}
48
49%description    devel
50The %{name}-devel package contains libraries and header files for
51developing applications that use %{name}.
52
53
54%prep
55%setup -q
56
57
58%build
59# FIXME: Enable libglade again one day
60%configure --enable-gtk-doc --disable-static --disable-gladeui
61# Remove rpaths
62sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
63sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
64
65# The LD_LIBRARY_PATH hack is needed for --enable-gtk-doc
66# because lt-libxfce4ui-scan is linked against libxfce4ui
67export LD_LIBRARY_PATH=$( pwd )/libxfce4ui/.libs
68
69make %{?_smp_mflags} V=1
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
75find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
76%find_lang %{name}
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%post
84/sbin/ldconfig
85touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
86gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
87update-desktop-database %{_datadir}/applications &> /dev/null || :
88
89%postun
90/sbin/ldconfig
91if [ $1 -eq 0 ]; then
92    touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
93    gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
94fi
95update-desktop-database %{_datadir}/applications &> /dev/null || :
96
97
98
99%files -f %{name}.lang
100%defattr(-,root,root,-)
101%doc AUTHORS COPYING NEWS README THANKS
102%config(noreplace) %{_sysconfdir}/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
103%{_bindir}/xfce4-about
104%{_libdir}/*.so.*
105%{_datadir}/applications/xfce4-about.desktop
106%{_datadir}/icons/hicolor/48x48/apps/xfce4-logo.png
107
108%files devel
109%defattr(-,root,root,-)
110%doc TODO
111%{_includedir}/*
112%{_libdir}/*.so
113%{_libdir}/pkgconfig/*.pc
114%doc %{_datadir}/gtk-doc/
115
116%changelog
117* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.10.0-1
118- new upstream release
119- remove Patch0
120- add Obsoletes: xfce-utils < 4.9
121
122* Mon Mar 28 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 4.8.0-6
123- Initial build for Vine Linux
124
125* Wed Mar 16 2011 Christoph Wickert <cwickert@fedoraproject.org> - 4.8.0-5
126- Remove requirements for libxfcegui4-devel now that glade support was omitted
127
128* Tue Feb 22 2011 Rakesh Pandit <rakesh@fedoraproject.org> - 4.8.0-4
129- Disable glade as it still uses old API
130
131* Tue Feb 22 2011 Rakesh Pandit <rakesh@fedoraproject.org> - 4.8.0-3
132- Rebuild for new glade
133
134* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8.0-2
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
136
137* Sun Jan 16 2011 Kevin Fenzi <kevin@tummy.com> - 4.8.0-1
138- Update to 4.8.0 final.
139
140* Sun Jan 02 2011 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.6-1
141- Update to 4.7.6
142
143* Mon Nov 29 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.5-1
144- Update to 4.7.5
145
146* Mon Nov 08 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.4-1
147- Update to 4.7.4
148
149* Sun Sep 05 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.3-1
150- Update to 4.7.3
151- Drop dependency on gtk-doc (#604399)
152
153* Tue Jul 27 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.2-2
154- Fix file conflict with libxfce4gui (#618719)
155
156* Fri May 21 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.2-1
157- Update to 4.7.2
158
159* Wed May 19 2010 Kevin Fenzi <kevin@tummy.com> - 4.7.1-3
160- Rebuild for new glade version.
161
162* Tue Jan 12 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.1-2
163- Fix license tag
164- Build gtk-doc
165
166* Tue Jan 05 2010 Christoph Wickert <cwickert@fedoraproject.org> - 4.7.1-1
167- Initial spec file, based on libxfcegui4.spec
168
Note: See TracBrowser for help on using the repository browser.