source: projects/specs/trunk/lib/libw/libwvstreams/libwvstreams-vl.spec @ 521

Revision 521, 6.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: WvStreams is a network programming library written in C++
2Summary: WvStreams - C++ で記述されたネットワークプログラミングライブラリ
3Name: libwvstreams
4Version: 4.4
5Release: 1%{?_dist_release}
6Source: http://wvstreams.googlecode.com/files/wvstreams-%{version}.tar.gz
7Patch1: wvstreams-4.2.2-multilib.patch
8URL: http://alumnit.ca/wiki/index.php?page=WvStreams
9Group: System Environment/Libraries
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11BuildRequires: openssl-devel, pkgconfig, zlib-devel, readline-devel
12License: LGPLv2+
13
14%description
15WvStreams aims to be an efficient, secure, and easy-to-use library for
16doing network applications development.
17
18%package devel
19Summary: Development files for WvStreams
20Group: Development/Libraries
21Requires: %{name} = %{version}-%{release}
22
23%description devel
24WvStreams aims to be an efficient, secure, and easy-to-use library for
25doing network applications development.  This package contains the files
26needed for developing applications which use WvStreams.
27
28%prep
29%setup -q -n wvstreams-%{version}
30%patch1 -p1 -b .multilib
31
32%build
33#  --with-fam              FAM
34#  --with-fftw             FFTW
35#  --with-bdb              Berkeley DB 1.x (or compatible)
36#  --with-gdbm             GDBM
37#  --with-ogg              Ogg
38#  --with-openssl          OpenSSL
39#  --with-pam              PAM
40#  --with-tcl              Tcl
41#  --with-swig             SWIG
42#  --with-qt               Qt
43#  --with-speex            Speex
44#  --with-vorbis           Vorbis
45#  --with-xplc             XPLC
46#  --with-zlib             zlib
47touch configure
48%configure --with-pam --with-openssl --without-fam --without-fftw --without-gdbm --without-pgg --without-tcl --without-swig --without-qt --without-speex --without-vorbis --with-xplc --disable-static
49
50make COPTS="$RPM_OPT_FLAGS -fPIC -fpermissive" CXXOPTS="$RPM_OPT_FLAGS -fPIC -fpermissive" VERBOSE=1
51
52%install
53rm -rf $RPM_BUILD_ROOT
54make install DESTDIR=$RPM_BUILD_ROOT
55chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so.*
56rm -fr $RPM_BUILD_ROOT/usr/bin
57
58pushd $RPM_BUILD_ROOT
59rm -f \
60   ./etc/uniconf.conf \
61   .%{_bindir}/uni \
62   .%{_libdir}/pkgconfig/liboggspeex.pc \
63   .%{_libdir}/pkgconfig/liboggvorbis.pc \
64   .%{_libdir}/pkgconfig/libwvfft.pc \
65   .%{_libdir}/pkgconfig/libwvqt.pc \
66   .%{_sbindir}/uniconfd \
67   .%{_mandir}/man8/uni.8* \
68   .%{_mandir}/man8/uniconfd.8* \
69   .%{_var}/lib/uniconf/uniconfd.ini
70popd
71
72%clean
73rm -rf $RPM_BUILD_ROOT
74
75%files
76%defattr(-,root,root)
77%doc COPYING.LIB README
78%{_libdir}/*.so.*
79
80%files devel
81%defattr(-,root,root)
82%{_includedir}/wvstreams
83%{_libdir}/*.so
84%{_libdir}/*.a
85%{_libdir}/pkgconfig/*.pc
86
87%post -p /sbin/ldconfig
88%postun -p /sbin/ldconfig
89
90%changelog
91* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 4.4-1vl5
92- applied new versioning policy, spec in utf-8
93
94* Mon Nov 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4-0vl1
95- initial build for Vine Linux
96
97* Fri Aug 17 2007 Harald Hoyer <harald@rawhide.home> - 4.4-1
98- version 4.4
99- changed license tag to LGPLv2+
100
101* Thu Jun 28 2007 Harald Hoyer <harald@redhat.com> - 4.3-2
102- added static libs, esp. xplc-cxx
103
104* Thu Jun 28 2007 Harald Hoyer <harald@redhat.com> - 4.3-1
105- version 4.3
106
107* Wed Apr 18 2007 Harald Hoyer <harald@redhat.com> - 4.2.2-4
108- specfile review
109
110* Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 4.2.2-3
111- fixed code for new g++ version
112
113* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.2.2-2.1
114- rebuild
115
116* Fri Jun 02 2006 Harald Hoyer <harald@redhat.com> 4.2.2-2
117- more corrections to multilib patch (bug #192717)
118
119* Wed May 24 2006 Harald Hoyer <harald@redhat.com> 4.2.2-1
120- version 4.2.2
121- fixed multilib issue (bug #192717)
122
123* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 4.2.1-2
124- rebuild for ppc TLS issue (#184446)
125
126* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.2.1-1.2
127- bump again for double-long bug on ppc(64)
128
129* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.2.1-1.1
130- rebuilt for new gcc4.1 snapshot and glibc changes
131
132* Mon Dec 19 2005 Harald Hoyer <harald@redhat.com> 4.2.1-1
133- version 4.2.1
134
135* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
136- rebuilt
137
138* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> 3.75.0-6
139- rebuilt against new openssl
140- the gcc4 patch shouldn't be used anymore
141
142* Mon Mar 14 2005 Harald Hoyer <harald@redhat.com> 3.75.0-5
143- gcc4 patch added
144
145* Wed Mar  2 2005 Jindrich Novy <jnovy@redhat.com> 3.75.0-4
146- rebuilt
147
148* Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
149- rebuilt
150
151* Wed Jun 28 2004 Harald Hoyer <harald@redhat.com> 3.75.0-2
152- added libwvstreams-3.75.0-stringbuf.patch (114996)
153
154* Mon Jun 21 2004 Harald Hoyer <harald@redhat.com> 3.75.0-1
155- version 3.75.0
156
157* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
158- rebuilt
159
160* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
161- rebuilt
162
163* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
164- rebuilt
165
166* Fri Oct 10 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-12
167- link libwvstreams shared libs against libcrypt, upon which they depend
168
169* Mon Sep  8 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-11
170- rebuild
171
172* Mon Sep  8 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-10
173- rebuild
174
175* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
176- rebuilt
177
178* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
179- rebuilt
180
181* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-7
182- rebuild
183
184* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
185- correct an const/not-const type mismatch that breaks compilation with newer
186  OpenSSL
187- add flags from pkgconfig so that OpenSSL is always found
188
189* Tue Sep 10 2002 Mike A. Harris <mharris@redhat.com> 3.70-6
190- use FHS macros for multilib systems
191
192* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
193- rebuilt with gcc-3.2 (we hope)
194
195* Mon Jul 22 2002 Tim Powers <timp@redhat.com>
196- rebuild using gcc-3.2-0.1
197
198* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
199- automated rebuild
200
201* Sun May 26 2002 Tim Powers <timp@redhat.com>
202- automated rebuild
203
204* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 3.70-1
205- patch to build with gcc 3.x
206- build with -fPIC
207
208* Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com>
209- update to 3.70
210
211* Wed Mar 27 2002 Nalin Dahyabhai <nalin@redhat.com> 3.69-1
212- pull in from upstream tarball
213
214* Wed Feb 27 2002 Nalin Dahyabhai <nalin@redhat.com>
215- merge the main and -devel packages into one .spec file
216- use globbing to shorten the file lists
217- don't define name, version, and release as macros (RPM does this by default)
218- use the License: tag instead of Copyright: (equivalent at the package level,
219  but License: reflects the intent of the tag better)
220- use a URL to point to the source of the source tarball
221- add BuildRequires: openssl-devel (libwvcrypto uses libcrypto)
222- move the buildroot to be under %%{_tmppath}, so that it can be moved by
223  altering RPM's configuration
224
225* Tue Jan 29 2002 Patrick Patterson <ppatters@nit.ca>
226- Initial Release of WvStreams
Note: See TracBrowser for help on using the repository browser.