source: projects/specs/trunk/lib/libw/libwvstreams/libwvstreams-vl.spec @ 10581

Revision 10581, 8.3 KB checked in by Takemikaduchi, 8 years ago (diff)

xlockmore: new upstream release
others: rebuild with gcc-5.4.0

Line 
1Name: libwvstreams
2Version: 4.6.1
3Release: 5%{?_dist_release}
4Summary: WvStreams is a network programming library written in C++
5Summary(ja): WvStreams - C++ で記述されたネットワークプログラミングライブラリ
6
7License: LGPLv2+
8Group: System Environment/Libraries
9URL: https://code.google.com/p/wvstreams/
10
11Source: http://wvstreams.googlecode.com/files/wvstreams-%{version}.tar.gz
12#fixed multilib issue (bug #192717)
13Patch1: wvstreams-4.2.2-multilib.patch
14#install-xplc target was missing
15Patch2: wvstreams-4.5-noxplctarget.patch
16#Fix parallel build (#226061)
17Patch3: wvstreams-4.6.1-make.patch
18#sys/stat.h is missing some files in rawhide build
19Patch4: wvstreams-4.6.1-statinclude.patch
20#const X509V3_EXT_METHOD * -> X509V3_EXT_METHOD * conversion not allowed
21#by rawhide gcc
22Patch5: wvstreams-4.6.1-gcc.patch
23# fix missing unistd.h header for gcc 4.7
24Patch6: wvstreams-4.6.1-gcc47.patch
25Patch7: wvstreams-4.6.1-magic.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: openssl-devel, pkgconfig, zlib-devel, readline-devel, dbus-devel
29
30%description
31WvStreams aims to be an efficient, secure, and easy-to-use library for
32doing network applications development.
33
34%package devel
35Summary: Development files for WvStreams
36Summary(ja): WvStreams の開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41WvStreams aims to be an efficient, secure, and easy-to-use library for
42doing network applications development.  This package contains the files
43needed for developing applications which use WvStreams.
44
45%prep
46%setup -q -n wvstreams-%{version}
47%patch1 -p1 -b .multilib
48%patch2 -p1 -b .xplctarget
49%patch3 -p1 -b .make
50%patch4 -p1 -b .statinclude
51%patch5 -p1 -b .gcc
52%patch6 -p1 -b .gcc47
53%patch7 -p1 -b .magic
54
55%build
56export CXXFLAGS="$RPM_OPT_FLAGS -fPIC -fpermissive -fno-strict-aliasing -fno-tree-dce -fno-optimize-sibling-calls"
57export CFLAGS="$RPM_OPT_FLAGS -fPIC -fno-strict-aliasing"
58
59#  --without-PACKAGE       do not use PACKAGE (same as --with-PACKAGE=no)
60#  --with-dbus             DBUS
61#  --with-openssl          OpenSSL >= 0.9.7 (required)
62#  --with-pam              PAM
63#  --with-tcl              Tcl
64#  --with-qt               Qt
65#  --with-zlib             zlib (required)
66touch configure
67%configure --with-dbus --with-pam --with-openssl --without-tcl --without-qt --with-zlib
68
69make COPTS="$RPM_OPT_FLAGS -fPIC -fpermissive" CXXOPTS="$RPM_OPT_FLAGS -fPIC -fpermissive" VERBOSE=1
70
71%install
72rm -rf $RPM_BUILD_ROOT
73make install DESTDIR=$RPM_BUILD_ROOT
74chmod 755 $RPM_BUILD_ROOT%{_libdir}/*.so.*
75rm -fr $RPM_BUILD_ROOT/usr/bin
76
77pushd $RPM_BUILD_ROOT
78rm -f \
79   ./etc/uniconf.conf \
80   .%{_bindir}/uni \
81   .%{_libdir}/pkgconfig/liboggspeex.pc \
82   .%{_libdir}/pkgconfig/liboggvorbis.pc \
83   .%{_libdir}/pkgconfig/libwvfft.pc \
84   .%{_libdir}/pkgconfig/libwvqt.pc \
85   .%{_sbindir}/uniconfd \
86   .%{_mandir}/man8/uni.8* \
87   .%{_mandir}/man8/uniconfd.8* \
88   .%{_var}/lib/uniconf/uniconfd.ini
89popd
90
91%clean
92rm -rf $RPM_BUILD_ROOT
93
94%files
95%defattr(-,root,root)
96%doc LICENSE README
97%{_libdir}/*.so.*
98
99%files devel
100%defattr(-,root,root)
101%{_includedir}/wvstreams
102%{_libdir}/*.so
103%{_libdir}/*.a
104%{_libdir}/valgrind/*.supp
105%{_libdir}/pkgconfig/*.pc
106
107%post -p /sbin/ldconfig
108%postun -p /sbin/ldconfig
109
110%changelog
111* Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-5
112- rebuild with gcc-5.4.0
113
114* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-4
115- rebuild with openssl-1.0.2
116
117* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-3
118- rebuild with readline-6.3
119
120* Tue Feb 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.6.1-2
121- added Patch6 and 7 from Feroda
122  * Mon Jun 04 2012 Michal Sekletar <msekleta@redhat.com> - 4.6.1-5
123  - Fix crashes caused by compiler optimizations, #812651
124  * Thu Jan 05 2012 Jan Synáček <jsynacek@redhat.com> - 4.6.1-4
125  - Fix missing unistd.h header for gcc 4.7
126- updated URL
127 
128* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.6.1-1
129- update to 4.6.1
130- fix Patch1 (wvstreams-4.2.2-multilib.patch)
131- add Patch2 (wvstreams-4.5-noxplctarget.patch) from FC package
132- add Patch3 (wvstreams-4.6.1-make.patch) from FC package
133- add Patch4 (wvstreams-4.6.1-statinclude.patch) from FC package
134- add Patch5 (wvstreams-4.6.1-gcc.patch) from FC package
135
136* Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 4.4-1vl5
137- applied new versioning policy, spec in utf-8
138
139* Mon Nov 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4-0vl1
140- initial build for Vine Linux
141
142* Fri Aug 17 2007 Harald Hoyer <harald@rawhide.home> - 4.4-1
143- version 4.4
144- changed license tag to LGPLv2+
145
146* Thu Jun 28 2007 Harald Hoyer <harald@redhat.com> - 4.3-2
147- added static libs, esp. xplc-cxx
148
149* Thu Jun 28 2007 Harald Hoyer <harald@redhat.com> - 4.3-1
150- version 4.3
151
152* Wed Apr 18 2007 Harald Hoyer <harald@redhat.com> - 4.2.2-4
153- specfile review
154
155* Wed Jan 24 2007 Harald Hoyer <harald@redhat.com> - 4.2.2-3
156- fixed code for new g++ version
157
158* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.2.2-2.1
159- rebuild
160
161* Fri Jun 02 2006 Harald Hoyer <harald@redhat.com> 4.2.2-2
162- more corrections to multilib patch (bug #192717)
163
164* Wed May 24 2006 Harald Hoyer <harald@redhat.com> 4.2.2-1
165- version 4.2.2
166- fixed multilib issue (bug #192717)
167
168* Fri Mar 10 2006 Bill Nottingham <notting@redhat.com> - 4.2.1-2
169- rebuild for ppc TLS issue (#184446)
170
171* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.2.1-1.2
172- bump again for double-long bug on ppc(64)
173
174* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.2.1-1.1
175- rebuilt for new gcc4.1 snapshot and glibc changes
176
177* Mon Dec 19 2005 Harald Hoyer <harald@redhat.com> 4.2.1-1
178- version 4.2.1
179
180* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
181- rebuilt
182
183* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> 3.75.0-6
184- rebuilt against new openssl
185- the gcc4 patch shouldn't be used anymore
186
187* Mon Mar 14 2005 Harald Hoyer <harald@redhat.com> 3.75.0-5
188- gcc4 patch added
189
190* Wed Mar  2 2005 Jindrich Novy <jnovy@redhat.com> 3.75.0-4
191- rebuilt
192
193* Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
194- rebuilt
195
196* Mon Jun 28 2004 Harald Hoyer <harald@redhat.com> 3.75.0-2
197- added libwvstreams-3.75.0-stringbuf.patch (114996)
198
199* Mon Jun 21 2004 Harald Hoyer <harald@redhat.com> 3.75.0-1
200- version 3.75.0
201
202* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
203- rebuilt
204
205* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
206- rebuilt
207
208* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
209- rebuilt
210
211* Fri Oct 10 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-12
212- link libwvstreams shared libs against libcrypt, upon which they depend
213
214* Mon Sep  8 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-11
215- rebuild
216
217* Mon Sep  8 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-10
218- rebuild
219
220* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
221- rebuilt
222
223* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
224- rebuilt
225
226* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com> 3.70-7
227- rebuild
228
229* Fri Jan  3 2003 Nalin Dahyabhai <nalin@redhat.com>
230- correct an const/not-const type mismatch that breaks compilation with newer
231  OpenSSL
232- add flags from pkgconfig so that OpenSSL is always found
233
234* Tue Sep 10 2002 Mike A. Harris <mharris@redhat.com> 3.70-6
235- use FHS macros for multilib systems
236
237* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
238- rebuilt with gcc-3.2 (we hope)
239
240* Mon Jul 22 2002 Tim Powers <timp@redhat.com>
241- rebuild using gcc-3.2-0.1
242
243* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
244- automated rebuild
245
246* Sun May 26 2002 Tim Powers <timp@redhat.com>
247- automated rebuild
248
249* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 3.70-1
250- patch to build with gcc 3.x
251- build with -fPIC
252
253* Wed Apr 10 2002 Nalin Dahyabhai <nalin@redhat.com>
254- update to 3.70
255
256* Wed Mar 27 2002 Nalin Dahyabhai <nalin@redhat.com> 3.69-1
257- pull in from upstream tarball
258
259* Wed Feb 27 2002 Nalin Dahyabhai <nalin@redhat.com>
260- merge the main and -devel packages into one .spec file
261- use globbing to shorten the file lists
262- don't define name, version, and release as macros (RPM does this by default)
263- use the License: tag instead of Copyright: (equivalent at the package level,
264  but License: reflects the intent of the tag better)
265- use a URL to point to the source of the source tarball
266- add BuildRequires: openssl-devel (libwvcrypto uses libcrypto)
267- move the buildroot to be under %%{_tmppath}, so that it can be moved by
268  altering RPM's configuration
269
270* Tue Jan 29 2002 Patrick Patterson <ppatters@nit.ca>
271- Initial Release of WvStreams
Note: See TracBrowser for help on using the repository browser.