source: projects/specs/trunk/lib/libv/libvorbis/libvorbis-vl.spec @ 521

Revision 521, 10.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define liboggver 1.1.4
3%define epoch_num 1
4
5Summary:        The Vorbis General Audio Compression Codec.
6Summary(ja):    Vorbis - 汎用オーディオ圧縮コーデック
7Name:           libvorbis
8Version:        1.2.3
9Release:        1%{?_dist_release}
10Epoch:          %{epoch_num}
11
12Group:          System Environment/Libraries
13License:        BSD
14URL:            http://www.xiph.org/
15Source:         http://downloads.xiph.org/releases/vorbis/%{name}-%{version}.tar.gz
16Patch2:         libvorbis-cvs-r14502.patch
17Patch3:         libvorbis-cvs-r14598-CVE-2008-1420.patch
18Patch4:         libvorbis-cvs-r14602-CVE-2008-1419.patch
19Patch5:         libvorbis-cvs-r14602-CVE-2008-1423.patch
20Patch6:         libvorbis-cvs-r14811.patch
21Patch7:         libvorbis-1.2.0-CVE-2009-2663.patch
22
23BuildRoot:      %{_tmppath}/%{name}-%{version}-root
24BuildRequires:  libogg-devel >= %{liboggver}
25BuildRequires:  perl
26
27Requires:       libogg >= %{liboggver}
28
29Vendor:         Project Vine
30Distribution:   Vine Linux
31
32%description
33Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
34general-purpose compressed audio format for audio and music at fixed
35and variable bitrates from 16 to 128 kbps/channel.
36
37The libvorbis package contains runtime libraries for use in programs
38that support Ogg Voribs.
39
40%description -l ja
41Ogg Vorbis は完全にオープンで、知的所有権による制約、特許やロイヤリティ
42と関係ない汎用のオーディオ圧縮フォーマットで、チャンネルあたり 16〜128
43kbps の固定/可変ビットレートのオーディオや音楽用です。
44
45このパッケージには、Ogg Vorbis をサポートするプログラムで使われるランタ
46イムライブラリが含まれています。
47
48%package devel
49Summary:        Development files for Vorbis applications.
50Summary(ja):    Vorbis アプリケーションの開発用ファイル
51Group:          Development/Libraries
52Requires:       %{name} = %{epoch_num}:%{version}-%{release}
53Requires:       libogg-devel >= %{liboggver}
54
55%description devel
56The libvorbis-devel package contains the header files, static libraries
57and documentation needed to develop applications with libvorbis.
58
59%description -l ja devel
60このパッケージには、libvorbis を使ったアプリケーションの開発に必要な
61ヘッダファイル、静的ライブラリ、及びドキュメントが含まれています。
62
63# compat32
64%package -n compat32-%{name}
65Summary:        The Vorbis General Audio Compression Codec.
66Summary(ja):    Vorbis - 汎用オーディオ圧縮コーデック
67Group:          System Environment/Libraries
68Requires:       compat32-libogg >= %{liboggver}
69
70%description -n compat32-%{name}
71Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
72general-purpose compressed audio format for audio and music at fixed
73and variable bitrates from 16 to 128 kbps/channel.
74
75The libvorbis package contains runtime libraries for use in programs
76that support Ogg Voribs.
77
78%description -n compat32-%{name} -l ja
79Ogg Vorbis は完全にオープンで、知的所有権による制約、特許やロイヤリティ
80と関係ない汎用のオーディオ圧縮フォーマットで、チャンネルあたり 16〜128
81kbps の固定/可変ビットレートのオーディオや音楽用です。
82
83このパッケージには、Ogg Vorbis をサポートするプログラムで使われるランタ
84イムライブラリが含まれています。
85
86%package -n compat32-%{name}-devel
87Summary:        Development files for Vorbis applications.
88Summary(ja):    Vorbis アプリケーションの開発用ファイル
89Group:          Development/Libraries
90Requires:       compat32-%{name} = %{epoch_num}:%{version}-%{release}
91Requires:       compat32-libogg-devel >= %{liboggver}
92
93%description -n compat32-%{name}-devel
94The libvorbis-devel package contains the header files, static libraries
95and documentation needed to develop applications with libvorbis.
96
97%description -n compat32-%{name}-devel -l ja
98このパッケージには、libvorbis を使ったアプリケーションの開発に必要な
99ヘッダファイル、静的ライブラリ、及びドキュメントが含まれています。
100
101%prep
102%setup -q
103#patch2 -p0 -b .r14502
104#patch3 -p0 -b .cve-2008-1420
105#patch4 -p0 -b .cve-2008-1419
106#patch5 -p0 -b .cve-2008-1423
107#patch6 -p0 -b .r14811
108#patch7 -p1 -b .CVE-2009-2663
109
110perl -p -i -e "s/-O20/%{optflags}/" configure
111perl -p -i -e "s/-ffast-math//" configure
112
113%build
114%configure --with-ogg-libraries=%{_libdir} --disable-static
115make %{?_smp_mflags}
116
117%install
118[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
119make DESTDIR=%{buildroot} install
120
121#rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.a
122rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
123
124%clean
125[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
126
127%post -p /sbin/ldconfig
128
129%postun -p /sbin/ldconfig
130
131%post -n compat32-%{name} -p /sbin/ldconfig
132
133%postun -n compat32-%{name} -p /sbin/ldconfig
134
135%files
136%defattr(-,root,root)
137%doc AUTHORS COPYING README todo.txt
138%{_libdir}/*.so.*
139
140%files devel
141%defattr(-,root,root)
142%doc doc/*
143%{_includedir}/vorbis
144#{_libdir}/*.la
145%{_libdir}/*.so
146%{_libdir}/pkgconfig/*.pc
147%{_datadir}/aclocal/vorbis.m4
148
149# compat32
150%if %{build_compat32}
151%files -n compat32-%{name}
152%defattr(-,root,root)
153%{_libdir}/*.so.*
154
155%files -n compat32-%{name}-devel
156%defattr(-,root,root)
157#{_libdir}/*.la
158%{_libdir}/*.so
159%{_libdir}/pkgconfig/*.pc
160%endif
161
162%changelog
163* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
164- new upstream release
165- dropped Patch2-7 (merged into upstream)
166
167* Wed Aug 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-9
168- add patch7 to fix CVE-2009-2663 (OGG Processing) from fc10
169
170* Sun Jun 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-8
171- fix compat32-devel Require tag (adding epoch)
172
173* Sun Jun 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-7
174- rollback to 1.2.0 because of pulseaudio lockup issue
175- add Epoch 1
176- patch2-6 are added again
177
178* Wed Jun 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
179- new upstream release
180- drop old patches
181
182* Fri Jun 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-6
183- used --disable-static option
184
185* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.0-5
186- added compat32 package for x86_64 arch support
187- removed lib*.a from devel package
188
189* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.0-4vl5
190- spec in utf-8
191
192* Sun Jun 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-3vl5
193- added Patches for security fix based on VinePlus 1.2.0-3vl4
194  * Sat Jun 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-3vl4
195  - add patch2,6 for additional hardening/sanity checks
196  - add patch3 for CVE-2008-1420
197  - add patch4 for CVE-2008-1419
198  - add patch5 for CVE-2008-1423
199
200* Mon May 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
201- applied new versioning policy
202- removed lib*.la from devel package
203
204* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl4
205- fixed include file location
206
207* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl3
208- rebuild for VineSeed
209
210* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl2
211- rebuild for Vine Linux 4.1
212
213* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
214- new upstream release (CVE-2007-3106, CVE-2007-4029)
215
216* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
217- rebuild with new toolchain
218
219* Tue Nov 29 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
220- source upgrade
221
222* Fri Jul 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
223- source upgrade
224- add Japanese summary and description
225
226* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
227- source upgrade
228- update source-URL
229
230* Fri Mar 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl3
231- rebuild
232
233* Sat Nov 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl2
234- rebuild for VineSeedPlus
235
236* Fri Nov 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl1
237- source upgrade
238- build for VinePlus/2.6
239- add %%{_libdir}/*.la and %%{_libdir}/pkgconfig/*.pc to devel package
240- disable %%configure script
241
242* Sat Oct  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl3
243- rebuild with new toolchains
244- use License tag
245
246* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl2
247- rebuild with new toolchains
248
249* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl1
250- source upgrade
251- update %description devel
252- add PreReq: ldconfig
253- delete Patch
254
255* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.99.3-1vl1
256- build for VineSeed
257- change version number to 0.99.3 (means 1.0rc3)
258
259* Tue Jan  1 2002 Bill Nottingham <notting@redhat.com>
260- update to 1.0rc3
261
262* Thu Aug 16 2001 Bill Nottingham <notting@redhat.com>
263- fix bug in floor backend (<michael@stroucken.org>)
264
265* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
266- update to 1.0rc2
267
268* Fri Jul 20 2001 Bill Nottingham <notting@redhat.com>
269- split out from the main vorbis package
270
271* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
272- own %%{_libdir}/ao
273- I love libtool
274
275* Tue Jun 26 2001 Florian La Roche <Florian.LaRoche@redhat.de>
276- add links from library major version numbers in rpms
277
278* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
279- update to rc1
280
281* Fri May  4 2001 Oliver Paukstadt <oliver.paukstadt@millenux.com>
282- fixed perl line in spec file to set optims correctly
283
284* Tue Mar 20 2001 Bill Nottingham <notting@redhat.com>
285- fix alpha/ia64, again
286- use optflags, not -O20 -ffast-math (especially on alpha...)
287
288* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
289- fix license tag
290
291* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
292- beta4
293
294* Fri Feb  9 2001 Bill Nottingham <notting@redhat.com>
295- fix alpha/ia64
296
297* Thu Feb  8 2001 Bill Nottingham <notting@redhat.com>
298- update CVS in prep for beta4
299
300* Wed Feb 07 2001 Philipp Knirsch <pknirsch@redhat.de>
301- Fixed bugzilla bug #25391. ogg123 now usses the OSS driver by default if
302  none was specified.
303
304* Tue Jan  9 2001 Bill Nottingham <notting@redhat.com>
305- update CVS, grab aRts backend for libao
306
307* Thu Dec 27 2000 Bill Nottingham <notting@redhat.com>
308- update CVS
309
310* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
311- rebuild because of broken fileutils
312
313* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
314- hack up specfile some, merge some packages
315
316* Sat Oct 21 2000 Jack Moffitt <jack@icecast.org>
317- initial spec file created
Note: See TracBrowser for help on using the repository browser.