source: projects/specs/trunk/lib/libv/libvorbis/libvorbis-vl.spec @ 12561

Revision 12561, 10.4 KB checked in by tomop, 3 years ago (diff)

updated 6 packages

LibRaw?-0.20.2-1

djvulibre-3.5.28-1

libvorbis-1.3.7-1

re2c-2.0.3-1

vorbis-tools-1.4.2-1

xterm-366-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define liboggver 1.3.2
3
4Summary:        The Vorbis General Audio Compression Codec.
5Summary(ja):    Vorbis - 汎用オーディオ圧縮コーデック
6Name:           libvorbis
7Epoch:          1
8Version:        1.3.7
9Release:        1%{?_dist_release}
10Group:          system
11Vendor:         Project Vine
12Distribution:   Vine Linux
13
14License:        BSD
15URL:            https://www.xiph.org/
16Source:         http://downloads.xiph.org/releases/vorbis/%{name}-%{version}.tar.xz
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  libogg-devel >= %{liboggver}
20BuildRequires:  perl
21
22%description
23Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
24general-purpose compressed audio format for audio and music at fixed
25and variable bitrates from 16 to 128 kbps/channel.
26
27The libvorbis package contains runtime libraries for use in programs
28that support Ogg Voribs.
29
30%description -l ja
31Ogg Vorbis は完全にオープンで、知的財産権による制約、特許やロイヤリティ
32と関係ない汎用のオーディオ圧縮フォーマットで、チャンネルあたり 16〜128
33kbps の固定/可変ビットレートのオーディオや音楽用です。
34
35このパッケージには、Ogg Vorbis をサポートするプログラムで使われるランタ
36イムライブラリが含まれています。
37
38
39%package devel
40Summary:        Development files for Vorbis applications.
41Summary(ja):    Vorbis アプリケーションの開発用ファイル
42Group:          programming
43Requires:       %{name} = %{epoch}:%{version}-%{release}
44Requires:       libogg-devel >= %{liboggver}
45
46%description devel
47The libvorbis-devel package contains the header files, static libraries
48and documentation needed to develop applications with libvorbis.
49
50%description -l ja devel
51このパッケージには、libvorbis を使ったアプリケーションの開発に必要な
52ヘッダファイル、静的ライブラリ、及びドキュメントが含まれています。
53
54
55%package        devel-docs
56Summary:        Documentation for developing Vorbis applications
57Group:          documentation
58BuildArch:      noarch
59Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
60
61%description    devel-docs
62Documentation for developing applications with libvorbis.
63
64
65# compat32
66%package -n compat32-%{name}
67Summary:        The Vorbis General Audio Compression Codec.
68Summary(ja):    Vorbis - 汎用オーディオ圧縮コーデック
69Group:          system,legacy
70
71%description -n compat32-%{name}
72Ogg Vorbis is a fully open, non-proprietary, patent-and-royalty-free,
73general-purpose compressed audio format for audio and music at fixed
74and variable bitrates from 16 to 128 kbps/channel.
75
76The libvorbis package contains runtime libraries for use in programs
77that support Ogg Voribs.
78
79
80%description -n compat32-%{name} -l ja
81Ogg Vorbis は完全にオープンで、知的財産権による制約、特許やロイヤリティ
82と関係ない汎用のオーディオ圧縮フォーマットで、チャンネルあたり 16〜128
83kbps の固定/可変ビットレートのオーディオや音楽用です。
84
85このパッケージには、Ogg Vorbis をサポートするプログラムで使われるランタ
86イムライブラリが含まれています。
87
88%package -n compat32-%{name}-devel
89Summary:        Development files for Vorbis applications.
90Summary(ja):    Vorbis アプリケーションの開発用ファイル
91Group:          programming,legacy
92Requires:       compat32-%{name} = %{epoch}:%{version}-%{release}
93Requires:       compat32-libogg-devel >= %{liboggver}
94
95%description -n compat32-%{name}-devel
96The libvorbis-devel package contains the header files, static libraries
97and documentation needed to develop applications with libvorbis.
98
99%description -n compat32-%{name}-devel -l ja
100このパッケージには、libvorbis を使ったアプリケーションの開発に必要な
101ヘッダファイル、静的ライブラリ、及びドキュメントが含まれています。
102
103
104%debug_package
105
106
107%prep
108%setup -q
109sed -i "s/-ffast-math//" configure
110sed -i "s/-mcpu=750//" configure
111
112
113%build
114%configure --disable-static
115make %{?_smp_mflags}
116
117
118%install
119[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
120make DESTDIR=%{buildroot} docdir=%{_pkgdocdir} install
121
122rm -f %{buildroot}%{_libdir}/lib*.la
123
124%ifnarch x86_64
125rm -rf %{buildroot}%{_pkgdocdir}
126%endif
127
128%check
129make check
130
131
132%clean
133[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
134
135
136%ldconfig_scriptlets
137%ldconfig_scriptlets -n compat32-%{name}
138
139
140%files
141%defattr(-,root,root)
142%license COPYING
143%doc AUTHORS README todo.txt
144%{_libdir}/*.so.*
145
146%files devel
147%defattr(-,root,root)
148%doc doc/*
149%{_includedir}/vorbis
150%{_libdir}/*.so
151%{_libdir}/pkgconfig/*.pc
152%{_datadir}/aclocal/vorbis.m4
153
154%ifarch x86_64
155%files devel-docs
156%{_pkgdocdir}/*
157%exclude %{_pkgdocdir}/doxygen-build.stamp
158%endif
159
160# compat32
161%if %{build_compat32}
162%files -n compat32-%{name}
163%defattr(-,root,root)
164%{_libdir}/*.so.*
165
166%files -n compat32-%{name}-devel
167%defattr(-,root,root)
168%{_libdir}/*.so
169%endif
170
171
172%changelog
173* Wed Mar 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.7-1
174- new upstream release.
175- dropped Patch0.
176
177* Mon Feb 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
178- new upstream release.
179- imported Patch0 from rawhide.
180
181* Sat May 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.5-1
182- new upstream release
183
184* Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.4-1
185- new upstream release
186
187* Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.3-1
188- new upstream release
189
190* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.1-1
191- new upstream release
192- built with rpm-4.8.1
193
194* Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
195- new upstream release
196- dropped Patch2-7 (merged into upstream)
197
198* Wed Aug 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-9
199- add patch7 to fix CVE-2009-2663 (OGG Processing) from fc10
200
201* Sun Jun 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-8
202- fix compat32-devel Require tag (adding epoch)
203
204* Sun Jun 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-7
205- rollback to 1.2.0 because of pulseaudio lockup issue
206- add Epoch 1
207- patch2-6 are added again
208
209* Wed Jun 24 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
210- new upstream release
211- drop old patches
212
213* Fri Jun 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-6
214- used --disable-static option
215
216* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.0-5
217- added compat32 package for x86_64 arch support
218- removed lib*.a from devel package
219
220* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.0-4vl5
221- spec in utf-8
222
223* Sun Jun 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-3vl5
224- added Patches for security fix based on VinePlus 1.2.0-3vl4
225  * Sat Jun 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-3vl4
226  - add patch2,6 for additional hardening/sanity checks
227  - add patch3 for CVE-2008-1420
228  - add patch4 for CVE-2008-1419
229  - add patch5 for CVE-2008-1423
230
231* Mon May 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-1
232- applied new versioning policy
233- removed lib*.la from devel package
234
235* Fri Aug 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl4
236- fixed include file location
237
238* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl3
239- rebuild for VineSeed
240
241* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl2
242- rebuild for Vine Linux 4.1
243
244* Tue Aug  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.0-0vl1
245- new upstream release (CVE-2007-3106, CVE-2007-4029)
246
247* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.1.2-0vl2
248- rebuild with new toolchain
249
250* Tue Nov 29 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
251- source upgrade
252
253* Fri Jul 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
254- source upgrade
255- add Japanese summary and description
256
257* Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
258- source upgrade
259- update source-URL
260
261* Fri Mar 26 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl3
262- rebuild
263
264* Sat Nov 22 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl2
265- rebuild for VineSeedPlus
266
267* Fri Nov 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.1-0vl1
268- source upgrade
269- build for VinePlus/2.6
270- add %%{_libdir}/*.la and %%{_libdir}/pkgconfig/*.pc to devel package
271- disable %%configure script
272
273* Sat Oct  4 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl3
274- rebuild with new toolchains
275- use License tag
276
277* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl2
278- rebuild with new toolchains
279
280* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0-0vl1
281- source upgrade
282- update %description devel
283- add PreReq: ldconfig
284- delete Patch
285
286* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 0.99.3-1vl1
287- build for VineSeed
288- change version number to 0.99.3 (means 1.0rc3)
289
290* Tue Jan  1 2002 Bill Nottingham <notting@redhat.com>
291- update to 1.0rc3
292
293* Thu Aug 16 2001 Bill Nottingham <notting@redhat.com>
294- fix bug in floor backend (<michael@stroucken.org>)
295
296* Mon Aug 13 2001 Bill Nottingham <notting@redhat.com>
297- update to 1.0rc2
298
299* Fri Jul 20 2001 Bill Nottingham <notting@redhat.com>
300- split out from the main vorbis package
301
302* Tue Jul 10 2001 Bill Nottingham <notting@redhat.com>
303- own %%{_libdir}/ao
304- I love libtool
305
306* Tue Jun 26 2001 Florian La Roche <Florian.LaRoche@redhat.de>
307- add links from library major version numbers in rpms
308
309* Tue Jun 19 2001 Bill Nottingham <notting@redhat.com>
310- update to rc1
311
312* Fri May  4 2001 Oliver Paukstadt <oliver.paukstadt@millenux.com>
313- fixed perl line in spec file to set optims correctly
314
315* Tue Mar 20 2001 Bill Nottingham <notting@redhat.com>
316- fix alpha/ia64, again
317- use optflags, not -O20 -ffast-math (especially on alpha...)
318
319* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
320- fix license tag
321
322* Mon Feb 26 2001 Bill Nottingham <notting@redhat.com>
323- beta4
324
325* Fri Feb  9 2001 Bill Nottingham <notting@redhat.com>
326- fix alpha/ia64
327
328* Thu Feb  8 2001 Bill Nottingham <notting@redhat.com>
329- update CVS in prep for beta4
330
331* Wed Feb 07 2001 Philipp Knirsch <pknirsch@redhat.de>
332- Fixed bugzilla bug #25391. ogg123 now usses the OSS driver by default if
333  none was specified.
334
335* Tue Jan  9 2001 Bill Nottingham <notting@redhat.com>
336- update CVS, grab aRts backend for libao
337
338* Wed Dec 27 2000 Bill Nottingham <notting@redhat.com>
339- update CVS
340
341* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
342- rebuild because of broken fileutils
343
344* Mon Nov 13 2000 Bill Nottingham <notting@redhat.com>
345- hack up specfile some, merge some packages
346
347* Sat Oct 21 2000 Jack Moffitt <jack@icecast.org>
348- initial spec file created
Note: See TracBrowser for help on using the repository browser.