source: projects/specs/trunk/lib/libv/libvisio/libvisio-vl.spec @ 9791

Revision 9791, 7.4 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%global apiversion 0.1
2
3Name: libvisio
4Version: 0.1.3
5Release: 1%{?_dist_release}
6Summary: A library for import of Microsoft Visio diagrams
7Summary(ja): Microsoft Visio ダイアグラムをインポートするためのライブラリ
8
9License: MPLv2.0
10Group: System Environment/Libraries
11URL: http://wiki.documentfoundation.org/DLP/Libraries/libvisio
12
13Source: http://dev-www.libreoffice.org/src/%{name}/%{name}-%{version}.tar.xz
14
15Patch0: 0001-fix-test.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: doxygen
19BuildRequires: cppunit-devel
20BuildRequires: gperf
21BuildRequires: help2man
22BuildRequires: libboost-devel
23BuildRequires: libicu-devel
24BuildRequires: librevenge-devel
25BuildRequires: libxml2-devel
26BuildRequires: perl
27BuildRequires: zlib-devel
28
29%description
30%{name} is library providing ability to interpret and import
31Microsoft Visio diagrams into various applications. You can find it
32being used in libreoffice.
33
34%package devel
35Summary: Development files for %{name}
36Summary(ja): %{name} の開発用ファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41The %{name}-devel package contains libraries and header files for
42developing applications that use %{name}.
43
44%package doc
45Summary: Documentation of %{name} API
46Summary(ja): %{name} API のドキュメント
47Group: Documentation
48BuildArch: noarch
49
50%description doc
51The %{name}-doc package contains documentation files for %{name}.
52
53%package tools
54Summary: Tools to transform Microsoft Visio diagrams into other formats
55Summary(ja): Microsoft Visio ダイアグラムを他のフォーマットに変換するツール
56Group: Applications/Productivity
57Requires: %{name} = %{version}-%{release}
58
59%description tools
60Tools to transform Microsoft Visio diagrams into other formats.
61Currently supported: XHTML, raw, plain text.
62
63%prep
64%setup -q
65%patch0 -p1
66
67%build
68%configure --disable-static --disable-silent-rules
69sed -i \
70    -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
71    -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
72    libtool
73make %{?_smp_mflags}
74
75export LD_LIBRARY_PATH=`pwd`/src/lib/.libs${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
76help2man -N -n 'debug the conversion library' -o vsd2raw.1 ./src/conv/raw/.libs/vsd2raw
77help2man -N -n 'convert Visio document into SVG' -o vsd2xhtml.1 ./src/conv/svg/.libs/vsd2xhtml
78help2man -N -n 'convert Visio document into plain text' -o vsd2text.1 ./src/conv/text/.libs/vsd2text
79help2man -N -n 'debug the conversion library' -o vss2raw.1 ./src/conv/raw/.libs/vss2raw
80help2man -N -n 'convert Visio stencil into SVG' -o vss2xhtml.1 ./src/conv/svg/.libs/vss2xhtml
81help2man -N -n 'convert Visio stencil into plain text' -o vss2text.1 ./src/conv/text/.libs/vss2text
82
83%install
84rm -rf %{buildroot}
85make install DESTDIR=%{buildroot}
86rm -f %{buildroot}/%{_libdir}/*.la
87# rhbz#1001240 we install API docs directly from build
88rm -rf %{buildroot}/%{_docdir}/%{name}
89
90install -m 0755 -d %{buildroot}/%{_mandir}/man1
91install -m 0644 vsd2*.1 vss2*.1 %{buildroot}/%{_mandir}/man1
92
93%post -p /sbin/ldconfig
94%postun -p /sbin/ldconfig
95
96%check
97export LD_LIBRARY_PATH=%{buildroot}%{_libdir}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
98# Workaround time formatting problem in the test
99export TZ='CET'
100make check %{?_smp_mflags}
101
102%clean
103rm -rf %{buildroot}
104
105%files
106%doc AUTHORS COPYING.*
107%{_libdir}/%{name}-%{apiversion}.so.*
108
109%files devel
110%doc ChangeLog
111%{_includedir}/%{name}-%{apiversion}
112%{_libdir}/%{name}-%{apiversion}.so
113%{_libdir}/pkgconfig/%{name}-%{apiversion}.pc
114
115%files doc
116%doc COPYING.*
117%doc docs/doxygen/html
118
119%files tools
120%{_bindir}/vsd2raw
121%{_bindir}/vsd2text
122%{_bindir}/vsd2xhtml
123%{_bindir}/vss2raw
124%{_bindir}/vss2text
125%{_bindir}/vss2xhtml
126%{_mandir}/man1/vsd2raw.1*
127%{_mandir}/man1/vsd2text.1*
128%{_mandir}/man1/vsd2xhtml.1*
129%{_mandir}/man1/vss2raw.1*
130%{_mandir}/man1/vss2text.1*
131%{_mandir}/man1/vss2xhtml.1*
132
133%changelog
134* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.3-1
135- new upstream release
136- add Patch0 (0001-fix-test.patch) from fedora
137
138* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.1.1-2
139- Initial build for Vine Linux
140
141* Fri Jan 02 2015 David Tardon <dtardon@redhat.com> - 0.1.1-1
142- new upstream release
143
144* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-4
145- rebuild for ICU 53.1
146
147* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-3
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
149
150* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-2
151- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
152
153* Mon May 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-1
154- new upstream release
155
156* Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 0.0.31-4
157- Rebuild for boost 1.55.0
158
159* Wed Apr 09 2014 David Tardon <dtardon@redhat.com> - 0.0.31-3
160- generate man pages
161
162* Wed Feb 12 2014 Rex Dieter <rdieter@fedoraproject.org> 0.0.31-2
163- rebuild (libicu)
164
165* Mon Sep 02 2013 David Tardon <dtardon@redhat.com> - 0.0.31-1
166- new release
167
168* Fri Aug 30 2013 David Tardon <dtardon@redhat.com> - 0.0.30-4
169- Resolves: rhbz#1001240 duplicate documentation files / potentially conflicting
170
171* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.30-3
172- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
173
174* Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 0.0.30-2
175- Rebuild for boost 1.54.0
176
177* Mon Jul 15 2013 David Tardon <dtardon@redhat.com> - 0.0.30-1
178- new release
179
180* Tue Jul 02 2013 David Tardon <dtardon@redhat.com> - 0.0.29-1
181- new release
182
183* Wed Jun 05 2013 David Tardon <dtardon@redhat.com> - 0.0.28-1
184- new release
185
186* Thu May 16 2013 David Tardon <dtardon@redhat.com> - 0.0.27-1
187- new release
188
189* Tue Apr 23 2013 David Tardon <dtardon@redhat.com> - 0.0.26-1
190- new release
191
192* Thu Feb 28 2013 David Tardon <dtardon@redhat.com> - 0.0.25-1
193- new release
194
195* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.24-2
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
197
198* Tue Dec 18 2012 David Tardon <dtardon@redhat.com> - 0.0.24-1
199- new release
200
201* Mon Dec 03 2012 David Tardon <dtardon@redhat.com> - 0.0.23-1
202- new release
203
204* Thu Nov 29 2012 David Tardon <dtardon@redhat.com> - 0.0.22-1
205- new upstream release
206
207* Wed Nov 21 2012 David Tardon <dtardon@redhat.com> - 0.0.21-1
208- new upstream release
209
210* Tue Nov 06 2012 David Tardon <dtardon@redhat.com> - 0.0.20-1
211- new upstream version
212
213* Fri Jul 27 2012 David Tardon <dtardon@redhat.com> - 0.0.19-2
214- rebuilt for boost 1.50
215
216* Thu Jul 26 2012 David Tardon <dtardon@redhat.com> - 0.0.19-1
217- new upstream version
218
219* Tue Jul 24 2012 David Tardon <dtardon@redhat.com> - 0.0.18-3
220- fix endless loop with text fields in VSD6
221
222* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.18-2
223- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
224
225* Fri Jun 22 2012 David Tardon <dtardon@redhat.com> 0.0.18-1
226- new upstream version
227
228* Fri Jun 01 2012 David Tardon <dtardon@redhat.com> 0.0.17-1
229- new upstream version
230
231* Tue Apr 17 2012 David Tardon <dtardon@redhat.com> 0.0.16-1
232- new upstream version
233
234* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.15-2
235- Rebuilt for c++ ABI breakage
236
237* Tue Feb 21 2012 David Tardon <dtardon@redhat.com> 0.0.15-1
238- new upstream version
239
240* Wed Jan 25 2012 David Tardon <dtardon@redhat.com> 0.0.14-1
241- bump version
242
243- initial import
244* Wed Dec 21 2011 David Tardon <dtardon@redhat.com> 0.0.11-1
245- initial import
Note: See TracBrowser for help on using the repository browser.