source: projects/specs/trunk/lib/libv/libvisio/libvisio-vl.spec @ 12386

Revision 12386, 7.9 KB checked in by tomop, 4 years ago (diff)

updated 15 packages

epiphany-3.30.5-3

evolution-data-server-3.30.5-3

harfbuzz-2.6.4-2

icu-67.1-1

libvisio-0.1.7-3

php74-7.4.5-2

postfix-3.5.1-2

qt5-qtbase-5.12.8-2

qt5-qtlocation-5.12.8-2

qt5-qtwebengine-5.12.8-2

samba-4.12.1-2

tracker-miners-2.3.3-2

tracker-2.3.4-1

webkitgtk4-2.28.1-1

xfsprogs-5.6.0-1

Line 
1%global apiversion 0.1
2
3Name: libvisio
4Version: 0.1.7
5Release: 3%{?_dist_release}
6Summary: A library for import of Microsoft Visio diagrams
7Summary(ja): Microsoft Visio ダイアグラムをインポートするためのライブラリ
8Group: System Environment/Libraries
9Vendor: Project Vine
10Distribution: Vine Linux
11
12License: MPLv2.0
13URL: http://wiki.documentfoundation.org/DLP/Libraries/libvisio
14Source: http://dev-www.libreoffice.org/src/%{name}/%{name}-%{version}.tar.xz
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: doxygen
18BuildRequires: cppunit-devel
19BuildRequires: gperf
20BuildRequires: help2man
21BuildRequires: libboost-devel
22BuildRequires: libicu-devel
23BuildRequires: librevenge-devel
24BuildRequires: libxml2-devel
25BuildRequires: perl
26BuildRequires: zlib-devel
27
28%description
29%{name} is library providing ability to interpret and import
30Microsoft Visio diagrams into various applications. You can find it
31being used in libreoffice.
32
33%package devel
34Summary: Development files for %{name}
35Summary(ja): %{name} の開発用ファイル
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The %{name}-devel package contains libraries and header files for
41developing applications that use %{name}.
42
43%package doc
44Summary: Documentation of %{name} API
45Summary(ja): %{name} API のドキュメント
46Group: Documentation
47BuildArch: noarch
48
49%description doc
50The %{name}-doc package contains documentation files for %{name}.
51
52%package tools
53Summary: Tools to transform Microsoft Visio diagrams into other formats
54Summary(ja): Microsoft Visio ダイアグラムを他のフォーマットに変換するツール
55Group: Applications/Productivity
56Requires: %{name} = %{version}-%{release}
57
58%description tools
59Tools to transform Microsoft Visio diagrams into other formats.
60Currently supported: XHTML, raw, plain text.
61
62%prep
63%setup -q
64
65%build
66%configure --disable-static --disable-silent-rules
67sed -i \
68    -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
69    -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
70    libtool
71make %{?_smp_mflags}
72
73export LD_LIBRARY_PATH=`pwd`/src/lib/.libs${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
74help2man -N -n 'debug the conversion library' -o vsd2raw.1 ./src/conv/raw/.libs/vsd2raw
75help2man -N -n 'convert Visio document into SVG' -o vsd2xhtml.1 ./src/conv/svg/.libs/vsd2xhtml
76help2man -N -n 'convert Visio document into plain text' -o vsd2text.1 ./src/conv/text/.libs/vsd2text
77help2man -N -n 'debug the conversion library' -o vss2raw.1 ./src/conv/raw/.libs/vss2raw
78help2man -N -n 'convert Visio stencil into SVG' -o vss2xhtml.1 ./src/conv/svg/.libs/vss2xhtml
79help2man -N -n 'convert Visio stencil into plain text' -o vss2text.1 ./src/conv/text/.libs/vss2text
80
81%install
82rm -rf %{buildroot}
83make install DESTDIR=%{buildroot}
84rm -f %{buildroot}/%{_libdir}/*.la
85# rhbz#1001240 we install API docs directly from build
86rm -rf %{buildroot}/%{_docdir}/%{name}
87
88install -m 0755 -d %{buildroot}/%{_mandir}/man1
89install -m 0644 vsd2*.1 vss2*.1 %{buildroot}/%{_mandir}/man1
90
91%post -p /sbin/ldconfig
92%postun -p /sbin/ldconfig
93
94%check
95export LD_LIBRARY_PATH=%{buildroot}%{_libdir}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
96# Workaround time formatting problem in the test
97export TZ='CET'
98make check %{?_smp_mflags}
99
100%clean
101rm -rf %{buildroot}
102
103%files
104%license COPYING.*
105%doc AUTHORS
106%{_libdir}/%{name}-%{apiversion}.so.*
107
108%files devel
109%doc ChangeLog
110%{_includedir}/%{name}-%{apiversion}
111%{_libdir}/%{name}-%{apiversion}.so
112%{_libdir}/pkgconfig/%{name}-%{apiversion}.pc
113
114%files doc
115%doc COPYING.*
116%doc docs/doxygen/html
117
118%files tools
119%{_bindir}/vsd2raw
120%{_bindir}/vsd2text
121%{_bindir}/vsd2xhtml
122%{_bindir}/vss2raw
123%{_bindir}/vss2text
124%{_bindir}/vss2xhtml
125%{_mandir}/man1/vsd2raw.1*
126%{_mandir}/man1/vsd2text.1*
127%{_mandir}/man1/vsd2xhtml.1*
128%{_mandir}/man1/vss2raw.1*
129%{_mandir}/man1/vss2text.1*
130%{_mandir}/man1/vss2xhtml.1*
131
132%changelog
133* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-3
134- rebuilt with icu-67.
135
136* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-2
137- rebuilt with icu-66.
138
139* Sun Oct 13 2019 Toshiaki Ara <ara_t@384.jp> - 0.1.7-1
140- new upstream release
141
142* Tue Jan 16 2018 Toshiaki Ara <ara_t@384.jp> - 0.1.5-2
143- rebuild under current VineSeed
144
145* Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.5-1
146- new upstream release
147- remove Patch0 (0001-fix-test.patch)
148
149* Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.3-1
150- new upstream release
151- add Patch0 (0001-fix-test.patch) from fedora
152
153* Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.1.1-2
154- Initial build for Vine Linux
155
156* Fri Jan 02 2015 David Tardon <dtardon@redhat.com> - 0.1.1-1
157- new upstream release
158
159* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-4
160- rebuild for ICU 53.1
161
162* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-3
163- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
164
165* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
167
168* Mon May 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-1
169- new upstream release
170
171* Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 0.0.31-4
172- Rebuild for boost 1.55.0
173
174* Wed Apr 09 2014 David Tardon <dtardon@redhat.com> - 0.0.31-3
175- generate man pages
176
177* Wed Feb 12 2014 Rex Dieter <rdieter@fedoraproject.org> 0.0.31-2
178- rebuild (libicu)
179
180* Mon Sep 02 2013 David Tardon <dtardon@redhat.com> - 0.0.31-1
181- new release
182
183* Fri Aug 30 2013 David Tardon <dtardon@redhat.com> - 0.0.30-4
184- Resolves: rhbz#1001240 duplicate documentation files / potentially conflicting
185
186* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.30-3
187- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
188
189* Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 0.0.30-2
190- Rebuild for boost 1.54.0
191
192* Mon Jul 15 2013 David Tardon <dtardon@redhat.com> - 0.0.30-1
193- new release
194
195* Tue Jul 02 2013 David Tardon <dtardon@redhat.com> - 0.0.29-1
196- new release
197
198* Wed Jun 05 2013 David Tardon <dtardon@redhat.com> - 0.0.28-1
199- new release
200
201* Thu May 16 2013 David Tardon <dtardon@redhat.com> - 0.0.27-1
202- new release
203
204* Tue Apr 23 2013 David Tardon <dtardon@redhat.com> - 0.0.26-1
205- new release
206
207* Thu Feb 28 2013 David Tardon <dtardon@redhat.com> - 0.0.25-1
208- new release
209
210* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.24-2
211- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
212
213* Tue Dec 18 2012 David Tardon <dtardon@redhat.com> - 0.0.24-1
214- new release
215
216* Mon Dec 03 2012 David Tardon <dtardon@redhat.com> - 0.0.23-1
217- new release
218
219* Thu Nov 29 2012 David Tardon <dtardon@redhat.com> - 0.0.22-1
220- new upstream release
221
222* Wed Nov 21 2012 David Tardon <dtardon@redhat.com> - 0.0.21-1
223- new upstream release
224
225* Tue Nov 06 2012 David Tardon <dtardon@redhat.com> - 0.0.20-1
226- new upstream version
227
228* Fri Jul 27 2012 David Tardon <dtardon@redhat.com> - 0.0.19-2
229- rebuilt for boost 1.50
230
231* Thu Jul 26 2012 David Tardon <dtardon@redhat.com> - 0.0.19-1
232- new upstream version
233
234* Tue Jul 24 2012 David Tardon <dtardon@redhat.com> - 0.0.18-3
235- fix endless loop with text fields in VSD6
236
237* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.18-2
238- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
239
240* Fri Jun 22 2012 David Tardon <dtardon@redhat.com> 0.0.18-1
241- new upstream version
242
243* Fri Jun 01 2012 David Tardon <dtardon@redhat.com> 0.0.17-1
244- new upstream version
245
246* Tue Apr 17 2012 David Tardon <dtardon@redhat.com> 0.0.16-1
247- new upstream version
248
249* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.15-2
250- Rebuilt for c++ ABI breakage
251
252* Tue Feb 21 2012 David Tardon <dtardon@redhat.com> 0.0.15-1
253- new upstream version
254
255* Wed Jan 25 2012 David Tardon <dtardon@redhat.com> 0.0.14-1
256- bump version
257
258- initial import
259* Wed Dec 21 2011 David Tardon <dtardon@redhat.com> 0.0.11-1
260- initial import
Note: See TracBrowser for help on using the repository browser.