source: projects/specs/trunk/lib/libu/libuser/libuser-vl.spec @ 8418

Revision 8418, 18.7 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release

Line 
1%define WITH_SELINUX 0
2%define python %(python -c 'import sys;print(sys.version[0:3])')
3
4
5Name: libuser
6Version: 0.60
7Release: 1%{?_dist_release}
8Summary: A user and group account administration library.
9Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
10Group: System Environment/Base
11License: LGPL
12URL: https://fedorahosted.org/libuser/
13Source: libuser-%{version}.tar.xz
14Patch0: libuser-selinux.patch
15BuildRoot: %{_tmppath}/%{name}-root
16BuildRequires: pam-devel
17BuildRequires: popt
18BuildRequires: python-devel
19BuildRequires: gtk-doc
20BuildRequires: linuxdoc-tools
21BuildRequires: pkgconfig
22BuildRequires: glib2-devel
23BuildRequires: popt-devel
24#BuildPrereq: cyrus-sasl-devel, openldap-devel
25
26%description
27The libuser library implements a standardized interface for manipulating
28and administering user and group accounts.  The library uses pluggable
29back-ends to interface to its data sources.
30
31Sample applications modeled after those included with the shadow password
32suite are included.
33
34%package devel
35Group: Development/Libraries
36Summary: Files needed for developing applications which use libuser.
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The libuser-devel package contains header files, static libraries, and other
41files useful for developing applications with libuser.
42
43%prep
44%setup -q
45%if %{WITH_SELINUX}
46#SELinux
47%patch0 -p1 -b .selinux
48%endif
49
50%build
51CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
52%configure \
53        --with-python-version=%{python} \
54        --with-python-path=%{_includedir}/python%{python} \
55        --with-html-dir=%{_datadir}/gtk-doc/html \
56        --with-pic
57make
58
59%clean
60rm -fr $RPM_BUILD_ROOT
61
62%install
63rm -fr $RPM_BUILD_ROOT
64make install DESTDIR=$RPM_BUILD_ROOT
65
66rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
67
68LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
69export LD_LIBRARY_PATH
70
71# Verify that all python modules load, just in case.
72pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
73python%{python} -c "import libuser"
74popd
75
76# remove .la
77rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
78rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
79         
80
81%find_lang %{name}
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87%files -f %{name}.lang
88%defattr(-,root,root)
89%doc AUTHORS COPYING NEWS README TODO docs/*.txt python/modules.txt
90%config(noreplace) %{_sysconfdir}/libuser.conf
91
92%attr(0755,root,root) %{_bindir}/*
93%attr(0755,root,root) %{python_sitearch}/*.so
94%attr(0755,root,root) %{_libdir}/*.so.*
95%dir %attr(0755,root,root) %{_libdir}/%{name}
96%attr(0755,root,root) %{_libdir}/%{name}/*.so
97#%attr(0644,root,root) %{_libdir}/%{name}/*.la
98%attr(0755,root,root) %{_sbindir}/*
99
100%files devel
101%defattr(-,root,root)
102%attr(0755,root,root) %dir %{_includedir}/libuser
103%attr(0644,root,root) %{_includedir}/libuser/*
104#attr(0644,root,root) %{_libdir}/*.la
105%attr(0755,root,root) %{_libdir}/*.so
106#%attr(0644,root,root) %{_mandir}/man3/*
107%attr(0644,root,root) %{_mandir}/man5/*
108
109%attr(0644,root,root) %{_libdir}/pkgconfig/*
110
111%{_datadir}/gtk-doc/html/*
112%{_mandir}/man1/*
113
114%changelog
115* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.60-1
116- new upstream release
117
118* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-5
119- rebuild with python-2.7.2
120
121* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-4
122- rebuild with rpm-4.8.1 for pkg-config file
123
124* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
125- add BuildRequires: pkgconfig, glib2-devel, popt-devel
126
127* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
128- rebuild for python-2.6
129
130* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
131- new upstream release
132
133* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
134- rebuilt with python-2.5.2
135- removed *.la
136
137* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
138- applied new versioning policy
139
140* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
141- new upstream release
142
143* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
144- rebuild with python-2.4.1-0vl1
145
146* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
147- rebuild with python-2.3.3-0vl1
148
149* Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
150- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
151
152* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
153- resync to fedora
154
155* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
156- initial build for Vine Linux
157
158* Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
159- degrade gracefully
160- build with --with-pic and -fPIC
161- remove unpackaged man page
162
163* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
164- translation updates
165
166* Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
167- doc updates -- cvs tree moved
168- language updates
169- disallow weird characters in account names
170
171* Sun May 26 2002 Tim Powers <timp@redhat.com>
172- automated rebuild
173
174* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
175- files: ignore blank lines in files
176- libuser: disallow creation of accounts with names containing whitespace,
177  control characters, or non-ASCII characters
178
179* Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
180- refresh translations
181- fix a heap-corruption bug in the python bindings
182
183* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
184- bump version
185- refresh translations
186
187* Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
188- ldap: cache an entity's dn in the entity structure to try to speed things up
189
190* Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
191- rebuild in new environment
192
193* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
194- add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
195- translation refresh
196
197* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
198- fix python bindings of enumerateFull functions
199- adjust prompter wrapping to not error out on successful returns
200
201* Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
202- be more careful about printing error messages
203- fix refreshing after adding of accounts
204- ldap: try to use a search to convert names to DNs, and only fall back to
205  guessing if it turns up nothing
206- files: fix an off-by-one in removal of entries
207
208* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
209- refresh translations
210- fix admin() constructor comments in the python module
211
212* Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
213- automatically refresh entities after add, modify, setpass, removepass,
214  lock, and unlock operations
215- remove debug spewage when creating and removing mail spools
216- files: fix saving of multi-valued attributes
217- rename MEMBERUID attribute for groups to MEMBERNAME
218
219* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
220- files: fix bug in removals
221- ldap: revert attempts at being smart at startup time, because it makes UIs
222  very messy (up the three whole dialogs just to start the ldap stuff!)
223
224* Sat Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
225- fix thinko in dispatch routines
226
227* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
228- lgroupmod: fix thinko
229
230* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
231- rebuild in new environment
232
233* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
234- move shadow initialization for groups to the proper callback
235- rework locking in the files module to not require that files be writable
236
237* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
238- expose lu_strerror()
239- add various typedefs for types used by the library
240
241* Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
242- add removepass() functions
243
244* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
245- lchfn,lchsh,lpasswd - reorder PAM authentication calls
246- include API docs in the package
247
248* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
249- ldap: finish port to new API
250- sasl: finish port to new API (needs test)
251- libuser: don't commit object changes before passing data to service
252  functions which might need differing data sets to figure out what to
253  change (for example, ldap)
254
255* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
256- bind the internal mail spool creation/removal functions for python
257
258* Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
259- renamed the python module
260- revamped internals to use gobject's gvalues and gvaluearrays instead of
261  glists of cached strings
262- add enumeration-with-data functions to the C library
263
264* Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
265- require linuxdoc-tools instead of sgml-tools for rawhide
266
267* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
268- fixup build files to allow building for arbitrary versions of python
269
270* Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
271- link the python module against libpam
272- attempt to import the python modules at build-time to verify dependencies
273
274* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
275- fix a file-parsing bug that popped up in 0.29's mmap modifications
276
277* Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
278- quotaq: fix argument order when reading quota information
279- user_quota: set quota grace periods correctly
280- luseradd: never create home directories for system accounts
281
282* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
283- add da translation files
284- update translations
285
286* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
287- add an explicit build dependency on jade (for the docs)
288
289* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
290- HUP nscd on modifications
291- userutil.c: mmap files we're reading for probable speed gain
292- userutil.c: be conservative with the amount of random data we read
293- docs fixes
294
295* Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
296- apps: print usage on errors
297- lnewusers.c: initialize groups as groups, not users
298- lnewusers.c: set passwords for new accounts
299- luseradd.c: accept group names in addition to IDs for the -g flag
300- luseradd.c: allow the primary GID to be a preexisting group
301
302* Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
303- add ko translation files
304- files.c: fix a heap corruption bug in lock/unlock (#51750)
305- files.c: close a memory leak in reading of files
306
307* Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
308- files.c: remove implementation limits on lengths of lines
309
310* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
311- lusermod: change user name in groups the user is a member of during renames
312- lgroupmod: change primary GID for users who are in the group during renumbers
313- ldap.c: handle new attributes more gracefully if possible
314- add ru translation files
315
316* Tue Aug  7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
317- rename the quota source files to match the library, which clears up a
318  file conflict with older quota packages
319- add ja translation files
320
321* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com>
322- add lu_ent_clear_all() function
323
324* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
325- close up some memory leaks
326- add the ability to include resident versions of modules in the library
327
328* Wed Aug  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
329- fix incorrect Py_BuildValue invocation in python module
330
331* Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
332- stop leaking descriptors in the files module
333- speed up user creation by reordering some checks for IDs being in use
334- update the shadowLastChanged attribute when we set a password
335- adjust usage of getXXXXX_r where needed
336- fix assorted bugs in python binding which break prompting
337
338* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
339- install sv translation
340- make lpasswd prompt for passwords when none are given on the command line
341- make sure all user-visible strings are marked for translation
342- clean up some user-visible strings
343- require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
344
345* Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
346- print uids and gids of users and names in lid app
347- fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
348- implement enumerate_by_group and enumerate_by_user in ldap module
349- fix id-based lookups in the ldap module
350- implement islocked() method in ldap module
351- implement setpass() method in ldap module
352- add lchfn and lchsh apps
353- add %%d substitution to libuser.conf
354
355* Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
356- finish adding a sasldb module which manipulates a sasldb file
357- add users_enumerate_by_group and groups_enumerate_by_users
358
359* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
360- luserdel: remove the user's primary group if it has the same name as
361  the user and has no members configured (-G disables)
362- fixup some configure stuff to make libuser.conf get generated correctly
363  even when execprefix isn't specified
364
365* Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
366- only call the auth module when setting passwords (oops)
367- use GTrees instead of GHashTables for most internal tables
368- files: complain properly about unset attributes
369- files: group passwords are single-valued, not multiple-valued
370- add lpasswd app, make sure all apps start up popt with the right names
371
372* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
373- actually make the new optional arguments optional
374- fix lu_error_new() to actually report errors right
375- fix part of the python bindings
376- include tools in the binary package again
377- fixup modules so that password-changing works right again
378- add a "key" field to prompt structures for use by apps which like to
379  cache these things
380- add an optional "mvhomedir" argument to userModify (python)
381
382* Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
383- finish home directory population
384- implement home directory moving
385- change entity get semantics in the python bindings to allow default values for .get()
386- add lu_ent_has(), and a python has_key() method to Entity types
387- don't include tools in the binary package
388- add translated strings
389
390* Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
391- lib/user.c: catch and ignore errors when running stacks
392- lusermod: fix slightly bogus help messages
393- luseradd: when adding a user and group, use the gid of the group
394  instead of the user's uid as the primary group
395- properly set the password field in user accounts created using
396  auth-only auth modules (shadow needs "x" instead of "!!")
397- implement home directory removal, start on population
398
399* Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
400- fix group password setting in the files module
401- setpass affects both auth and info, so run both stacks
402
403* Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
404- make the testbed apps noinst
405
406* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
407- fix errors due to uninitialized fields in the python bindings
408- add kwargs support to all python wrappers
409- add a mechanism for passing arguments to python callbacks
410
411* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
412- stub out the krb5 and ldap modules so that they'll at least compile again
413 
414* Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
415- don't bail when writing empty fields to colon-delimited files
416- use permissions of the original file when making backup files instead of 0600
417
418* Fri Jul  6 2001 Nalin Dahyabhai <nalin@redhat.com>
419- finish implementing is_locked methods in files/shadow module
420- finish cleanup of the python bindings
421- allow conditional builds of modules so that we can build without
422  all of the prereqs for all of the modules
423
424* Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
425- add error reporting facilities
426- split public header into pieces by function
427- backend cleanups
428
429* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
430- make %%{name}-devel require %%{name} and not %%{name}-devel
431
432* Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
433- clean up quota bindings some more
434- finish most of the ldap bindings
435- fix a subtle bug in the files module that would show up when renaming accounts
436- fix mapping methods for entity structures in python
437
438* Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
439- get bindings for prompts to work correctly
440- clean up some of the add/remove semantics (set source on add)
441- ldap: implement enumeration
442- samples/enum: fix the argument order
443
444* Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
445- clean up python bindings for quota
446
447* Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
448- finish up python bindings for quota support
449
450* Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
451- finish up quota support libs
452
453* Fri Jun  8 2001 Nalin Dahyabhai <nalin@redhat.com>
454- start quota support library to get some type safety
455
456* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
457- start looking at quota manipulation
458
459* Wed Jun  6 2001 Nalin Dahyabhai <nalin@redhat.com>
460- add functions for enumerating users and groups, optionally per-module
461- lusermod.c: -s should specify the shell, not the home directory
462
463* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
464- finish the python bindings and verify that the file backend works again
465
466* Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
467- remove a redundant check which was breaking modifications
468
469* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
470- finish adding setpass methods
471
472* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
473- get a start on some Python bindings
474
475* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
476- make binary-incompatible change in headers
477
478* Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
479- add doxygen docs and a "doc" target for them
480
481* Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
482- add a "quiet" prompter
483- add --interactive flag to sample apps and default to using quiet prompter
484- ldap: attempt a "self" bind if other attempts fail
485- krb5: connect to the password-changing service if the user principal has
486  the NULL instance
487
488* Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
489- the great adding-of-the-copyright-statements
490- take more care when creating backup files in the files module
491
492* Wed Jan  3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
493- add openldap-devel as a buildprereq
494- krb5: use a continuous connection
495- krb5: add "realm" config directive
496- ldap: use a continuous connection
497- ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
498- ldap: actually finish the account deletion function
499- ldap: don't send cleartext passwords to the directory
500- fix naming attribute for users (should be uid, not gid)
501- refine the search-by-id,convert-to-name,search-by-name logic
502- fix handling of defaults when the config file is read in but contains no value
503- implement an LDAP information store
504- try to clean up module naming with libtool
505- luseradd: pass plaintext passwords along
506- luseradd: use symbolic attribute names instead of hard-coded
507- lusermod: pass plaintext passwords along
508- lgroupadd: pass plaintext passwords along
509- lgroupmod: pass plaintext passwords along
510- add libuser as a dependency of libuser-devel
511
512* Tue Jan  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
513- initial packaging
Note: See TracBrowser for help on using the repository browser.