source: projects/specs/trunk/lib/libu/libuser/libuser-vl.spec @ 5701

Revision 5701, 18.6 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define WITH_SELINUX 0
2%define python %(python -c 'import sys;print(sys.version[0:3])')
3
4
5Name: libuser
6Version: 0.56.9
7Release: 5%{?_dist_release}
8Summary: A user and group account administration library.
9Summary(ja): ユーザアカウントとグループアカウントを管理するライブラリ
10Group: System Environment/Base
11License: LGPL
12URL: https://fedorahosted.org/libuser/
13Source: libuser-%{version}.tar.bz2
14Patch0: libuser-selinux.patch
15BuildRoot: %{_tmppath}/%{name}-root
16BuildRequires: pam-devel
17BuildRequires: popt
18BuildRequires: python-devel
19BuildRequires: gtk-doc
20BuildRequires: linuxdoc-tools
21BuildRequires: pkgconfig
22BuildRequires: glib2-devel
23BuildRequires: popt-devel
24#BuildPrereq: cyrus-sasl-devel, openldap-devel
25
26%description
27The libuser library implements a standardized interface for manipulating
28and administering user and group accounts.  The library uses pluggable
29back-ends to interface to its data sources.
30
31Sample applications modeled after those included with the shadow password
32suite are included.
33
34%package devel
35Group: Development/Libraries
36Summary: Files needed for developing applications which use libuser.
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The libuser-devel package contains header files, static libraries, and other
41files useful for developing applications with libuser.
42
43%prep
44%setup -q
45%if %{WITH_SELINUX}
46#SELinux
47%patch0 -p1 -b .selinux
48%endif
49
50%build
51CFLAGS="$RPM_OPT_FLAGS -fPIC" ; export CFLAGS
52%configure \
53        --with-python-version=%{python} \
54        --with-python-path=%{_includedir}/python%{python} \
55        --with-html-dir=%{_datadir}/gtk-doc/html \
56        --with-pic
57make
58
59%clean
60rm -fr $RPM_BUILD_ROOT
61
62%install
63rm -fr $RPM_BUILD_ROOT
64make install DESTDIR=$RPM_BUILD_ROOT
65
66rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
67
68LD_LIBRARY_PATH=$RPM_BUILD_ROOT/%{_libdir}:${LD_LIBRARY_PATH}
69export LD_LIBRARY_PATH
70
71# Verify that all python modules load, just in case.
72pushd $RPM_BUILD_ROOT/%{_libdir}/python%{python}/site-packages/
73python%{python} -c "import libuser"
74popd
75
76# remove .la
77rm -f $RPM_BUILD_ROOT%{_libdir}/libuser/*.la
78rm -f $RPM_BUILD_ROOT%{_libdir}/python%{python}/site-packages/*.la
79         
80
81%find_lang %{name}
82
83%post -p /sbin/ldconfig
84
85%postun -p /sbin/ldconfig
86
87%files -f %{name}.lang
88%defattr(-,root,root)
89%doc AUTHORS COPYING NEWS README TODO docs/*.txt python/modules.txt
90%config(noreplace) %{_sysconfdir}/libuser.conf
91
92%attr(0755,root,root) %{_bindir}/*
93%attr(0755,root,root) %{python_sitearch}/*.so
94%attr(0755,root,root) %{_libdir}/*.so.*
95%dir %attr(0755,root,root) %{_libdir}/%{name}
96%attr(0755,root,root) %{_libdir}/%{name}/*.so
97#%attr(0644,root,root) %{_libdir}/%{name}/*.la
98%attr(0755,root,root) %{_sbindir}/*
99
100%files devel
101%defattr(-,root,root)
102%attr(0755,root,root) %dir %{_includedir}/libuser
103%attr(0644,root,root) %{_includedir}/libuser/*
104#attr(0644,root,root) %{_libdir}/*.la
105%attr(0755,root,root) %{_libdir}/*.so
106#%attr(0644,root,root) %{_mandir}/man3/*
107%attr(0644,root,root) %{_mandir}/man5/*
108
109%attr(0644,root,root) %{_libdir}/pkgconfig/*
110
111%{_datadir}/gtk-doc/html/*
112%{_mandir}/man1/*
113
114%changelog
115* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-5
116- rebuild with python-2.7.2
117
118* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-4
119- rebuild with rpm-4.8.1 for pkg-config file
120
121* Sun Feb 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.56.9-3
122- add BuildRequires: pkgconfig, glib2-devel, popt-devel
123
124* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-2
125- rebuild for python-2.6
126
127* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56.9-1
128- new upstream release
129
130* Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 0.53.8-3
131- rebuilt with python-2.5.2
132- removed *.la
133
134* Mon Jun  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.53.8-2
135- applied new versioning policy
136
137* Sun Aug 21 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.8-1vl1
138- new upstream release
139
140* Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl3
141- rebuild with python-2.4.1-0vl1
142
143* Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl2
144- rebuild with python-2.3.3-0vl1
145
146* Thu Apr 15 2004 Shu KONNO <owa@bg.wakwak.com> 0.51.7-7vl1.1
147- rebuild with python-2.3.3-0vl0.3 (for TestPkg)
148
149* Sat Apr 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.51.7-7vl1
150- resync to fedora
151
152* Sat Jan 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51.2-1vl1
153- initial build for Vine Linux
154
155* Wed Dec 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.2-1
156- degrade gracefully
157- build with --with-pic and -fPIC
158- remove unpackaged man page
159
160* Tue Aug 27 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-2
161- translation updates
162
163* Wed Jul 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51.1-1
164- doc updates -- cvs tree moved
165- language updates
166- disallow weird characters in account names
167
168* Sun May 26 2002 Tim Powers <timp@redhat.com>
169- automated rebuild
170
171* Mon May 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.51-1
172- files: ignore blank lines in files
173- libuser: disallow creation of accounts with names containing whitespace,
174  control characters, or non-ASCII characters
175
176* Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50.2-1
177- refresh translations
178- fix a heap-corruption bug in the python bindings
179
180* Mon Apr 15 2002 Nalin Dahyabhai <nalin@redhat.com> 0.50-1
181- bump version
182- refresh translations
183
184* Thu Mar 14 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.102-1
185- ldap: cache an entity's dn in the entity structure to try to speed things up
186
187* Mon Mar 11 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-3
188- rebuild in new environment
189
190* Thu Mar  7 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-2
191- add missing buildreqs on cyrus-sasl-devel and openldap-devel (#59456)
192- translation refresh
193
194* Fri Mar  1 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.101-1
195- fix python bindings of enumerateFull functions
196- adjust prompter wrapping to not error out on successful returns
197
198* Thu Feb 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.100-1
199- be more careful about printing error messages
200- fix refreshing after adding of accounts
201- ldap: try to use a search to convert names to DNs, and only fall back to
202  guessing if it turns up nothing
203- files: fix an off-by-one in removal of entries
204
205* Mon Feb 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.99-1
206- refresh translations
207- fix admin() constructor comments in the python module
208
209* Thu Feb 21 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.98-1
210- automatically refresh entities after add, modify, setpass, removepass,
211  lock, and unlock operations
212- remove debug spewage when creating and removing mail spools
213- files: fix saving of multi-valued attributes
214- rename MEMBERUID attribute for groups to MEMBERNAME
215
216* Wed Feb 20 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.97-1
217- files: fix bug in removals
218- ldap: revert attempts at being smart at startup time, because it makes UIs
219  very messy (up the three whole dialogs just to start the ldap stuff!)
220
221* Sun Feb 16 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.96-1
222- fix thinko in dispatch routines
223
224* Wed Feb 13 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.95-1
225- lgroupmod: fix thinko
226
227* Thu Jan 31 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.94-2
228- rebuild in new environment
229
230* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.93-1
231- move shadow initialization for groups to the proper callback
232- rework locking in the files module to not require that files be writable
233
234* Tue Jan 29 2002 Nalin Dahyabhai <nalin@redhat.com>
235- expose lu_strerror()
236- add various typedefs for types used by the library
237
238* Mon Jan 28 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.92-1
239- add removepass() functions
240
241* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com>
242- lchfn,lchsh,lpasswd - reorder PAM authentication calls
243- include API docs in the package
244
245* Thu Jan 24 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.91-1
246- ldap: finish port to new API
247- sasl: finish port to new API (needs test)
248- libuser: don't commit object changes before passing data to service
249  functions which might need differing data sets to figure out what to
250  change (for example, ldap)
251
252* Thu Jan 17 2002 Nalin Dahyabhai <nalin@redhat.com> 0.49.90-1
253- bind the internal mail spool creation/removal functions for python
254
255* Wed Jan 16 2002 Nalin Dahyabhai <nalin@redhat.com>
256- renamed the python module
257- revamped internals to use gobject's gvalues and gvaluearrays instead of
258  glists of cached strings
259- add enumeration-with-data functions to the C library
260
261* Mon Jan 07 2002 Florian La Roche <Florian.LaRoche@redhat.de>
262- require linuxdoc-tools instead of sgml-tools for rawhide
263
264* Tue Nov 13 2001 Nalin Dahyabhai <nalin@redhat.com>
265- fixup build files to allow building for arbitrary versions of python
266
267* Wed Aug 29 2001 Nalin Dahyabhai <nalin@redhat.com> 0.32-1
268- link the python module against libpam
269- attempt to import the python modules at build-time to verify dependencies
270
271* Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 0.31-1
272- fix a file-parsing bug that popped up in 0.29's mmap modifications
273
274* Mon Aug 27 2001 Nalin Dahyabhai <nalin@redhat.com> 0.30-1
275- quotaq: fix argument order when reading quota information
276- user_quota: set quota grace periods correctly
277- luseradd: never create home directories for system accounts
278
279* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com>
280- add da translation files
281- update translations
282
283* Tue Aug 21 2001 Nalin Dahyabhai <nalin@redhat.com> 0.29-1
284- add an explicit build dependency on jade (for the docs)
285
286* Mon Aug 20 2001 Nalin Dahyabhai <nalin@redhat.com>
287- HUP nscd on modifications
288- userutil.c: mmap files we're reading for probable speed gain
289- userutil.c: be conservative with the amount of random data we read
290- docs fixes
291
292* Wed Aug 15 2001 Nalin Dahyabhai <nalin@redhat.com> 0.28-1
293- apps: print usage on errors
294- lnewusers.c: initialize groups as groups, not users
295- lnewusers.c: set passwords for new accounts
296- luseradd.c: accept group names in addition to IDs for the -g flag
297- luseradd.c: allow the primary GID to be a preexisting group
298
299* Tue Aug 14 2001 Nalin Dahyabhai <nalin@redhat.com> 0.27-1
300- add ko translation files
301- files.c: fix a heap corruption bug in lock/unlock (#51750)
302- files.c: close a memory leak in reading of files
303
304* Mon Aug 13 2001 Nalin Dahyabhai <nalin@redhat.com>
305- files.c: remove implementation limits on lengths of lines
306
307* Thu Aug  9 2001 Nalin Dahyabhai <nalin@redhat.com> 0.26-1
308- lusermod: change user name in groups the user is a member of during renames
309- lgroupmod: change primary GID for users who are in the group during renumbers
310- ldap.c: handle new attributes more gracefully if possible
311- add ru translation files
312
313* Tue Aug  7 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25.1-1
314- rename the quota source files to match the library, which clears up a
315  file conflict with older quota packages
316- add ja translation files
317
318* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com>
319- add lu_ent_clear_all() function
320
321* Thu Aug  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.25-1
322- close up some memory leaks
323- add the ability to include resident versions of modules in the library
324
325* Wed Aug  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-4
326- fix incorrect Py_BuildValue invocation in python module
327
328* Tue Jul 31 2001 Nalin Dahyabhai <nalin@redhat.com> 0.24-3
329- stop leaking descriptors in the files module
330- speed up user creation by reordering some checks for IDs being in use
331- update the shadowLastChanged attribute when we set a password
332- adjust usage of getXXXXX_r where needed
333- fix assorted bugs in python binding which break prompting
334
335* Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.23-1
336- install sv translation
337- make lpasswd prompt for passwords when none are given on the command line
338- make sure all user-visible strings are marked for translation
339- clean up some user-visible strings
340- require PAM authentication in lchsh, lchfn, and lpasswd for non-networked modules
341
342* Fri Jul 27 2001 Nalin Dahyabhai <nalin@redhat.com>
343- print uids and gids of users and names in lid app
344- fix tree traversal in users_enumerate_by_group and groups_enumerate_by_users
345- implement enumerate_by_group and enumerate_by_user in ldap module
346- fix id-based lookups in the ldap module
347- implement islocked() method in ldap module
348- implement setpass() method in ldap module
349- add lchfn and lchsh apps
350- add %%d substitution to libuser.conf
351
352* Thu Jul 26 2001 Nalin Dahyabhai <nalin@redhat.com> 0.21-1
353- finish adding a sasldb module which manipulates a sasldb file
354- add users_enumerate_by_group and groups_enumerate_by_users
355
356* Wed Jul 25 2001 Nalin Dahyabhai <nalin@redhat.com>
357- luserdel: remove the user's primary group if it has the same name as
358  the user and has no members configured (-G disables)
359- fixup some configure stuff to make libuser.conf get generated correctly
360  even when execprefix isn't specified
361
362* Tue Jul 24 2001 Nalin Dahyabhai <nalin@redhat.com> 0.20-1
363- only call the auth module when setting passwords (oops)
364- use GTrees instead of GHashTables for most internal tables
365- files: complain properly about unset attributes
366- files: group passwords are single-valued, not multiple-valued
367- add lpasswd app, make sure all apps start up popt with the right names
368
369* Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com> 0.18-1
370- actually make the new optional arguments optional
371- fix lu_error_new() to actually report errors right
372- fix part of the python bindings
373- include tools in the binary package again
374- fixup modules so that password-changing works right again
375- add a "key" field to prompt structures for use by apps which like to
376  cache these things
377- add an optional "mvhomedir" argument to userModify (python)
378
379* Fri Jul 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.16.1-1
380- finish home directory population
381- implement home directory moving
382- change entity get semantics in the python bindings to allow default values for .get()
383- add lu_ent_has(), and a python has_key() method to Entity types
384- don't include tools in the binary package
385- add translated strings
386
387* Thu Jul 19 2001 Nalin Dahyabhai <nalin@redhat.com>
388- lib/user.c: catch and ignore errors when running stacks
389- lusermod: fix slightly bogus help messages
390- luseradd: when adding a user and group, use the gid of the group
391  instead of the user's uid as the primary group
392- properly set the password field in user accounts created using
393  auth-only auth modules (shadow needs "x" instead of "!!")
394- implement home directory removal, start on population
395
396* Wed Jul 18 2001 Nalin Dahyabhai <nalin@redhat.com>
397- fix group password setting in the files module
398- setpass affects both auth and info, so run both stacks
399
400* Tue Jul 17 2001 Nalin Dahyabhai <nalin@redhat.com>
401- make the testbed apps noinst
402
403* Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
404- fix errors due to uninitialized fields in the python bindings
405- add kwargs support to all python wrappers
406- add a mechanism for passing arguments to python callbacks
407
408* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
409- stub out the krb5 and ldap modules so that they'll at least compile again
410 
411* Tue Jul 10 2001 Nalin Dahyabhai <nalin@redhat.com>
412- don't bail when writing empty fields to colon-delimited files
413- use permissions of the original file when making backup files instead of 0600
414
415* Fri Jul  6 2001 Nalin Dahyabhai <nalin@redhat.com>
416- finish implementing is_locked methods in files/shadow module
417- finish cleanup of the python bindings
418- allow conditional builds of modules so that we can build without
419  all of the prereqs for all of the modules
420
421* Thu Jun 21 2001 Nalin Dahyabhai <nalin@redhat.com>
422- add error reporting facilities
423- split public header into pieces by function
424- backend cleanups
425
426* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
427- make %%{name}-devel require %%{name} and not %%{name}-devel
428
429* Fri Jun 15 2001 Nalin Dahyabhai <nalin@redhat.com>
430- clean up quota bindings some more
431- finish most of the ldap bindings
432- fix a subtle bug in the files module that would show up when renaming accounts
433- fix mapping methods for entity structures in python
434
435* Thu Jun 14 2001 Nalin Dahyabhai <nalin@redhat.com>
436- get bindings for prompts to work correctly
437- clean up some of the add/remove semantics (set source on add)
438- ldap: implement enumeration
439- samples/enum: fix the argument order
440
441* Wed Jun 13 2001 Nalin Dahyabhai <nalin@redhat.com>
442- clean up python bindings for quota
443
444* Tue Jun 12 2001 Nalin Dahyabhai <nalin@redhat.com> 0.11
445- finish up python bindings for quota support
446
447* Sun Jun 10 2001 Nalin Dahyabhai <nalin@redhat.com>
448- finish up quota support libs
449
450* Fri Jun  8 2001 Nalin Dahyabhai <nalin@redhat.com>
451- start quota support library to get some type safety
452
453* Thu Jun  7 2001 Nalin Dahyabhai <nalin@redhat.com>
454- start looking at quota manipulation
455
456* Wed Jun  6 2001 Nalin Dahyabhai <nalin@redhat.com>
457- add functions for enumerating users and groups, optionally per-module
458- lusermod.c: -s should specify the shell, not the home directory
459
460* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.10
461- finish the python bindings and verify that the file backend works again
462
463* Wed May 30 2001 Nalin Dahyabhai <nalin@redhat.com>
464- remove a redundant check which was breaking modifications
465
466* Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
467- finish adding setpass methods
468
469* Wed May  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.9
470- get a start on some Python bindings
471
472* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.2
473- make binary-incompatible change in headers
474
475* Mon Apr 30 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8.1
476- add doxygen docs and a "doc" target for them
477
478* Sat Jan 20 2001 Nalin Dahyabhai <nalin@redhat.com> 0.8
479- add a "quiet" prompter
480- add --interactive flag to sample apps and default to using quiet prompter
481- ldap: attempt a "self" bind if other attempts fail
482- krb5: connect to the password-changing service if the user principal has
483  the NULL instance
484
485* Wed Jan 10 2001 Nalin Dahyabhai <nalin@redhat.com>
486- the great adding-of-the-copyright-statements
487- take more care when creating backup files in the files module
488
489* Wed Jan  3 2001 Nalin Dahyabhai <nalin@redhat.com> 0.7
490- add openldap-devel as a buildprereq
491- krb5: use a continuous connection
492- krb5: add "realm" config directive
493- ldap: use a continuous connection
494- ldap: add "server", "basedn", "binddn", "user", "authuser" config directives
495- ldap: actually finish the account deletion function
496- ldap: don't send cleartext passwords to the directory
497- fix naming attribute for users (should be uid, not gid)
498- refine the search-by-id,convert-to-name,search-by-name logic
499- fix handling of defaults when the config file is read in but contains no value
500- implement an LDAP information store
501- try to clean up module naming with libtool
502- luseradd: pass plaintext passwords along
503- luseradd: use symbolic attribute names instead of hard-coded
504- lusermod: pass plaintext passwords along
505- lgroupadd: pass plaintext passwords along
506- lgroupmod: pass plaintext passwords along
507- add libuser as a dependency of libuser-devel
508
509* Tue Jan  2 2001 Nalin Dahyabhai <nalin@redhat.com> 0.6
510- initial packaging
Note: See TracBrowser for help on using the repository browser.