source: projects/specs/trunk/lib/libt/libtool/libtool-vl.spec @ 12225

Revision 12225, 21.1 KB checked in by tomop, 5 years ago (diff)

updated 4 packages

binutils-2.32-1

gcc-8.3.1-1

glibc-2.30-1

libtool-2.4.6-5

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 8.3.1
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool
8Version: 2.4.6
9Release: 5%{?_dist_release}
10Vendor: Project Vine
11Distribution: Vine Linux
12License: GPLv2+ and LGPLv2+ and GFDL
13Group:   Development/Tools
14URL:     http://www.gnu.org/software/libtool/
15
16Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
17Patch0:  libtool-2.4.6-rpath.patch
18
19# ~> downstream (TODO)
20Patch1: libtool-2.4.6-am-1.16-test.patch
21
22# ~> upstream 702a97fbb
23Patch2: libtool-2.4.6-specs.patch
24
25# See the rhbz#1289759 and rhbz#1214506.  We disable hardening namely because
26# that bakes the CFLAGS/LDFLAGS into installed /bin/libtool and ltmain.sh files.
27
28# At the same time we want to have libltdl.so hardened.  Downstream-only patch.
29%undefine _hardened_build
30Patch3: libtool-2.4.6-hardening.patch
31
32# rhbz#1622611, upstream 350082b6aa89f9ef603fcebbb4cf33f15a743f2f
33Patch4: libtool-2.4.6-fatal-handler.patch
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36Requires(post):  /sbin/install-info
37Requires(preun): /sbin/install-info
38
39BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
40Requires: autoconf >= 2.58, automake >= 1.4
41# make sure we can configure all supported langs
42BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
43#BuildRequires: gcc-java
44# /usr/bin/libtool includes paths within gcc's versioned directories
45# Libtool must be rebuilt whenever a new upstream gcc is built
46Requires: gcc = %{gcc_version}
47
48Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
49Requires: libtool-ltdl = %{version}-%{release}, mktemp
50
51%description
52GNU Libtool is a set of shell scripts which automatically configure UNIX and
53UNIX-like systems to generically build shared libraries. Libtool provides a
54consistent, portable interface which simplifies the process of using shared
55libraries.
56
57If you are developing programs which will use shared libraries, but do not use
58the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
59should install the libtool package.
60
61The libtool package also includes all files needed to integrate the GNU
62Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
63(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
64and GNU Automake).
65
66This package includes a modification from the original GNU Libtool to allow
67support for multi-architecture systems, such as the AMD64 Opteron and the Intel
6864-bit Xeon.
69
70%description -l ja
71GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
72にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
73共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
74スを提供します。
75
76もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
77ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
78する必要があります。
79
80このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
81システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
82
83
84%package ltdl
85Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
86Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
87Group:    System Environment/Libraries
88Provides: libtool-libs = %{version}-%{release}
89Obsoletes: libtool-libs < 1.5.20
90License:  LGPL
91Requires(post):  /sbin/ldconfig
92Requires(postun):  /sbin/ldconfig
93
94
95%description ltdl
96The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
97library that provides a consistent, portable interface which simplifies the
98process of using dynamic modules.
99
100These runtime libraries are needed by programs that link directly to the
101system-installed ltdl libraries; they are not needed by software built using the
102rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
103
104%description -l ja ltdl
105libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
106ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
107利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
108
109
110%package ltdl-devel
111Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
112Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
113Group:    Development/Libraries
114Requires: libtool-ltdl = %{version}-%{release}
115License:  LGPL
116
117
118%description ltdl-devel
119Static libraries and header files for development with ltdl.
120
121%description -l ja ltdl-devel
122ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
123
124
125## to build compat32 for x86_64 architecture support
126%package -n compat32-%{name}-ltdl
127Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
128Group: System Environment/Libraries
129%description -n compat32-%{name}-ltdl
130The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
131library that provides a consistent, portable interface which simplifies the
132process of using dynamic modules.
133
134%package -n compat32-%{name}-ltdl-devel
135Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
136Group: Development/Libraries
137Requires: compat32-%{name}-ltdl = %{version}-%{release}
138%description -n compat32-%{name}-ltdl-devel
139Static libraries and header files for development with ltdl.
140
141
142%prep
143%setup -q
144%patch0 -p1
145%patch1 -p1
146%patch2 -p1
147%patch3 -p1
148%patch4 -p1
149
150
151%build
152
153autoreconf -v
154
155export CC=gcc
156export CXX=g++
157export F77=gfortran
158export CFLAGS="$RPM_OPT_FLAGS -fPIC"
159# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
160./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
161# build not smp safe:
162make #%{?_smp_mflags}
163
164
165#check
166#make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
167
168
169%install
170rm -rf %{buildroot}
171make install DESTDIR=$RPM_BUILD_ROOT
172rm -f %{buildroot}%{_infodir}/dir
173rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
174
175
176%clean
177rm -rf %{buildroot}
178
179
180%post
181/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
182
183%preun
184if [ "$1" = 0 ]; then
185   /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
186fi
187
188%post ltdl -p /sbin/ldconfig
189
190%postun ltdl -p /sbin/ldconfig
191
192%post -n compat32-%{name}-ltdl
193/sbin/ldconfig
194
195%postun -n compat32-%{name}-ltdl
196/sbin/ldconfig
197
198
199%files
200%defattr(-,root,root)
201%license COPYING
202%doc AUTHORS NEWS README THANKS TODO ChangeLog
203%{_bindir}/libtool
204%{_bindir}/libtoolize
205%{_datadir}/aclocal/*.m4
206%{_datadir}/libtool
207%{_infodir}/libtool.info*.gz
208%{_mandir}/man1/libtool.1.gz
209%{_mandir}/man1/libtoolize.1.gz
210
211%files ltdl
212%defattr(-,root,root)
213%license libltdl/COPYING.LIB
214%doc libltdl/README
215%{_libdir}/libltdl.so.*
216
217%files ltdl-devel
218%defattr(-,root,root)
219%{_libdir}/libltdl.so
220%{_includedir}/ltdl.h
221%{_includedir}/libltdl/*
222
223%if %{build_compat32}
224## to build compat32 for x86_64 architecture support
225%files -n compat32-%{name}-ltdl
226%defattr(-,root,root)
227%{_libdir}/libltdl.so.*
228
229%files -n compat32-%{name}-ltdl-devel
230%defattr(-,root,root)
231%{_libdir}/libltdl.so
232%endif
233
234
235%changelog
236* Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-5
237- rebuilt with gcc-8.3.1.
238
239* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-4
240- imported Patch1-4 from rawhide.
241
242* Mon Jan 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-3
243- rebuilt with gcc-8.2.0.
244
245* Sun Jun 26 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
246- rebuild with gcc-5.4.0
247
248* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
249- new upstream release
250- update Patch0 (libtool-2.4.6-rpath.patch)
251
252* Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-4
253- rebuild with gcc-4.8.2-1
254
255* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
256- rebuild with gcc-4.8.1-2
257
258* Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
259- rebuild with gcc-4.8.1
260- add BuildRequires: help2man
261
262* Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
263- new upstream release
264
265* Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
266- rebuilt with gcc-4.6.2
267
268* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
269- new upstream release
270- update Patch0
271
272* Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
273- rebuilt with gcc-4.4.5
274
275* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
276- new upstream release
277
278* Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
279- rebuilt with gcc-4.4.3-1 (w/o gcc-java)
280
281* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
282- remove comment before compat32 scriptlet to avoid scriptlet failure.
283
284* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
285- removed %%if !%%{build_compat32} case condition
286
287* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
288- update to 2.2.6a
289- remove libltdl static library
290
291* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
292- updated to 1.5.26, importing changes from Fedora 1.5.26-2
293- new versioning policy; spec in UTF-8
294- define gcc_version to 4.1.2 for Vine
295
296* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
297- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
298
299* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
300- remove BuildRequires: libstdc++3-devel
301- add Requres: libtool-ltdl instead of libtool-libs
302
303* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
304- rebuilt with gcc4 (F77=gfortran now)
305- import Patch2 and Patch3 from FC6 1.5.22-6.1
306
307  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
308  - detect gcc path at runtime instead of requiring one specific version
309
310  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
311  - miscellaneous upstream fixes
312
313* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
314- new upstream release
315
316* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
317- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
318- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
319
320* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
321- added compat32-* packages for x86_64 architecture support
322
323* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
324- add Japanese Summaries and descriptions
325
326* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
327- new upstream release
328
329* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
330- updated to 1.5.18 based on Fedora package
331  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
332  - update to the 1.5.12 bugfix release
333  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
334  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
335  - Interpret `include' statements in toplevel ld.so.conf file.
336  - While "parsing" /etc/ld.so.conf, skip comments.
337  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
338    gcc's internal directories
339  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
340  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
341  - update to the 1.5.10 bugfix release
342    - obsoletes libtool-1.4-nonneg.patch
343    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
344    - obsoletes libtool-1.4.2-multilib.patch
345    - obsoletes libtool-1.4.2-demo.patch
346    - obsoletes libtool-1.5-testfailure.patch
347  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
348  - compile libltdl.a PIC
349
350* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
351- rebuild with gcc-3.3.5
352
353* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
354- new upstream release
355
356* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
357- merged with fedora-1.5.2-2
358  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
359  - update to 1.5.2 bugfix release
360  - update libtool-1.5-libtool.m4-x86_64.patch
361  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
362    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
363    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
364
365  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
366  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
367    [Joe Orton]
368
369* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
370- merged with rawhide 1.5-5
371  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
372  - based on 1.4.3-2 from Rawhide and built for Vine Linux
373  - added BuildPreReq: automake14
374
375* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
376- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
377  and s390x again
378
379* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
380- Fix misapplied chunk for expsym-linux patch
381
382* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
383- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
384  [reported by twaugh]
385- use -nostdlib also when linking with g++ and non-GNU ld in
386  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
387- use %%configure with CC and CXX set
388
389* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
390- don't use %%configure since target options caused libtool to assume
391  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
392- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
393  searched when relinking (#91110) [patch from Joe Orton]
394
395* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
396- rebuilt
397
398* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
399- update to 1.5
400- no longer override config.{guess,sub} for rpmbuild %%configure,
401  redhat-rpm-config owns those now
402- update and rename libtool-1.4.2-s390_x86_64.patch to
403  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
404- buildrequire autoconf and automake, no longer automake14
405- skip make check on s390 temporarily
406- no longer skip demo-nopic.test on x86_64, s390 and s390x
407- from Owen Taylor
408  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
409  - add quoting in mktemp patch
410  - add libtool-1.5-readonlysym.patch
411  - add libtool-1.5-testfailure.patch workaround
412  - relink patch no longer needed
413
414* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
415- add config.guess and config.sub, otherwise old versions of
416  these files can creep into /usr/share/libtool/
417
418* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
419- rebuilt
420
421* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
422- fix mktemp to work when running mktemp fails (#76602)
423  [reported by (Oron Peled)]
424- remove info dir file, don't exclude it
425- fix typo in -libs description (#79619)
426- use buildroot instead of RPM_BUILD_ROOT
427
428* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
429- use lib64 on s390x, too.
430
431* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
432- add comment to explain why we use an old Automake for building
433- buildrequire automake14
434
435* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
436- add --without check build option to allow disabling of "make check"
437- exclude info dir file rather than removing
438
439* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
440- define SED in ltmain.sh for historic ltconfig files
441- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
442- leave old missing file for now
443- general spec file cleanup
444  - don't copy install files to demo nor mess with installed ltdl files
445  - don't need to run make in doc
446  - force removal of info dir file
447  - don't need to create install prefix dir
448  - don't bother gzipping info files ourselves
449
450* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
451- update to 1.4.3
452- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
453- apply the multilib patch to just the original config files
454- update x86_64/s390 patch and just apply to original config files
455- use automake-1.4 in "make check" for demo-make.test to pass!
456- remove info dir file that is not installed
457- make autoreconf update missing
458
459* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
460- Added s390x and x64_64 support.
461
462* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
463- rebuild
464
465* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
466- patch to find the proper libdir on multilib boxes
467 
468* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
469- don't include demo in doc, specially now that we "make check" (#71609)
470
471* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
472- don't hardcode "configure.in" in libtoolize (#70864)
473  [reported by bastiaan@webcriminals.com]
474- make check, but not on ia64
475
476* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
477- automated rebuild
478
479* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
480- automated rebuild
481
482* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
483- add old patch from aoliva to fix relinking when installing into a buildroot
484- backport dup-deps fix from cvs stable branch
485
486* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
487- run ldconfig in postin and postun
488
489* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
490- rebuild in new environment
491
492* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
493- revert filemagic and archive-shared patches following cvs (#54887)
494- don't change "&& test" to "-a" in ltmain.in
495
496* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
497- automated rebuild
498
499* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
500- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
501- use file_magic for Linux ELF (#54887)
502- allow link against an archive when building a shared library (#54887)
503- include ltdl.m4 in manifest (#56671)
504
505* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
506- added URL to spec
507
508* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
509- 1.4.2 - sync up with autoconf...
510
511* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
512- extend s390 patch to 2 more files
513- s/Copyright/License/
514
515* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
516- add s390 patch for deplibs_check_method=pass_all
517
518* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
519- add patches from Tim Waugh #42724
520
521* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
522- add patches from cvs mainline
523
524* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
525- fix a "test" bug in ltmain.sh
526
527* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
528- disable the post commands to modify /usr/share/doc/
529
530* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
531- Require automake 1.4p1
532
533* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
534- update to libtool 1.4
535- adjust or remove patches
536
537* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
538- Fix recognition of ^0[0-9]+$ as a non-negative integer.
539
540* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
541- automatic rebuild
542
543* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
544- patch to use mktemp to create the tempdir
545- use %%configure after defining __libtoolize to /bin/true
546
547* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
548- subpackage libltdl into libtool-libs
549
550* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
551- running libtoolize on the libtool source tree ain't right :)
552
553* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
554- FHS packaging.
555
556* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
557- update to 1.3.5.
558
559* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
560- add prereqs for m4 and perl inorder to run autoconf/automake.
561
562* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
563- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
564
565* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
566- update to 1.3.4.
567
568* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
569- change from noarch to per-arch in order to package libltdl.a (#7493).
570
571* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
572- update to 1.3.3.
573
574* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
575- update to 1.3.2.
576
577* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
578- explicitly disable per-arch libraries (#2210)
579- undo hard links and remove zero length file (#2689)
580
581* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
582- update to 1.3.
583
584* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
585- disable the --cache-file passing to ltconfig; this breaks the older
586  ltconfig scripts found around.
587
588* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
589- auto rebuild in the new build environment (release 2)
590
591* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
592- update to 1.2f
593
594* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
595- completed arm patch
596- added patch to make it more arm-friendly
597- upgrade to version 1.2d
598
599* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
600- fixed busted group
601
602* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
603- Update to 1.0h
604- added install-info support
605
606* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
607- Update to 1.0f
608- BuildRoot it
609- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.