source: projects/specs/trunk/lib/libt/libtool/libtool-vl.spec @ 12525

Revision 12525, 21.3 KB checked in by tomop, 3 years ago (diff)

updated 10 packages

binutils-2.36.1-1

elfutils-0.183-1

gcc-10.2.1-1

gdb-10.1-1

glibc-2.33-1

isl-0.23-1

libtirpc-1.3.1-1

libtool-2.4.6-7

libxcrypt-4.4.17-1

valgrind-3.16.1-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 10.2.1
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool
8Version: 2.4.6
9Release: 7%{?_dist_release}
10Group: programming
11Vendor: Project Vine
12Distribution: Vine Linux
13
14License: GPLv2+ and LGPLv2+ and GFDL
15URL:     http://www.gnu.org/software/libtool/
16Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
17Patch0:  libtool-2.4.6-rpath.patch
18
19# ~> downstream (TODO)
20Patch1: libtool-2.4.6-am-1.16-test.patch
21
22# ~> upstream 702a97fbb
23Patch2: libtool-2.4.6-specs.patch
24
25# See the rhbz#1289759 and rhbz#1214506.  We disable hardening namely because
26# that bakes the CFLAGS/LDFLAGS into installed /bin/libtool and ltmain.sh files.
27
28# At the same time we want to have libltdl.so hardened.  Downstream-only patch.
29%undefine _hardened_build
30Patch3: libtool-2.4.6-hardening.patch
31
32# rhbz#1622611, upstream 350082b6aa89f9ef603fcebbb4cf33f15a743f2f
33Patch4: libtool-2.4.6-fatal-handler.patch
34
35BuildRoot: %{_tmppath}/%{name}-%{version}-root
36Requires(post):  /sbin/install-info
37Requires(preun): /sbin/install-info
38
39BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
40Requires: autoconf >= 2.58, automake >= 1.4
41# make sure we can configure all supported langs
42BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
43#BuildRequires: gcc-java
44# /usr/bin/libtool includes paths within gcc's versioned directories
45# Libtool must be rebuilt whenever a new upstream gcc is built
46Requires: gcc = %{gcc_version}
47
48Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
49Requires: libtool-ltdl = %{version}-%{release}, mktemp
50
51%description
52GNU Libtool is a set of shell scripts which automatically configure UNIX and
53UNIX-like systems to generically build shared libraries. Libtool provides a
54consistent, portable interface which simplifies the process of using shared
55libraries.
56
57If you are developing programs which will use shared libraries, but do not use
58the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
59should install the libtool package.
60
61The libtool package also includes all files needed to integrate the GNU
62Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
63(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
64and GNU Automake).
65
66This package includes a modification from the original GNU Libtool to allow
67support for multi-architecture systems, such as the AMD64 Opteron and the Intel
6864-bit Xeon.
69
70%description -l ja
71GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
72にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
73共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
74スを提供します。
75
76もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
77ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
78する必要があります。
79
80このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
81システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
82
83
84%package ltdl
85Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
86Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
87Group:    system
88Provides: libtool-libs = %{version}-%{release}
89Obsoletes: libtool-libs < 1.5.20
90License:  LGPL
91Requires(post):  /sbin/ldconfig
92Requires(postun):  /sbin/ldconfig
93
94
95%description ltdl
96The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
97library that provides a consistent, portable interface which simplifies the
98process of using dynamic modules.
99
100These runtime libraries are needed by programs that link directly to the
101system-installed ltdl libraries; they are not needed by software built using the
102rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
103
104%description -l ja ltdl
105libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
106ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
107利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
108
109
110%package ltdl-devel
111Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
112Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
113Group:    programming
114Requires: libtool-ltdl = %{version}-%{release}
115License:  LGPL
116
117
118%description ltdl-devel
119Static libraries and header files for development with ltdl.
120
121%description -l ja ltdl-devel
122ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
123
124
125## to build compat32 for x86_64 architecture support
126%package -n compat32-%{name}-ltdl
127Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
128Group: system
129%description -n compat32-%{name}-ltdl
130The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
131library that provides a consistent, portable interface which simplifies the
132process of using dynamic modules.
133
134%package -n compat32-%{name}-ltdl-devel
135Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
136Group: programming
137Requires: compat32-%{name}-ltdl = %{version}-%{release}
138%description -n compat32-%{name}-ltdl-devel
139Static libraries and header files for development with ltdl.
140
141
142%debug_package
143
144
145%prep
146%setup -q
147%patch0 -p1
148%patch1 -p1
149%patch2 -p1
150%patch3 -p1
151%patch4 -p1
152
153
154%build
155autoreconf -v
156
157export CC=gcc
158export CXX=g++
159export F77=gfortran
160export CFLAGS="$RPM_OPT_FLAGS -fPIC"
161# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
162./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
163# build not smp safe:
164make #%{?_smp_mflags}
165
166
167#check
168#make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
169
170
171%install
172rm -rf %{buildroot}
173make install DESTDIR=$RPM_BUILD_ROOT
174rm -f %{buildroot}%{_infodir}/dir
175rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
176
177
178%clean
179rm -rf %{buildroot}
180
181
182%post
183/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
184
185%preun
186if [ "$1" = 0 ]; then
187   /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
188fi
189
190%post ltdl -p /sbin/ldconfig
191%postun ltdl -p /sbin/ldconfig
192
193%post -n compat32-%{name}-ltdl -p /sbin/ldconfig
194%postun -n compat32-%{name}-ltdl -p /sbin/ldconfig
195
196
197%files
198%defattr(-,root,root)
199%license COPYING
200%doc AUTHORS NEWS README THANKS TODO ChangeLog
201%{_bindir}/libtool
202%{_bindir}/libtoolize
203%{_datadir}/aclocal/*.m4
204%{_datadir}/libtool
205%{_infodir}/libtool.info*.gz
206%{_mandir}/man1/libtool.1.gz
207%{_mandir}/man1/libtoolize.1.gz
208
209%files ltdl
210%defattr(-,root,root)
211%license libltdl/COPYING.LIB
212%doc libltdl/README
213%{_libdir}/libltdl.so.*
214
215%files ltdl-devel
216%defattr(-,root,root)
217%{_libdir}/libltdl.so
218%{_includedir}/ltdl.h
219%{_includedir}/libltdl/*
220
221%if %{build_compat32}
222## to build compat32 for x86_64 architecture support
223%files -n compat32-%{name}-ltdl
224%defattr(-,root,root)
225%{_libdir}/libltdl.so.*
226
227%files -n compat32-%{name}-ltdl-devel
228%defattr(-,root,root)
229%{_libdir}/libltdl.so
230%endif
231
232
233%changelog
234* Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-7
235- rebuilt with gcc-10.2.1.
236
237* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-6
238- rebuilt with gcc-9.3.1.
239
240* Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-5
241- rebuilt with gcc-8.3.1.
242
243* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-4
244- imported Patch1-4 from rawhide.
245
246* Mon Jan 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-3
247- rebuilt with gcc-8.2.0.
248
249* Sun Jun 26 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
250- rebuild with gcc-5.4.0
251
252* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
253- new upstream release
254- update Patch0 (libtool-2.4.6-rpath.patch)
255
256* Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-4
257- rebuild with gcc-4.8.2-1
258
259* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
260- rebuild with gcc-4.8.1-2
261
262* Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
263- rebuild with gcc-4.8.1
264- add BuildRequires: help2man
265
266* Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
267- new upstream release
268
269* Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
270- rebuilt with gcc-4.6.2
271
272* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
273- new upstream release
274- update Patch0
275
276* Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
277- rebuilt with gcc-4.4.5
278
279* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
280- new upstream release
281
282* Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
283- rebuilt with gcc-4.4.3-1 (w/o gcc-java)
284
285* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
286- remove comment before compat32 scriptlet to avoid scriptlet failure.
287
288* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
289- removed %%if !%%{build_compat32} case condition
290
291* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
292- update to 2.2.6a
293- remove libltdl static library
294
295* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
296- updated to 1.5.26, importing changes from Fedora 1.5.26-2
297- new versioning policy; spec in UTF-8
298- define gcc_version to 4.1.2 for Vine
299
300* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
301- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
302
303* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
304- remove BuildRequires: libstdc++3-devel
305- add Requres: libtool-ltdl instead of libtool-libs
306
307* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
308- rebuilt with gcc4 (F77=gfortran now)
309- import Patch2 and Patch3 from FC6 1.5.22-6.1
310
311  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
312  - detect gcc path at runtime instead of requiring one specific version
313
314  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
315  - miscellaneous upstream fixes
316
317* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
318- new upstream release
319
320* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
321- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
322- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
323
324* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
325- added compat32-* packages for x86_64 architecture support
326
327* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
328- add Japanese Summaries and descriptions
329
330* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
331- new upstream release
332
333* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
334- updated to 1.5.18 based on Fedora package
335  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
336  - update to the 1.5.12 bugfix release
337  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
338  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
339  - Interpret `include' statements in toplevel ld.so.conf file.
340  - While "parsing" /etc/ld.so.conf, skip comments.
341  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
342    gcc's internal directories
343  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
344  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
345  - update to the 1.5.10 bugfix release
346    - obsoletes libtool-1.4-nonneg.patch
347    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
348    - obsoletes libtool-1.4.2-multilib.patch
349    - obsoletes libtool-1.4.2-demo.patch
350    - obsoletes libtool-1.5-testfailure.patch
351  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
352  - compile libltdl.a PIC
353
354* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
355- rebuild with gcc-3.3.5
356
357* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
358- new upstream release
359
360* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
361- merged with fedora-1.5.2-2
362  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
363  - update to 1.5.2 bugfix release
364  - update libtool-1.5-libtool.m4-x86_64.patch
365  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
366    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
367    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
368
369  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
370  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
371    [Joe Orton]
372
373* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
374- merged with rawhide 1.5-5
375  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
376  - based on 1.4.3-2 from Rawhide and built for Vine Linux
377  - added BuildPreReq: automake14
378
379* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
380- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
381  and s390x again
382
383* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
384- Fix misapplied chunk for expsym-linux patch
385
386* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
387- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
388  [reported by twaugh]
389- use -nostdlib also when linking with g++ and non-GNU ld in
390  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
391- use %%configure with CC and CXX set
392
393* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
394- don't use %%configure since target options caused libtool to assume
395  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
396- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
397  searched when relinking (#91110) [patch from Joe Orton]
398
399* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
400- rebuilt
401
402* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
403- update to 1.5
404- no longer override config.{guess,sub} for rpmbuild %%configure,
405  redhat-rpm-config owns those now
406- update and rename libtool-1.4.2-s390_x86_64.patch to
407  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
408- buildrequire autoconf and automake, no longer automake14
409- skip make check on s390 temporarily
410- no longer skip demo-nopic.test on x86_64, s390 and s390x
411- from Owen Taylor
412  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
413  - add quoting in mktemp patch
414  - add libtool-1.5-readonlysym.patch
415  - add libtool-1.5-testfailure.patch workaround
416  - relink patch no longer needed
417
418* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
419- add config.guess and config.sub, otherwise old versions of
420  these files can creep into /usr/share/libtool/
421
422* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
423- rebuilt
424
425* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
426- fix mktemp to work when running mktemp fails (#76602)
427  [reported by (Oron Peled)]
428- remove info dir file, don't exclude it
429- fix typo in -libs description (#79619)
430- use buildroot instead of RPM_BUILD_ROOT
431
432* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
433- use lib64 on s390x, too.
434
435* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
436- add comment to explain why we use an old Automake for building
437- buildrequire automake14
438
439* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
440- add --without check build option to allow disabling of "make check"
441- exclude info dir file rather than removing
442
443* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
444- define SED in ltmain.sh for historic ltconfig files
445- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
446- leave old missing file for now
447- general spec file cleanup
448  - don't copy install files to demo nor mess with installed ltdl files
449  - don't need to run make in doc
450  - force removal of info dir file
451  - don't need to create install prefix dir
452  - don't bother gzipping info files ourselves
453
454* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
455- update to 1.4.3
456- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
457- apply the multilib patch to just the original config files
458- update x86_64/s390 patch and just apply to original config files
459- use automake-1.4 in "make check" for demo-make.test to pass!
460- remove info dir file that is not installed
461- make autoreconf update missing
462
463* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
464- Added s390x and x64_64 support.
465
466* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
467- rebuild
468
469* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
470- patch to find the proper libdir on multilib boxes
471 
472* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
473- don't include demo in doc, specially now that we "make check" (#71609)
474
475* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
476- don't hardcode "configure.in" in libtoolize (#70864)
477  [reported by bastiaan@webcriminals.com]
478- make check, but not on ia64
479
480* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
481- automated rebuild
482
483* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
484- automated rebuild
485
486* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
487- add old patch from aoliva to fix relinking when installing into a buildroot
488- backport dup-deps fix from cvs stable branch
489
490* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
491- run ldconfig in postin and postun
492
493* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
494- rebuild in new environment
495
496* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
497- revert filemagic and archive-shared patches following cvs (#54887)
498- don't change "&& test" to "-a" in ltmain.in
499
500* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
501- automated rebuild
502
503* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
504- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
505- use file_magic for Linux ELF (#54887)
506- allow link against an archive when building a shared library (#54887)
507- include ltdl.m4 in manifest (#56671)
508
509* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
510- added URL to spec
511
512* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
513- 1.4.2 - sync up with autoconf...
514
515* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
516- extend s390 patch to 2 more files
517- s/Copyright/License/
518
519* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
520- add s390 patch for deplibs_check_method=pass_all
521
522* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
523- add patches from Tim Waugh #42724
524
525* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
526- add patches from cvs mainline
527
528* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
529- fix a "test" bug in ltmain.sh
530
531* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
532- disable the post commands to modify /usr/share/doc/
533
534* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
535- Require automake 1.4p1
536
537* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
538- update to libtool 1.4
539- adjust or remove patches
540
541* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
542- Fix recognition of ^0[0-9]+$ as a non-negative integer.
543
544* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
545- automatic rebuild
546
547* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
548- patch to use mktemp to create the tempdir
549- use %%configure after defining __libtoolize to /bin/true
550
551* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
552- subpackage libltdl into libtool-libs
553
554* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
555- running libtoolize on the libtool source tree ain't right :)
556
557* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
558- FHS packaging.
559
560* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
561- update to 1.3.5.
562
563* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
564- add prereqs for m4 and perl inorder to run autoconf/automake.
565
566* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
567- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
568
569* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
570- update to 1.3.4.
571
572* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
573- change from noarch to per-arch in order to package libltdl.a (#7493).
574
575* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
576- update to 1.3.3.
577
578* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
579- update to 1.3.2.
580
581* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
582- explicitly disable per-arch libraries (#2210)
583- undo hard links and remove zero length file (#2689)
584
585* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
586- update to 1.3.
587
588* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
589- disable the --cache-file passing to ltconfig; this breaks the older
590  ltconfig scripts found around.
591
592* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
593- auto rebuild in the new build environment (release 2)
594
595* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
596- update to 1.2f
597
598* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
599- completed arm patch
600- added patch to make it more arm-friendly
601- upgrade to version 1.2d
602
603* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
604- fixed busted group
605
606* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
607- Update to 1.0h
608- added install-info support
609
610* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
611- Update to 1.0f
612- BuildRoot it
613- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.