source: projects/specs/trunk/lib/libt/libtool/libtool-vl.spec @ 12131

Revision 12131, 21.0 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gcc_version 8.2.0
4
5Summary: The GNU Portable Library Tool
6Summary(ja): GNU ポータブルライブラリツール
7Name:    libtool
8Version: 2.4.6
9Release: 4%{?_dist_release}
10License: GPLv2+ and LGPLv2+ and GFDL
11Group:   Development/Tools
12URL:     http://www.gnu.org/software/libtool/
13
14Source:  http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.xz
15Patch0:  libtool-2.4.6-rpath.patch
16
17# ~> downstream (TODO)
18Patch1: libtool-2.4.6-am-1.16-test.patch
19
20# ~> upstream 702a97fbb
21Patch2: libtool-2.4.6-specs.patch
22
23# See the rhbz#1289759 and rhbz#1214506.  We disable hardening namely because
24# that bakes the CFLAGS/LDFLAGS into installed /bin/libtool and ltmain.sh files.
25
26# At the same time we want to have libltdl.so hardened.  Downstream-only patch.
27%undefine _hardened_build
28Patch3: libtool-2.4.6-hardening.patch
29
30# rhbz#1622611, upstream 350082b6aa89f9ef603fcebbb4cf33f15a743f2f
31Patch4: libtool-2.4.6-fatal-handler.patch
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
34Requires(post):  /sbin/install-info
35Requires(preun): /sbin/install-info
36
37BuildRequires: autoconf >= 2.59, automake >= 1.9.2, texinfo, help2man
38Requires: autoconf >= 2.58, automake >= 1.4
39# make sure we can configure all supported langs
40BuildRequires: gcc, gcc-c++, libstdc++-devel, gcc-gfortran
41#BuildRequires: gcc-java
42# /usr/bin/libtool includes paths within gcc's versioned directories
43# Libtool must be rebuilt whenever a new upstream gcc is built
44Requires: gcc = %{gcc_version}
45
46Requires: autoconf >= 2.50, automake >= 1.4p1, m4, perl
47Requires: libtool-ltdl = %{version}-%{release}, mktemp
48
49Vendor: Project Vine
50Distribution: Vine Linux
51
52%description
53GNU Libtool is a set of shell scripts which automatically configure UNIX and
54UNIX-like systems to generically build shared libraries. Libtool provides a
55consistent, portable interface which simplifies the process of using shared
56libraries.
57
58If you are developing programs which will use shared libraries, but do not use
59the rest of the GNU Autotools (such as GNU Autoconf and GNU Automake), you
60should install the libtool package.
61
62The libtool package also includes all files needed to integrate the GNU
63Portable Library Tool (libtool) and the GNU Libtool Dynamic Module Loader
64(ltdl) into a package built using the GNU Autotools (including GNU Autoconf
65and GNU Automake).
66
67This package includes a modification from the original GNU Libtool to allow
68support for multi-architecture systems, such as the AMD64 Opteron and the Intel
6964-bit Xeon.
70
71%description -l ja
72GNU Libtoolは、UNIX及びUNIXライクなアーキテクチャで共有ライブラリを汎用的
73にビルドするための設定を自動化するシェルスクリプトのセットです。libtoolは、
74共有ライブラリを利用する工程を単純化する首尾一貫した移植可能なインターフェー
75スを提供します。
76
77もし、GNU Autotools (GNU Autoconf および GNU Automake) を使わずに共有ライ
78ブラリを利用するプログラムを開発するなら、libtool パッケージをインストール
79する必要があります。
80
81このパッケージの Libtool は、AMD64 や Intel EM64T などのマルチアーキテクチャ
82システムをサポートするために、オリジナルのGNU Libtoolから変更が施されています。
83
84
85%package ltdl
86Summary:  Runtime libraries for GNU Libtool Dynamic Module Loader
87Summary(ja): GNU Libtool ダイナミックモジュールローダのランタイムライブラリ
88Group:    System Environment/Libraries
89Provides: libtool-libs = %{version}-%{release}
90Obsoletes: libtool-libs < 1.5.20
91License:  LGPL
92Requires(post):  /sbin/ldconfig
93Requires(postun):  /sbin/ldconfig
94
95
96%description ltdl
97The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
98library that provides a consistent, portable interface which simplifies the
99process of using dynamic modules.
100
101These runtime libraries are needed by programs that link directly to the
102system-installed ltdl libraries; they are not needed by software built using the
103rest of the GNU Autotools (including GNU Autoconf and GNU Automake).
104
105%description -l ja ltdl
106libtool-ltdl パッケージにはGNU Libtool 動的モジュールローダのランタイムライ
107ブラリが含まれています。GNU Libtool 動的モジュールローダは、動的モジュールを
108利用する工程を単純化する首尾一貫した移植可能なインターフェースを提供します。
109
110
111%package ltdl-devel
112Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
113Summary(ja): GNU Libtool ダイナミックモジュールローダを使った開発に必要なファイル群
114Group:    Development/Libraries
115Requires: libtool-ltdl = %{version}-%{release}
116License:  LGPL
117
118
119%description ltdl-devel
120Static libraries and header files for development with ltdl.
121
122%description -l ja ltdl-devel
123ltdlを使った開発に必要なスタティックライブラリおよびヘッダファイル
124
125
126## to build compat32 for x86_64 architecture support
127%package -n compat32-%{name}-ltdl
128Summary: Runtime libraries for GNU Libtool Dynamic Module Loader
129Group: System Environment/Libraries
130%description -n compat32-%{name}-ltdl
131The libtool-ltdl package contains the GNU Libtool Dynamic Module Loader, a
132library that provides a consistent, portable interface which simplifies the
133process of using dynamic modules.
134
135%package -n compat32-%{name}-ltdl-devel
136Summary: Tools needed for development using the GNU Libtool Dynamic Module Loader
137Group: Development/Libraries
138Requires: compat32-%{name}-ltdl = %{version}-%{release}
139%description -n compat32-%{name}-ltdl-devel
140Static libraries and header files for development with ltdl.
141
142
143%prep
144%setup -q
145%patch0 -p1
146%patch1 -p1
147%patch2 -p1
148%patch3 -p1
149%patch4 -p1
150
151
152%build
153
154autoreconf -v
155
156export CC=gcc
157export CXX=g++
158export F77=gfortran
159export CFLAGS="$RPM_OPT_FLAGS -fPIC"
160# dumb redhat-rpm-config replaces config.{sub,guess} with ancient ones in %%configure, use ./configure instead:
161./configure --prefix=%{_prefix} --exec-prefix=%{_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --mandir=%{_mandir} --infodir=%{_infodir}
162# build not smp safe:
163make #%{?_smp_mflags}
164
165
166#check
167#make check VERBOSE=yes > make_check.log 2>&1 || (cat make_check.log && false)
168
169
170%install
171rm -rf %{buildroot}
172make install DESTDIR=$RPM_BUILD_ROOT
173rm -f %{buildroot}%{_infodir}/dir
174rm -f %{buildroot}%{_libdir}/libltdl.{a,la}
175
176
177%clean
178rm -rf %{buildroot}
179
180
181%post
182/sbin/install-info %{_infodir}/libtool.info.gz %{_infodir}/dir || :
183
184%preun
185if [ "$1" = 0 ]; then
186   /sbin/install-info --delete %{_infodir}/libtool.info.gz %{_infodir}/dir || :
187fi
188
189%post ltdl -p /sbin/ldconfig
190
191%postun ltdl -p /sbin/ldconfig
192
193%post -n compat32-%{name}-ltdl
194/sbin/ldconfig
195
196%postun -n compat32-%{name}-ltdl
197/sbin/ldconfig
198
199
200%files
201%defattr(-,root,root)
202%license COPYING
203%doc AUTHORS NEWS README THANKS TODO ChangeLog
204%{_bindir}/libtool
205%{_bindir}/libtoolize
206%{_datadir}/aclocal/*.m4
207%{_datadir}/libtool
208%{_infodir}/libtool.info*.gz
209%{_mandir}/man1/libtool.1.gz
210%{_mandir}/man1/libtoolize.1.gz
211
212%files ltdl
213%defattr(-,root,root)
214%doc libltdl/COPYING.LIB libltdl/README
215%{_libdir}/libltdl.so.*
216
217%files ltdl-devel
218%defattr(-,root,root)
219%{_libdir}/libltdl.so
220%{_includedir}/ltdl.h
221%{_includedir}/libltdl/*
222
223%if %{build_compat32}
224## to build compat32 for x86_64 architecture support
225%files -n compat32-%{name}-ltdl
226%defattr(-,root,root)
227%{_libdir}/libltdl.so.*
228
229%files -n compat32-%{name}-ltdl-devel
230%defattr(-,root,root)
231%{_libdir}/libltdl.so
232%endif
233
234
235%changelog
236* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-4
237- imported Patch1-4 from rawhide.
238
239* Mon Jan 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.6-3
240- rebuilt with gcc-8.2.0.
241
242* Sun Jun 26 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-2
243- rebuild with gcc-5.4.0
244
245* Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.6-1
246- new upstream release
247- update Patch0 (libtool-2.4.6-rpath.patch)
248
249* Mon Nov 04 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-4
250- rebuild with gcc-4.8.2-1
251
252* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-3
253- rebuild with gcc-4.8.1-2
254
255* Mon Sep 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4.2-2
256- rebuild with gcc-4.8.1
257- add BuildRequires: help2man
258
259* Sat Dec 03 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.2-1
260- new upstream release
261
262* Mon Nov 28 2011 NAKAMURA Kenta <kenta@vinelinux.org> 2.4-2
263- rebuilt with gcc-4.6.2
264
265* Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.4-1
266- new upstream release
267- update Patch0
268
269* Sun Mar 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6b-2
270- rebuilt with gcc-4.4.5
271
272* Sat Feb 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2.6b-1
273- new upstream release
274
275* Mon Jan 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.6a-4
276- rebuilt with gcc-4.4.3-1 (w/o gcc-java)
277
278* Tue May 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-3
279- remove comment before compat32 scriptlet to avoid scriptlet failure.
280
281* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.6a-2
282- removed %%if !%%{build_compat32} case condition
283
284* Wed Apr 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.6a-1
285- update to 2.2.6a
286- remove libltdl static library
287
288* Wed Jun 18 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.26-3
289- updated to 1.5.26, importing changes from Fedora 1.5.26-2
290- new versioning policy; spec in UTF-8
291- define gcc_version to 4.1.2 for Vine
292
293* Wed May 30 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl4
294- rebuilt with gcc-4.1.2-0vl10 (gcc -dumpversion begets 4.1.2, not 4.1.3)
295
296* Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl3
297- remove BuildRequires: libstdc++3-devel
298- add Requres: libtool-ltdl instead of libtool-libs
299
300* Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.22-0vl2
301- rebuilt with gcc4 (F77=gfortran now)
302- import Patch2 and Patch3 from FC6 1.5.22-6.1
303
304  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-6
305  - detect gcc path at runtime instead of requiring one specific version
306
307  - Thu Jun 29 2006 Karsten Hopp <karsten@redhat.de> 1.5.22-5
308  - miscellaneous upstream fixes
309
310* Sat Sep 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.22-0vl1
311- new upstream release
312
313* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl4
314- moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
315- changed '%postun -p /sbin/ldconfig' to '%postun' and /sbin/ldconfig command
316
317* Thu Feb 02 2006 Shu KONNO <owa@bg.wakwak.com> 1.5.20-0vl3
318- added compat32-* packages for x86_64 architecture support
319
320* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl2
321- add Japanese Summaries and descriptions
322
323* Mon Oct 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.20-0vl1
324- new upstream release
325
326* Tue Aug 16 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.18-3vl1
327- updated to 1.5.18 based on Fedora package
328  * Sun Feb  6 2005 Daniel Reed <djr@redhat.com> 1.5.12.multilib2-3.4.3
329  - update to the 1.5.12 bugfix release
330  - Makes use of $datarootdir, which is necessary for Autoconf >= 2.60.
331  - Correctly skip hppa, x86_64, and s390* in tests/demo-nopic.test.
332  - Interpret `include' statements in toplevel ld.so.conf file.
333  - While "parsing" /etc/ld.so.conf, skip comments.
334  - add dependency on gcc version; /usr/bin/libtool hardcodes paths into
335    gcc's internal directories
336  - replace "libtool-libs" with "libtool-ltdl" and "libtool-ltdl-devel"
337  * Tue Oct 26 2004 Daniel Reed <djr@redhat.com> 1.5.10-1
338  - update to the 1.5.10 bugfix release
339    - obsoletes libtool-1.4-nonneg.patch
340    - obsoletes libtool-1.5-libtool.m4-x86_64.patch
341    - obsoletes libtool-1.4.2-multilib.patch
342    - obsoletes libtool-1.4.2-demo.patch
343    - obsoletes libtool-1.5-testfailure.patch
344  * Thu May 13 2004 Thomas Woerner <twoerner@redhat.com> - 1.5.6-2
345  - compile libltdl.a PIC
346
347* Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.6-0vl2
348- rebuild with gcc-3.3.5
349
350* Sun May  2 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-0vl1
351- new upstream release
352
353* Fri Feb 20 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 1.5.2-2vl1
354- merged with fedora-1.5.2-2
355  * Mon Jan 26 2004 Jens Petersen <petersen@redhat.com> - 1.5.2-1
356  - update to 1.5.2 bugfix release
357  - update libtool-1.5-libtool.m4-x86_64.patch
358  - nolonger need libtool-1.5-mktemp.patch, libtool-1.5-expsym-linux.patch,
359    libtool-1.5-readonlysym.patch, libtool-1.5-relink-libdir-order-91110.patch,
360    libtool-1.5-AC_PROG_LD_GNU-quote-v-97608.patch and libtool-1.5-nostdlib.patch
361
362  * Tue Oct 28 2003 Jens Petersen <petersen@redhat.com> - 1.5-8
363  - update libtool-1.4.2-multilib.patch to also deal with powerpc64 (#103316)
364    [Joe Orton]
365
366* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-5vl1
367- merged with rawhide 1.5-5
368  * Mon Dec 09 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.3-2vl2
369  - based on 1.4.3-2 from Rawhide and built for Vine Linux
370  - added BuildPreReq: automake14
371
372* Thu Jul 17 2003 Jens Petersen <petersen@redhat.com> - 1.5-5
373- bring back libtool-1.4.2-demo.patch to disable nopic tests on amd64
374  and s390x again
375
376* Tue Jul 15 2003 Owen Taylor <otaylor@redhat.com>
377- Fix misapplied chunk for expsym-linux patch
378
379* Tue Jul  8 2003 Jens Petersen <petersen@redhat.com> - 1.5-4
380- remove the quotes around LD in AC_PROG_LD_GNU (#97608)
381  [reported by twaugh]
382- use -nostdlib also when linking with g++ and non-GNU ld in
383  _LT_AC_LANG_CXX_CONFIG [reported by fnasser, patch by aoliva]
384- use %%configure with CC and CXX set
385
386* Thu Jun 12 2003 Jens Petersen <petersen@redhat.com> - 1.5-3
387- don't use %%configure since target options caused libtool to assume
388  i386-redhat-linux-gcc instead of gcc for CC (reported by Joe Orton)
389- add libtool-1.5-relink-libdir-order-91110.patch to fix order of lib dirs
390  searched when relinking (#91110) [patch from Joe Orton]
391
392* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
393- rebuilt
394
395* Thu May  1 2003 Jens Petersen <petersen@redhat.com> - 1.5-1
396- update to 1.5
397- no longer override config.{guess,sub} for rpmbuild %%configure,
398  redhat-rpm-config owns those now
399- update and rename libtool-1.4.2-s390_x86_64.patch to
400  libtool-1.5-libtool.m4-x86_64.patch since s390 now included
401- buildrequire autoconf and automake, no longer automake14
402- skip make check on s390 temporarily
403- no longer skip demo-nopic.test on x86_64, s390 and s390x
404- from Owen Taylor
405  - add libtool-1.4.2-expsym-linux.patch (#55607) [from James Henstridge]
406  - add quoting in mktemp patch
407  - add libtool-1.5-readonlysym.patch
408  - add libtool-1.5-testfailure.patch workaround
409  - relink patch no longer needed
410
411* Sat Feb 08 2003 Florian La Roche <Florian.LaRoche@redhat.de> - 1.4.3-5
412- add config.guess and config.sub, otherwise old versions of
413  these files can creep into /usr/share/libtool/
414
415* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
416- rebuilt
417
418* Mon Jan 13 2003 Jens Petersen <petersen@redhat.com> 1.4.3-3
419- fix mktemp to work when running mktemp fails (#76602)
420  [reported by (Oron Peled)]
421- remove info dir file, don't exclude it
422- fix typo in -libs description (#79619)
423- use buildroot instead of RPM_BUILD_ROOT
424
425* Tue Jan 07 2003 Karsten Hopp <karsten@redhat.de> 1.4.3-2.2
426- use lib64 on s390x, too.
427
428* Thu Dec  5 2002 Jens Petersen <petersen@redhat.com>
429- add comment to explain why we use an old Automake for building
430- buildrequire automake14
431
432* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com>
433- add --without check build option to allow disabling of "make check"
434- exclude info dir file rather than removing
435
436* Sat Nov 23 2002 Jens Petersen <petersen@redhat.com> 1.4.3-2
437- define SED in ltmain.sh for historic ltconfig files
438- define macro AUTOTOOLS to hold automake-1.4 and aclocal-1.4, and use it
439- leave old missing file for now
440- general spec file cleanup
441  - don't copy install files to demo nor mess with installed ltdl files
442  - don't need to run make in doc
443  - force removal of info dir file
444  - don't need to create install prefix dir
445  - don't bother gzipping info files ourselves
446
447* Mon Nov 18 2002 Jens Petersen <petersen@redhat.com> 1.4.3-1
448- update to 1.4.3
449- remove obsolete patches (test-quote, dup-deps, libtoolize-configure.ac)
450- apply the multilib patch to just the original config files
451- update x86_64/s390 patch and just apply to original config files
452- use automake-1.4 in "make check" for demo-make.test to pass!
453- remove info dir file that is not installed
454- make autoreconf update missing
455
456* Mon Oct 07 2002 Phil Knirsch <pknirsch@redhat.com>  1.4.2-12.2
457- Added s390x and x64_64 support.
458
459* Fri Oct  4 2002 Nalin Dahyabhai <nalin@redhat.com> 1.4.2-12.1
460- rebuild
461
462* Fri Sep 13 2002 Nalin Dahyabhai <nalin@redhat.com>
463- patch to find the proper libdir on multilib boxes
464 
465* Mon Aug 19 2002 Jens Petersen <petersen@redhat.com> 1.4.2-12
466- don't include demo in doc, specially now that we "make check" (#71609)
467
468* Tue Aug 13 2002 Jens Petersen <petersen@redhat.com> 1.4.2-11
469- don't hardcode "configure.in" in libtoolize (#70864)
470  [reported by bastiaan@webcriminals.com]
471- make check, but not on ia64
472
473* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.4.2-10
474- automated rebuild
475
476* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.4.2-9
477- automated rebuild
478
479* Fri Apr 26 2002 Jens Petersen <petersen@redhat.com> 1.4.2-8
480- add old patch from aoliva to fix relinking when installing into a buildroot
481- backport dup-deps fix from cvs stable branch
482
483* Wed Mar 27 2002 Jens Petersen <petersen@redhat.com> 1.4.2-7
484- run ldconfig in postin and postun
485
486* Thu Feb 28 2002 Jens Petersen <petersen@redhat.com> 1.4.2-6
487- rebuild in new environment
488
489* Tue Feb 12 2002 Jens Petersen <petersen@redhat.com> 1.4.2-5
490- revert filemagic and archive-shared patches following cvs (#54887)
491- don't change "&& test" to "-a" in ltmain.in
492
493* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.4.2-4
494- automated rebuild
495
496* Mon Dec  3 2001 Jens Petersen <petersen@redhat.com> 1.4.2-3
497- test quoting patch should be on ltmain.in not ltmain.sh (#53276)
498- use file_magic for Linux ELF (#54887)
499- allow link against an archive when building a shared library (#54887)
500- include ltdl.m4 in manifest (#56671)
501
502* Wed Oct 24 2001 Jens Petersen <petersen@redhat.com> 1.4.2-2
503- added URL to spec
504
505* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.4.2-1
506- 1.4.2 - sync up with autoconf...
507
508* Thu Jul  5 2001 Bernhard Rosenkraenzer <bero@redhat.de> 1.4-8
509- extend s390 patch to 2 more files
510- s/Copyright/License/
511
512* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
513- add s390 patch for deplibs_check_method=pass_all
514
515* Tue Jun 12 2001 Florian La Roche <Florian.LaRoche@redhat.de>
516- add patches from Tim Waugh #42724
517
518* Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de>
519- add patches from cvs mainline
520
521* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
522- fix a "test" bug in ltmain.sh
523
524* Sun Jun 03 2001 Florian La Roche <Florian.LaRoche@redhat.de>
525- disable the post commands to modify /usr/share/doc/
526
527* Sat May 12 2001 Owen Taylor <otaylor@redhat.com>
528- Require automake 1.4p1
529
530* Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
531- update to libtool 1.4
532- adjust or remove patches
533
534* Thu Jul 13 2000 Elliot Lee <sopwith@redhat.com>
535- Fix recognition of ^0[0-9]+$ as a non-negative integer.
536
537* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
538- automatic rebuild
539
540* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
541- patch to use mktemp to create the tempdir
542- use %%configure after defining __libtoolize to /bin/true
543
544* Mon Jul  3 2000 Matt Wilson <msw@redhat.com>
545- subpackage libltdl into libtool-libs
546
547* Sun Jun 18 2000 Bill Nottingham <notting@redhat.com>
548- running libtoolize on the libtool source tree ain't right :)
549
550* Mon Jun  5 2000 Jeff Johnson <jbj@redhat.com>
551- FHS packaging.
552
553* Thu Jun  1 2000 Nalin Dahyabhai <nalin@redhat.com>
554- update to 1.3.5.
555
556* Fri Mar  3 2000 Jeff Johnson <jbj@redhat.com>
557- add prereqs for m4 and perl inorder to run autoconf/automake.
558
559* Mon Feb 28 2000 Jeff Johnson <jbj@redhat.com>
560- functional /usr/doc/libtool-*/demo by end-user %post procedure (#9719).
561
562* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
563- update to 1.3.4.
564
565* Mon Dec  6 1999 Jeff Johnson <jbj@redhat.com>
566- change from noarch to per-arch in order to package libltdl.a (#7493).
567
568* Thu Jul 15 1999 Jeff Johnson <jbj@redhat.com>
569- update to 1.3.3.
570
571* Mon Jun 14 1999 Jeff Johnson <jbj@redhat.com>
572- update to 1.3.2.
573
574* Tue May 11 1999 Jeff Johnson <jbj@redhat.com>
575- explicitly disable per-arch libraries (#2210)
576- undo hard links and remove zero length file (#2689)
577
578* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
579- update to 1.3.
580
581* Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
582- disable the --cache-file passing to ltconfig; this breaks the older
583  ltconfig scripts found around.
584
585* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
586- auto rebuild in the new build environment (release 2)
587
588* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
589- update to 1.2f
590
591* Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
592- completed arm patch
593- added patch to make it more arm-friendly
594- upgrade to version 1.2d
595
596* Thu May 07 1998 Donnie Barnes <djb@redhat.com>
597- fixed busted group
598
599* Sat Jan 24 1998 Marc Ewing <marc@redhat.com>
600- Update to 1.0h
601- added install-info support
602
603* Tue Nov 25 1997 Elliot Lee <sopwith@redhat.com>
604- Update to 1.0f
605- BuildRoot it
606- Make it a noarch package
Note: See TracBrowser for help on using the repository browser.